Jump to content
MaLd0n

[GUIDE] EL Capitan / Sierra / High Sierra / Mojave on Intel LGA 775 motherboards / DSDT

816 posts in this topic

Recommended Posts

Hey MaLd0n, could you help me sort this errors and enable the add audio device id for me if possible?  It's for an hp pavilion with idt 92HD66C3_65. I can't seem to get the audio working because my dsdt i extracted from clover has 3 errors.. Running 10.12.6.

DSDT.aml

Share this post


Link to post
Share on other sites
Advertisement
9 hours ago, Blaggah said:

Hey MaLd0n, could you help me sort this errors and enable the add audio device id for me if possible?  It's for an hp pavilion with idt 92HD66C3_65. I can't seem to get the audio working because my dsdt i extracted from clover has 3 errors.. Running 10.12.6.

DSDT.aml

DSDT.aml.zip

Share this post


Link to post
Share on other sites
10 hours ago, Blaggah said:

Thanks for the help, did you do anything else to the dsdt other than fixing the errors?

search for _DSM and many others, essentials, etc

MaLd0n 2018-11-15 às 15.11.50.png

Share this post


Link to post
Share on other sites

Hello Mald0n,

I moved from socket 775 to socket 1366. Is it out of topic to send for a DSDT & clover config edit here?

Share this post


Link to post
Share on other sites
36 minutes ago, disty69 said:

Hello Mald0n,

I moved from socket 775 to socket 1366. Is it out of topic to send for a DSDT & clover config edit here?

post her, no problem

send me full dump

RunMe.app

Share this post


Link to post
Share on other sites
On 11/4/2018 at 11:30 AM, andy_172 said:

Hello Mald0n,

Could you please help me with my machine? It's Asus P5KPL-AM SE with modded bios for E5450 and GeForce 240 running Mojave. Ive already patched my DSDT, but not 100% sure about patches. Actually everything seems to work fine, but sleep. I can't get it. The screen is go to sleep, HDD stop and after moment run again and after that I can't get system to work, mouse, keyboard, reset and power buttons won't work. Only complete power off. 

Send me Mac-Pro.zip


Hi,

I have P5KPL-AM mainboard and to make the computer sleep you need to change jumper position for USB Keyboard/Mouse power [PS2_USBPW14] (see Manual English version page 1-9)

P5KPL-AM SE Manual (English version)

It is quite common situation on old ASUS mainboards (I had it first time on P5GC-MX/1333 board).

NOTE: GeForce 240 does not support 'Metal' in Mojave (try to play DVD to see manifestation of the problem). You can replace video card with GTX650 Ti (Kepler microarchitecture 600 series cards should work) or GTX710 (with 700 series you should be on alert for example 750 Ti has Maxwell core which is not supported, you need a video card with Kepler core)

1. Metal (API)
2. Supported GPUs

3. Kepler (microarchitecture)

GeForce 600 series (look for code name starting with GK.... -- GeForce Kepler)
GeForce 700 series (look for code name starting with GK.... -- GeForce Kepler)


osx151212

Edited by osx151212

Share this post


Link to post
Share on other sites
36 minutes ago, MaLd0n said:

some log about "coreaudiod" prevent sleep

I tried disconnecting the usb audio amplifier, but didn't help. I tried to quit and force quit coreaudiod process in Activity Monitor, but keeps restarting automatically, so I cannot check if sleep works without it. What else can I do?

Share this post


Link to post
Share on other sites
44 minutes ago, disty69 said:

I tried disconnecting the usb audio amplifier, but didn't help. I tried to quit and force quit coreaudiod process in Activity Monitor, but keeps restarting automatically, so I cannot check if sleep works without it. What else can I do?

after sleep system restart?

Share this post


Link to post
Share on other sites

No, it works fine it doesn't actually sleep. Only the monitor shuts off.

Share this post


Link to post
Share on other sites

Hey, guys! Need your help here, got weird problems with MacOS Sierra on the following hardware: GA-EP45-UD3LR, Xeon L5420, 6gigs 667 RAM and Radeon 7870.

The thing is when I try to boot from USB stick installation doesn't switch from verbose console output to graphic mode normally. It needs to be restarted 3-5 times to finally load language selection page. If I manage to install it at last, system hangs on apple logo after installation - sometimes progress bar just begin to load and stops, sometimes it may hang in a middle, and even in the end.

On the 10th restart Login screen may load normally, or it may be gray, with transparent apple logo on the background. It seems like something blocks the login screen. Or different situation: system loads fast and skips apple logo at all, but login screen still doesn't load normally - its transparent, like something in background block it. When I press any keys it blinks with grey color. Maybe its Finder problem? And sometimes when I enter my password screen doesn't show entered symbols, but hard drive load the system. If I then hold down Ctrl+UpArrow I am able to switch between desktops (which are normal colors, not grayed), but initial screen is still transparent and doesn't let me proceed to OS.

 

Really new to MacOS, so don't know what to do. I tried different bootargs, "-v npci=0x2000 kext-dev-mode=1", tried to change different SMBIOSes, inject ATI and load VBIOS. Even downloaded special DSDT for my MoBo, thought something was wrong with it. Also changed videocard GeForce 9600GT, but got black screen using nvidia injection, nv_disable=1, nvda_drv=1, returned to Radeon.

 

So looking for your adviсe, fellas.

Also want to thank MaLd0n, really great job, man.

Managed to boot into OS from 50th attempt, so send you files :D

 

DSDT F11bios.zip

origin.zip

Send me.zip

 

p.s. Booted system with iMac11.1 id instead of default Clovers' iMac10.1.

p.p.s Using ps/2 keybaord and HDMI display connection.

Edited by fly44

Share this post


Link to post
Share on other sites
On 11/29/2018 at 4:55 PM, disty69 said:

No, it works fine it doesn't actually sleep. Only the monitor shuts off.

no idea, bro

 

On 12/3/2018 at 5:19 PM, fly44 said:

Hey, guys! Need your help here, got weird problems with MacOS Sierra on the following hardware: GA-EP45-UD3LR, Xeon L5420, 6gigs 667 RAM and Radeon 7870.

The thing is when I try to boot from USB stick installation doesn't switch from verbose console output to graphic mode normally. It needs to be restarted 3-5 times to finally load language selection page. If I manage to install it at last, system hangs on apple logo after installation - sometimes progress bar just begin to load and stops, sometimes it may hang in a middle, and even in the end.

On the 10th restart Login screen may load normally, or it may be gray, with transparent apple logo on the background. It seems like something blocks the login screen. Or different situation: system loads fast and skips apple logo at all, but login screen still doesn't load normally - its transparent, like something in background block it. When I press any keys it blinks with grey color. Maybe its Finder problem? And sometimes when I enter my password screen doesn't show entered symbols, but hard drive load the system. If I then hold down Ctrl+UpArrow I am able to switch between desktops (which are normal colors, not grayed), but initial screen is still transparent and doesn't let me proceed to OS.

 

Really new to MacOS, so don't know what to do. I tried different bootargs, "-v npci=0x2000 kext-dev-mode=1", tried to change different SMBIOSes, inject ATI and load VBIOS. Even downloaded special DSDT for my MoBo, thought something was wrong with it. Also changed videocard GeForce 9600GT, but got black screen using nvidia injection, nv_disable=1, nvda_drv=1, returned to Radeon.

 

So looking for your adviсe, fellas.

Also want to thank MaLd0n, really great job, man.

Managed to boot into OS from 50th attempt, so send you files :D

 

DSDT F11bios.zip

origin.zip

Send me.zip

 

p.s. Booted system with iMac11.1 id instead of default Clovers' iMac10.1.

p.p.s Using ps/2 keybaord and HDMI display connection.

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4799 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4799 for VMware.zip". Mount Clover-v2.4k-4799-X64 by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo) New!
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By Gymnae
      Since I'm an NVIDIA user, I won't update until the farce with NVIDIA's web drivers for Mojave is solved - but this guide works already for 10.14
       

      Introduction
      The H370 chipset powers 8th generation Intel Core-i CPUs. Even though the name H370 rings comparable to Z370, the H370 is based on newer silicon. This it also requires some new approaches compared to the Z370. An example would be on-die USB 3.1 and WiFi support.
       
      Since this guide is not a "hold-your-hand-every-step" guide, I assume you know:
      Clover installation and configuration How to create an install medium for MacOS Access and configure the BIOS Have heard of ACPI patching (I'm a newb at this myself)  
      What works
      Sleep (via DSDT edits and emulated NVRAM) On-board Audio (via AppleALC and native AppleHDA) Native power management (without any kext or patch) All USB ports (and only those present are active) iGPU for both acceleration and display dGPU (I'm running an Nvidia GTX 1080)  
      Untested
      NIC --> I'm using WiFi only  
      What doesn't work
      Native NVRAM via AptioMemoryFix.efi DMVT Pre-alloc higher than 64MB (but not necessary)  
      Community additions
      User @Panzerschiffe added a helpful post, altering this guide for user with AMD cards and not needing on-board sound.
      He also runs Mojave, which I don't run yet.
       
       
      Changes to the guide:
      22.5.18: Added SSDT hot-patching to enable sleep, replacing DSDT static patching as an alternative.
      23.5.18: Add iMac18,1 as alternative SMBIOS config for those relying on the iGPU for output
      25.6.18: Added update info
      28.8.18: Small changes for clarity, changed info for afps loading & updated USB patch for 13.6
      04.10.18: Update to Mojave will come once Mojave is more mature
      02.12.18: Removed unnecessary patches, fakepciid and audio patch method & linked to AMD post & added whatevergreen.kext as replacement for previois GPU kexts
       
      1. Installation
      This guide heavy inspired by the work of /u/corpnewt of /r/hackintosh and his (sorta) Vanilla guide
       
      1.1 Create the install media for MacOS
      Follow this, if you are using a Mac to start off with. If you are totally new to MacOS, then please check the basic guide Creation of an installer media in windows or linux
       
      1.2 Install Clover on the install media
      Using the Clover installer, ensure you are installing to the USB medium you are using for the installer.
      Chose the following options, leaving the others on default: 
       
      UEFI driver: AptioMemoryFix UEFI driver: ApfsDriverLoader UEFI booting only Install to ESP  
      You have to get your hands on an apfs.efi. A google search can help, or extracting it from the Installer package. Make sure you procure a version matching the MacOS version you are about to install. Place the apfs.efi in drivers64UEFI.
       
      1.2 Adjust the config.plist for the installer
      You can use the config.plist attached as a guideline, but take a look at it before and at least adjust the SMBIOS - otherwise it won't boot.
      Attention: The attached plist contains audio patches introduced by a post-install step. If you run into problems, you might remove those. It also contains a manual slide value, which should normally not be needed, but works fine for me. It is also tuned for usage with an Nvidia Pascal dGPU as main GPU.
       
      The config you create now should serve you nicely for install and running the system.
       
      Take care of adding the following basics:
      SMBIOS: iMac18,3 - You can generate a serial number via Clover Configurator. The creation of a proper SMBIOS is covered in many guides to good extend Note: If you aim at using the iGPU for output, a user reported that iMac18,1 works better - since iMac18,3 produces sever flicker. Look at the graphics section and adjust the injection for Intel to your situation  
      Fixes

      Patches

      Devices

      Graphics
      Important:
      Change 0x59120003 to 0x59120000 if you don't use a dGPU as your main display Driver and instead use the iGPU for output.
      Also note. SMBIOS iMac18,1 has been reported to work better in this configuration. But 18,3 works fine for me.

      Kernel and Kext patches
       
      1.3 kexts and friends
      Add the supplied SSDT-UAIC.aml to "patched" - it limits the injected USB Ports to the actual number and ports valid for this board.
       
      Required kexts on "Other":
      FakeSMC.kext Whatevergreen.kext Lilu.kext AppleALC.kext IntelMausiEthernet.kext in case you're running Ethernet USBInjectAll.kext with the HCI-300-series-injector.kext --> These two should be installed to /L/E after install  
      We are leaving sound out at the moment, this is something for post-install.
       
      1.4 Check BIOS and install
      You should be ready for install. But before you reboot, please take a look at your BIOS and set it up accordingly (copied from the aforementioned guide and adapted):
      Load Optimized Defaults Disable VT-d setting If your system has Secure Boot Mode, disable it Set OS Type to Windows 8/10 or OtherOS - I have not seen a difference Turn off internal Serial and Parallel port Turn off Network stack for boot Turn off wake-on-lan (for now) Set XHCI Handoff to enabled Don't enable decode over 4G Depending on your GPU, set priority for boot Set internal GPU (iGPU) to enable - not auto or disabled Set DMVT pre-alloc min to 64MB and max to 128MB. For this selection to appear you might need to reboot after setting iGPU to enable Set USB legacy to enabled Activate XMP profile 1 f your Ram has it (mine doesn't and I added the timings manually) Set ERP to enable, disable platform power management (I need to do more research if this could be enabled)  
      I've attached my current BIOS config "hack2". You can place that on a fat32 drive (the EFI partition of your install USB drive might be an idea) and see if it loads. It's made for and with the F2 BIOS.
       
      The install itself should be like other MacOS Hackintosh installs with it several reboots and ensuring to select the correct boot device in Clover.
       
      2. Post-install
       
      2.1 Install clover on target
      This is a no-brainer, but install a fresh copy of Clover on your target medium.
       
      During install select again AptioMemoryFix but also additionally
      EmuVariableUefi-64.efi Install RC scripts on target volume because otherwise NVRAM doesn't seem to work
       
      After the install, copy
      config.plist contents of "Other" content of "patched" to your new clover install.
       
      2.2 Edit ACPI for slumber
      Choose one option, not both. The hot-patch is experimental, but for the moment it is stable.
       
      2.2.1 Edit DSDT
      This is necessary only once on initial install and every time, you edit or upgrade the BIOS. The DSDT.aml attached to this post might work for your system or give you a file to compare to. Don't expect it to work for you, though.
      I won't go into the details of DSDT extraction and patching. There are better guides (the linked guide is a rip-off of rehabman's guide from a different forum). Please follow such a guide to extract your ACPI data.
       
      Locate and disassemble the DSDT with the newest iasl binary you can put your hands on, then open it with MacIASL in its newest version you can find (Hint: Here is a good source) You can check if the version is new enough if MacIASL doesn't throw error upon compiling a freshly extracted DSDT.aml or DSDT.dst
       
      Add rehabmans repo (as per linked guide) and apply the following patches:
      Rename _DSM to _XDSM Fix _WAK Arg0 v2 USB3 _PRW 0x6D Skylake (instant wake) Find the CNVW device and remove the _PWR function there.
       
      Compile the DSDT and place it in "patched".
       
      2.2.2 Use SSDT hot-patching
      Instead of having to re-extract and re-patch the DSDT on every BIOS change or update, Hardware change one can also use ACPI hot-patching.
      It's a combination of config.plist patches and an SSDT, which is hot-patched into the ACPI (if I understand the process correctly)
       
      You need to add this SSDT-GPRW.aml to your Clover folder in the designated position at Clover/ACPI/patched You need to add this patch to your config.plist. It goes into the DSDT patch section  
      Note: This works for me, but the patch removes the _PRW method from all devices in the DSDT. This could have side-effects. So far, I have seen none. At the moment I'm also not applying any other patch, compared with the additional edits I made to the DSDT method before.
       
      2.3 Install kexts to system
      As mentioned in the install section, it's better to follow rehabman's instruction and install USBinjectAll.kext to /L/E:
      sudo cp -R Release/USBInjectAll.kext /Library/Extensions sudo touch /System/Library/Extensions && sudo kextcache -u / 2.4 Enable onboard Audio - Install AppleALC kext
      Make sure your EFI partition is mounted and that you have a vanilla AppleHDA kext available. See below for a guide how to get a vanilla AppleHDA if needed
      Note: Our Audio codec is ALC887 and it's running with layout ID 1.
      Download the newest AppleALC kext from here and install it together with lilu.kext from here into your usual /clover/kexts/others location. Done. No scripts or config.plist patches necessary.
      Add layout ID 1 to config.plist, if it's not there yet:
      <key>Audio</key> <dict> <key>Inject</key> <integer>1</integer> <key>ResetHDA</key> <true/> </dict> If you previously  installed any  audio patches, please follow this guide to "vanilla-ize" your install.
       
      2.4 Optional steps for Graphics
      If you have a dGPU, now it's the time to install its drivers and adjust the config.plist for it. The detaisl are specific to your GPU and thus of scope of this guide. Yet, my supplied config.plist is ready to be used with Nvidia Pascal cards and using the Nvidia web driver.
      Whatevergreen.kext helps with Intel iGPU and NVIDIA dGPU fixes.
       
      At the moment I'm also testing out a special bootflag: 'shikigva=12' to enable faster rendering in Final Cut Pro X. Without whatevergreen.kext and a shikigva bootflag, rendering in final cut seem very slow.
       
      2.4.1 Framebuffers
      If you're facing problems with output from your internal GPU, you can try the framebuffer patches listed by @BackwardMac:
       
       
      3. Updating
      Updating inside 10.3.x/ 10.4.x point updates doesn't require much attention:
      Download the update from the AppStore as any Mac would do Allow the system to reboot Before booting MacOS with Clover, make sure to disable extra drivers for dGPUs which require non-native support. If using an Nvidia dGPU: Remove "nvda_drv=1"  from your boot arguments and disable Nvidia injection If using a non natively supported AMD card, do the same for AMD (I'm not using AMD, thus I cannot be specific) Boot into the newly created Install MacOS partition Repeat this process until the Install partition is gone Boot MacOS again, still following 3., and potentially install updated drivers Your Audio might require re-patching  
      4. ToDo
      Move away from static DSDT patching to SSDT hotpatching --> requires my work Native NVRAM --> requires developer work Audio without AppleHDA patching --> requires developer work  
      5. Thanks to
      @MaLd0nfor helping finding the right way with the DSDT
      @RehabMan, for being a legend and helping me out patching
      @toleda, for audio patches for the 300 series
      /u/corpnewt, for his superb vanilla guide
      @wmchris for his super XPS 9550 guide and introducing me to hot-patching
      @Panzerschiffe for his addition to this guide
      all the developers of clover and it's awesomeness
       
      SSDT-UIAC.aml
       
      DSDT.aml
      hack2
    • By BrianWong11031
      Hi,
      Please help me to enable and use hd 3000 with Mojave.
      I know that I can install some .bundle or .kext files to make it can be enable.
      But it always show an err msg up. "IOConsoleUsers gIOScreenLockState 3 ......"
      I have tried to reinstall the refi drivers and kexts.
      but still not solved this issue.
      I will upload my EFI partition as a zip file below (Google Drive, Because It's bigger than 10 mb).
      Thanks for helping.
      For the details about my hardwares, please see my "About Me" page->Brian's Budget Hackintosh.
      https://drive.google.com/file/d/1E2aFpweYwKzcJj98zRroWSwFLVf5gz62/view?usp=sharing
      Cheers,
      Brian
    • By BrianWong11031
      Hi, my hackintosh won't sleep!
      It often sleeps for 3-5 seconds and auto wakes up.
      sometimes it can't enter the sleep mode even you click the sleep button.
      I have uploaded my DSDT file.
      but I don't know how to patch DSDT.
      If you know how to solve this issue, please help me!
       
      Cheers,
      Brian
      DSDT.aml
×