Jump to content
MaLd0n

[GUIDE] EL Capitan / Sierra / High Sierra / Mojave on Intel LGA 775 motherboards / DSDT

861 posts in this topic

Recommended Posts

Advertisement
44 minutes ago, MaLd0n said:

check whatevergreen;)

 

I used it, but it does not help me, I still get a black screen after boot. Although, during the installation, card normally displayed graphics. 

Share this post


Link to post
Share on other sites
On 9/28/2018 at 11:51 PM, cobradera said:

Looking for a GTX 760 in this case. Thanks!

In case it helps someone, it works natively with a nVidia GTX 760 2G DDR5. 

Edited by cobradera

Share this post


Link to post
Share on other sites

Hi Madlon, i've recently done a clean install of High sierra on my first main Pc in signature.

All is working good except for wake after sleep when i have a black screen and i have to reboot the pc (in sierra 10.12.6 it worked just fine).

I have installed nvidia web drivers and i have used quite the same clover folder configuration of the previous sierra installation.

Here attached my configuration, Can you or anyone give me some help?? thank you in advance

 

have a nice day

 

 

CLOVER.zip

Share this post


Link to post
Share on other sites
15 minutes ago, stefano.85 said:

Hi Madlon, i've recently done a clean install of High sierra on my first main Pc in signature.

All is working good except for wake after sleep when i have a black screen and i have to reboot the pc (in sierra 10.12.6 it worked just fine).

I have installed nvidia web drivers and i have used quite the same clover folder configuration of the previous sierra installation.

Here attached my configuration, Can you or anyone give me some help?? thank you in advance

 

have a nice day

 

 

CLOVER.zip

u can try a darkwake option in clover? 

Share this post


Link to post
Share on other sites
3 hours ago, MaLd0n said:

u can try a darkwake option in clover? 

Any preferences about the value of darkwake? or just trying out some?

thanks

 

EDIT: i have tried darkwake 8 and 10 without success (always bk screen after wake)

 

Don’t know if it helps bue my monitor is connected via Display Port cable to GFX card.

Edited by stefano.85

Share this post


Link to post
Share on other sites
9 hours ago, stefano.85 said:

I use the latest Nvidia web drivers for 10.13.6

and native don't work?

Share this post


Link to post
Share on other sites

Help,

I'm wanna try to install newer version of macOS on my old PC, then i'm download mojave from AppStore then create bootable using mojave patcher program from dosdude and clover then.

 

After succsesfull booting from USB then open disk utility hard drive not showing/detect on there and when os install also (only flashdisk installer showing), before i'm tried make bootable previous version macos and this same problem :'( also

 

But i'm not faced this problem on installer from distro hackintosh zone in Yosemite-Sierra 

 

Now i'm using Sierra zone for while....

 

please anyone explain how to fix this. 

my PC specification :

Intel Core 2 duo e8500

Asus p5k

nVidia 9500gt

 

thanks,

IMG_20181010_231139.jpg

Share this post


Link to post
Share on other sites

ich10fix

Cacu Cantiwa:
Help,

I'm wanna try to install newer version of macOS on my old PC, then i'm download mojave from AppStore then create bootable using mojave patcher program from dosdude and clover then.

 

After succsesfull booting from USB then open disk utility hard drive not showing/detect on there and when os install also (only flashdisk installer showing), before i'm tried make bootable previous version macos and this same problem :'( also

 

But i'm not faced this problem on installer from distro hackintosh zone in Yosemite-Sierra 

 

Now i'm using Sierra zone for while....

 

please anyone explain how to fix this. 

my PC specification :

Intel Core 2 duo e8500

Asus p5k (doesn't have ahci option)

nVidia 9500gt

 

thanks,

Share this post


Link to post
Share on other sites

Before i'm tried make bootable previous version macos vanila (elcap-high sierra) and have same problem,  only yosemite-sierra zone no issue.

 

Share this post


Link to post
Share on other sites
9 hours ago, robif2002 said:

Before i'm tried make bootable previous version macos vanila (elcap-high sierra) and have same problem,  only yosemite-sierra zone no issue.

 

u need check what cause problem

Share this post


Link to post
Share on other sites
and native don't work?

Hi Madlon, i’ve Just tried with the native ones... even with that i have black screen on wake. Thank you


Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Hi Maldon! Installed High Sierra 10.13.6 on my Dell 780 (LGA 775) thank you. It says to post for DSDT if you can help. My files are attached. :D

 

 

SPECS:

High Sierra 10.13.6

Dell Optiplex 780 Mini Tower

Q9400 Core2Quad CPU

AMD 6450 1GB Video Card

Send me iMac.at.net.zip

Edited by bocajoe

Share this post


Link to post
Share on other sites

Hello Mald0n,

 

I hope everything is going well for you. You have made DSDT edits for me in the past for macOS Sierra.

 

I have installed macOS Mojave successfully but I get a black screen at boot. I can overcome that either by using -x boot flag or by deleting AMDRadeonX4000.kext. Therefore I don't have graphics acceleration. Could you please help me with that? Also, runme.app gets in an error loop and cannot finish. I am attaching the error message of runme.app. Thank you.

 

runme error.jpg

Share this post


Link to post
Share on other sites
20 hours ago, bocajoe said:

Hi Maldon! Installed High Sierra 10.13.6 on my Dell 780 (LGA 775) thank you. It says to post for DSDT if you can help. My files are attached. :D

 

 

SPECS:

High Sierra 10.13.6

Dell Optiplex 780 Mini Tower

Q9400 Core2Quad CPU

AMD 6450 1GB Video Card

Send me iMac.at.net.zip

i'll check it

40 minutes ago, disty69 said:

Hello Mald0n,

 

I hope everything is going well for you. You have made DSDT edits for me in the past for macOS Sierra.

 

I have installed macOS Mojave successfully but I get a black screen at boot. I can overcome that either by using -x boot flag or by deleting AMDRadeonX4000.kext. Therefore I don't have graphics acceleration. Could you please help me with that? Also, runme.app gets in an error loop and cannot finish. I am attaching the error message of runme.app. Thank you.

 

 

https://www.youtube.com/watch?v=k9wmIfGLe3A

Share this post


Link to post
Share on other sites
14 minutes ago, MaLd0n said:

try

DSDT.aml.zip

DSDT have a several errors xD

 

Thank you Maldon! I installed the new DSDT and it booted fine. The first thing I tried was putting it to sleep which it did. I tried pressing the spacebar and moving the mouse and it would not wake. I pressed the power button and it woke and went to enter the password but it seemed to have froze. :(

Edited by bocajoe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?f=45&t=9172
       
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM / REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By AppleBytes
      Hello,
      I'm working on a re-install of OSX on a dell inspiron 9400. I was finally able to get a copy of SL on it. But it still needs MUCH work, as the graphics (NVIDIA Geforce Go 7800) isn't properly recognized -- either by model, or installed VRAM.
      It has 512Mb, but only initializes 256Mb VESA.
      Anyway, as a start, I thought it best to use a valid dsdt.dsl for compilation, and start there. I've managed to remove all the warnings, and errors save 2
      OUTPUT:
      # sudo iasl -ta ./dsdt.dslll Intel ACPI Component Architecture ASL Optimizing Compiler version 20110527-64 [May 27 2011] Copyright (c) 2000 - 2011 Intel Corporation ./dsdt.dslll   3519:                                 Return (0x00) Error    4080 -           Invalid object type for reserved name ^  (found INTEGER, requires Buffer) ./dsdt.dslll   3956:                     Return (Package (0x00) {}) Remark   5072 -         Effective AML package length is zero ^ ASL Input:  ./dsdt.dslll - 4997 lines, 158533 bytes, 1633 keywords Compilation complete. 1 Errors, 0 Warnings, 1 Remarks, 577 Optimizations I'm attaching a copy of the above output, and the dsdt.dsl file in a tarball to this post in hopes someone with the required knowledge can help me fix it.
      FWIW
      SMBIOS I'm using indicates this is a MBP 3,1
      cpu: cd2 (T7400 @2.16Ghz)
      graphics: NVIDIA Geforce Go 7800 ( G70M? )
      ram: 4Gb
      dell inspiron 9400 (Laptop)
       
      Thank you for all your time, and consideration!
       
      --Chris
       
      DSDT-DSL.tar
    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f16 --> build 16G2016 (thanks to Cyberdevs) New!
      Nvidia Web Driver - 378.05.05.25f15 --> build 16G1918 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f14 --> build 16G1917 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f13 --> build 16G1815 (thanks to flowrider)
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By Candrahm
      Hi everybody,
       
      I'm new here and French. 
      I success to hack my Asus X751LJ and pass it to High Sierra 10.13.6, not easily, and everything works except the keyboard and the touchpad.
      I tried VoodooPS2Controller, ApplePS2SmartTouchpad, even VoodooI2C, but nothing works...
      Could someone help me? Is there a DSDT problem? Witch kext should I use?
      I post my ACPI and Kexts folders and my IOReg.
      Please... Help me. I'm desperate...
      MacBook Pro de Candrahm.ioreg
      Archive.zip
    • By penghubingzhou
      URL:https://github.com/penghubingzhou/VoodooI2C-DSDT
       
      VoodooI2C-DSDT is a repository that is aiming at collecting various successful DSDTs for Voodoo I2C.
      Purpose
      The purpose of this repository is to provide some useful code examples for people who haven't yet make Voodoo I2C work. Maybe It don't have your model of laptop, but code in this repository may have some help and references for you.
      Note that the code in this repository is ONLY FOR REFERENCES and it can‘t replace your own work!
      For Submission
      This repository welcomes everyone to submit DSDT code examples that have successfully made VoodooI2C work by PR. To submit your example, please put the DSDT file (or Hotpatch SSDT file), an ioreg without Voodoo I2C installed, and Info.txt in a folder named by your laptop model. Info.txt should include:
      Your CPU model (better for including CPU platform)
      Your touchpad Device ID
      The mode you use (GPIO interrupt or polling)
      Satellite Driver You Use
      Then, fork this repository and clone it, put your file in and commit it to your repository. After checking the conflicts, you can send your commit as a PR to me.
      An example for submitting can be found in Lenovo Xiaoxin Chao 7000-14.
      Credits
      @Alexandred for VoodooI2C @daggeryu for the idea in this repository @penghubingzhou and @williambj1 for maintaining
×