Jump to content
MaLd0n

[GUIDE] EL Capitan / Sierra / High Sierra / Mojave / Catalina on Intel LGA 775 motherboards / DSDT

877 posts in this topic

Recommended Posts

send me error photo

It's the same screen, I don't think it's useful, just enumarate kexts I think.

I'll try to get a boot log because it writes more very fast before this screen and then reboot, I used Don't reboot on panic to take the photo.

 

Edit: What the.... I just booted without dsdt and it actually booted... Clover folder is the one I sent you PM yesterday but without dsdt... that's very very weird.

Edit2: I found the trick, when I check InjectNvidia in clover I get the weird kp, if I uncheck it the system boots.

I'll put again your post clover and run runme.app and send you the file.

Edit3: Attached SendMe.zip

Send me LuCys-Mac-Pro.zip

Share this post


Link to post
Share on other sites
Advertisement

It's the same screen, I don't think it's useful, just enumarate kexts I think.

I'll try to get a boot log because it writes more very fast before this screen and then reboot, I used Don't reboot on panic to take the photo.

 

Edit: What the.... I just booted without dsdt and it actually booted... Clover folder is the one I sent you PM yesterday but without dsdt... that's very very weird.

Edit2: I found the trick, when I check InjectNvidia in clover I get the weird kp, if I uncheck it the system boots.

I'll put again your post clover and run runme.app and send you the file.

Edit3: Attached SendMe.zip

@MaLd0n can you help me? Sorry for bothering you..

Share this post


Link to post
Share on other sites

back ur old DSDT, have a GPU patch and work ;) if clover fail with ur GPU...

Sorry I don't understand what you mean..

You tell me to use my old clover with dsdt? and what gpu patch?

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites

here

Device (PEGP)
            {
                Name (_ADR, 0x00010000)  // _ADR: Address
                Device (GFX0)
                {
                    Name (_ADR, Zero)  // _ADR: Address
                    Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                    {
                        Store (Package (0x1E)
                            {
                                "AAPL,slot-name", 
                                Buffer (0x07)
                                {
                                    "Slot-1"
                                }, 

                                "@0,compatible", 
                                Buffer (0x0B)
                                {
                                    "NVDA,NVMac"
                                }, 

                                "@0,connector-type", 
                                Buffer (0x04)
                                {
                                     0x00, 0x08, 0x00, 0x00                         
                                }, 

                                "@0,device_type", 
                                Buffer (0x08)
                                {
                                    "display"
                                }, 

                                "@0,name", 
                                Buffer (0x0F)
                                {
                                    "NVDA,Display-A"
                                }, 

                                "@1,compatible", 
                                Buffer (0x0B)
                                {
                                    "NVDA,NVMac"
                                }, 

                                "@1,connector-type", 
                                Buffer (0x04)
                                {
                                     0x00, 0x08, 0x00, 0x00                         
                                }, 

                                "@1,device_type", 
                                Buffer (0x08)
                                {
                                    "display"
                                }, 

                                "@1,name", 
                                Buffer (0x0F)
                                {
                                    "NVDA,Display-B"
                                }, 

                                "NVCAP", 
                                Buffer (0x18)
                                {
                                    /* 0000 */  0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x03, 0x00,
                                    /* 0008 */  0x0C, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x07,
                                    /* 0010 */  0x00, 0x00, 0x00, 0x00                         
                                }, 

                                "VRAM,totalsize", 
                                Buffer (0x04)
                                {
                                     0x00, 0x00, 0x00, 0x10                         
                                }, 

                                "device_type", 
                                Buffer (0x0C)
                                {
                                    "NVDA,Parent"
                                }, 

                                "model", 
                                Buffer (0x17)
                                {
                                    "NVIDIA GeForce 8600 GT"
                                }, 

                                "rom-revision", 
                                Buffer (0x1E)
                                {
                                    "nVidia 8600 GT OpenGL Engine"
                                }, 

                                "hda-gfx", 
                                Buffer (0x0A)
                                {
                                    "onboard-1"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }
            }

Share this post


Link to post
Share on other sites

 

here

Device (PEGP)
            {
                Name (_ADR, 0x00010000)  // _ADR: Address
                Device (GFX0)
                {
                    Name (_ADR, Zero)  // _ADR: Address
                    Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                    {
                        Store (Package (0x1E)
                            {
                                "AAPL,slot-name", 
                                Buffer (0x07)
                                {
                                    "Slot-1"
                                }, 

                                "@0,compatible", 
                                Buffer (0x0B)
                                {
                                    "NVDA,NVMac"
                                }, 

                                "@0,connector-type", 
                                Buffer (0x04)
                                {
                                     0x00, 0x08, 0x00, 0x00                         
                                }, 

                                "@0,device_type", 
                                Buffer (0x08)
                                {
                                    "display"
                                }, 

                                "@0,name", 
                                Buffer (0x0F)
                                {
                                    "NVDA,Display-A"
                                }, 

                                "@1,compatible", 
                                Buffer (0x0B)
                                {
                                    "NVDA,NVMac"
                                }, 

                                "@1,connector-type", 
                                Buffer (0x04)
                                {
                                     0x00, 0x08, 0x00, 0x00                         
                                }, 

                                "@1,device_type", 
                                Buffer (0x08)
                                {
                                    "display"
                                }, 

                                "@1,name", 
                                Buffer (0x0F)
                                {
                                    "NVDA,Display-B"
                                }, 

                                "NVCAP", 
                                Buffer (0x18)
                                {
                                    /* 0000 */  0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x03, 0x00,
                                    /* 0008 */  0x0C, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x07,
                                    /* 0010 */  0x00, 0x00, 0x00, 0x00                         
                                }, 

                                "VRAM,totalsize", 
                                Buffer (0x04)
                                {
                                     0x00, 0x00, 0x00, 0x10                         
                                }, 

                                "device_type", 
                                Buffer (0x0C)
                                {
                                    "NVDA,Parent"
                                }, 

                                "model", 
                                Buffer (0x17)
                                {
                                    "NVIDIA GeForce 8600 GT"
                                }, 

                                "rom-revision", 
                                Buffer (0x1E)
                                {
                                    "nVidia 8600 GT OpenGL Engine"
                                }, 

                                "hda-gfx", 
                                Buffer (0x0A)
                                {
                                    "onboard-1"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }
            }

I already have this in my old dsdt, so the sleep can't be fixed?

Share this post


Link to post
Share on other sites

if sleep problem is related to GPU, idk

I don't know if is related to gpu, with an ati hd 5870 the problem was the same and I have a laptop with Nvidia 130m and same problem, on Sierra sleep is ok but hs don't wake.

I think it's something related to ich chipsets.

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites

So, if the sleep can't be fixed I have one last problem with audio.

I have ALC1200 with AppleALC and layout-id 7.

On the rear panel I have 6 jacks: green, black and orange are working as output; pink is working as input; gray and blue aren't working but I don't need them anyway.

On the front panel I have green(headphones) and pink(mic) which aren't working at all.

My question is: How can I make front panel to work?

Share this post


Link to post
Share on other sites

So, if the sleep can't be fixed I have one last problem with audio.

I have ALC1200 with AppleALC and layout-id 7.

On the rear panel I have 6 jacks: green, black and orange are working as output; pink is working as input; gray and blue aren't working but I don't need them anyway.

On the front panel I have green(headphones) and pink(mic) which aren't working at all.

My question is: How can I make front panel to work?

http://olarila.com/forum/viewtopic.php?f=28&t=2676

Share this post


Link to post
Share on other sites

Yes, is possible, but no fast way

Your tutorial seems to be very complicated to me :D

What other ways I have?

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites

u can try a AppleHdaPatcher by Mirone

 

I'm trying with AppleHDAPatcher by Mirone with ALC888 because I see ALC1200 is actually 888 but I can't get sound at all...

 

I'll try your tutorial but I don't have linux.

Share this post


Link to post
Share on other sites

I found layout.xml and platforms.xml for my board and I compiled AppleALC and added another layout-id, now my headphones front panel works but I don't know how to make them hot-plug, you have any idea? I mean I permanently have my speakers in rear panel green jack and when I connect headphones on front panel(green) to switch automatically to headphones.

Share this post


Link to post
Share on other sites

I found layout.xml and platforms.xml for my board and I compiled AppleALC and added another layout-id, now my headphones front panel works but I don't know how to make them hot-plug, you have any idea? I mean I permanently have my speakers in rear panel green jack and when I connect headphones on front panel(green) to switch automatically to headphones.

no idea, need check in AppleAlc topic, i think ppl share xD

Share this post


Link to post
Share on other sites

Hi MaLd0n, I'm from Poland :D

 

Spec:

 

MOBO: ASUS P5N-E SLI (nForce 650i SLI) (LEGACY BIOS)
CPU: QuadCore Intel Xeon E5450
GPU: nVIDIA GeForce GTX 750 Ti
RAM: 8 GB (DDR2-800 (400 MHz) DDR2 SDRAM
Ethernet: nVIDIA nForce 430i (MCP51)
Wi-Fi: No
Audio: nVIDIA HDMI/DP @ nVIDIA GM107 - High Definition Audio Controller

 

post-2396156-0-53907700-1518711846_thumb.jpg

 

My problem is:

 

When I want install High Sierra without NullCPUPowerManagement.kext, I got this panic:

 

post-2396156-0-75528000-1518713242_thumb.jpg

 

When I install with this kext, my computer does not want to reboot.

 

Problem video:

 

https://drive.google.com/file/d/1jFH93TgFHNJ7PTD6A81XHidpltbZpRLv/view

 

A message appears and nothing else happens:

 

post-2396156-0-64784400-1518712320_thumb.jpg

 

Then I must restart PC with restart button.

 

This is my: DSDT and SSDT from Clover F4 ;) DSDT + SSDT.zip

 

This is my: RunMe file: Send me Mac-Endriu.zip

 

I tried many settings in config.plist and still the same.

 

Now my config it has only "Boot" options, the other tabs are default.

 

post-2396156-0-11161100-1518712872_thumb.jpg

 

My config.plist: config.zip

 

Please help me, I do not know how to fix this restart ;)

Share this post


Link to post
Share on other sites

Hi MaLd0n, I'm from Poland :D

 

Spec:

 

MOBO: ASUS P5N-E SLI (nForce 650i SLI) (LEGACY BIOS)

CPU: QuadCore Intel Xeon E5450

GPU: nVIDIA GeForce GTX 750 Ti

RAM: 8 GB (DDR2-800 (400 MHz) DDR2 SDRAM

Ethernet: nVIDIA nForce 430i (MCP51)

Wi-Fi: No

Audio: nVIDIA HDMI/DP @ nVIDIA GM107 - High Definition Audio Controller

 

attachicon.gif123.jpg

 

My problem is:

 

When I want install High Sierra without NullCPUPowerManagement.kext, I got this panic:

 

attachicon.gif20180215_161828.jpg

 

When I install with this kext, my computer does not want to reboot.

 

Problem video:

 

https://drive.google.com/file/d/1jFH93TgFHNJ7PTD6A81XHidpltbZpRLv/view

 

A message appears and nothing else happens:

 

attachicon.gif20180210_202018.jpg

 

Then I must restart PC with restart button.

 

This is my: DSDT and SSDT from Clover F4 ;)attachicon.gifDSDT + SSDT.zip

 

This is my: RunMe file: attachicon.gifSend me Mac-Endriu.zip

 

I tried many settings in config.plist and still the same.

 

Now my config it has only "Boot" options, the other tabs are default.

 

attachicon.gif1.jpg

 

My config.plist: attachicon.gifconfig.zip

 

Please help me, I do not know how to fix this restart ;)

try

DSDT.aml.zip

Share this post


Link to post
Share on other sites

I'm sr @MaLd0n  :D

u put clover/acpi/patched :P

xD Welcome!

Ok :D

I must run installation with nullcpupowermanagement.kext or without? ;)

install u can use NULL, after install in SSD/HDD we remove it for Power Management

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      Install MacOS with Olarila Image, Step by Step, Install and Post Install  
      https://www.olarila.com/topic/5794-hackintosh-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Install Sierra/High Sierra and boot into system!   Post Installation   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.GA H110M-S2.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By DOGER92
      Hi guys, I'm new to the world of Hackintosh. I write in this section because I have a problem with the graphics card of my laptop. As far as I understand from the web, it is not possible to use a dedicated graphics card on a laptop. So I'm trying to use the integrated processor one. The problem is that I have tried various procedures seen online, but in spite of this I cannot solve the problem. If you need this is the equipment of my laptop:

      Asus VivoBook Pro 15 N580VD-FI038T

      Screen: Led 15.6” 16:9 (Ultra HD 3480x2160).
      Chipset: Intel HM175.
      Cpu: Intel Core i7-7700HQ (2.80 GHz / 3.80 GHz, 4 core, 6 MB CACHE L3).
      Graphics Card: INTEL HD Graphics 630 + NVIDIA GeForce GTX 1050 4 GB GDDR5.
      Hard Disk: SSD M.2 512 GB SATA 3.0 + SSD 750GB.
      Ram: 32GB DDR4-2666.
      Audio: audio stereo Harman Kardon.
      Webcam: webcam HD with integrated headphone.
      Lan: Intel LAN 10/100/1000, Wi-Fi 802.11ac (2x2), Bluetooth 4.2.
      USB: 2 x USB 2.0, 1 x USB 3.0, 1 x USB 3.1 Type-C Gen 1, 1 x HDMI, 1 x LAN RJ-45, 1 x jack
      Slot: 1 x SD.

      I hope there is someone who can help me with this problem
    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on Catalina 10.15.4 and Clover EFI 5104 (Catalina Patcher)
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman Voodoo PS2 Controller (here) acidanthera AppleALC (here) acidanthera Lilu (here) acidanthera VirtualSMC (here) acidanthera SMCBatteryManager (here) acidanthera SMCLightSensor (here) acidanthera WhateverGreen (here) Mieze Realtek RTL8111 (here)
    • By Prasanth_1991
      I recently installed Hackintosh Sierra. I don't have dedicated graphics card so I just used Intel integrated graphics which is Intel HD 4600 but since the Mac OS Sierra graphics acceleration not supported by native VGA output I'm left out options. I tired many things but nothing works. It's 2020 I'm pretty sure many people probably have better solution for this, if yes please help me.   Details PC Spec  i7 4790k HD 4600 Motherboard Gigabyte B85M-D3H-A
×