Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave on Intel 5, 6, 7, 8, 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

2,277 posts in this topic

Recommended Posts

Hello :)

 

I've just installed Mojave 10.14.2 on my build:

MSI Z77A-G43 (Ivy Bridge)
Intel Xeon E3-1230v2
Radeon R9 280X 3GB
SSD 256GB SATA3

 

Would you like to check my config?
I'm attaching the folder created with the RunMe app

 

Thank you,
Kind regards

Send me Z77A-OSX.zip

Share this post


Link to post
Share on other sites
Advertisement
18 hours ago, rocky376 said:

Hello :)

 

I've just installed Mojave 10.14.2 on my build:

MSI Z77A-G43 (Ivy Bridge)
Intel Xeon E3-1230v2
Radeon R9 280X 3GB
SSD 256GB SATA3

 

Would you like to check my config?
I'm attaching the folder created with the RunMe app

 

Thank you,
Kind regards

Send me Z77A-OSX.zip

DSDT.aml.zip

CLOVER FOLDER

https://olarila.com/forum/viewtopic.php?f=28&t=8222

7 hours ago, nemois said:

Hi MaLd0n, can you helpme with my DSDT and config... thanks!!

Send me iMac.zip

RUN UPDATED APP

RunMe.app

Share this post


Link to post
Share on other sites

 

9 hours ago, MaLd0n said:

 

Thank You very much :D

My computer works great now, I have only problems with sleep&wake.

PC is going to sleep normally but when waked up, there are some issues like: black screen / login screen and freeze / very, very slow performance.

 

This is not a very big thing - I can handle without sleep&wake but I would be grateful if you could take a look.

I'm attaching new files, generated after changes.

 

Kind regards :)

Send me Z77A-OSX.zip

Share this post


Link to post
Share on other sites
On 1/9/2019 at 2:42 PM, rocky376 said:

 

 

Thank You very much :D

My computer works great now, I have only problems with sleep&wake.

PC is going to sleep normally but when waked up, there are some issues like: black screen / login screen and freeze / very, very slow performance.

 

This is not a very big thing - I can handle without sleep&wake but I would be grateful if you could take a look.

I'm attaching new files, generated after changes.

 

Kind regards :)

Send me Z77A-OSX.zip

i think is a gpu problem

Share this post


Link to post
Share on other sites
22 hours ago, nemois said:

This is the new one, my config its the next...

 

GA-Z77X-UP4 TH
i7 3770k

Mining RX 470 (tint Pink Screen) only 1 port DVI (with Whatevergreen only pink screen)

Send me iMac.zip

DSDT.aml.zip

Share this post


Link to post
Share on other sites
4 hours ago, MaLd0n said:

Thanks...
i can fix the Pink Screen with... http://www.mathewinkson.com/2013/03/force-rgb-mode-in-mac-os-x-to-fix-the-picture-quality-of-an-external-monitor
I don't have Second display by iGPU, I have only one video output in my RX470, I don't have HDMI AUDIO by RX470, I don't have QuickSync,  I think my config.cfg it's a mess, can you help me with my config.plist file?

Thanks in Advance...

config.plist

Share this post


Link to post
Share on other sites
9 hours ago, MaLd0n said:

i think is a gpu problem

Hello, I did some research and I found that R9 280X have wake issues, and I don't have iGPU in my processor  - so, everything is clear :)

Thank you very much for your support :)

 

Kind regards. 

 

Share this post


Link to post
Share on other sites
13 hours ago, nemois said:

Thanks...
i can fix the Pink Screen with... http://www.mathewinkson.com/2013/03/force-rgb-mode-in-mac-os-x-to-fix-the-picture-quality-of-an-external-monitor
I don't have Second display by iGPU, I have only one video output in my RX470, I don't have HDMI AUDIO by RX470, I don't have QuickSync,  I think my config.cfg it's a mess, can you help me with my config.plist file?

Thanks in Advance...

config.plist

idk about hardware accel in ur hardware, never use it

Share this post


Link to post
Share on other sites

Hi Mald0n,

would you help me with my DSDT and config ?

I've just updated to 10.14.2 and my USB3 ports don't work.

I have a 4790K on a Gigabyte z97x ud5h motherboard, and a sapphire pulse RX580 8GB.

Thanks a lot

magoz

Send me rickys-iMac.zip

Edited by magoz
update

Share this post


Link to post
Share on other sites
2 hours ago, magoz said:

Hi Mald0n,

would you help me with my DSDT and config ?

I've just updated to 10.14.2 and my USB3 ports don't work.

I have a 4790K on a Gigabyte z97x ud5h motherboard, and a sapphire pulse RX580 8GB.

Thanks a lot

magoz

Send me rickys-iMac.zip

DSDT.aml.zip

use my clover folder or ur usbs dont work

https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip

 

after u need a excluded unused ports

https://olarila.com/forum/viewtopic.php?p=65287#p65287

Share this post


Link to post
Share on other sites

Hi MaLd0n,

 

Happy new year to you bro! Hope you are well!

 

Had a bit more progress with my Lenovo t470s - upgraded to 10.14.2 and things a lot better and smoother now.

 

May I ask you take a look at the run me files and offer any assistance (trackpad and battery specifically)

Send me Macbooks-MacBook-Pro.zip

Many thanks

Share this post


Link to post
Share on other sites
1 hour ago, Dan_Marshall said:

Hi MaLd0n,

 

Happy new year to you bro! Hope you are well!

 

Had a bit more progress with my Lenovo t470s - upgraded to 10.14.2 and things a lot better and smoother now.

 

May I ask you take a look at the run me files and offer any assistance (trackpad and battery specifically)

Send me Macbooks-MacBook-Pro.zip

Many thanks

DSDT.aml.zip

check if battery work

 

trackpad is just a kext, u use last voodoops2?

 

Share this post


Link to post
Share on other sites
26 minutes ago, MaLd0n said:

DSDT.aml.zip

check if battery work

 

trackpad is just a kext, u use last voodoops2?

 

Hi mate,

 

Big step - battery status is showing! However, showing at 0% (not charging even though plugged in).

 

Also new DSDT broke sound - no control over volume and unable to adjust.

 

Trackpad is now working in sys prefs, still a little jumpy but not as much as before however can be adjusted in sys prefs.

 

New voodoo installed and seems to be better

 

New dump files 

Send me Macbooks-MacBook-Pro.zip

Edited by Dan_Marshall

Share this post


Link to post
Share on other sites
9 hours ago, Dan_Marshall said:

Hi mate,

 

Big step - battery status is showing! However, showing at 0% (not charging even though plugged in).

 

Also new DSDT broke sound - no control over volume and unable to adjust.

 

Trackpad is now working in sys prefs, still a little jumpy but not as much as before however can be adjusted in sys prefs.

 

New voodoo installed and seems to be better

 

New dump files 

Send me Macbooks-MacBook-Pro.zip

audio inject via clover

 

battery check in rehabman repo, have a good tutorial too

 

 

Share this post


Link to post
Share on other sites

Hi @MaLd0n

Can you please take a look at my system

Thanks

Mac OS 10.12.4

Laptop Model: HP 240 G5   

CPU: Intel Core i5 6200U
          Socket 1168 BGA
Motherboard: HP 81DB
Memory: 8G DDR3
Graphic: Intel HD Graphics 520
               1366x768 Monitor
Audio & Microphone: ALC282 @ Intel Sunrise Point-LP PCH
Touchpad: HP ELAN Touchpad
Network: 802.11n Broadcom
Bluetooth: Broadcom 43142
 
 
I have tried your method of installing mojave, but when i try to install, it stops and then says panic, panic.apple.com
The first version of clover folder, its the one when i followed your guide step by step, and after flashing usb drive, it has that folder.
The second version, i also followed your guide step by step, but took some advice from another guide(https://www.tonymacx86.com/threads/guide-hp-probook-430-g3-skylake-mojave.256770/) from a notebook that has similiar specs to mine, but i only modified cetain kext files that in that guide told me to modify.
In both cases it goes to panic.
Please help me.

CLOVER(version1).rar

CLOVER(version2).rar

Share this post


Link to post
Share on other sites
On 1/12/2019 at 3:25 PM, MaLd0n said:

Thank you very much. I'll give it a try this evening.

What SMBios do you suggest ? I'm currently on iMac 14,2 but macpro 5,1 seems better to other guys...

Edited by magoz
update

Share this post


Link to post
Share on other sites

Hello and thanks for the work you do for the community!!  I hope you could help me here....I have to replace my z270 and i7 7700k on a working Sierra 10.12.6 system , and I was thinking on a z390 and i7 9700k.. would those work on Sierra 10.12.6? or I have to upgrade to H sierra or Mojave? my problem is the gtx 1080 , that with Sierra work perfectly.... and i haven't really understood yet it would work well on high Sierra and mojave because of the driver.... and actually if it would be possible to stay on my system 10.12.6 without much trouble after the hardware upgrade it could save me lot of stress.............  I'm a bit lost here....   could you lend me a hand??!!

Share this post


Link to post
Share on other sites
3 hours ago, Redragon12 said:

Hello and thanks for the work you do for the community!!  I hope you could help me here....I have to replace my z270 and i7 7700k on a working Sierra 10.12.6 system , and I was thinking on a z390 and i7 9700k.. would those work on Sierra 10.12.6? or I have to upgrade to H sierra or Mojave? my problem is the gtx 1080 , that with Sierra work perfectly.... and i haven't really understood yet it would work well on high Sierra and mojave because of the driver.... and actually if it would be possible to stay on my system 10.12.6 without much trouble after the hardware upgrade it could save me lot of stress.............  I'm a bit lost here....   could you lend me a hand??!!

use high sierra 10.13.6

Share this post


Link to post
Share on other sites
On 1/14/2019 at 12:38 AM, primetrack said:

Hi @MaLd0n

Can you please take a look at my system

Thanks

Mac OS 10.12.4

Laptop Model: HP 240 G5   

CPU: Intel Core i5 6200U
          Socket 1168 BGA
Motherboard: HP 81DB
Memory: 8G DDR3
Graphic: Intel HD Graphics 520
               1366x768 Monitor
Audio & Microphone: ALC282 @ Intel Sunrise Point-LP PCH
Touchpad: HP ELAN Touchpad
Network: 802.11n Broadcom
Bluetooth: Broadcom 43142
 
 
I have tried your method of installing mojave, but when i try to install, it stops and then says panic, panic.apple.com
The first version of clover folder, its the one when i followed your guide step by step, and after flashing usb drive, it has that folder.
The second version, i also followed your guide step by step, but took some advice from another guide(https://www.tonymacx86.com/threads/guide-hp-probook-430-g3-skylake-mojave.256770/) from a notebook that has similiar specs to mine, but i only modified cetain kext files that in that guide told me to modify.
In both cases it goes to panic.
Please help me.

CLOVER(version1).rar

CLOVER(version2).rar

Your HP Lappy is closely related to my HP EliteBook G3.. Try this clover and replace with yours..

CLOVER.zip

Share this post


Link to post
Share on other sites

Hello I'm trying to do fresh install of Mojave on Intel DX79SI and need help. Previous install was with Mavericks but after trying to extract DSDT while in clover boot menu I screwed it((. Now can't even boot into old build. When I'm trying to boot into Mojave external installer sometimes I get freeze Apple logo and progress bar, sometimes closed circle. I have successfully created USB drive UEFI Boot Mode with Graphics configuration for nVidia. Could you please help me figure out how can I boot into OSX installer? What boot flags should I use? Thank you in advance! Can some one help me please. Work computer with current job in 3D. Thank you in advance.

 

Intel DX79SI Logic Board
CPU Intel 3.2 GHz
NVIDIA GeForce GTX 680 2048 MB
16 GB 1600 MHz DDR3
SSD 120 GB

 

IMG_0742.JPG

Edited by ak-78
updates

Share this post


Link to post
Share on other sites

Hello Maldon. A little over a year ago you helped me make a dsdt and work some bugs out of my hackintosh. (Page 28 of this thread) I'm still on the same system but i just installed an XFX RX 480 gfx card and need my dsdt edited. In the attachment are the dsdt you made a year ago, and the ssdt's I made and found for my board. Included is the new IOREG dump and my current config file. Speedstep, turbo boost, and system temps are all ok in Intel Speed Gadget. I'm still on 10.12.6, but now that I have Metal support with the RX 480 I will probably install High Sierra soon. Thanks.

for maldon.zip

Share this post


Link to post
Share on other sites

Hi @MaLd0n

 

Since macOS 10.13.6 and now under macOS 10.14.3, I've got a issue with my patched DSDT: Mojave restart randomly at first boot. I have to reboot several times to get a normal startup. Rebuilding don't solve the problem.

 

Could you take a look on my patched DSDT. Please.

 

Thanks

 

Sorry for my bad english

DSDT.aml.zip

Share this post


Link to post
Share on other sites
On 1/23/2019 at 4:30 PM, ak-78 said:

Hello I'm trying to do fresh install of Mojave on Intel DX79SI and need help. Previous install was with Mavericks but after trying to extract DSDT while in clover boot menu I screwed it((. Now can't even boot into old build. When I'm trying to boot into Mojave external installer sometimes I get freeze Apple logo and progress bar, sometimes closed circle. I have successfully created USB drive UEFI Boot Mode with Graphics configuration for nVidia. Could you please help me figure out how can I boot into OSX installer? What boot flags should I use? Thank you in advance! Can some one help me please. Work computer with current job in 3D. Thank you in advance.

 

Intel DX79SI Logic Board
CPU Intel 3.2 GHz
NVIDIA GeForce GTX 680 2048 MB
16 GB 1600 MHz DDR3
SSD 120 GB

 

 

check

https://olarila.com/files/Clover.Folder/CLOVER.X79.zip

 

IN SOME CASES X79 NEED A DSDT PATCH FOR INSTALL

On 1/23/2019 at 7:25 PM, mikey1953 said:

Hello Maldon. A little over a year ago you helped me make a dsdt and work some bugs out of my hackintosh. (Page 28 of this thread) I'm still on the same system but i just installed an XFX RX 480 gfx card and need my dsdt edited. In the attachment are the dsdt you made a year ago, and the ssdt's I made and found for my board. Included is the new IOREG dump and my current config file. Speedstep, turbo boost, and system temps are all ok in Intel Speed Gadget. I'm still on 10.12.6, but now that I have Metal support with the RX 480 I will probably install High Sierra soon. Thanks.

for maldon.zip

i posted in Olarila, check there

7 hours ago, Matgen84 said:

Hi @MaLd0n

 

Since macOS 10.13.6 and now under macOS 10.14.3, I've got a issue with my patched DSDT: Mojave restart randomly at first boot. I have to reboot several times to get a normal startup. Rebuilding don't solve the problem.

 

Could you take a look on my patched DSDT. Please.

 

Thanks

 

Sorry for my bad english

DSDT.aml.zip

post a full dump

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ltooz_audis
      I always want to have a long lasting battery ultrabook to install Mojave on. I was looking at Dell XPS 13 but its design is not very good with the camera and other problems. HP Spectre x360 is a nice design but the wifi module is soldered on board. The Envy 13" is the best one in the bunch for MacOS Mojave. I would not use any other macOS besides Mojave, it's the best one so far. If you can't get it done with macOS Mojave, you don't do it correctly, it's much more refined and given than older macOS's.
      I wanted the 8th generation because of the 4 cores which is almost 1.5 times faster than this 7th generation i7-7500u, but the price is too high. I picked up this one on Craigslist for $400. I've just ordered the 500GB NVME WD Black for $104 and DW1560 for $29. So, the perfect MacBook Pro 14,2 is less than $600 that last 5-6 hours with Mojave and 8-9 hours on Windows 10. The bench mark is the same as the real MacBookPro 14,2. BTW, this is the first try, there will be on going testing and confirming. 250GB hard drive is hardly enough for dual boot Windows and Mac. You need at least 500GB, I don't use Windows at all, so I'll partition 200GB for Windows and 300GB for Mojave.
      All new HP laptops will have kernel panic if using Clover to boot UEFI, at least a fix was found. I'll have more videos and info when I have time to write them. Watch the videos and ask questions if you have any problems.
      1. Clover 4558 - Lilu.kext (1.3.3) - AppleALC.kext (1.3.1) - Whatevergreen.kext (1.2.3) - USBInjectAll.kext (0.6.5) - Fakesmc.kext (6.25-332-gf3a8525c.1758) - ACPIBatteryManager.kext (1.81.4) - AHCIPortInjector.kext - BrcmFirmwareRepo.kext (2.2.7) - BrcmPatchRAM2.kext (2.2.7) - CodecCommander.kext (2.6.2) - FakePCIID_Broadcom_WiFi.kext (1.3.9) - FakePCIID_Intel_HD_Graphics.kext (1.3.9) - FakePCIID.kext (1.3.9) - SSDT-AUIC-ALL.aml - SSDT-USBX.aml - SSDT-PNLF.aml - SSDT-PluginType1.aml - PreLoader.efi.
      2. For the keys F2 & F3 to work with backlight slider - the Fakesmc.kext version is important for some reasons, I'm still trying to find out why.
      The touchscreen actually works without the voodooI2C kexts, just need to patch the clover.
       
      I've been playing with the laptop for over a week now. Ordered the WD 500GB WDS500G2X0C from Amazon for $104, the 256GB is too small for dual booting Windows 10 & Mojave. It's really plug and play.
       
      Hardware - needed to make this a perfect macbook Pro14,2.
      1. DW1560 BCM94352Z - make sure it has 2 notches - Tape the 2 right pins on the 4 pins tab for it to work without a hitch on both Windows 10 and Mojave. You can buy from Ebay cheaper but you have to wait for months.
      2. 500GB NVMe SSD m.2 connector M is a must for dual boot - the cheaper one will be slower - Crucial NVMe 500GB is $25 less than WD.
      3. NOVOO USB-C to HDMI hub that works and inexpensive.
       
      Let's start to get this Kaby Lake working on the HP - I believe HP has the same components for similar configuration on different models. In order to get Mojave to work on Intel Laptop, we need a few important components - Sound is important (look for Realtek - ALC295) - Ethernet if any -Realtek - Trackpad  and TouchScreen (Synaptics or Elan).
       
      REPLACE VNMe SSD HARD DRIVE and DW1560 BCM94352Z
       
      The current BIOS is F22, the newest one is F27 but I don't want to update since it's working well. Since I don't really need the original Windows 10 with Junk software in it, I install the latest Windows 10 using Media Creation USB Boot Drive. The important thing is we have to prepare the SSD correctly or our EFI folder will only be set at 100MB which is not enough to install Clover or any other boot loaders. So instead of letting the Windows installer to create the EFI folder automatically, we can set the size ourselves using "diskpart" command. In order to use diskpart, we need to boot with Windows 10 USB installer (hit F9 then select UEFI USB installer) - select system repair and not installation - then select command prompt, from here we can create EFI folder and MSR for Windows installer to install. The product ID is already in the UEFI bios, so we don't really have to manually activate the Windows 10.

       
       
      diskpart
      select disk 0
      clean
      convert gpt
      create partition efi=300 !!! you can change it from 300MB to any size.
      format quick fs=fat32 label="EFI"
      create partition msr size=16
      exit

      After exit, reboot with the USB installer again in UEFI mode, select the custom. The Windows installer will select the 300MB EFI folder we've just created.
       
       
      How to fix KP on Clover UEFI Boot.
       
       
      This is the macBook Pro 14,2 from HP 13-ad010nr
       
       
       
      Louis
       
    • By yehia2amer
      Problem:
      When I Attempt to wake my Machine from sleep, the screen stays black, although the computer is obviously awake !
      This Machine has a 1300W Power Supply So Sleep is Very Useful.
       
      I Tried:
      1) FIX_WAK and FixShutdown as per Clover Wiki.
      2) Although I am using "SAPPHIRE Radeon PULSE RX 580 8GB GDDR5", which Should be completely Supported by Mojave, I Also changed the Part Number to "113-4E353BU-O4E" as per this Guide: http://www.xlr8yourmac.com/archives/feb18/RadeonRX-580_MacPro.html. The GPU is working GREAT without even Clover Inject
      3) Tried to Run this command: disablehibernate.command.zip
      4) Tried darkwake=0 to 10
      5) Disabled wake on USB & Wake on LAN (BIOS)
       
      Logs:
      sudo pmset -g
      System-wide power settings: Currently in use: hibernatemode 0 disksleep 10 womp 0 networkoversleep 0 sleep 0 Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage autorestart 0 gpuswitch 2 displaysleep 10 pmset -g assertions
      2019-02-19 18:51:04 +0200 Assertion status system-wide: BackgroundTask 1 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 1 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 56(powerd): [0x0000001700088000] 00:13:44 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" pid 100(hidd): [0x00000025000980a7] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968578.17" Timeout will fire in 600 secs Action=TimeoutActionRelease pid 200(mds_stores): [0x0000034e000b8279] 00:00:00 BackgroundTask named: "com.apple.metadata.mds_stores.power" Kernel Assertions: 0x4=USB id=502 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d130000 owner=USB Keyboard id=503 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d120000 owner=Lenovo Optical Mouse Idle sleep preventers: IODisplayWrangler  
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors
      RAM: 128 GB 1333 MHz DDR3 ECC Memory
      GPU: SAPPHIRE Radeon PULSE RX 580 8GB GDDR5
      Chipset: Intel C602
      Audio: Realtek ALC3220 (ALC280) High Definition Audio
      SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  
      Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210 
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      for more info:
       
      Any Help will be appreciated, Thanks !
       
      Send me Yehias-Mac-Pro.zip
    • By yehia2amer
      Dell Precision T7610 Workstation
      Hackintosh GUIDE (Work in Progress)
       
                        
      Introduction: 
      Hi Everyone,
      This Workstation used to be a Beast with Dual CPUs and tons of RAM, I Know it is now normal to get that much cores in a Desktop but it is still a very decent machine for me (As a Programmer), and I thought it would be a good idea to Install MacOS as the Daily Driver Rather than Linux and It turns out to be a very Great Experience (with Some Challenges ).
       
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors RAM: 128 GB 1333 MHz DDR3 ECC Memory GPU: SAPPHIRE PULSE Radeon RX 580 8GD5 Chipset: Intel C602 Audio: Realtek ALC3220 (ALC280) High Definition Audio SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      Working:
      Both "Xeon E5-2680 v2" and all cores with Power Management and P-States (using VoodooTSCSync & ssdtPRGen.sh) ATI Radeon HD 4870 (Vanilla) Realtek ALC3220 (ALC280)  (using VoodooHDA till Now - it is partially working with AppleALC using layout-id 13) LSI 2308 SAS (using AstekFusion2) Intel 82579 Network Controller (Vanilla) Intel I210 Network Controller (IntelMausiEthernet) USB 2.0  
      Not Working:
      NEC USB3.0 xHCI Controller (Renesas Electronics uPD720201 & uPD720202) Sleep  
      https://github.com/yehia2amer/Dell-Precision-T7610-Workstation-Hackintosh-Guide
    • By wen1
      Work in progress
       
      This is mini guide and config files for installing Mojave on a Dell XPS 13 9370.
       
      I took inspiration from sensibleJoe at on reddit
       
      My laptop's specs
       
      i7-8550U Intel HD 620 Graphics UHD Display 256GB Samsung NVMe SSD PM961 Killer 1435 Wifi  
      Here is what works
       
      Intel HD Graphics  Sleep Sound & Mic USB Wifi (Internal Killer Wifi will not work) Bluetooth Power Management Battery Management Screen Brightness Control  
      What does not work
       
      Internal Wifi Camera SD Card reader  
       
       
      I followed the vanilla guide here to create the Mac OS Mojave install USB. I used Mac OS 10.14.3.
       
      Here are some rough steps
       
      1. Create the USB installer for Mojave. You can use apple's own instructions
      2. Once the installer USB creation is complete, Install the latest version of clover to the USB disk with the following options 
      Install Clover for UEFI booting only
      Install Clover to the ESP
       
      Leave everything else as default (minimal install without a bunch of drivers)
       
      3. Then mount the EFI folder on the USB drive and replace the files in the config folder with the ones from the attached zip file over writing the files already there. This config is specifically for Dell XPS 13 9370.
      4. Go into the UEFI/BIOS on the laptop, Make sure your SATA mode is set to AHCI (And not Raid). Save and Exit
      5. Boot with the USB disk and install Mojave
      6. After the install is complete, Use the USB to boot again but this time boot into the newly installed Mojave partition.
      7. Install Clover on to the SSD with the same options as before.
      8. Then copy the config files to the EFI folder on the SSD overwriting the config folder there.
      9. Acquire the backlight AppleBacklightFixup.kext from here and install to /Library/Extensions (Thanks to Rehabman for the kext)
      10. Reboot.
       
      EDIT: V4 fixes many things, like powermanagement, backlight control etc. you also need to install AppleBacklightFixup.kext to /Library/Extensions
       
       
      CLOVER-v4.zip
    • By mhendawy
      Hello There,
       
          I had Mojave 10.14.2 over HP ProBook 450 G4 and most probably all functions are working except an issue that when I connecting the device to HDMI it reboots. although the EFI is fully patched [ DSDT & SSDT] and the behavior of sleep\wakeup please find all the attached problem files.
       
      Thanks 
      PrF.zip
×