Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave on Intel 5, 6, 7, 8, 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

2,312 posts in this topic

Recommended Posts

Hello :)

 

I've just installed Mojave 10.14.2 on my build:

MSI Z77A-G43 (Ivy Bridge)
Intel Xeon E3-1230v2
Radeon R9 280X 3GB
SSD 256GB SATA3

 

Would you like to check my config?
I'm attaching the folder created with the RunMe app

 

Thank you,
Kind regards

Send me Z77A-OSX.zip

Share this post


Link to post
Share on other sites
Advertisement
18 hours ago, rocky376 said:

Hello :)

 

I've just installed Mojave 10.14.2 on my build:

MSI Z77A-G43 (Ivy Bridge)
Intel Xeon E3-1230v2
Radeon R9 280X 3GB
SSD 256GB SATA3

 

Would you like to check my config?
I'm attaching the folder created with the RunMe app

 

Thank you,
Kind regards

Send me Z77A-OSX.zip

DSDT.aml.zip

CLOVER FOLDER

https://olarila.com/forum/viewtopic.php?f=28&t=8222

7 hours ago, nemois said:

Hi MaLd0n, can you helpme with my DSDT and config... thanks!!

Send me iMac.zip

RUN UPDATED APP

RunMe.app

Share this post


Link to post
Share on other sites

 

9 hours ago, MaLd0n said:

 

Thank You very much :D

My computer works great now, I have only problems with sleep&wake.

PC is going to sleep normally but when waked up, there are some issues like: black screen / login screen and freeze / very, very slow performance.

 

This is not a very big thing - I can handle without sleep&wake but I would be grateful if you could take a look.

I'm attaching new files, generated after changes.

 

Kind regards :)

Send me Z77A-OSX.zip

Share this post


Link to post
Share on other sites
On 1/9/2019 at 2:42 PM, rocky376 said:

 

 

Thank You very much :D

My computer works great now, I have only problems with sleep&wake.

PC is going to sleep normally but when waked up, there are some issues like: black screen / login screen and freeze / very, very slow performance.

 

This is not a very big thing - I can handle without sleep&wake but I would be grateful if you could take a look.

I'm attaching new files, generated after changes.

 

Kind regards :)

Send me Z77A-OSX.zip

i think is a gpu problem

Share this post


Link to post
Share on other sites
22 hours ago, nemois said:

This is the new one, my config its the next...

 

GA-Z77X-UP4 TH
i7 3770k

Mining RX 470 (tint Pink Screen) only 1 port DVI (with Whatevergreen only pink screen)

Send me iMac.zip

DSDT.aml.zip

Share this post


Link to post
Share on other sites
4 hours ago, MaLd0n said:

Thanks...
i can fix the Pink Screen with... http://www.mathewinkson.com/2013/03/force-rgb-mode-in-mac-os-x-to-fix-the-picture-quality-of-an-external-monitor
I don't have Second display by iGPU, I have only one video output in my RX470, I don't have HDMI AUDIO by RX470, I don't have QuickSync,  I think my config.cfg it's a mess, can you help me with my config.plist file?

Thanks in Advance...

config.plist

Share this post


Link to post
Share on other sites
9 hours ago, MaLd0n said:

i think is a gpu problem

Hello, I did some research and I found that R9 280X have wake issues, and I don't have iGPU in my processor  - so, everything is clear :)

Thank you very much for your support :)

 

Kind regards. 

 

Share this post


Link to post
Share on other sites
13 hours ago, nemois said:

Thanks...
i can fix the Pink Screen with... http://www.mathewinkson.com/2013/03/force-rgb-mode-in-mac-os-x-to-fix-the-picture-quality-of-an-external-monitor
I don't have Second display by iGPU, I have only one video output in my RX470, I don't have HDMI AUDIO by RX470, I don't have QuickSync,  I think my config.cfg it's a mess, can you help me with my config.plist file?

Thanks in Advance...

config.plist

idk about hardware accel in ur hardware, never use it

Share this post


Link to post
Share on other sites

Hi Mald0n,

would you help me with my DSDT and config ?

I've just updated to 10.14.2 and my USB3 ports don't work.

I have a 4790K on a Gigabyte z97x ud5h motherboard, and a sapphire pulse RX580 8GB.

Thanks a lot

magoz

Send me rickys-iMac.zip

Edited by magoz
update

Share this post


Link to post
Share on other sites
2 hours ago, magoz said:

Hi Mald0n,

would you help me with my DSDT and config ?

I've just updated to 10.14.2 and my USB3 ports don't work.

I have a 4790K on a Gigabyte z97x ud5h motherboard, and a sapphire pulse RX580 8GB.

Thanks a lot

magoz

Send me rickys-iMac.zip

DSDT.aml.zip

use my clover folder or ur usbs dont work

https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip

 

after u need a excluded unused ports

https://olarila.com/forum/viewtopic.php?p=65287#p65287

Share this post


Link to post
Share on other sites

Hi MaLd0n,

 

Happy new year to you bro! Hope you are well!

 

Had a bit more progress with my Lenovo t470s - upgraded to 10.14.2 and things a lot better and smoother now.

 

May I ask you take a look at the run me files and offer any assistance (trackpad and battery specifically)

Send me Macbooks-MacBook-Pro.zip

Many thanks

Share this post


Link to post
Share on other sites
1 hour ago, Dan_Marshall said:

Hi MaLd0n,

 

Happy new year to you bro! Hope you are well!

 

Had a bit more progress with my Lenovo t470s - upgraded to 10.14.2 and things a lot better and smoother now.

 

May I ask you take a look at the run me files and offer any assistance (trackpad and battery specifically)

Send me Macbooks-MacBook-Pro.zip

Many thanks

DSDT.aml.zip

check if battery work

 

trackpad is just a kext, u use last voodoops2?

 

Share this post


Link to post
Share on other sites
26 minutes ago, MaLd0n said:

DSDT.aml.zip

check if battery work

 

trackpad is just a kext, u use last voodoops2?

 

Hi mate,

 

Big step - battery status is showing! However, showing at 0% (not charging even though plugged in).

 

Also new DSDT broke sound - no control over volume and unable to adjust.

 

Trackpad is now working in sys prefs, still a little jumpy but not as much as before however can be adjusted in sys prefs.

 

New voodoo installed and seems to be better

 

New dump files 

Send me Macbooks-MacBook-Pro.zip

Edited by Dan_Marshall

Share this post


Link to post
Share on other sites
9 hours ago, Dan_Marshall said:

Hi mate,

 

Big step - battery status is showing! However, showing at 0% (not charging even though plugged in).

 

Also new DSDT broke sound - no control over volume and unable to adjust.

 

Trackpad is now working in sys prefs, still a little jumpy but not as much as before however can be adjusted in sys prefs.

 

New voodoo installed and seems to be better

 

New dump files 

Send me Macbooks-MacBook-Pro.zip

audio inject via clover

 

battery check in rehabman repo, have a good tutorial too

 

 

Share this post


Link to post
Share on other sites

Hi @MaLd0n

Can you please take a look at my system

Thanks

Mac OS 10.12.4

Laptop Model: HP 240 G5   

CPU: Intel Core i5 6200U
          Socket 1168 BGA
Motherboard: HP 81DB
Memory: 8G DDR3
Graphic: Intel HD Graphics 520
               1366x768 Monitor
Audio & Microphone: ALC282 @ Intel Sunrise Point-LP PCH
Touchpad: HP ELAN Touchpad
Network: 802.11n Broadcom
Bluetooth: Broadcom 43142
 
 
I have tried your method of installing mojave, but when i try to install, it stops and then says panic, panic.apple.com
The first version of clover folder, its the one when i followed your guide step by step, and after flashing usb drive, it has that folder.
The second version, i also followed your guide step by step, but took some advice from another guide(https://www.tonymacx86.com/threads/guide-hp-probook-430-g3-skylake-mojave.256770/) from a notebook that has similiar specs to mine, but i only modified cetain kext files that in that guide told me to modify.
In both cases it goes to panic.
Please help me.

CLOVER(version1).rar

CLOVER(version2).rar

Share this post


Link to post
Share on other sites
On 1/12/2019 at 3:25 PM, MaLd0n said:

Thank you very much. I'll give it a try this evening.

What SMBios do you suggest ? I'm currently on iMac 14,2 but macpro 5,1 seems better to other guys...

Edited by magoz
update

Share this post


Link to post
Share on other sites

Hello and thanks for the work you do for the community!!  I hope you could help me here....I have to replace my z270 and i7 7700k on a working Sierra 10.12.6 system , and I was thinking on a z390 and i7 9700k.. would those work on Sierra 10.12.6? or I have to upgrade to H sierra or Mojave? my problem is the gtx 1080 , that with Sierra work perfectly.... and i haven't really understood yet it would work well on high Sierra and mojave because of the driver.... and actually if it would be possible to stay on my system 10.12.6 without much trouble after the hardware upgrade it could save me lot of stress.............  I'm a bit lost here....   could you lend me a hand??!!

Share this post


Link to post
Share on other sites
3 hours ago, Redragon12 said:

Hello and thanks for the work you do for the community!!  I hope you could help me here....I have to replace my z270 and i7 7700k on a working Sierra 10.12.6 system , and I was thinking on a z390 and i7 9700k.. would those work on Sierra 10.12.6? or I have to upgrade to H sierra or Mojave? my problem is the gtx 1080 , that with Sierra work perfectly.... and i haven't really understood yet it would work well on high Sierra and mojave because of the driver.... and actually if it would be possible to stay on my system 10.12.6 without much trouble after the hardware upgrade it could save me lot of stress.............  I'm a bit lost here....   could you lend me a hand??!!

use high sierra 10.13.6

Share this post


Link to post
Share on other sites
On 1/14/2019 at 12:38 AM, primetrack said:

Hi @MaLd0n

Can you please take a look at my system

Thanks

Mac OS 10.12.4

Laptop Model: HP 240 G5   

CPU: Intel Core i5 6200U
          Socket 1168 BGA
Motherboard: HP 81DB
Memory: 8G DDR3
Graphic: Intel HD Graphics 520
               1366x768 Monitor
Audio & Microphone: ALC282 @ Intel Sunrise Point-LP PCH
Touchpad: HP ELAN Touchpad
Network: 802.11n Broadcom
Bluetooth: Broadcom 43142
 
 
I have tried your method of installing mojave, but when i try to install, it stops and then says panic, panic.apple.com
The first version of clover folder, its the one when i followed your guide step by step, and after flashing usb drive, it has that folder.
The second version, i also followed your guide step by step, but took some advice from another guide(https://www.tonymacx86.com/threads/guide-hp-probook-430-g3-skylake-mojave.256770/) from a notebook that has similiar specs to mine, but i only modified cetain kext files that in that guide told me to modify.
In both cases it goes to panic.
Please help me.

CLOVER(version1).rar

CLOVER(version2).rar

Your HP Lappy is closely related to my HP EliteBook G3.. Try this clover and replace with yours..

CLOVER.zip

Share this post


Link to post
Share on other sites

Hello I'm trying to do fresh install of Mojave on Intel DX79SI and need help. Previous install was with Mavericks but after trying to extract DSDT while in clover boot menu I screwed it((. Now can't even boot into old build. When I'm trying to boot into Mojave external installer sometimes I get freeze Apple logo and progress bar, sometimes closed circle. I have successfully created USB drive UEFI Boot Mode with Graphics configuration for nVidia. Could you please help me figure out how can I boot into OSX installer? What boot flags should I use? Thank you in advance! Can some one help me please. Work computer with current job in 3D. Thank you in advance.

 

Intel DX79SI Logic Board
CPU Intel 3.2 GHz
NVIDIA GeForce GTX 680 2048 MB
16 GB 1600 MHz DDR3
SSD 120 GB

 

IMG_0742.JPG

Edited by ak-78
updates

Share this post


Link to post
Share on other sites

Hello Maldon. A little over a year ago you helped me make a dsdt and work some bugs out of my hackintosh. (Page 28 of this thread) I'm still on the same system but i just installed an XFX RX 480 gfx card and need my dsdt edited. In the attachment are the dsdt you made a year ago, and the ssdt's I made and found for my board. Included is the new IOREG dump and my current config file. Speedstep, turbo boost, and system temps are all ok in Intel Speed Gadget. I'm still on 10.12.6, but now that I have Metal support with the RX 480 I will probably install High Sierra soon. Thanks.

for maldon.zip

Share this post


Link to post
Share on other sites

Hi @MaLd0n

 

Since macOS 10.13.6 and now under macOS 10.14.3, I've got a issue with my patched DSDT: Mojave restart randomly at first boot. I have to reboot several times to get a normal startup. Rebuilding don't solve the problem.

 

Could you take a look on my patched DSDT. Please.

 

Thanks

 

Sorry for my bad english

DSDT.aml.zip

Share this post


Link to post
Share on other sites
On 1/23/2019 at 4:30 PM, ak-78 said:

Hello I'm trying to do fresh install of Mojave on Intel DX79SI and need help. Previous install was with Mavericks but after trying to extract DSDT while in clover boot menu I screwed it((. Now can't even boot into old build. When I'm trying to boot into Mojave external installer sometimes I get freeze Apple logo and progress bar, sometimes closed circle. I have successfully created USB drive UEFI Boot Mode with Graphics configuration for nVidia. Could you please help me figure out how can I boot into OSX installer? What boot flags should I use? Thank you in advance! Can some one help me please. Work computer with current job in 3D. Thank you in advance.

 

Intel DX79SI Logic Board
CPU Intel 3.2 GHz
NVIDIA GeForce GTX 680 2048 MB
16 GB 1600 MHz DDR3
SSD 120 GB

 

 

check

https://olarila.com/files/Clover.Folder/CLOVER.X79.zip

 

IN SOME CASES X79 NEED A DSDT PATCH FOR INSTALL

On 1/23/2019 at 7:25 PM, mikey1953 said:

Hello Maldon. A little over a year ago you helped me make a dsdt and work some bugs out of my hackintosh. (Page 28 of this thread) I'm still on the same system but i just installed an XFX RX 480 gfx card and need my dsdt edited. In the attachment are the dsdt you made a year ago, and the ssdt's I made and found for my board. Included is the new IOREG dump and my current config file. Speedstep, turbo boost, and system temps are all ok in Intel Speed Gadget. I'm still on 10.12.6, but now that I have Metal support with the RX 480 I will probably install High Sierra soon. Thanks.

for maldon.zip

i posted in Olarila, check there

7 hours ago, Matgen84 said:

Hi @MaLd0n

 

Since macOS 10.13.6 and now under macOS 10.14.3, I've got a issue with my patched DSDT: Mojave restart randomly at first boot. I have to reboot several times to get a normal startup. Rebuilding don't solve the problem.

 

Could you take a look on my patched DSDT. Please.

 

Thanks

 

Sorry for my bad english

DSDT.aml.zip

post a full dump

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By davi11084
      Salve, recentemente ho installato Mojave sul mio computer. È andato tutto bene soltanto che mi risulta impossibile fare l'accesso con il mio AppleID. Ne da iTunes, ne App Store etc.
      A volte mi dice che ho raggiunto il massimo di dispositivi su all'account quando non ne ho neanche uno collegato. Come posso fare? Rischio il ban dell'appleID? 
      Elenco qua sotto i miei componenti
      I5 7400
      H270 msi gaming m3
      1050 ti 
      16 gb di ram DDR4 Corsair 
       
      Grazie mille aspetto risposte!
    • By RamLalith
      I executed all my DSDT's and SSDTs with no errors 
      I can't patch the battery

      I need help
      I am attaching my ACPI folder
      ACPI.zip
    • By DiddyKong
      Fully optimizing DSDT & SSDT for OS X Sierra POST INSTALL on a Dell345MT with a i7 - 920(first gen) 
       
      I know how this forum feels about 3rd party software, but that was just a crutch, I'm 100% vanilla now which is why I'm now posting for help because I eliminated the possibility having to do with 3rd party. Anyways, with that said I just have a couple things I want to be sure of.
       
      I used a n---bistro to get a App Store copy of Sierra, as I didn't know there were other ways of getting it now from a windows10 machine. anyways, I was able to build a vanilla usb. I couldn't figure the EFI out on my vanilla Sierra-usb, but the EFI on the usb-ni---bistro I had would boot my pre-install and post-install. so I was able to install Sierra. After a few days of figuring out how to remake a EFI and config, I broke my EFI.
      So back to my windows10 SSD and I found BootDiskUtility, and that made a EFI usb with the newest version of clover(r4895). So then swapped SSDs back to my OS X, plugged in the BDU-usb, after trial and error I got back into my Sierra. Now with the newest version of clover and no traces of ni---bistro anymore. Then copied the BDU-usb to my SSD EFI and was able to boot without a usb again!! YAY.
       
      Then starting working on fixing my web drivers for my gtx 1050 2gb. Installed the os update so i'm at 10.12.6, pulled my hair out figuring out the web drivers, eventually got them installed and the cuda fixed.
       
      Now all 3 of my screens work, yet windows can't sit 'between' screens, I just simply haven't looked for that fix yet as I want the sys itself running like a top first.
      My screen saver works, I don't get stuck in screensaver, I did once before, I believe lilu.kext and whatevergreen.kext fixed that.
      Now with all that I felt it was time to give my config.plist a diet cos it was bloated, I generated a config copied the clover settings check for check instead of coping text cos I'm trying to shrink it.
      Config.plist boots my system with DSDT-1FE7B5D7
       
      So after the above, This is now where I'm stuck
       a 100% correct DSDT and SSDT, from my understanding with a patched DSDT I wouldn't need any options selected in clover on the ACPI page?
       
      So with the patching part that I think I understand how to do it now, but when I extract with F4 every file has RSDT in front of it, I have one that says RSDP.aml and RSDT.aml
      so would I just erase the RSDT from the beginning of each file then go from their, which would then leave me with a DSDT.aml and 17 SSDTs?
      I know I have to decompile and patch them, but with my file names[DSDT table extract] not matching tutorials online I'm having a difficult time understanding which files I need.
      IS the RDST-DSDT.aml my DSDT? it is the biggest file.
      which ones that have SSDT in the filename is the SSDT(s) I need to patch?
       
      also how do I know if everything is patched correctly? like if my CPU is fully working and not just sorta working that way when I start running software like photoshop, unity, 10 chrome tabs, my hackintosh doesn't crash
       
      System details
      i7 920 (first gen) very similar to nehelam
      GeForce 1050 2Gb (3 monitors connected all work, one acer on HD connection, two HP s2031 on HD, using adapters to change all ports on GPU card to HD for screens)
          display port, HDMI, and HD
      4x 1Gg + 2x 8Gb RAM running at 1066 after injecting smbios with ram info macOS sees all my ram correctly
      Samsung SSD 860 EVO 500Gb
       
      Thanks to anyone that can help me out, I've been working on my system for about two weeks and this is basically the wall I finally can't seem to figure out how to pass
      I can post another info also if it helps
       
      Boot.log
      DSDTdump.Log

×