Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave on Intel 5, 6, 7, 8, 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

2,132 posts in this topic

Recommended Posts

1 minute ago, bocajoe said:

I don't think I understand 100%.

When I select Internal speaker I don't get any sound. I haven't tried headphones but I will buy some in the morning.

I'm not sure what you mean by "change ato in some layout ids"

Thank you Maldon

*auto change xD

Share this post


Link to post
Share on other sites
Advertisement
Just now, MaLd0n said:

*auto change xD

OK. I'm not sure where/what Auto Change is. Sorry Maldon, I'm not the best at this but I try and like to learn.

Share this post


Link to post
Share on other sites
12 hours ago, MaLd0n said:

PM is working ;)

audio is alc662, i inject 5, if dont work u can try other, 5,7,11,12,13

MaLd0n 2018-04-15 às 00.20.08.png

Inject here, save, reboot

MaLd0n 2018-04-15 às 00.24.30.png

https://www5.zippyshare.com/d/OVhoGx6q/9412/CLOVER.zip

Hi Maldon. I just realized when I insert a USB (2.0 or 3.0) it says "USB Accessory Needs Power" (see pic below)

Here are my RunMe File results

https://drive.google.com/file/d/1ZMQvbbBizbjkU_AjY0moeTUSxV7jEME_/view?usp=sharing

Screen Shot 2018-04-15 at 11.03.06 AM.png

Share this post


Link to post
Share on other sites
2 hours ago, bocajoe said:

Hi Maldon. I just realized when I insert a USB (2.0 or 3.0) it says "USB Accessory Needs Power" (see pic below)

Here are my RunMe File results

https://drive.google.com/file/d/1ZMQvbbBizbjkU_AjY0moeTUSxV7jEME_/view?usp=sharing

Screen Shot 2018-04-15 at 11.03.06 AM.png

k

replace DSDT

DSDT.aml.zip

and replace UsbInjectall too, use this version

USBInjectAll.kext.zip

Share this post


Link to post
Share on other sites
18 minutes ago, MaLd0n said:

k

replace DSDT

DSDT.aml.zip

and replace UsbInjectall too, use this version

USBInjectAll.kext.zip

Of course that worked... Maldon touched it!!!!! :)

Thank you very much Maldon! 

Question on the DSDT: If I change/upgrade my video card or CPU does the DSDT have to be changed?

Share this post


Link to post
Share on other sites
3 minutes ago, bocajoe said:

Of course that worked... Maldon touched it!!!!! :)

Thank you very much Maldon! 

Question on the DSDT: If I change/upgrade my video card or CPU does the DSDT have to be changed?

No, u can use same file, CPU is just a PlugIn type and video i apply a Name _SUN ;)

Boca, send me new SEND_ME, i need check log

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, MaLd0n said:

No, u can use same file, CPU is just a PlugIn type and video i apply a Name _SUN ;)

You make it sound easy because you know EVERYTHING THERE IS TO KNOW! 

But I don't know where PlugIn type is or where or what the heck Apply a Name _SUN. :lol:

You are way to smart and I can't keep up!

Do you have links on DSDT and SSDT tutorials? I would love to learn!

Edited by bocajoe

Share this post


Link to post
Share on other sites
1 hour ago, bocajoe said:

You make it sound easy because you know EVERYTHING THERE IS TO KNOW! 

But I don't know where PlugIn type is or where or what the heck Apply a Name _SUN. :lol:

You are way to smart and I can't keep up!

Do you have links on DSDT and SSDT tutorials? I would love to learn!

in my very old topic have some useful links

https://www.insanelymac.com/forum/forums/topic/235523-dsdt-auto-patcher/

Share this post


Link to post
Share on other sites
3 minutes ago, bocajoe said:

Excellent, I will check them out. Thank you for everything Maldon!

Welcome, boca!

Enjoy!

Share this post


Link to post
Share on other sites
Posted (edited)

Hello, I wonder if you can have a look into my RunMe files.

https://www.dropbox.com/s/1ij6f3jpwdn61kb/Send me MacBook-Pro.zip?dl=1

It's an Acer Aspire S3 laptop, i5-2467M, 4 GB RAM.

My biggest headache: Computer cannot sleep.

Other things: not sound, no wifi.

Thank you very much in advance,

EDIT - Details about it: To create this hackintosh, I cloned High Sierra from another S3, i5-3317M, but I couldn't use its CLOVER folder, neither its wifi and audio kexts, it didn't boot.

It finally booted, thanks to you, using your CLOVER Install.zip, and now I'm stuck in the DSDT patches section, because this S3 is very different from the other one (the 3rd gen S3 was UEFI, this 2nd gen S3 has BIOS...) and I don't know how to patch it all.

EDIT 2: Installing High Sierra 10.13.0

 

EDIT 3: Done! I got it! Thank you!

Edited by skyfly555

Share this post


Link to post
Share on other sites

Hey MaLd0n.. Sorry to keep bugging you with my system problems. I just did a bios update and all works fine still except wake from sleep is hit or miss again. Ive went through bios and made all the appropriate changes but i may be missing something somewhere. If you could help that would be awesome!

 

https://drive.google.com/open?id=1EauhwQhN65KO9G1jNW9NM-Kma8OoaXvR

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, I have been trying to get a stable hack for a while now with my new setup.

 

My specifications are:

macOS 10.13.4

GIGABYTE GA-Z97X-UD3H

i7 4770K

 

I have attached the output of the F4 and RunMe app.

 

Thanks

Send me Mohameds-iMac.zip

Edited by moman2000

Share this post


Link to post
Share on other sites
22 hours ago, tikizondo94 said:

Hey MaLd0n.. Sorry to keep bugging you with my system problems. I just did a bios update and all works fine still except wake from sleep is hit or miss again. Ive went through bios and made all the appropriate changes but i may be missing something somewhere. If you could help that would be awesome!

 

https://drive.google.com/open?id=1EauhwQhN65KO9G1jNW9NM-Kma8OoaXvR

what happens with wake?

2 hours ago, moman2000 said:

Hi, I have been trying to get a stable hack for a while now with my new setup.

 

My specifications are:

macOS 10.13.4

GIGABYTE GA-Z97X-UD3H

i7 4770K

 

I have attached the output of the F4 and RunMe app.

 

Thanks

Send me Mohameds-iMac.zip

replace, reboot and send me new files

CLOVER moman2000.zip

Share this post


Link to post
Share on other sites
16 minutes ago, MaLd0n said:

what happens with wake?

replace, reboot and send me new files

CLOVER moman2000.zip

Computer will wake but just to a black screen. Or sometimes when it does wake it wont mount USB connected drives. Sometimes it will work normal. I know... It makes no sense lol. 

Share this post


Link to post
Share on other sites

sound like a video problem, try update Nvidia Fx kext and Clover bootloader

Share this post


Link to post
Share on other sites

Man, haven't been on these forums in a while.

 

Anyone try this on an ASRock Extreme4 Gen3? Thinking about giving Hackintosh another go.

Share this post


Link to post
Share on other sites
1 minute ago, nylock10 said:

Man, haven't been on these forums in a while.

 

Anyone try this on an ASRock Extreme4 Gen3? Thinking about giving Hackintosh another go.

send me files

RunMe.app.zip

Share this post


Link to post
Share on other sites
8 hours ago, korlione2009 said:

How do you compile dsdt with errors?

Screen Shot 2018-04-22 at 10.37.18.png

use acpi6,1

Share this post


Link to post
Share on other sites
27 minutes ago, firefly_can_fly said:

hey MaLd0n 

It's been a while since I used clover, so a lot of things went rusty. Can you please look at my setup and guide/help what should be done next? 

https://fex.net/354949878474?fileId=441517695

 

Current setup: 

GA-Z97X-UD3H

Xeon e3 1245v3 

Msi GTX 1050ti Gaming X

https://www23.zippyshare.com/v/VUykquYp/file.html
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By pmidmaker
      Hello friends,
       
      I've installed OSx 10.4 in my laptop but I have the following component not working after installing Clover
       
      Laptop: Dell Vostro 15 3549
      Intel HD Graphics 5500, not working at all
      Wireless: Dell wireless 1705.802.11 
      Trackpad and keyboard: ???
      Sound: Realtek High Definition ALC3234
      Battery
       
      Very appreciate if someone can help me
       
      Br.
       
       
       
    • By rdall96
      Hello everyone!
       
      I am fairly new to the world of Hackintosh. I recently moved my previous build into a smaller form factor. However, I am running into a series of problems with the USB ports on the new case and the new motherboard.
       
      Part List:
      - i7-7700k
      - Gigabyte Z270N Gaming 5
      - 16GB Trident Z RGB 3200 MHz
      - Sapphire RX 470
      - NZXT Kraken x62
      - NZXT H200 for the case
       
      Everything in the Hackintosh works just like it did before, nothing changed in the hardware department other than the motherboard (previously a gigabyte Z20X Ultra) and the case.
      This motherboard does not have any USB 2.0 ports in the back, there is only one header on the board, currently taken by the Kraken x62. The rest of the ports are all either USB 3.1 Gen1 or USB 3.1 Gen2, and the front of the case has 3.1 Gen1 ports as well.
       
      This is my current problem:
      When I plug something into either the type A or type C Gen2 ports, it works fine as a normal USB 3.x device with normal speeds, but when I plug something into any other USB port, it only works at lower 2.0 speeds. This is a big problem for me, since I have a few external devices that need the 3.0+ speeds and I don't know what to do.
      I tried to follow many different guides on how to patch USB ports, remove the limits, etc... But nothing seems to work.
       
      Please someone help me!
    • By BrianWong11031
      Hi, my hackintosh won't sleep!
      It often sleeps for 3-5 seconds and auto wakes up.
      sometimes it can't enter the sleep mode even you click the sleep button.
      I have uploaded my DSDT file.
      but I don't know how to patch DSDT.
      If you know how to solve this issue, please help me!
       
      Cheers,
      Brian
      DSDT.aml
    • By angelo_ios
      EDIT: MacOS Mojave 10.14 ONLY I didn’t test 10.14.1! The EFI folder is compatible with High Sierra.
       
      Guide to installing 10.14 Mojave on a ASUS X555L
       
      What Works:
      -WiFi
      -Sound
      -Graphics (Intel)
       
      What doesn't Work:
      -Bluetooth
      -NVidia Web Drivers
      -Battery Indicator
       
      Used Kexts:
      Picture
       
      Clover setup:
      Clover plist is downloadable in this topic.
       
      Let's start
       
      Step one:
      First get a USB with 8+ GB of storage and a MacOS Mojave 10.14 installer from the AppStore.
       
      Partition the USB in a GUID style and 2 partitions, one partition HFS+ and one partition FAT32.
       
      In the FAT32 partition put the EFI Folder there.
       
      On the HFS+ partition get the MacOS Mojave .app using this command:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USBNAME --applicationpath /Applications/Install\ macOS\ Mojave.app --nointeraction Lets install!
       
      Put the USB in a 3.0 port on the LEFT side of the Notebook.
       
      In the BIOS follow the default Hackintosh settings, do NOT forget to put Memory allocation to 64MB (Otherwise you won't boot)
       
      Boot into the Installer and install MacOS Mojave.
       
      Boot into MacOS. Now your Graphics are working but your WiFi and Sound are not! for the WiFi follow this video:
      https://www.youtube.com/watch?v=OxFsjhc-AuM Once rebooted WiFi is working! 
       
      For sound get the VooDooHDA.kext and place it into /Library/Extensions
       
      Reboot once again and your sound is now working flawlessly!
       
      My EFI Folder is downloadable

      config.plist
      EFI.zip
×