Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave on Intel 5, 6, 7, 8, 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

2,312 posts in this topic

Recommended Posts

Advertisement

Doesn't work for me

 

Enviado de meu ASUS_Z017DC usando Tapatalk

Have you already tried osxaptiofix2drv instead of osxaptiofixdrv?

Share this post


Link to post
Share on other sites

 

Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell, SkyLake attachicon.gifbone.png 
 
[snip]

 

Hello MaLd0n,

 

 

Thanks for your easy to follow guide.

 

I'm following these instructions on a system with a Gigabyte GA-Z87X-UD3H, 16Gb RAM, Core i5 4670K. OSX is installed on a 120GB OCZ Vertex SSD. I intend to dual boot with windows 10.

 

Graphics at present are the integrated intel GPU, but once everything is stable the plan is to put my GeForce 1060 back into the system.

 

The audio isn't working at the moment, but everything else is working well enough for me to be able to send this message from within OSX.

 

I've attached my clover folder, and "send me" zip. IOReg is too big to attach but the dropbox link is: https://www.dropbox.com/s/etmgb1grycw7uqx/IOReg.zip?dl=0

 

Hope you can help me get this fine tuned and ready for use!

 

 

CLOVER.zip

Send me Philip’s iMac.zip

Share this post


Link to post
Share on other sites

Hello MaLd0n,

 

 

Thanks for your easy to follow guide.

 

I'm following these instructions on a system with a Gigabyte GA-Z87X-UD3H, 16Gb RAM, Core i5 4670K. OSX is installed on a 120GB OCZ Vertex SSD. I intend to dual boot with windows 10.

 

Graphics at present are the integrated intel GPU, but once everything is stable the plan is to put my GeForce 1060 back into the system.

 

The audio isn't working at the moment, but everything else is working well enough for me to be able to send this message from within OSX.

 

I've attached my clover folder, and "send me" zip. IOReg is too big to attach but the dropbox link is: https://www.dropbox.com/s/etmgb1grycw7uqx/IOReg.zip?dl=0

 

Hope you can help me get this fine tuned and ready for use!

put ur nvidia, install web driver

CLOVER.zip

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Hi MaLdOn,

 

Finally I could create a usb installer under windows 10 and boot again in mac.

I upgraded to Sierra.

I did not do any post-installation with multicast yet.

 

MB: Z77X-UD5H Bios F16-h

I7 3770K

32GB RAM

SSD

GTX670

 

I don't know how to attach files -:(

 

Thank you MaLdOn :-)


 


 

Share this post


Link to post
Share on other sites

DSDT.fallen00sniper.zip

Hi MaLd0n,

 

thank you for your support

CLOVER.zip

Hi MaLdOn,

 

Finally I could create a usb installer under windows 10 and boot again in mac.

I upgraded to Sierra.

I did not do any post-installation with multicast yet.

 

MB: Z77X-UD5H Bios F16-h

I7 3770K

32GB RAM

SSD

GTX670

 

I don't know how to attach files - :(

 

Thank you MaLdOn :-)

 

Use ZippyShare

Share this post


Link to post
Share on other sites

Hi @mald0n,

 

I've this configuration

 

Intel Core i7 4790K + GA-Z87X-UD7 TH + nVidia Evga GTX 970 SC
 
however I'm not able to boot using clover + high sierra.
I've create the usb using diskmakerx as in your other guide for newer mobos, added this thread clover config and I get a kernel panic on AppleACPIPlatform
 
I've attached the origin folder created within clover as it's the only thing I can create without having a running OSX install.

origin.zip

Share this post


Link to post
Share on other sites

 

Hi @mald0n,

 

I've this configuration

 

Intel Core i7 4790K + GA-Z87X-UD7 TH + nVidia Evga GTX 970 SC
 
however I'm not able to boot using clover + high sierra.
I've create the usb using diskmakerx as in your other guide for newer mobos, added this thread clover config and I get a kernel panic on AppleACPIPlatform
 
I've attached the origin folder created within clover as it's the only thing I can create without having a running OSX install.

 

check Olarila High Sierra installer, burn in windows if dont solve

try

CLOVER.zip

Share this post


Link to post
Share on other sites

Hey MaLd0n,

 

Just got this guy working for the most part, think I could get the patches from ya?  :)

 

Sager NP9377SM-A Laptop

     hm87 Chipset (8 Series)

     4910MQ CPU

     4x SSD (2 in RAID 0 running OS X, 1 Windows, 1 Kali) + 1 HDD for storage

     GTX980M (the only video card, no optimus)

 

It's been fun so far :)

 

I had to remove the softraid.kext from my clover folder in order to upload it.  The kext is 12+ MB. 

EmmTeh-CLOVER.zip

Send me EmmTeh’s MacBook Air.zip

lspci-nn_emmteh.txt

Share this post


Link to post
Share on other sites

Help me patch DSDT @mald0n

hi mald0n

Im use Mac High Sierra 10.3

Hardware :

Main EVGA X79 DARK

CPU E5 2670

GPU: GTX1070 Xtrem Gaming (Gigabyte)

Onboard LAN LAN Chipset Intel 82579 Second LAN Chipset Intel 82574 Onboard Audio Audio Chipset Realtek ALC898 Audio Channels 8 Channels

i want Cpu power management

Thankls you!

File in attach

DSDT .zip

Share this post


Link to post
Share on other sites

Hey MaLd0n,

 

Just got this guy working for the most part, think I could get the patches from ya?  :)

 

Sager NP9377SM-A Laptop

     hm87 Chipset (8 Series)

     4910MQ CPU

     4x SSD (2 in RAID 0 running OS X, 1 Windows, 1 Kali) + 1 HDD for storage

     GTX980M (the only video card, no optimus)

 

It's been fun so far :)

 

I had to remove the softraid.kext from my clover folder in order to upload it.  The kext is 12+ MB. 

check

CLOVER.zip

what ur audio codec?

Help me patch DSDT @mald0n

hi mald0n

Im use Mac High Sierra 10.3

Hardware :

Main EVGA X79 DARK

CPU E5 2670

GPU: GTX1070 Xtrem Gaming (Gigabyte)

Onboard LAN LAN Chipset Intel 82579 Second LAN Chipset Intel 82574 Onboard Audio Audio Chipset Realtek ALC898 Audio Channels 8 Channels

i want Cpu power management

Thankls you!

File in attach

ur processsor have a native support, what happens if u boot without nullcpupm?

 

send me one ioreg

IORegistryExplorer.app.zip

Share this post


Link to post
Share on other sites

Dear MaLdOn,

 

Sierra is now booting and running well (except that shut down is rebooting and characters 0 to 9 don't work on my keyboard's numeric pad)

 

Here is my configuration:

- GA Z77X-UD5H

- i7 3770k

- GTX 670

- SSD 830

- Texas Instruments FireWire PCI card with RME400 soundcard connected

 

And the files:

Mac Pro de Olivier.zip

 
Thanks for your help once again MaLdOn!

Share this post


Link to post
Share on other sites

 

Dear MaLdOn,

 

Sierra is now booting and running well (except that shut down is rebooting and characters 0 to 9 don't work on my keyboard's numeric pad)

 

Here is my configuration:

- GA Z77X-UD5H

- i7 3770k

- GTX 670

- SSD 830

- Texas Instruments FireWire PCI card with RME400 soundcard connected

 

And the files:

Mac Pro de Olivier.zip

 
Thanks for your help once again MaLdOn!

 

1- replace full clover folder

CLOVER.zip

2- update clover bootloader

https://sourceforge.net/projects/cloverefiboot/files/Installer/Clover_v2.4k_r4297.zip/download

3- reboot and send me new ioreg with new files

hi mald0n

Here extract: is attach

plea Help me patch cpu power and more 

u need test, i dont have any x79 for test, i think the Pike's patch work for u, i use it in my x99

check

Captura de Tela 2017-11-18 às 16.34.50.png

 

Hi Maldon
 
I need your help. I've this configuration for a friend :   P55UD5 - I5 650 - GEFORCE 8400 GS . Sierra 10.12.6. I can't sleep the Mac : direct reboot.
 
Thanks

 

DSDT.peterios.zip

Share this post


Link to post
Share on other sites

Hi MaLdOn,

 

I did what you told me to do.

Here is my new ioreg file:

 

Mac Pro de Olivier 2.zip

 

Thank you very much!  :)

u have kexts installed in s/l/e or l/e, u dont need it, check clover/kexts/others, all u need is there

now, generate ur ssdt for a good PM

SSDT_Automator.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By DiddyKong
      Fully optimizing DSDT & SSDT for OS X Sierra POST INSTALL on a Dell345MT with a i7 - 920(first gen) 
       
      I know how this forum feels about 3rd party software, but that was just a crutch, I'm 100% vanilla now which is why I'm now posting for help because I eliminated the possibility having to do with 3rd party. Anyways, with that said I just have a couple things I want to be sure of.
       
      I used a n---bistro to get a App Store copy of Sierra, as I didn't know there were other ways of getting it now from a windows10 machine. anyways, I was able to build a vanilla usb. I couldn't figure the EFI out on my vanilla Sierra-usb, but the EFI on the usb-ni---bistro I had would boot my pre-install and post-install. so I was able to install Sierra. After a few days of figuring out how to remake a EFI and config, I broke my EFI.
      So back to my windows10 SSD and I found BootDiskUtility, and that made a EFI usb with the newest version of clover(r4895). So then swapped SSDs back to my OS X, plugged in the BDU-usb, after trial and error I got back into my Sierra. Now with the newest version of clover and no traces of ni---bistro anymore. Then copied the BDU-usb to my SSD EFI and was able to boot without a usb again!! YAY.
       
      Then starting working on fixing my web drivers for my gtx 1050 2gb. Installed the os update so i'm at 10.12.6, pulled my hair out figuring out the web drivers, eventually got them installed and the cuda fixed.
       
      Now all 3 of my screens work, yet windows can't sit 'between' screens, I just simply haven't looked for that fix yet as I want the sys itself running like a top first.
      My screen saver works, I don't get stuck in screensaver, I did once before, I believe lilu.kext and whatevergreen.kext fixed that.
      Now with all that I felt it was time to give my config.plist a diet cos it was bloated, I generated a config copied the clover settings check for check instead of coping text cos I'm trying to shrink it.
      Config.plist boots my system with DSDT-1FE7B5D7
       
      So after the above, This is now where I'm stuck
       a 100% correct DSDT and SSDT, from my understanding with a patched DSDT I wouldn't need any options selected in clover on the ACPI page?
       
      So with the patching part that I think I understand how to do it now, but when I extract with F4 every file has RSDT in front of it, I have one that says RSDP.aml and RSDT.aml
      so would I just erase the RSDT from the beginning of each file then go from their, which would then leave me with a DSDT.aml and 17 SSDTs?
      I know I have to decompile and patch them, but with my file names[DSDT table extract] not matching tutorials online I'm having a difficult time understanding which files I need.
      IS the RDST-DSDT.aml my DSDT? it is the biggest file.
      which ones that have SSDT in the filename is the SSDT(s) I need to patch?
       
      also how do I know if everything is patched correctly? like if my CPU is fully working and not just sorta working that way when I start running software like photoshop, unity, 10 chrome tabs, my hackintosh doesn't crash
       
      System details
      i7 920 (first gen) very similar to nehelam
      GeForce 1050 2Gb (3 monitors connected all work, one acer on HD connection, two HP s2031 on HD, using adapters to change all ports on GPU card to HD for screens)
          display port, HDMI, and HD
      4x 1Gg + 2x 8Gb RAM running at 1066 after injecting smbios with ram info macOS sees all my ram correctly
      Samsung SSD 860 EVO 500Gb
       
      Thanks to anyone that can help me out, I've been working on my system for about two weeks and this is basically the wall I finally can't seem to figure out how to pass
      I can post another info also if it helps
       
      Boot.log
      DSDTdump.Log

    • By Reel
      All work 10.10, 10.11, 10,12
      camera not work in 10.13, 10.14
      You need SwitchResX that the screen does not freeze
      Custom resolutions: Back porch - lines change to 2
      UEFI boot moded bios https://github.com/Thiblizz/l502x-modded-bios
       
      For 10.14 you need: HD3000 Fix for Mojave.zip
      Installed in S/L/E 
       
      SMBIOS: MacbookPro 8.3 or MacbookPro 9.1
       
       

       

       
       
    • By glasgood
      CLOVER DUAL BOOT MOJAVE & WINDOWS 10 GUIDE 
       

       
       
      INCLUDES  MBR / LEGACY BIOS  TO  GPT / EFI CONVERSION
      USING MBR2GPT TOOL
       
       
      PREREQUISITE: Two physical discs ( SSD’s or HDD’s )
       
       
       
       
       
      STEP 1 - Clover dual boot configuration 
       
      Open config.plist with Clover Configurator
       
      Boot
       Legacy = PBR Timeout = True ( will remove the Timeout countdown, from Clover boot menu)  

       
      GUI 
      Scan / Custom
       Entries = True  Tool = True  Legacy = False ( removes extra Windows 10 entries )  
      Hide Volume
      - Preboot ( macOS Preboot )
      - Recovery ( macOS Recovery )
       

       
      So at boot you will have two options: boot macOS Mojave or Windows 10 
       
       
       
       
       
       
       
      ————————————————————
       
       
      STEP 2 - Using a drive without Windows 10 installed
       
      Disconnect system drive that contains your macOS Mojave install from computer ( This is so that Windows does not overwrite existing macOS Mojave boot loader )
       
      Proceed with a Windows 10 UEFI install.  
      After installation reconnect macOS Mojave Drive, the Windows installation should now be detected and usable in Clover. 
      If Windows 10 is not detected or able to boot,  then verify you installed Windows 10 as UEFI and not MBR ---->  ( Read step 2 - For a drive with Windows 10 installed )
       
       
      OR
       
       
       
      STEP 2 - Using a drive with Windows 10 already installed
       
      Verify your Windows install is  GPT / UEFI or MBR / Legacy BIOS.   
      If Windows install is GPT UEFI then Windows 10 install is ready to use at Clover boot menu, you should be able to boot into Windows directly from Clover boot screen. 
       

       
       
      But if  Windows drive is detected at Clover boot screen, but when booting Windows you get a black screen with a cursor on the top left,
      then this is most likely because Windows drive is MBR ( Legacy BIOS ).  You can easily convert MBR to GPT using  Windows MBR2GPT tool ( this saves hours work having to reinstall Windows 10 and setting up all your applications again  ) 
       
      If Windows 10 install is MBR / Legacy BIOS  then simply convert to GPT / UEFI  following instructions below ( read video summary and view video )
       
       
      ** To use Windows 10  MBR2GPT tool  you must have Windows 10 version 1703 ( creators update  ) or later and less than 3 partitions on 
      the Windows 10 drive **
       
      Video summary:
       
      Confirm Windows 10 drive is MBR Legacy BIOS ( in Windows Disk Management ) Reboot into Windows PE ( Advanced Startup ) Convert from MBR Legacy BIOS to GPT UEFI ( using commands below ) mbr2gpt /validate mbr2gpt /convert Restart Verify Windows 10 drive has changed to GPT UEFI ( in Windows Disk Management )  
       
       
       
      After conversion Windows 10 is ready to use at the Clover boot menu 
       
       
×