Jump to content
MaLd0n

[Guide] El Capitan, Sierra / High Sierra / Mojave / Catalina on Intel 5, 6, 7, 8, 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

2,483 posts in this topic

Recommended Posts

I dont know what your EFI did to my system but I can’t pass by this menu anymore and pressing F2 or del doesn’t even help... what should I do now ?

 

https://streamable.com/86pq9

 

update: false alarm, it was just some of my other hdd that didn't wanna boot for some reason so I removed every hdd I have and reseted coms* then reorganized the sata cables and then everything started to work just fine.

Edited by axonleo

Share this post


Link to post
Share on other sites
Advertisement
On 7/9/2019 at 1:28 PM, MaLd0n said:

bad, is just a video patch, try others ig-platform-id

 

Hi, I took some time and tried the PlatformIds provided in the Hackintool.

 

The 0x3E9B0007 went through a smooth boot, but ended in a black screen. Maybe that's an success.. Like booted but sent the signal to the wrong port ?

Tried an HDMI monitor but nothing.

 

 

Share this post


Link to post
Share on other sites

Good afternoon, MaldOn, I installed the Mojave in my notebook a DELL L15 5548 B20, but there are still some things that I can not do, the intel wifi already know that it does not work, but the bluetooth of it, it works and it has no way to disable, another thing that I can not is sleep / wake function (wake reason GLAN, GLAN XHC), brightness ok, battery appears right, amd radeon r7 m265 is disabled trough ssdt, however what worries me the most is the duration of the same as in windows is about 2-3 already in the hack barely reaches 1 hour, the I think it's all right, thank you in advance for helping me! I'll leave the runme here.

Send me MacBook-de-Gabriel.zip

Share this post


Link to post
Share on other sites

Hi @MaLd0n, I'm in need of your magic hands again :rofl:

With Catalina DP5 sleep is not functioning. Or actually, it is.The system goes into sleep normally.  However, there are 2 issues:

The system either wakes up normally but the monitor won't turn on and USB loses power;
OR
The system reboots instead of waking up.
 

Could you take a look please?

Thanks!
Send me iMac-van-Rico.zip

Share this post


Link to post
Share on other sites
On 7/12/2019 at 10:46 AM, blackbird_n1 said:

 

Hi, I took some time and tried the PlatformIds provided in the Hackintool.

 

The 0x3E9B0007 went through a smooth boot, but ended in a black screen. Maybe that's an success.. Like booted but sent the signal to the wrong port ?

Tried an HDMI monitor but nothing.

 

 

solve?

 

On 7/12/2019 at 6:20 PM, GabrielDT said:

Good afternoon, MaldOn, I installed the Mojave in my notebook a DELL L15 5548 B20, but there are still some things that I can not do, the intel wifi already know that it does not work, but the bluetooth of it, it works and it has no way to disable, another thing that I can not is sleep / wake function (wake reason GLAN, GLAN XHC), brightness ok, battery appears right, amd radeon r7 m265 is disabled trough ssdt, however what worries me the most is the duration of the same as in windows is about 2-3 already in the hack barely reaches 1 hour, the I think it's all right, thank you in advance for helping me! I'll leave the runme here.

Send me MacBook-de-Gabriel.zip

DSDT.aml.zip

 

48 minutes ago, ricoc90 said:

Hi @MaLd0n, I'm in need of your magic hands again :rofl:

With Catalina DP5 sleep is not functioning. Or actually, it is.The system goes into sleep normally.  However, there are 2 issues:

The system either wakes up normally but the monitor won't turn on and USB loses power;
OR
The system reboots instead of waking up.
 

Could you take a look please?

Thanks!
Send me iMac-van-Rico.zip

EFI.zip

stay with one usb stick for recovery if need, ur serie 8 mobo is like one serie 7, use one EHCI device

 

extract new send_me after reboot

Share this post


Link to post
Share on other sites
17 minutes ago, MaLd0n said:

stay with one usb stick for recovery if need, ur serie 8 mobo is like one serie 7, use one EHCI device

 

 I originally renamed H_EC to EC0 but I encountered alot of crashes AppleUserHIDDrivers so I was trying to figure out what the cause was :P
 

20 minutes ago, MaLd0n said:

extract new send_me after reboot


Here you go! Thanks bud
Send me iMac-van-Rico.zip

Share this post


Link to post
Share on other sites
3 minutes ago, ricoc90 said:

 

 I originally renamed H_EC to EC0 but I encountered alot of crashes AppleUserHIDDrivers so I was trying to figure out what the cause was :P
 


Here you go! Thanks bud
Send me iMac-van-Rico.zip

ye

 

remove edited dsdt and extract new send_me, lets start again with original tables

Share this post


Link to post
Share on other sites
7 minutes ago, MaLd0n said:

ye

 

remove edited dsdt and extract new send_me, lets start again with original tables


Here you go: 
Send me iMac-van-Rico.zip

Edited by ricoc90

Share this post


Link to post
Share on other sites
19 minutes ago, MaLd0n said:

DSDT.aml.zip

test usb ports with device usb 3

 

new send_me


Thanks buddy


USB3:
  Frontpanel working
  Backpanel working

USB2: 
Frontpanel working
Backpanel not working

 

Send me iMac-van-Rico.zip

Share this post


Link to post
Share on other sites
12 minutes ago, MaLd0n said:


Something funny is going on. So system profiler does show me the USB bus now. I can also plug in USB drives and they do show up in System Profiler, however with any USB port (usb2.0 and usb3.0) the issue is that they don't show up in Disk utility nor Finder unless I reboot with the USB drive plugged in ...

 

Spoiler

340673495_Schermafbeelding2019-08-02om17_56_05.thumb.png.e8a6d029c2e5b5ef3cb22f1dae180092.png

Send me iMac-van-Rico.zip

 

 

Share this post


Link to post
Share on other sites
3 minutes ago, ricoc90 said:


Something funny is going on. So system profiler does show me the USB bus now. I can also plug in USB drives and they do show up in System Profiler, however with any USB port (usb2.0 and usb3.0) the issue is that they don't show up in Disk utility nor Finder unless I reboot with the USB drive plugged in ...

 

  Hide contents

 

Send me iMac-van-Rico.zip

 

 

u try with last dsdt(i put ehci devices again, in ur case u need it) without usbinjectall?

Share this post


Link to post
Share on other sites
8 minutes ago, MaLd0n said:

u try with last dsdt(i put ehci devices again, in ur case u need it) without usbinjectall?


I did not :blush: Now I did and USB ports do work as they should, thanks buddy :D
Waking up issue is still present: no USB and monitor after wake

Share this post


Link to post
Share on other sites

Hello,

Sandy Bridge here (ASUS P8z68-V, i7 2600K, Sapphire RX 580).

 

I did the ssd with PikerAlpha and select Drop OEM and now it should work well looking at Intel Power Gadget.

I also installed Catalina Beta with the RX 580 from Sapphire. It works with a patch and Inject ATI (without it I receive a black screen).

 

The only problem is that I have USB 3.0 working only with GenericUSBXHCI kext, but with it I have no sleep.

With USBInjectAll kext sleep function but USB 3.0 don't work.

 

Edit: to boot in Catalina Beta 4 I have to use SSDT-ECUSBX.aml in EFI/CLOVER/ACPI/patched

 

Any suggestion? Thank you very much.

Send me iMacdiFrancesco.lan.zip

Edited by Franz22

Share this post


Link to post
Share on other sites
27 minutes ago, ricoc90 said:


I did not :blush: Now I did and USB ports do work as they should, thanks buddy :D
Waking up issue is still present: no USB and monitor after wake

wake problem i think is about nvidia, need test with one rx560 for check

 

put it in clover/acpi/patched and reboot, is a oem ssdt with little mods

SSDT-2-SaSsdt .aml.zip

 

if fail just block this ssdt via boot screen, press O

 

about usb, we can check

Share this post


Link to post
Share on other sites
24 minutes ago, Franz22 said:

Hello,

Sandy Bridge here (ASUS P8z68-V, i7 2600K, Sapphire RX 580).

 

I did the ssd with PikerAlpha and select Drop OEM and now it should work well looking at Intel Power Gadget.

I also installed Catalina Beta with the RX 580 from Sapphire. It works with a patch and Inject ATI (without it I receive a black screen).

 

The only problem is that I have USB 3.0 working only with GenericUSBXHCI kext, but with it I have no sleep.

With USBInjectAll kext sleep function but USB 3.0 don't work.

 

Edit: to boot in Catalina Beta 4 I have to use SSDT-ECUSBX.aml in EFI/CLOVER/ACPI/patched

 

Any suggestion? Thank you very much.

Send me iMacdiFrancesco.lan.zip

replace, reboot, extract new send_me

EFI.zip

 

ur usb 3 is not intel, need a extra kext, this kext cause some problems

Share this post


Link to post
Share on other sites
20 hours ago, MaLd0n said:

wake problem i think is about nvidia, need test with one rx560 for check

 

put it in clover/acpi/patched and reboot, is a oem ssdt with little mods

SSDT-2-SaSsdt .aml.zip

 

if fail just block this ssdt via boot screen, press O

 

about usb, we can check


With that SSDT the system reboots instead of waking up

Edit: I also found out an issue with USB; whenever I attach my iPhone i'll get a warning message among the lines of "USB Accessory needs power"

Edited by ricoc90

Share this post


Link to post
Share on other sites
13 minutes ago, MaLd0n said:

replace, reboot, extract new send_me

EFI.zip

 

ur usb 3 is not intel, need a extra kext, this kext cause some problems

Thank you so much for your answer and your help!

 

I’ve tried to replace with that efi but I can’t boot..

Share this post


Link to post
Share on other sites

In signature you'll see my configuration. I put in attach EFI folder. I have installed MacOS Sierra, but i want update to MacOS Mojave, and i have a problem in boot.

EFI.zip

Share this post


Link to post
Share on other sites

Hi @MaLdON, I installed MacOs mojave 10.14 MacBookAir6,2 on HP pavilion dv4 notebook. I've working for a month to find a solution for my intel HD graphics 3000 but seems injecting kext on efi clover and library extension not working on my device. And  patching DSDT SSDT solve will everything can u guide a noob newbie like me. 

thank you. :)

 

Send me CLoverLeafs-MacBook-Air.zip

Edited by themonyo666

Share this post


Link to post
Share on other sites

Hi MaldOn, I finally got free time from work to return to my build. I was able to mount my usb EFI partition, edit it and lunch CLOVER.
Formatted my target drive to GUID partition table and got to OS X installation process. Then before 2 min remained I got message "An error occurred validating this installer data. The download is either damaged or incomplete."
I've tried trick buy replacing OsxAptioFixDrv-64.efi for the OsxAptioFix2Drv-free2000.efi in the EFI/CLOVER/drivers64UEFI folder. Even reassemble USB stick with OS X 10.14.4, but unfortunately it didn't worked. Also tried to enable RTX profile 1 in BIOS Ram section, computer could boot. Trying profile 2 resulted in blinking cyan stripes on display.

I extracted native ACPI files from BIOS of my Intel DX79SI at Clover boot screen and having hard time disassembling ACPI files in terminal using refs.txt for patching in MacIASL. Can you please help me to compile it? Files attached.

EFI.zip

Share this post


Link to post
Share on other sites
13 hours ago, ak-78 said:

Hi MaldOn, I finally got free time from work to return to my build. I was able to mount my usb EFI partition, edit it and lunch CLOVER.
Formatted my target drive to GUID partition table and got to OS X installation process. Then before 2 min remained I got message "An error occurred validating this installer data. The download is either damaged or incomplete."
I've tried trick buy replacing OsxAptioFixDrv-64.efi for the OsxAptioFix2Drv-free2000.efi in the EFI/CLOVER/drivers64UEFI folder. Even reassemble USB stick with OS X 10.14.4, but unfortunately it didn't worked. Also tried to enable RTX profile 1 in BIOS Ram section, computer could boot. Trying profile 2 resulted in blinking cyan stripes on display.

I extracted native ACPI files from BIOS of my Intel DX79SI at Clover boot screen and having hard time disassembling ACPI files in terminal using refs.txt for patching in MacIASL. Can you please help me to compile it? Files attached.

EFI.zip

EFI.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tonyx86
      *** I have started another thread for installing Catalina on the Dell Latitude E6410.  If you were thinking of installing Mojave, but would prefer to skip right to Catalina, click here. ***
       
      I was inspired by @duduclx post here for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5 and subsequently 10.14.6.  Everything works perfectly (including sleep).  I'm starting this thread hoping to help others install Mojave on their E6410s.  A brief installation guide is provided later in this first post.  The interested reader is encouraged to read the other posts in this thread to see how this solution evolved and to learn additional tips/details not provided in this first post (including dual-booting with macOS and Windows).
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) MacOS: Mojave 10.14.6 (APFS) (Patched with DosDude Mojave Patcher 1.3.3) MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09") Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 6 developed by @Dr. Hurt and compiled by @bronxteck), not the original version), USBInjectAll (with custom SSDT-UIAC), VoodooSDHC.kext (configured as shown here). Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext) CLOVER (Legacy): R4961  
      Configuration items that may be different from what you have seen in other E6410 configurations
      Addition of _OFF and _ON methods to _PTS and _WAK methods respectively (to control discrete graphics in order to enable sleep/wake) LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2 ECDV renamed to EC so that AppleBusPowerController loads AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states) DSDT patched to include HDAU device (device-id 0x0be3)  
      What is NOT working:
      Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings. Graphics Power Management - AGPM loads (because 10de,0a29 device is injected), but there's no evidence that 3100m frequency and voltage is changing.
        What is NOT tested:
      Smartcard Reader eSata (I have this disabled in my BIOS) Firewire Port (it does appear in the Network settings, just haven't tried it) Microphone Jack PC Card Slot (I have this disabled in my BIOS)  
      What IS working:
      SLEEP IS WORKING! Everything else not mentioned above.   Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long Shutdown is fast Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher) Brightness (adjusted with brightness keys on keyboard) works perfectly Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext. Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext) Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout." Ethernet port (with IntelMausiEthernet.kext) Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext) Optical Drive External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: here) for working external VGA display. Headphone jack Display Port (tested using DP > HDMI adapter) Camera SD Card Reader  
      Known issues and their solutions (These issues have all been resolved, with the solutions incorporated into the attached config files.  The issues are listed here for historical purposes and no further work is needed unless stated otherwise).
      Laptop does not sleep on lid close.  Solution is to add Notify (LID0) code to Method (BTNV) in the DSDT.  This is solved in the attached DSDT. Leaving this for historical purposes, but the CLOVER USBFix is no longer necessary after finding that I had incorrectly applied the DSDT _DSM patch for Device (EHC1).  The CLOVER USBFix is not needed after fixing the DSDT..  AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  Thank you, @feartech, for this tip. ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement.  I've implemented and tested this on my system.  The ALPS version of VoodooPS2Controller.kext mixes up a few keys.  Need to switch the Command and Option keys (System Preferences > Keyboard > Modifier Keys) and change keyboard type to ISO European. This configuration (captured in the attached config files) uses an injected device-id (10de,0a29) for NVidia 3100m to get AGPM to load.  While I haven't observed any performance differences, a better approach may be to inject AGPM properties for device 10de,0a6c (the actual device-id for the 3100m).  This AGPM method is discussed later in this thread.  I have briefly tested this "FakeSMC.kext method" for injecting AGPM attributes without any noticeable changes in laptop/graphics behavior. IOHWControl is not loaded under AGPM (Should be AGP > VID > NVDA,Display-A@0 > NVDATesla > AGPM > gpu-control > IOHWControl as viewed in IORegistryExplorer).  It is loaded on a real MacBookPro6,2 running Mojave and is loaded on this Dell Latitude E6410 running High Sierra.  If I "Inject NVidia" via CLOVER, IOHWControl loads properly. The Dell Latitude DSDT (BIOS A17) has a bug in Method (GNOT).  In the method, the expression  If (LOr (LGreater (OSYS, 0x07D0), LLess (OSYS, 0x07D6))) always evaluates to TRUE, so the patched DSDT has no dependency on the value of OSYS.  I suspect that LOr should be replaced with LAnd, so that this expression is TRUE for variants of Windows 2001 and False for any other OS.  While this may have no affect on MacOS, it makes one wonder how such an obvious bug made it through Dell QA and is still present in BIOS A17.  Also makes one wonder whether the sleep problem (which no one has solved) was fixed in Windows to address another DSDT bug. The assigned value of ACOS and OSYS in the DSDT are conditional on the operating system.  There is no condition for "Darwin."  The solution is to add a condition for "Darwin" (making it equivalent to one of the defined operating systems (e.g. Linux, Win7, etc).  The attached config hard-codes ACOS and OSYS values equivalent to those for Linux.  Another way to handle this (different from the method employed in the attached config files) might be to override _OSI with XOSI (defined in a custom SSDT). The portType of the Internal Bluetooth device is portType=0 which, according to Rehabman's comments in SSDT-UIAC-All.dsl, is an external USB 2 port.  This should be an internal USB port (portType=2).  I learned through trial and error that the HUB1 and HUB2 definitions in Rehabman's SSDT-UIAC-ALL.dsl apply to the ports on the EHCx USB hubs.  The solution is to include the HUB1 definition in SSDT-UIAC.dsl and change portType to 2 for HP15.  This change doesn't appear to affect/fix sleep, but it may prevent instant wake if we get sleep working. There are minor differences between a real MacBookPro6,2 IORegistry dump and this HackBookPro6,2 IORegistry dump that can be resolved with simple DSDT edits.  I am now running with these changes, but haven't found these changes to make any difference in operational behavior.
      Rename Device (AC) -> Device (ADP1) Remove UID from Device (HPET) Add compatible ID "PNP0C01" to Device (HPET) Change ADP1:_STA from 0x0F to 0xFFFFFFFF Enable Ambient Light Sensor and renamed to Device (ALS0) from Device (ALS) Add compatible ID "smc-als" to ALS0 Rename LID -> LID0 Change "name" definitions to Buffers in _DSM methods Rename Device (PBTN) to PWRB Rename Device (SBTN) to (SLPB) Change HDAU.hda-gfx from "onboard-1" to "onboard-2" Change GFX0.hda-gfx from "onboard-1" to "onboard-2" Sleep / Wake does not work with the basic DSDT edits.  I have discovered that Sleep / Wake can be made to work by adding discrete graphics _OFF and _ON methods to _PTS and _WAK methods respectively (borrowed the concept and code from a working E6430 DSDT: Credit here: https://osxlatitude.com/forums/topic/9248-working-sleep-on-intel-hd-and-nvidia-nvs-on-dell-latitude-e6430-optimus-enabled-or-disabled/page/6/. The Clover boot arg should be changed to "darkwake=0" for reasons explained by @holyfield in this thread.  Leaving this for historical purposes: LCD screen is blank when waking laptop by opening lid (screen is not blank when waking with power button).  Solution is to add darkwake=8 to CLOVER boot args.  Thank you @Hervé for this tip.  
      Brief Installation Guide:
      Configure BIOS (version A17) as follows (leave default unless listed here): Boot Sequence: USB, Internal HDD, CD/DVD, Modular Bay HDD; Boot List Option: Legacy; Integrated NIC: Enabled; Parallel Port: Disabled; Serial Port: Disabled; SATA Operation: AHCI; Misc Devices: Enable Modular Bay, Camera, External USB, Microphone, Media Card and 1394; Latitude ON Reader: Disabled; Keyboard Illumination: Auto ALS and Input; Ambient Light Sensor: Enabled; OROM Keyboard Access: Disable; TPM Security: Disable; Computrace: Deactivate; CPU XD Support: Enable; Performance: Enable all options; Power Management: Disable Wake on AC, Disable Wake on LAN/WAN, Express Charge: Standard, Charge Behavior: Enabled; Keypad: Fn Key Only; Mouse/Touchpad: Touchpad/PS-2 Mouse; USB Emulation: Enable Legacy; Fn Key Emulation: Disabled; Fastboot: Thorough; Virtualization: Enable Intel Virtualization, Disable VT for Direct I/O, Disable Trusted Execution; Wireless Switch: Bluetooth and WLAN; Wireless Device Enable: Bluetooth and WLAN;  Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh). Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist Install MacOS to your SSD.  When you run DosDude's Mojave Patcher, DO NOT install LegacyUSBInjector.kext - you're going to use Rehabman's USBInjectAll.kext.  Also, do not install the DosDude SIP kext (you're using CLOVER to manage SIP). Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original), VoodooSDHC.kext (configured as shown here). Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys).  Also change keyboard type to ISO European to fix the [ ` ~ ] key (to the left of the "1" (one) key. Install VoodooHDA Install HWMonitor application  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z After applying Mojave updates, HWMonitor may not display discrete graphics attributes.  On systems with multiple displays, a second (or third display) may not be active after applying the Mojave update.  The solution to this is to run "sudo kextcache -i /" (in a terminal window) and reboot.  This will usually fix the issue.  If the issue is not fixed, run DosDude's Post Install Utility, apply the Legacy Graphics Patch, reboot and then run "sudo kextcache -i /" if necessary.  
      Credits
      In addition to those mentioned in this first post and in subsequent posts in this thread, much of this solution for the Latitude E6410 was made possible by the numerous contributions of @RehabMan.  I hope he's doing well, wherever he is.  Hopefully he has long since forgotten what a PIA I was (and still am) as I was (and still am) learning hackOS.  
       
       


      E6410-Mojave-6v3.zip
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By headkaze
      English: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md
      Russian: https://www.applelife.ru/threads/intel-hd-graphics-3000-4000-4400-4600-5000-5500-5600-520-530-630.1289648/
      Chinese: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.cn.md
×