Jump to content
MaLd0n

[Guide] El Capitan, Sierra / High Sierra / Mojave / Catalina on Intel 5, 6, 7, 8, 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

2,483 posts in this topic

Recommended Posts

Advertisement

Dear Maldon this time I replaced CLOVER folder and got kernel panic as well. I tried several different args with no luck. Could't load installer.

IMG_1139.JPG

Share this post


Link to post
Share on other sites

Dear Maldon this time I replaced CLOVER folder and got kernel panic as well. I tried several different args with no luck. Could't load installer.

Share this post


Link to post
Share on other sites

Hello and thank you for this space, I just installed 10.13.6 and seems to work fine, except for the USB ports in the back and the bluetooth device (I have an IOGEAR GBU521W6 Bluetooth 4.0 USB) it was very difficult for me to patch the Nvidia drivers and the ALC audio and nothing seems to work in order to put the usb and bluetooth back to normal (I had them working on Sierra but now I cannot).

 

I have this setup:

 

Processor: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz

MOBO: GA-Z77X-UP4 TH 

GPU: NVIDIA GTX 1080ti

SSD: KINGSTON SUV480GB

 

this is my EFI file

 

any help will be much appreciated

 

Edited by agaliarept
processor specs

Share this post


Link to post
Share on other sites
8 hours ago, agaliarept said:

Hello and thank you for this space, I just installed 10.13.6 and seems to work fine, except for the USB ports in the back and the bluetooth device (I have an IOGEAR GBU521W6 Bluetooth 4.0 USB) it was very difficult for me to patch the Nvidia drivers and the ALC audio and nothing seems to work in order to put the usb and bluetooth back to normal (I had them working on Sierra but now I cannot).

 

I have this setup:

 

Processor: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz

MOBO: GA-Z77X-UP4 TH 

GPU: NVIDIA GTX 1080ti

SSD: KINGSTON SUV480GB

 

this is my EFI file

 

any help will be much appreciated

 

--Run_Me
RunMe.app

Share this post


Link to post
Share on other sites

Hi @MaLd0n

 

Since macOS 10.13.6 and now under macOS 10.14.3, I've got a issue with my patched DSDT both IMac 13,1 or macmini7,1 SMBIOS: Mojave restart randomly at first boot. I have to reboot several times to get a normal startup. Rebuilding don't solve the problem.

 

On 1/25/2019 at 6:45 PM, Matgen84 said:

 

I can't post full dump: darwindumper 3.0.4 crashs and reboot my system under 10.14.3 

 

There is partial dump in attachements. Thanks.

DarwinDumper_3.0.4_25.01_18.33.22_iMac13,1_AMI_X64_4862_Unknown_18D42_mathieu.zip

 

Today, I use Run_Me: results in file attachement.

 

If you've a time to take a look, I will appreciate.

Thanks in advance

Send me iMac-de-Mathieu.zip

Edited by Matgen84

Share this post


Link to post
Share on other sites

Great guide, Mald0n. Everything works fine on 10.13.6 except HDMI audio. Even p-states and turbo with oc'd multiplier without adding anything extra.

My PC is connected to a 2k monitor and 4k tv ( through an AVR ) and I get occasional sound cutoffs on the tv which is running cable.

I guess osx is trying to play some system sounds through HDMI.

A noobish problem: I still can't manage to boot without the usb drive. I installed clover post-install to both the ssd and to UEFI.

I copied your folder to the ssd and the hidden EFI partition. Right now clover configurator sees 5 config files -

1 on the usb drive, 1 on the ssd and 1 on the hidden EFI. There are also 2 config-sample files.

What am I doing wrong ?

My system is:

Asrock p67 pro3

i5-3470

GTX 1060 6gb

Samsung 860 Evo 500gb

Archer T4U AC1300

 

 

Share this post


Link to post
Share on other sites
On 1/30/2019 at 3:30 AM, Matgen84 said:

Hi @MaLd0n

 

Since macOS 10.13.6 and now under macOS 10.14.3, I've got a issue with my patched DSDT both IMac 13,1 or macmini7,1 SMBIOS: Mojave restart randomly at first boot. I have to reboot several times to get a normal startup. Rebuilding don't solve the problem.

 

 

Today, I use Run_Me: results in file attachement.

 

If you've a time to take a look, I will appreciate.

Thanks in advance

Send me iMac-de-Mathieu.zip

use only it

CLOVER.zip

generate one SSDT for PM

https://olarila.com/files/Utils/SSDT_Automator.zip

Share this post


Link to post
Share on other sites
4 hours ago, MaLd0n said:

use only it

CLOVER.zip

generate one SSDT for PM

https://olarila.com/files/Utils/SSDT_Automator.zip

 

Thanks a lot :) In Clover/ACPI/Patched/SSDT for USB isn't necessary despite USBInjectAll Readme by RehabMan, Right?

 

Generate one SSDT for PM means PowerManagement, right? SSDT Automator shows only for CPU. I don't understand. Give me some explanations, please.

Capture d’écran 2019-02-04 à 07.05.09.png

Edited by Matgen84

Share this post


Link to post
Share on other sites
4 hours ago, Matgen84 said:

 

Thanks a lot :) In Clover/ACPI/Patched/SSDT for USB isn't necessary despite USBInjectAll Readme by RehabMan, Right?

 

Generate one SSDT for PM means PowerManagement, right? SSDT Automator shows only for CPU. I don't understand. Give me some explanations, please.

Capture d’écran 2019-02-04 à 07.05.09.png

in Mojave USB fix is mandatory

Share this post


Link to post
Share on other sites

Hi MaLd0n,

In attached my "send me" file

My main problem is the USB 3.0 that is not working ...

the mobo have 6 USB 3.0 on the back , and the case (fractal design Define R6) two USB 2.0 and two USB 3.0 on the front panel

 

My hardware is following :

 

MOBO Gigabyte GA-Z87X-UD7-TH

CPU INTEL CORE I7 4790K

GPU GIGABYTE GTX 760 4 GB

RAM KINGSTON HYPERX SAVAGE DDR3 2400 MHZ

 

Thank you in advance

Fabio

 

Send me Mac-Pro.fritz.box.zip

Edited by moonbase70

Share this post


Link to post
Share on other sites
3 hours ago, moonbase70 said:

Hi MaLd0n,

In attached my "send me" file

My main problem is the USB 3.0 that is not working ...

the mobo have 6 USB 3.0 on the back , and the case (fractal design Define R6) two USB 2.0 and two USB 3.0 on the front panel

 

My hardware is following :

 

MOBO Gigabyte GA-Z87X-UD7-TH

CPU INTEL CORE I7 4790K

GPU GIGABYTE GTX 760 4 GB

RAM KINGSTON HYPERX SAVAGE DDR3 2400 MHZ

 

Thank you in advance

Fabio

 

Send me Mac-Pro.fritz.box.zip

DSDT.aml.zip

usb check here

--USB Fix
https://olarila.com/forum/viewtopic.php?p=65287#p65287

Share this post


Link to post
Share on other sites
7 hours ago, MaLd0n said:

Hi MaLd0n,

Thank You for the DSDT !!

Can you explain me step by step how to install the DSDT on my hackintosh (i'm a beginner on DSDT SSDT) ?

I place the file on EFI/CLOVER/ACPI/PATCHED but i don't know if i must make any other settings

Plaease let me know

Thank you

Share this post


Link to post
Share on other sites

hi mlad0n
how to enable alc221 audio on hp 600 g1 pc high sierra
my spec
i5 4670
4gb ram
gt1030 2gb gpu

Sent from my SM-A520F using Tapatalk

hi mlad0n
how to enable alc221 audio on hp 600 g1 pc high sierra
my spec
i5 4670
4gb ram
gt1030 2gb gpu

Sent from my SM-A520F using Tapatalk

Share this post


Link to post
Share on other sites
10 hours ago, Matgen84 said:

 

Hi @MaLd0n

 

Do you know HotPlug patch for internal harddrive Intel7series chipset on 10.14.+. Please.

 

Thanks in advance

no idea, u try a old patch?

Share this post


Link to post
Share on other sites
10 hours ago, MaLd0n said:

no idea, u try a old patch?

 

Thanks. :)  I try a old patch this morning, it's seems to work.

Share this post


Link to post
Share on other sites

Hey @MaLd0n kinda need your assistance again here..
I'm trying to install 10.13.6 on my ADATA SX8200 Pro M.2.
Everything when smooth, OSX installer detected the drive.
But when restart, clover can't detect the drive and only shows the USB Installer.
What's the problem?

Here's my IOReg

Send me Hilmans-iMac.zip

Share this post


Link to post
Share on other sites

Hi, thank you for your amazing work. I've just upgraded my Hackintosh from 10.11.6 to 10.14.3 Mojave, all works fine but i've some random freeze of the system (maybe due to Intel GPU acceleration? I've read many things online...) and i can't find a solution. Check the screen. Also, some USB aren't recognized at bootup, so i'can't use keyBoard and mouse on USB 3.0 port on the back of the mobo.

137725736_Screenshot2019-02-1818_37_38.png.229661637dd648cfb6a25187477efb14.png

On El Capitan OS All worked fine, except of the GPU Rx 580, which I just bought last week. Before I use an old HD 7870. Windows run fine, so no hardware problems.

 

Specs:

Intel Core i5 3570K @4.2GHz

Asrock Z77 Extreme 4 mobo

24GB of  DDR3 1866MHz RAM

Intel SSD

Radeon Rx 580 8GB GPU

3440x1440p 34" 21:9 Monitor

 

This is my DSDT patch:

SSDT.aml

 

And here the file obtained after RunMe App:

Send me iMacdiEmanuele.fritz.box.zip

Thanks in advance!

 

 

Share this post


Link to post
Share on other sites
On 2/12/2019 at 5:59 AM, rio_suck said:

Hey @MaLd0n kinda need your assistance again here..
I'm trying to install 10.13.6 on my ADATA SX8200 Pro M.2.
Everything when smooth, OSX installer detected the drive.
But when restart, clover can't detect the drive and only shows the USB Installer.
What's the problem?

Here's my IOReg

Send me Hilmans-iMac.zip

DSDT.aml.zip

Share this post


Link to post
Share on other sites
1 hour ago, palia95 said:

Hi, thank you for your amazing work. I've just upgraded my Hackintosh from 10.11.6 to 10.14.3 Mojave, all works fine but i've some random freeze of the system (maybe due to Intel GPU acceleration? I've read many things online...) and i can't find a solution. Check the screen. Also, some USB aren't recognized at bootup, so i'can't use keyBoard and mouse on USB 3.0 port on the back of the mobo.

 

On El Capitan OS All worked fine, except of the GPU Rx 580, which I just bought last week. Before I use an old HD 7870. Windows run fine, so no hardware problems.

 

Specs:

Intel Core i5 3570K @4.2GHz

Asrock Z77 Extreme 4 mobo

24GB of  DDR3 1866MHz RAM

Intel SSD

Radeon Rx 580 8GB GPU

3440x1440p 34" 21:9 Monitor

 

This is my DSDT patch:

SSDT.aml

 

And here the file obtained after RunMe App:

Send me iMacdiEmanuele.fritz.box.zip

Thanks in advance!

 

 

CLOVER.zip

infos

https://olarila.com/forum/viewtopic.php?f=62&t=7164

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By sierra2600
      The laptop in question: Acer TravelMate 8472 TM8472 (Model: ZQ3) (refer to the "Spoiler" at the end if you want the machine specs)
       
      "So what are you bugging us for?" Good question, because I am usually an introvert and usually just keep looking for answers but I could not find some. Jumping to it...
      What does not work and I would like thoughts on:
      Bluetooth does not register, used to on previous installs (sorry, I did not pay attention to see if this was caused by me updating to 10.8.5 but that was necessary for the below functions) (It does not work in Debian either - Ignore) LAN and WLAN  - I have found Kexts (somewhere, I think I just lost them... dang it...) for the WLAN but I have yet to try them, nothing for the LAN I know this is cheating but I read that The NDISulator for FreeBSD (HINT HINT) is a port of NDISwrapper for Linux that runs Windows XP network drivers in Linux or BSD Brightness controls work from the middle down on the "Sun" brightness overlay, I got this far from following this: https://www.insanelymac.com/forum/topic/287133-guide-backlight-brightness-for-intel-80860046-1st-gen-hd-gma-5700mhd/ but I am kind of thinking of trying: https://www.insanelymac.com/forum/topic/287133-guide-backlight-brightness-for-intel-80860046-1st-gen-hd-gma-5700mhd/?do=findComment&comment=2214344 . My "magic number" is: 0xF        I used DSDTEditor in Windows, since I figured all the drivers are loaded, to extract the DSDT and compile something that somewhat works... Wake from sleep issue - I tried the above guide for that but I get a no backlit display and I can see that the cursor in the password field is not flashing when I use an external light source, but it will reboot when I press Ctrl + Alt + Power "button" (it is actually a slider) and then also clear my freaking CMOS right down to the clock... yeah I have the ACPI fix implmented and it usually works... DVD Player.app reports that no viable video device was found (personally I don't care about the DVD Player.app problem, just wanted to put that out there for the heck of it) The microphone port always sounds like it is going through a [dirty] guitar effects petal no matter what sliders are adjusted  
      Likely causes of:
      Bluetooth (BCM92046), WIFI (BCM943225HM) - So, I USED TO be able to turn on the WIFI from within Windows then reboot into Mac OS and have it work but I noticed recently that the indicator light for them turns off BEFORE it reboots now. When Windows or Android load, it lights up- "No... really, captain obvious?!"... anyways... working "No really Sherlock!" so OBVIOUSLY, the OS has to activate them... and preferably ignore the wireless switching button For the WIFI module, if you omit the 9 and HM in a search, results appear! Brightness - Will get reset to full "Bright light! Bright light!" when a "Load System Defaults" is applied from within the BIOS settings but like the WIFI and Bluetooth the OS will forcefully take control of it Microphone In sounding dirty - me being lazy with the audio drivers LAN (BCM57760) - I dunno...  when I search it, nothing comes up...  
      "How did you get this far?"
      Update the BIOS, this is oh so very important (refer to the battery section of the "Spoiler" for the reson) PLEASE BACKUP YOUR BIOS FIRST! PLUG THE MACHINE INTO THE AC ADAPTER/CHARGER! DO NOT FORCE THE COMPUTER TO SHUTDOWN NOR REMOVE THE BATTERY NOR UNPLUG IT FROM THE AC ADAPTER/CHARGER WHILE IT IS UPDATING! I WILL NOT BE HELD LIABLE FOR BRICKED MACHINES! So it will boot off of the (Niresh) Mac OS X 10.8 with no changes to anything "Awesome" but you may still need at least a USB mouse "Aww" If you have the option to remove the display drivers/kexts otherwise it will not to boot or not display If you forgot this, breathe "You think that's air your breathing?"... anyways... during the bootloader, go into single user mode [ -s ] and follow the on screen instructions to allow for modifying the files. You will want to PREFERABLY create a folder where Mac OS cannot read them and move the IntelHDGraphics Kexts into it You are likely going to need an external USB keyboard as well now that it is installed Now install the described Kexts in the "Spoiler" associated with the hardware to get more functionality and loose the USB HICs  
      Any help pertaining to the Bluetooth, WIFI, LAN, bizarre brightness and wake after sleep backlit display issue would be wonderful... Thank you for your time and I hope that I helped anyone else out with some of their own issues pertaining to the Acer TravelMate 8472 TM8472 ZQ3 no nVidia with i5 laptop...
      (Attached are non-modified extracted DSDT DSL and AML files "with errors according to DSDTEditor" for reference of the machine with a Phoenix BIOS version of 1.28 (07/20/2011))
      dsdt.aml
      dsdt.dsl
       
       
    • By DoZe
      Hi :0)
       
      Hope As usual a perfect matching DSDT for this good Laptop.
       
      Regards, Ray
       
       
      SendMeStudiMac.zip
    • By tonyx86
      *** I have started another thread for installing Catalina on the Dell Latitude E6410.  If you were thinking of installing Mojave, but would prefer to skip right to Catalina, click here. ***
       
      I was inspired by @duduclx post here for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5 and subsequently 10.14.6.  Everything works perfectly (including sleep).  I'm starting this thread hoping to help others install Mojave on their E6410s.  A brief installation guide is provided later in this first post.  The interested reader is encouraged to read the other posts in this thread to see how this solution evolved and to learn additional tips/details not provided in this first post (including dual-booting with macOS and Windows).
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) MacOS: Mojave 10.14.6 (APFS) (Patched with DosDude Mojave Patcher 1.3.3) MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09") Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 6 developed by @Dr. Hurt and compiled by @bronxteck), not the original version), USBInjectAll (with custom SSDT-UIAC), VoodooSDHC.kext (configured as shown here). Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext) CLOVER (Legacy): R4961  
      Configuration items that may be different from what you have seen in other E6410 configurations
      Addition of _OFF and _ON methods to _PTS and _WAK methods respectively (to control discrete graphics in order to enable sleep/wake) LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2 ECDV renamed to EC so that AppleBusPowerController loads AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states) DSDT patched to include HDAU device (device-id 0x0be3)  
      What is NOT working:
      Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings. Graphics Power Management - AGPM loads (because 10de,0a29 device is injected), but there's no evidence that 3100m frequency and voltage is changing.
        What is NOT tested:
      Smartcard Reader eSata (I have this disabled in my BIOS) Firewire Port (it does appear in the Network settings, just haven't tried it) Microphone Jack PC Card Slot (I have this disabled in my BIOS)  
      What IS working:
      SLEEP IS WORKING! Everything else not mentioned above.   Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long Shutdown is fast Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher) Brightness (adjusted with brightness keys on keyboard) works perfectly Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext. Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext) Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout." Ethernet port (with IntelMausiEthernet.kext) Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext) Optical Drive External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: here) for working external VGA display. Headphone jack Display Port (tested using DP > HDMI adapter) Camera SD Card Reader  
      Known issues and their solutions (These issues have all been resolved, with the solutions incorporated into the attached config files.  The issues are listed here for historical purposes and no further work is needed unless stated otherwise).
      Laptop does not sleep on lid close.  Solution is to add Notify (LID0) code to Method (BTNV) in the DSDT.  This is solved in the attached DSDT. Leaving this for historical purposes, but the CLOVER USBFix is no longer necessary after finding that I had incorrectly applied the DSDT _DSM patch for Device (EHC1).  The CLOVER USBFix is not needed after fixing the DSDT..  AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  Thank you, @feartech, for this tip. ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement.  I've implemented and tested this on my system.  The ALPS version of VoodooPS2Controller.kext mixes up a few keys.  Need to switch the Command and Option keys (System Preferences > Keyboard > Modifier Keys) and change keyboard type to ISO European. This configuration (captured in the attached config files) uses an injected device-id (10de,0a29) for NVidia 3100m to get AGPM to load.  While I haven't observed any performance differences, a better approach may be to inject AGPM properties for device 10de,0a6c (the actual device-id for the 3100m).  This AGPM method is discussed later in this thread.  I have briefly tested this "FakeSMC.kext method" for injecting AGPM attributes without any noticeable changes in laptop/graphics behavior. IOHWControl is not loaded under AGPM (Should be AGP > VID > NVDA,Display-A@0 > NVDATesla > AGPM > gpu-control > IOHWControl as viewed in IORegistryExplorer).  It is loaded on a real MacBookPro6,2 running Mojave and is loaded on this Dell Latitude E6410 running High Sierra.  If I "Inject NVidia" via CLOVER, IOHWControl loads properly. The Dell Latitude DSDT (BIOS A17) has a bug in Method (GNOT).  In the method, the expression  If (LOr (LGreater (OSYS, 0x07D0), LLess (OSYS, 0x07D6))) always evaluates to TRUE, so the patched DSDT has no dependency on the value of OSYS.  I suspect that LOr should be replaced with LAnd, so that this expression is TRUE for variants of Windows 2001 and False for any other OS.  While this may have no affect on MacOS, it makes one wonder how such an obvious bug made it through Dell QA and is still present in BIOS A17.  Also makes one wonder whether the sleep problem (which no one has solved) was fixed in Windows to address another DSDT bug. The assigned value of ACOS and OSYS in the DSDT are conditional on the operating system.  There is no condition for "Darwin."  The solution is to add a condition for "Darwin" (making it equivalent to one of the defined operating systems (e.g. Linux, Win7, etc).  The attached config hard-codes ACOS and OSYS values equivalent to those for Linux.  Another way to handle this (different from the method employed in the attached config files) might be to override _OSI with XOSI (defined in a custom SSDT). The portType of the Internal Bluetooth device is portType=0 which, according to Rehabman's comments in SSDT-UIAC-All.dsl, is an external USB 2 port.  This should be an internal USB port (portType=2).  I learned through trial and error that the HUB1 and HUB2 definitions in Rehabman's SSDT-UIAC-ALL.dsl apply to the ports on the EHCx USB hubs.  The solution is to include the HUB1 definition in SSDT-UIAC.dsl and change portType to 2 for HP15.  This change doesn't appear to affect/fix sleep, but it may prevent instant wake if we get sleep working. There are minor differences between a real MacBookPro6,2 IORegistry dump and this HackBookPro6,2 IORegistry dump that can be resolved with simple DSDT edits.  I am now running with these changes, but haven't found these changes to make any difference in operational behavior.
      Rename Device (AC) -> Device (ADP1) Remove UID from Device (HPET) Add compatible ID "PNP0C01" to Device (HPET) Change ADP1:_STA from 0x0F to 0xFFFFFFFF Enable Ambient Light Sensor and renamed to Device (ALS0) from Device (ALS) Add compatible ID "smc-als" to ALS0 Rename LID -> LID0 Change "name" definitions to Buffers in _DSM methods Rename Device (PBTN) to PWRB Rename Device (SBTN) to (SLPB) Change HDAU.hda-gfx from "onboard-1" to "onboard-2" Change GFX0.hda-gfx from "onboard-1" to "onboard-2" Sleep / Wake does not work with the basic DSDT edits.  I have discovered that Sleep / Wake can be made to work by adding discrete graphics _OFF and _ON methods to _PTS and _WAK methods respectively (borrowed the concept and code from a working E6430 DSDT: Credit here: https://osxlatitude.com/forums/topic/9248-working-sleep-on-intel-hd-and-nvidia-nvs-on-dell-latitude-e6430-optimus-enabled-or-disabled/page/6/. The Clover boot arg should be changed to "darkwake=0" for reasons explained by @holyfield in this thread.  Leaving this for historical purposes: LCD screen is blank when waking laptop by opening lid (screen is not blank when waking with power button).  Solution is to add darkwake=8 to CLOVER boot args.  Thank you @Hervé for this tip.  
      Brief Installation Guide:
      Configure BIOS (version A17) as follows (leave default unless listed here): Boot Sequence: USB, Internal HDD, CD/DVD, Modular Bay HDD; Boot List Option: Legacy; Integrated NIC: Enabled; Parallel Port: Disabled; Serial Port: Disabled; SATA Operation: AHCI; Misc Devices: Enable Modular Bay, Camera, External USB, Microphone, Media Card and 1394; Latitude ON Reader: Disabled; Keyboard Illumination: Auto ALS and Input; Ambient Light Sensor: Enabled; OROM Keyboard Access: Disable; TPM Security: Disable; Computrace: Deactivate; CPU XD Support: Enable; Performance: Enable all options; Power Management: Disable Wake on AC, Disable Wake on LAN/WAN, Express Charge: Standard, Charge Behavior: Enabled; Keypad: Fn Key Only; Mouse/Touchpad: Touchpad/PS-2 Mouse; USB Emulation: Enable Legacy; Fn Key Emulation: Disabled; Fastboot: Thorough; Virtualization: Enable Intel Virtualization, Disable VT for Direct I/O, Disable Trusted Execution; Wireless Switch: Bluetooth and WLAN; Wireless Device Enable: Bluetooth and WLAN;  Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh). Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist Install MacOS to your SSD.  When you run DosDude's Mojave Patcher, DO NOT install LegacyUSBInjector.kext - you're going to use Rehabman's USBInjectAll.kext.  Also, do not install the DosDude SIP kext (you're using CLOVER to manage SIP). Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original), VoodooSDHC.kext (configured as shown here). Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys).  Also change keyboard type to ISO European to fix the [ ` ~ ] key (to the left of the "1" (one) key. Install VoodooHDA Install HWMonitor application  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z After applying Mojave updates, HWMonitor may not display discrete graphics attributes.  On systems with multiple displays, a second (or third display) may not be active after applying the Mojave update.  The solution to this is to run "sudo kextcache -i /" (in a terminal window) and reboot.  This will usually fix the issue.  If the issue is not fixed, run DosDude's Post Install Utility, apply the Legacy Graphics Patch, reboot and then run "sudo kextcache -i /" if necessary.  
      Credits
      In addition to those mentioned in this first post and in subsequent posts in this thread, much of this solution for the Latitude E6410 was made possible by the numerous contributions of @RehabMan.  I hope he's doing well, wherever he is.  Hopefully he has long since forgotten what a PIA I was (and still am) as I was (and still am) learning hackOS.  
       
       


      E6410-Mojave-6v3.zip
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
×