Jump to content
MaLd0n

[Guide] El Capitan, Sierra / High Sierra / Mojave / Catalina on Intel 5, 6, 7, 8, 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

2,483 posts in this topic

Recommended Posts

5 hours ago, waters said:

Hello MaLd0n,
Please I need your support for Clover folder and dsdt-ssdt patching,
Im not newbie on hackintoshing, but gave a huge 4 years gap since 10.10 's  till Mojave :(

 

As you can see from my partition table and screenshots; (inside attached file.)
I have a 90% working mbr chameleon HSierra (Niresh) on one disk and decided to install guid Mojave on the other disk;
(Bios is ahci legacy, not UEFI as I need legacy for other os.)

 

I can success in getting QE/CI (HD4000) once in 10 times trial.     ...need your clover support...
But the main problem is; its an AllinOne PC, (no certain vendor but Acer did similars in 2013's)
So, oncpu vga has only hdmi out and inside lvds connect (old 2013's one finger touch)
I can only see from hdmi output, any osx installation will start from lvds screen and continue from hdmi output when choose your region screen
starts at installation procedure.

 

 

Specs;

--------------------
21.5 monitor, one finger touch, AllinOne PC

touch need no driver, one finger press left mouse, stay 3 sec more: right mouse. thats all.
H61 chipset; mainboard ECS H61H-G11 V1.0A  Ivy bridge
i5 3570K cpu, has HD4000 vga on it. hdmi out only, connected by lvds from inside like notebooks.
2x 4 gb ddr3 1333Mhz ram
slim mainboard, no pci slots. very huge fans.
1 minipci slot connected Broadcom wifi                     works
sound: realtek 662 +intel                                        works
network Realtek RTL811                                          works
usb bluetooth (Belkin-Broadcom)                           works
webcam                                                                 works
sd card reader  Realtek                                           works
usb kb and mouse                                                  works
i have no usb 3.0 ports, only 2.0

--------------------

 

note1: I cant install any external vga as the mainboard has no pci-e, pci, ... any slots available. no slot mainboard.
note2: if i choose in clover dsdt file:bios.aml its different, if i choose file:dsdt.aml its different!
note3: this (Mojave) is an installation of legacy, ahci bios, guid hdd.   (not an uefi guid installation)...


I think my smbios model should be iMac 13,2   -   not 14,2 ???
SSDT.aml in main folder taken by ssdtPRGen.command

 

Thanks.

www.insanelymac.com_files.zip

DSDT.aml.zip

Share this post


Link to post
Share on other sites
Advertisement

Hi, ty

After copying dsdt.aml to efi/clover/acpi/patched ... folder;

And in clover start ---> choosing the dsdt file=dsdt.aml,  instead of bios.aml,

 

its all same again; except that now i can see all my pci card definitions in the system report. (picture below)

it was empty before.

 

I can sometimes open system with full qe/ci (transparent menubar and taskbar) , but most of the times it is not, but always says hd4000 1.5 gb vga detected in system report.

 

Can you send me a sample config.plist for Ivy systems 3xxx series cpu, hd4000 vga,

my mainboard was Sandy with an i3 2xxx cpu, i updated bios(me) to ivy and updated cpu to i5 3xxx.

As im sure of its related with the clover acpi patch choices and mojave patches.

 

My config.plis below. cheers.

 

after_dsdt.png

config.plist.zip

Share this post


Link to post
Share on other sites

Thank you for your kind replies :)

 

I studied a bit, downloaded your config.plist for"Intel 5, 6, 7, 8, 9 Chipset Series"   edited config.plist boot arguments and added some Mojave patches,Now i can alwayz boot with qe/ci on, (from the hdmi output)   :)  :)  :)  

So this part is stable now!

 

By the way if i use your kext folder, as soon as graphics starts, computer shuts down.

So i use my kexts, this is maybe because of never kexts needed for Mojave side.

 

Mojave thinks my Mac is "Macmini6,2"    Its feasable because that one has no screen, only vga/dvi/hdmi out to an external monitor.

But i wanted my Mac to be either iMac13,2 or 14,2

 

Question 1: is it ok to edit smbios and serial number bla bla... to achieve iMac 13,2 ? or may it ruin my system - qe/ci ?

 

You see from below picture, right side is AllinOne PC, left side is external monitor.

just before OS starts, the white apple logo on black screen; the view goes to the external monitor. login screen comes from ext. mon.

 

Question 2 : From my past experience its related for HD4000 vga, AppleIntelFramebufferCapri.kext and AppleIntelSNBGraphicsFB.kext or similars for Mojave...

will i go on editing them for internal lvds screen or

will i go on editing clover setup with clover configurator for vga ?

 

Thanks a lot...

 

apple-mac-mini-2011.jpg

apple-imac-27-2012.jpg

screenmain.jpg

Share this post


Link to post
Share on other sites

Im so close more than ever :)

 

Added 01660005   (HD4000 vga on some notebooks) from clover menu inside graphics injector  fakeid ...

 

Now view is on both screens, of course no QE/CI :P

 

 

01660005.png

screenmain2.jpg

Share this post


Link to post
Share on other sites
5 hours ago, Fantasy761 said:

Hi @MaLd0n Is it possible to make startup/shutdown more consistent and quicker? Sometimes it takes a long time to shutdown. I have the DSDT you made for me.

DSDT.aml

clover have options for it

 

Reset Adress and Reset Value, acpi tab

Share this post


Link to post
Share on other sites
9 hours ago, MaLd0n said:

clover have options for it

 

Reset Adress and Reset Value, acpi tab

 

Is there anything else that will help? I tried all of it but i'm not sure if it does anything

Share this post


Link to post
Share on other sites

Hi MaLd0n,

 

Got somewhat further with my Lenovo T470s - wifi, start up / shut down and all functions seem ok

 

Still issue with Battery indicator / and trackpad (using Rehabman's kexts)

 

I've attached the runme files - hoping you could take a look and advise?

Send me MacBook-Pro-2.zip

 

Thanks in advance bro

Edited by Dan_Marshall

Share this post


Link to post
Share on other sites
11 hours ago, Fantasy761 said:

@MaLd0n I just ran into an issue. My USB 3.0 card reader doesnt work on macos. I tried it on Windows and it's working. 

Screen Shot 2018-10-12 at 8.46.10 PM.png

DSDT.aml.zip

5 hours ago, Dan_Marshall said:

Hi MaLd0n,

 

Got somewhat further with my Lenovo T470s - wifi, start up / shut down and all functions seem ok

 

Still issue with Battery indicator / and trackpad (using Rehabman's kexts)

 

I've attached the runme files - hoping you could take a look and advise?

Send me MacBook-Pro-2.zip

 

Thanks in advance bro

hey

trackpad u need a correct plugin PS2, u know a correct model u have?

 

Battery don't have in rehabman repository? have a some infos here

https://github.com/RehabMan/OS-X-ACPI-Battery-Driver

 

add a PlugIn type in ur config.plist, acpi tab

Share this post


Link to post
Share on other sites
22 minutes ago, MaLd0n said:

DSDT.aml.zip

hey

trackpad u need a correct plugin PS2, u know a correct model u have?

 

Battery don't have in rehabman repository? have a some infos here

https://github.com/RehabMan/OS-X-ACPI-Battery-Driver

 

add a PlugIn type in ur config.plist, acpi tab

Hi MaLd0n - Trackpad now working fine and set up well

 

Battery Kext in however still no go. When power pugged in, battery status is 0% and low battery warning when umplugged.

 

Attached send me files with updates

 

 

Send me MacBook-Pro-2.zip

Edited by Dan_Marshall

Share this post


Link to post
Share on other sites
1 hour ago, Dan_Marshall said:

Hi MaLd0n - Trackpad now working fine and set up well

 

Battery Kext in however still no go. When power pugged in, battery status is 0% and low battery warning when umplugged.

 

Attached send me files with updates

 

 

Send me MacBook-Pro-2.zip

what correct notebook model?

Share this post


Link to post
Share on other sites

Hello,

 

 

need help please! I am trying to install High Sierra (or Mojave, happy to have either) on a Dell Optiplex XE2 desktop, which has a Q87 chipset with Core i7 4770s haswell processor with 32GB (4x8GB) DDR3 160MHz Kingston RAM from Hynix.

I have an ASUS GT730 in the system, I will get that running in some way or other after the install... for the install I am happy to use VESA mode.

I have played around with Hackintosh in the past (last time being LION) and always managed to get it working, on different hardware - Dell and Lenovo laptops and Dell desktops mainly.

However, after a week of trying different versions of clover with different patch options, I have yet to be able to successfully start the High Sierra or Mojave installer. I have the high sierra latest version downloaded from the Mac store.

Not worried about USB3, about sound etc. I just want to get the installer working, get a system that boots, anything else is a bonus as I figure that I can work other stuff out later.

 

I have attached the DSDT dump of my system here, if anyone can help in any way, I would be very appreciative.

 

THanks,

 

Neale

ACPIDump.7z

Share this post


Link to post
Share on other sites
1 hour ago, nealedowling said:

Hello,

 

 

need help please! I am trying to install High Sierra (or Mojave, happy to have either) on a Dell Optiplex XE2 desktop, which has a Q87 chipset with Core i7 4770s haswell processor with 32GB (4x8GB) DDR3 160MHz Kingston RAM from Hynix.

I have an ASUS GT730 in the system, I will get that running in some way or other after the install... for the install I am happy to use VESA mode.

I have played around with Hackintosh in the past (last time being LION) and always managed to get it working, on different hardware - Dell and Lenovo laptops and Dell desktops mainly.

However, after a week of trying different versions of clover with different patch options, I have yet to be able to successfully start the High Sierra or Mojave installer. I have the high sierra latest version downloaded from the Mac store.

Not worried about USB3, about sound etc. I just want to get the installer working, get a system that boots, anything else is a bonus as I figure that I can work other stuff out later.

 

I have attached the DSDT dump of my system here, if anyone can help in any way, I would be very appreciative.

 

THanks,

 

Neale

ACPIDump.7z

DSDT.aml.zip

Share this post


Link to post
Share on other sites
39 minutes ago, MaLd0n said:

Wow, that was quick. Thank you. I'll try that now.

So to recap, just to check I'm not doing anything stupid:

 

Erase USB and destination disk in my MacOS VM with Disk Utility.

Create USB installer with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and High Sierre image from App Store / iTunes Store / Mac store (What do they call it on a mac?)

Download clover forlder for Intel 5 6 7 8 etc chipset from Olarila, and overwrite any existing files.

Use clover configurator to change :

SMBIOS - set up as iMac 14.3 (has i5 4570s whereas I have i7 4770s) - in system select Trust, generate SmUUID and Serial NUmber - ensure serial unused on real mac by checking warranty coverage with Apple.

image.png.26cfe4ee75a9f9d9c50eab897f35b8fa.png

Check ACPI settings to ensure correct DSDT name used and copy the extracted file you kindly uploaded and copy to CLOVER/ACPI/patched.

image.thumb.png.b4bafd1e5451ba7422441f535c73c74f.png

FYI, and as you can see from my clover configurator, I have not set any details for my RAM memory. I can do that if required...

 

I will give this setup a try now and let you know how I get on.....

There will definately be a beer or two to donate if I can get OSX at least installed.

Also, never know if DellSMBIOS patch is required or not.... is it for all Dell machines - maybe only laptops... will try with and without...

Share this post


Link to post
Share on other sites
26 minutes ago, nealedowling said:

Wow, that was quick. Thank you. I'll try that now.

So to recap, just to check I'm not doing anything stupid:

 

Erase USB and destination disk in my MacOS VM with Disk Utility.

Create USB installer with ##### and High Sierre image from App Store / iTunes Store / Mac store (What do they call it on a mac?)

Download clover forlder for Intel 5 6 7 8 etc chipset from Olarila, and overwrite any existing files.

Use clover configurator to change :

SMBIOS - set up as iMac 14.3 (has i5 4570s whereas I have i7 4770s) - in system select Trust, generate SmUUID and Serial NUmber - ensure serial unused on real mac by checking warranty coverage with Apple.

k

Share this post


Link to post
Share on other sites

It is getting further, for sure, and I have tried with and without the DellSMBIOS pach and without, and tried disabling the Intel Graphics and not...

Here is where it is getting to after selecting Installer from Clover. Do I need to set memory module info in clover configurator?Boot.thumb.jpg.f543faa2ff048f82e0ba03d15f656778.jpg:

One last question: I need to set plugin type to 1 as in the screenshot above right?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tonyx86
      *** I have started another thread for installing Catalina on the Dell Latitude E6410.  If you were thinking of installing Mojave, but would prefer to skip right to Catalina, click here. ***
       
      I was inspired by @duduclx post here for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5 and subsequently 10.14.6.  Everything works perfectly (including sleep).  I'm starting this thread hoping to help others install Mojave on their E6410s.  A brief installation guide is provided later in this first post.  The interested reader is encouraged to read the other posts in this thread to see how this solution evolved and to learn additional tips/details not provided in this first post (including dual-booting with macOS and Windows).
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) MacOS: Mojave 10.14.6 (APFS) (Patched with DosDude Mojave Patcher 1.3.3) MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09") Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 6 developed by @Dr. Hurt and compiled by @bronxteck), not the original version), USBInjectAll (with custom SSDT-UIAC), VoodooSDHC.kext (configured as shown here). Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext) CLOVER (Legacy): R4961  
      Configuration items that may be different from what you have seen in other E6410 configurations
      Addition of _OFF and _ON methods to _PTS and _WAK methods respectively (to control discrete graphics in order to enable sleep/wake) LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2 ECDV renamed to EC so that AppleBusPowerController loads AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states) DSDT patched to include HDAU device (device-id 0x0be3)  
      What is NOT working:
      Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings. Graphics Power Management - AGPM loads (because 10de,0a29 device is injected), but there's no evidence that 3100m frequency and voltage is changing.
        What is NOT tested:
      Smartcard Reader eSata (I have this disabled in my BIOS) Firewire Port (it does appear in the Network settings, just haven't tried it) Microphone Jack PC Card Slot (I have this disabled in my BIOS)  
      What IS working:
      SLEEP IS WORKING! Everything else not mentioned above.   Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long Shutdown is fast Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher) Brightness (adjusted with brightness keys on keyboard) works perfectly Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext. Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext) Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout." Ethernet port (with IntelMausiEthernet.kext) Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext) Optical Drive External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: here) for working external VGA display. Headphone jack Display Port (tested using DP > HDMI adapter) Camera SD Card Reader  
      Known issues and their solutions (These issues have all been resolved, with the solutions incorporated into the attached config files.  The issues are listed here for historical purposes and no further work is needed unless stated otherwise).
      Laptop does not sleep on lid close.  Solution is to add Notify (LID0) code to Method (BTNV) in the DSDT.  This is solved in the attached DSDT. Leaving this for historical purposes, but the CLOVER USBFix is no longer necessary after finding that I had incorrectly applied the DSDT _DSM patch for Device (EHC1).  The CLOVER USBFix is not needed after fixing the DSDT..  AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  Thank you, @feartech, for this tip. ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement.  I've implemented and tested this on my system.  The ALPS version of VoodooPS2Controller.kext mixes up a few keys.  Need to switch the Command and Option keys (System Preferences > Keyboard > Modifier Keys) and change keyboard type to ISO European. This configuration (captured in the attached config files) uses an injected device-id (10de,0a29) for NVidia 3100m to get AGPM to load.  While I haven't observed any performance differences, a better approach may be to inject AGPM properties for device 10de,0a6c (the actual device-id for the 3100m).  This AGPM method is discussed later in this thread.  I have briefly tested this "FakeSMC.kext method" for injecting AGPM attributes without any noticeable changes in laptop/graphics behavior. IOHWControl is not loaded under AGPM (Should be AGP > VID > NVDA,Display-A@0 > NVDATesla > AGPM > gpu-control > IOHWControl as viewed in IORegistryExplorer).  It is loaded on a real MacBookPro6,2 running Mojave and is loaded on this Dell Latitude E6410 running High Sierra.  If I "Inject NVidia" via CLOVER, IOHWControl loads properly. The Dell Latitude DSDT (BIOS A17) has a bug in Method (GNOT).  In the method, the expression  If (LOr (LGreater (OSYS, 0x07D0), LLess (OSYS, 0x07D6))) always evaluates to TRUE, so the patched DSDT has no dependency on the value of OSYS.  I suspect that LOr should be replaced with LAnd, so that this expression is TRUE for variants of Windows 2001 and False for any other OS.  While this may have no affect on MacOS, it makes one wonder how such an obvious bug made it through Dell QA and is still present in BIOS A17.  Also makes one wonder whether the sleep problem (which no one has solved) was fixed in Windows to address another DSDT bug. The assigned value of ACOS and OSYS in the DSDT are conditional on the operating system.  There is no condition for "Darwin."  The solution is to add a condition for "Darwin" (making it equivalent to one of the defined operating systems (e.g. Linux, Win7, etc).  The attached config hard-codes ACOS and OSYS values equivalent to those for Linux.  Another way to handle this (different from the method employed in the attached config files) might be to override _OSI with XOSI (defined in a custom SSDT). The portType of the Internal Bluetooth device is portType=0 which, according to Rehabman's comments in SSDT-UIAC-All.dsl, is an external USB 2 port.  This should be an internal USB port (portType=2).  I learned through trial and error that the HUB1 and HUB2 definitions in Rehabman's SSDT-UIAC-ALL.dsl apply to the ports on the EHCx USB hubs.  The solution is to include the HUB1 definition in SSDT-UIAC.dsl and change portType to 2 for HP15.  This change doesn't appear to affect/fix sleep, but it may prevent instant wake if we get sleep working. There are minor differences between a real MacBookPro6,2 IORegistry dump and this HackBookPro6,2 IORegistry dump that can be resolved with simple DSDT edits.  I am now running with these changes, but haven't found these changes to make any difference in operational behavior.
      Rename Device (AC) -> Device (ADP1) Remove UID from Device (HPET) Add compatible ID "PNP0C01" to Device (HPET) Change ADP1:_STA from 0x0F to 0xFFFFFFFF Enable Ambient Light Sensor and renamed to Device (ALS0) from Device (ALS) Add compatible ID "smc-als" to ALS0 Rename LID -> LID0 Change "name" definitions to Buffers in _DSM methods Rename Device (PBTN) to PWRB Rename Device (SBTN) to (SLPB) Change HDAU.hda-gfx from "onboard-1" to "onboard-2" Change GFX0.hda-gfx from "onboard-1" to "onboard-2" Sleep / Wake does not work with the basic DSDT edits.  I have discovered that Sleep / Wake can be made to work by adding discrete graphics _OFF and _ON methods to _PTS and _WAK methods respectively (borrowed the concept and code from a working E6430 DSDT: Credit here: https://osxlatitude.com/forums/topic/9248-working-sleep-on-intel-hd-and-nvidia-nvs-on-dell-latitude-e6430-optimus-enabled-or-disabled/page/6/. The Clover boot arg should be changed to "darkwake=0" for reasons explained by @holyfield in this thread.  Leaving this for historical purposes: LCD screen is blank when waking laptop by opening lid (screen is not blank when waking with power button).  Solution is to add darkwake=8 to CLOVER boot args.  Thank you @Hervé for this tip.  
      Brief Installation Guide:
      Configure BIOS (version A17) as follows (leave default unless listed here): Boot Sequence: USB, Internal HDD, CD/DVD, Modular Bay HDD; Boot List Option: Legacy; Integrated NIC: Enabled; Parallel Port: Disabled; Serial Port: Disabled; SATA Operation: AHCI; Misc Devices: Enable Modular Bay, Camera, External USB, Microphone, Media Card and 1394; Latitude ON Reader: Disabled; Keyboard Illumination: Auto ALS and Input; Ambient Light Sensor: Enabled; OROM Keyboard Access: Disable; TPM Security: Disable; Computrace: Deactivate; CPU XD Support: Enable; Performance: Enable all options; Power Management: Disable Wake on AC, Disable Wake on LAN/WAN, Express Charge: Standard, Charge Behavior: Enabled; Keypad: Fn Key Only; Mouse/Touchpad: Touchpad/PS-2 Mouse; USB Emulation: Enable Legacy; Fn Key Emulation: Disabled; Fastboot: Thorough; Virtualization: Enable Intel Virtualization, Disable VT for Direct I/O, Disable Trusted Execution; Wireless Switch: Bluetooth and WLAN; Wireless Device Enable: Bluetooth and WLAN;  Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh). Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist Install MacOS to your SSD.  When you run DosDude's Mojave Patcher, DO NOT install LegacyUSBInjector.kext - you're going to use Rehabman's USBInjectAll.kext.  Also, do not install the DosDude SIP kext (you're using CLOVER to manage SIP). Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original), VoodooSDHC.kext (configured as shown here). Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys).  Also change keyboard type to ISO European to fix the [ ` ~ ] key (to the left of the "1" (one) key. Install VoodooHDA Install HWMonitor application  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z After applying Mojave updates, HWMonitor may not display discrete graphics attributes.  On systems with multiple displays, a second (or third display) may not be active after applying the Mojave update.  The solution to this is to run "sudo kextcache -i /" (in a terminal window) and reboot.  This will usually fix the issue.  If the issue is not fixed, run DosDude's Post Install Utility, apply the Legacy Graphics Patch, reboot and then run "sudo kextcache -i /" if necessary.  
      Credits
      In addition to those mentioned in this first post and in subsequent posts in this thread, much of this solution for the Latitude E6410 was made possible by the numerous contributions of @RehabMan.  I hope he's doing well, wherever he is.  Hopefully he has long since forgotten what a PIA I was (and still am) as I was (and still am) learning hackOS.  
       
       


      E6410-Mojave-6v3.zip
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By headkaze
      English: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md
      Russian: https://www.applelife.ru/threads/intel-hd-graphics-3000-4000-4400-4600-5000-5500-5600-520-530-630.1289648/
      Chinese: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.cn.md
×