Jump to content
MaLd0n

[Guide] El Capitan, Sierra / High Sierra / Mojave / Catalina on Intel 5, 6, 7, 8, 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

2,490 posts in this topic

Recommended Posts

Advertisement
4 minutes ago, firefly_can_fly said:

Thank you. 

This made this build work almost fully without a hassle. Tomorrow will continue to dig in and clear configs. Thanks again! 

test all usb ports with device usb 3

Share this post


Link to post
Share on other sites

Hi Maldon

I install Gigabyte Thunder 3 card GC-ALPINE RIDGE

Please help for this

#Thunderbolt card not work my DSDT only work SSDT.

#shut down not work

#when I press sleep button sudden wake up system.

Thank you.

 

 

Edited by nmano

Share this post


Link to post
Share on other sites
On 4/26/2018 at 7:56 AM, nosize said:

Hi, please help with my DSDT

 

GA-Z77X-UD5H (rev. 1.1)

i7 3770K

4096Mb Gigabyte GeForce GTX970 G1 GAMING-4GD 

 

 

https://www.dropbox.com/s/nczx6fk684ym3yt/Send me iMac-Alexandr.zip?dl=0

send me new files after reboot, test all usb ports with device usb3

CLOVER.zip

Share this post


Link to post
Share on other sites
On 4/26/2018 at 8:20 PM, nylock10 said:

Got an install working on an ASRock Z68 Extreme4 Gen3 with an i5 2500K. Generated my own config.plist and used kexts specific for my system. Here's everything if you don't mind looking at it. Thanks.

send me new files after reboot, test all usb ports with device usb3

CLOVER.zip

Share this post


Link to post
Share on other sites
51 minutes ago, nmano said:

Hi Maldon

I install Gigabyte Thunder 3 card GC-ALPINE RIDGE

Please help for this

#Thunderbolt card not work my DSDT only work SSDT.

#shut down not work

#when I press sleep button sudden wake up system.

Thank you.

 

Send me navaratnams-Mac-Pro.zip

remove dsdt/ssdts and extact files without nothing

RunMe.app.zip

Share this post


Link to post
Share on other sites
1 hour ago, MaLd0n said:

send me new files after reboot, test all usb ports with device usb3

CLOVER.zip

 

Thank you! Here are newly generated files after adding your changes and patched DSDT.

 

All USB 2.0 ports work. However, nothing connected to the USB 3.0 ports work. System Report recognizes when something is plugged but nothing mounts (see attachment).

Screen Shot 2018-04-28 at 3.40.24 PM.png

Share this post


Link to post
Share on other sites
37 minutes ago, nylock10 said:

 

Thank you! Here are newly generated files after adding your changes and patched DSDT.

 

All USB 2.0 ports work. However, nothing connected to the USB 3.0 ports work. System Report recognizes when something is plugged but nothing mounts (see attachment).

Screen Shot 2018-04-28 at 3.40.24 PM.png

ur usb3.x is not Intel, u need check if have support

Share this post


Link to post
Share on other sites
57 minutes ago, vinhkm6 said:

Hi @MaLd0n

can you fix shutdown on mac 10.13.1

I used ur dsdt as signature

It  issues i shutdown the machine but it still runs (black screen)

tks so much

https://app.box.com/s/mresnxz8okgztiqh6tniggpyw2afsnep

https://app.box.com/s/jodlowrm0erufw7qz1ctl6ycbjfvnnec

looks good, shutdown is done

https://www74.zippyshare.com/v/siT42Vnd/file.html
 

Share this post


Link to post
Share on other sites
14 hours ago, MaLd0n said:

remove dsdt/ssdts and extact files without nothing

RunMe.app.zip

I remove DSDT and SSDT I update sendme.

Send me navaratnams-Mac-Pro.zip

Share this post


Link to post
Share on other sites
3 minutes ago, MaLd0n said:

use dsdt and kext from new folder, avoid use csm driver

yes i did so but no change, it stil not shutdown

i'm so sad:(

3 minutes ago, MaLd0n said:

use dsdt and kext from new folder, avoid use csm driver

yes i did so but no change, it stil not shutdown

i'm so sad:(

Share this post


Link to post
Share on other sites
2 hours ago, nmano said:

I remove DSDT and SSDT I update sendme.

Send me navaratnams-Mac-Pro.zip

DSDT.aml.zip

 

EVMR to PMCR
4556 4d52
504d 4352

 

GLAN to GIGE
474c 414e
4749 4745

 

ALZA to HDEF
414c 5a41
4844 4546

 

LPC0 to LPCB
4c50 4330
4c50 4342

 

SMBS to SBUS
534d 4253
5342 5553

 

SAT1 to SATA
5341 5431
5341 5441

 

HECI to IMEI
4845 4349
494d 4549

 

EVSS to SAT0
4556 5353
5341 5430

2 hours ago, nosize said:

Thank you. All USB 2 - 3 ports work.

Is it possible to transfer the GPU to slot number 1?

https://www.dropbox.com/s/16hwlb1sfm0kde1/Send me iMac-Alexandr.zip?dl=0

peg0 is a correct slot

11 minutes ago, vinhkm6 said:

yes i did so but no change, it stil not shutdown

i'm so sad:(

yes i did so but no change, it stil not shutdown

i'm so sad:(

the problem is other, shutdown is applied, something block it

Share this post


Link to post
Share on other sites
20 minutes ago, MaLd0n said:

the problem is other, shutdown is applied, something block it

i think so, it run perfect in 10.10.x but update 10.12.x or 10.13.x it block shutdown

once again tks u

Share this post


Link to post
Share on other sites

Hi Maldon

Now thunderbolt card work on DSDT

#Shout down not work

#Sleep not work

Thank you.

Send me navaratnams-Mac-Pro.zip

Share this post


Link to post
Share on other sites
12 minutes ago, nmano said:

Hi Maldon

Now thunderbolt card work on DSDT

#Shout down not work

#Sleep not work

Thank you.

Send me navaratnams-Mac-Pro.zip

try a simple config without sensors, etc

DSDT.aml.zip

check ur usb too, a good solution is usbinjectall+x99 injector + rename device to XHC

 

what hhapens with sleep and shutdown?

Share this post


Link to post
Share on other sites

Hello maldon..

 

i'm having trouble post installing Sierra or High Sierra :(

and actually kinda lost in bunch of trials..

No keyboard and touchpad

No sound

Cannot get 970M working with nvidia webdriver

M2 detected in Sierra but not working at all in HS

 

My system is :
Clevo P750ZM

i7 4790

GTX 970M

ADATA AXNS381E-64GM-B

 

Here's what i generated with send me app

 

Kindly need your assistance

Thank you

Edited by rio_suck

Share this post


Link to post
Share on other sites
6 hours ago, rio_suck said:

Hello maldon..

 

i'm having trouble post installing Sierra or High Sierra :(

and actually kinda lost in bunch of trials..

No keyboard and touchpad

No sound

Cannot get 970M working with nvidia webdriver

M2 detected in Sierra but not working at all in HS

 

My system is :
Clevo P750ZM

i7 4790

GTX 970M

ADATA AXNS381E-64GM-B

 

Here's what i generated with send me app

 

Kindly need your assistance

Thank you

CLOVER.zip

m2 use samsung 960, native support

send me new dump after reboot with new files

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By midi-sama
      After a long time of cooking this computer up with a lot of stuff, I'm finally releasing my guide for this P50 with OpenCore.
       
      Lenovo ThinkPad P50 macOS Install with OpenCore
       
      This thread may be used for questions/corrections/additions. Good Luck.
    • By DOGER92
      Hi guys, I'm new to the world of Hackintosh. I write in this section because I have a problem with the graphics card of my laptop. As far as I understand from the web, it is not possible to use a dedicated graphics card on a laptop. So I'm trying to use the integrated processor one. The problem is that I have tried various procedures seen online, but in spite of this I cannot solve the problem. If you need this is the equipment of my laptop:

      Asus VivoBook Pro 15 N580VD-FI038T

      Screen: Led 15.6” 16:9 (Ultra HD 3480x2160).
      Chipset: Intel HM175.
      Cpu: Intel Core i7-7700HQ (2.80 GHz / 3.80 GHz, 4 core, 6 MB CACHE L3).
      Graphics Card: INTEL HD Graphics 630 + NVIDIA GeForce GTX 1050 4 GB GDDR5.
      Hard Disk: SSD M.2 512 GB SATA 3.0 + SSD 750GB.
      Ram: 32GB DDR4-2666.
      Audio: audio stereo Harman Kardon.
      Webcam: webcam HD with integrated headphone.
      Lan: Intel LAN 10/100/1000, Wi-Fi 802.11ac (2x2), Bluetooth 4.2.
      USB: 2 x USB 2.0, 1 x USB 3.0, 1 x USB 3.1 Type-C Gen 1, 1 x HDMI, 1 x LAN RJ-45, 1 x jack
      Slot: 1 x SD.

      I hope there is someone who can help me with this problem
    • By Simon's InsaneMac
      Hi, I'm kind of lost when scrolling to Clover Configurator, so I decided to use an EFI from the web and just configure the most basic stuff. But that sadly didn't work, im always getting the attached screen IMG_0054.HEIC (and I don't know whether all the errors are listed, as I can't scroll). 
      Anyways I thought it'd be better to do a custom setup. Can anyone give me some help with what to choose in the settings? Here's my rig:
      i7 8700k
      Asus z370-G (Rog Strix)
      gtx 1060 6gb
      samsung ssd (SATA)
      WD hard drive
       
      Your help would be much appreciated!
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9600K, 9700K, 9900K, 9900KS
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Reference RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      Current EFIs 
      Updated 26/03/2020
      PLEASE NOTE - You MUST update to the latest Clover EFI before updating to 10.15.4 or you may find your unable to update.
       
      Clover EFI Updated 26/03/20 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
      Clover Z390 Master Vega Navi EFI 260320.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      Clover Z390 Master Polaris EFI 260320.zip - R5XX Polaris DSDT EFI
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - OpenCore No DSDT and Done the way OpenCore intended it (03/03/2020)
       

      Alternative EFI 2 - N-D-K Fork of OpenCore (03/03/2020)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Disabled
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on Catalina 10.15.4 and Clover EFI 5104 (Catalina Patcher)
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman Voodoo PS2 Controller (here) acidanthera AppleALC (here) acidanthera Lilu (here) acidanthera VirtualSMC (here) acidanthera SMCBatteryManager (here) acidanthera SMCLightSensor (here) acidanthera WhateverGreen (here) Mieze Realtek RTL8111 (here)
×