Jump to content
MaLd0n

[Guide] El Capitan, Sierra / High Sierra / Mojave / Catalina on Intel 5, 6, 7, 8, 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

2,490 posts in this topic

Recommended Posts

2 hours ago, MaLd0n said:

u try it?

http://www.insanelymac.com/forum/topic/327488-macos-high-sierra-final-release-is-out-17a365/page-10#entry2505086

<dict>
                <key>Comment</key>
                <string>fix IO error ICH10 for 10.13, credit SunKi</string>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Disabled</key>
                <false/>
                <key>Name</key>
                <string>AppleAHCIPort</string>
                <key>Find</key>
                <data>RYX2D5XCiciD4P5mhcl4D4TSdQs=</data>
                <key>Replace</key>
                <data>iciD4P5mhckPmMFBCMyQkJCQdQs=</data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>fix hotplug ICH10 for 10.13, credit SunKi</string>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Disabled</key>
                <false/>
                <key>Name</key>
                <string>AppleAHCIPort</string>
                <key>Find</key>
                <data>icglQGACAD1AIAAAdQyB4b9///+Ji1EBAAA=</data>
                <key>Replace</key>
                <data>kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJA=</data>
</dict>

solution was deleting AHCIportinjector.kext, 

a really really big THANK YOU you're awesome

Share this post


Link to post
Share on other sites
Advertisement
50 minutes ago, j0h.M said:

should i have to note something? I used CL Conf for the patches rebooted one time but nothing changed, if i wanna initialize the HDs i get i/o error 5. maybe the shell dd for analyse but it will a long procedure 

u need patches above

Share this post


Link to post
Share on other sites

Hi MaLd0n,

Trying to make a x58a-UD5 F13 with i7 920 at 2,66Ghz.

i follow this guide to install sierra.

i installed well, reboot with HD, installed clover but when i go to replace with your folder there is nothing in the efi partition of HD, only a folder efi with a folder named APPLE. i put your clover folder in efi partition/efi, and reboot and system start well, but after a minute kernel panic HPET...

there are a efi folder in the main directory of HD. the question is what efi is the good?

i cant make your runme.app can i give you the files in other way?

sorry for my english and my poor knowledge

thnks

Share this post


Link to post
Share on other sites
14 minutes ago, multiymedia said:

Hi MaLd0n,

Trying to make a x58a-UD5 F13 with i7 920 at 2,66Ghz.

i follow this guide to install sierra.

i installed well, reboot with HD, installed clover but when i go to replace with your folder there is nothing in the efi partition of HD, only a folder efi with a folder named APPLE. i put your clover folder in efi partition/efi, and reboot and system start well, but after a minute kernel panic HPET...

there are a efi folder in the main directory of HD. the question is what efi is the good?

i cant make your runme.app can i give you the files in other way?

sorry for my english and my poor knowledge

thnks

if i boot with the usb clover the HD boot ok. i run your app and to see if it is possible to solve it.

thnks i upload files in a while

Share this post


Link to post
Share on other sites
13 minutes ago, multiymedia said:

if i boot with the usb clover the HD boot ok. i run your app and to see if it is possible to solve it.

thnks i upload files in a while

here are my files for make your magic.

i dont konw what cant upload files directly here? always say error -200

https://drive.google.com/open?id=1FVxspcO3fo3C8TZE5CxAu6CHhWp_ZoXVSend me x58s-iMac.zipSend me x58s-iMac.zip

Share this post


Link to post
Share on other sites
18 minutes ago, multiymedia said:

here are my files for make your magic.

i dont konw what cant upload files directly here? always say error -200

https://drive.google.com/open?id=1FVxspcO3fo3C8TZE5CxAu6CHhWp_ZoXVSend me x58s-iMac.zipSend me x58s-iMac.zip

onlu work well less the shutdown. i know that i need some patch dsdt, im reading about but im nerdddd

try with this DSDT Auto-Patcher posted in

http://olarila.com/forum/viewtopic.php?f=19&t=385

is this tha way? 

thnks

Share this post


Link to post
Share on other sites
44 minutes ago, multiymedia said:

here are my files for make your magic.

i dont konw what cant upload files directly here? always say error -200

https://drive.google.com/open?id=1FVxspcO3fo3C8TZE5CxAu6CHhWp_ZoXVSend me x58s-iMac.zipSend me x58s-iMac.zip

replace, reboot send me new dump

http://www21.zippyshare.com/v/zfUGYjip/file.html
if have problem, check here

http://www.insanelymac.com/forum/topic/327488-macos-high-sierra-final-release-is-out-17a365/page-10#entry2505086

<dict>
                <key>Comment</key>
                <string>fix IO error ICH10 for 10.13, credit SunKi</string>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Disabled</key>
                <false/>
                <key>Name</key>
                <string>AppleAHCIPort</string>
                <key>Find</key>
                <data>RYX2D5XCiciD4P5mhcl4D4TSdQs=</data>
                <key>Replace</key>
                <data>iciD4P5mhckPmMFBCMyQkJCQdQs=</data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>fix hotplug ICH10 for 10.13, credit SunKi</string>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Disabled</key>
                <false/>
                <key>Name</key>
                <string>AppleAHCIPort</string>
                <key>Find</key>
                <data>icglQGACAD1AIAAAdQyB4b9///+Ji1EBAAA=</data>
                <key>Replace</key>
                <data>kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJA=</data>
</dict>

Share this post


Link to post
Share on other sites
8 minutes ago, MaLd0n said:

replace, reboot send me new dump

http://www21.zippyshare.com/v/zfUGYjip/file.html
if have problem, check here

http://www.insanelymac.com/forum/topic/327488-macos-high-sierra-final-release-is-out-17a365/page-10#entry2505086

<dict>
                <key>Comment</key>
                <string>fix IO error ICH10 for 10.13, credit SunKi</string>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Disabled</key>
                <false/>
                <key>Name</key>
                <string>AppleAHCIPort</string>
                <key>Find</key>
                <data>RYX2D5XCiciD4P5mhcl4D4TSdQs=</data>
                <key>Replace</key>
                <data>iciD4P5mhckPmMFBCMyQkJCQdQs=</data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>fix hotplug ICH10 for 10.13, credit SunKi</string>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Disabled</key>
                <false/>
                <key>Name</key>
                <string>AppleAHCIPort</string>
                <key>Find</key>
                <data>icglQGACAD1AIAAAdQyB4b9///+Ji1EBAAA=</data>
                <key>Replace</key>
                <data>kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJA=</data>
</dict>

 

you are the {censored} master. the new dump is fine fine

shutdown is ok¡¡

 

i'm testing thank you so much.

Share this post


Link to post
Share on other sites
14 minutes ago, multiymedia said:

 

you are the {censored} master. the new dump is fine fine

shutdown is ok¡¡

 

i'm testing thank you so much.

 

14 minutes ago, multiymedia said:

 

you are the {censored} master. the new dump is fine fine

shutdown is ok¡¡

 

i'm testing thank you so much.

something is wrong after the second shutdown this is what appears

https://drive.google.com/open?id=1TtuS9nptwwSHJ3Bul8ot1-dfJptGBsn0

2 minutes ago, multiymedia said:

 

something is wrong after the second shutdown this is what appears

https://drive.google.com/open?id=1TtuS9nptwwSHJ3Bul8ot1-dfJptGBsn0

talking tomorrow, i have to go, thnks... 

Share this post


Link to post
Share on other sites

@MaLd0n


Was wondering when you have a chance can you take a look at the system? You and I have similar dual cpu setups.

And is there a way instead of DSDT to do SSDT? makes debugging the problematic lines much easier.

https://www.dropbox.com/s/raa046i4f37pm8x/Send me Balamut-Mac-Pro.zip?dl=0

 

 

Share this post


Link to post
Share on other sites
16 hours ago, MaLd0n said:

UPDATE UR CLOVER BOOTLOADER TO LAST VERSION

i'm going with it. now i tell you. thnks.

it seems that the cmos is corrupt....

Share this post


Link to post
Share on other sites

Dear MaLdOn,

I'm upgrading system recently(Sierra-->High Sierra)

I have a situation here(see attach, it is 4.3mb so I split it to 3 pieces):

Issue 1:  The speed stepping looking good(up to 3.1~3.2 ghz) under HWMonitor, but it only have 1370cb (Cinebench R15  CPU 1980cb under Sierra). I reuse the ssdt file .

Issue 2: By the way, I can see USB3 (and storage which plugged) under system reports but not functional. No storage shown in Finder.

Help me please ...

 

Edited by wham17wham

Share this post


Link to post
Share on other sites
6 hours ago, Balamut said:

@MaLd0n


Was wondering when you have a chance can you take a look at the system? You and I have similar dual cpu setups.

And is there a way instead of DSDT to do SSDT? makes debugging the problematic lines much easier.

https://www.dropbox.com/s/raa046i4f37pm8x/Send me Balamut-Mac-Pro.zip?dl=0

 

 

I need SEND_ME files without any SSDT for identify all correct devices, SSDTs rename many devices

1 hour ago, multiymedia said:

i'm going with it. now i tell you. thnks.

it seems that the cmos is corrupt....

k

let me know

Share this post


Link to post
Share on other sites
59 minutes ago, wham17wham said:

Dear MaLdOn,

I'm upgrading system recently(Sierra-->High Sierra)

I have a situation here(see attach, it is 4.3mb so I split it to 3 pieces):

Issue 1:  I can see both cpu, speed stepping looking good(up to 3.1~3.2 ghz) under HWMonitor, but it only have 1370cb (Cinebench R15  CPU 1980cb under Sierra). I reuse the ssdt file .

Issue 2: By the way, I can see USB3 (and storage which plugged) under system reports but not functional. No storage shown in Finder.

Help me please ...

Send me osxwss-Mac-Pro 4.zip.001

Send me osxwss-Mac-Pro 4.zip.002

Send me osxwss-Mac-Pro 4.zip.003

http://www.zippyshare.com/

Share this post


Link to post
Share on other sites
13 hours ago, MaLd0n said:

Thank you. I found it was my fault :hysterical: . I didn't read the instruction carefully .

So the Issue 1 resolved by remove redundant cpu patch in plist. DSDT also no need.

And  for Issue 2. NEC USB 3.0 no works under High Sierra, It was a known issue.  :(

 

So, all Issue closed. So I remove all the files.

 

Edited by wham17wham

Share this post


Link to post
Share on other sites
13 hours ago, wham17wham said:

Thank you. I found it was my fault :hysterical: . I didn't read the instruction carefully .

So the Issue 1 resolved by remove redundant cpu patch in plist. DSDT also no need.

And  for Issue 2. NEC USB 3.0 no works under High Sierra, It was a known issue.  :(

 

So, all Issue closed. So I remove all the files.

 

i put all in DSDT ;)

 

USB3 u can try a generic xhci, but cause some problems and dont appears in system info

Share this post


Link to post
Share on other sites

Oh that was really quick @MaLd0n Thanks !

Here you go for the new dump !

https://www.dropbox.com/s/cw3izvqynivqbwr/Send me Hack.zip?dl=0

 

Sleep isn't really working. It goes to sleep and then instantanely wakes up. But now I see plenty of things in my PCI tab on System Information.app
My hackintosh seems to feel snappier too... I don't know what you did there, but I'm liking it a lot!

Could you summarize what you did exactly? :)

thank you very much for your help!

 

Edited by edenpulse

Share this post


Link to post
Share on other sites
11 minutes ago, edenpulse said:

Oh that was really quick @MaLd0n Thanks !

Here you go for the new dump !

https://www.dropbox.com/s/cw3izvqynivqbwr/Send me Hack.zip?dl=0

 

Sleep isn't really working. It goes to sleep and then instantanely wakes up. But now I see plenty of things in my PCI tab on System Information.app
My hackintosh seems to feel snappier too... I don't know what you did there, but I'm liking it a lot!

Could you summarize what you did exactly? :)

thank you very much for your help!

test it, replace in clover/acpi/patched

DSDT.aml.zip

u need test all usb ports with one usb3 device

Share this post


Link to post
Share on other sites
15 minutes ago, MaLd0n said:

test it, replace in clover/acpi/patched

DSDT.aml.zip

u need test all usb ports with one usb3 device

Here's the new dump if needed : https://www.dropbox.com/s/z62lcr4dlrawwoi/Send me Hack 2.zip?dl=0

I tested all usb ports with an USB3 device. All USB3 ports works at USB3 speeds and all USB2 ports work at USB2 speeds.

No improvements on sleep thought.

Share this post


Link to post
Share on other sites
49 minutes ago, edenpulse said:

Here's the new dump if needed : https://www.dropbox.com/s/z62lcr4dlrawwoi/Send me Hack 2.zip?dl=0

I tested all usb ports with an USB3 device. All USB3 ports works at USB3 speeds and all USB2 ports work at USB2 speeds.

No improvements on sleep thought.

run in terminal and paste result here

log show --style syslog | fgrep "Wake reason"

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By batty86
      Buonasera a tutti, ho bisogno di aiuto per l'installazione di Mojave sul pc in firma. Ho provato ad installarlo, tutto procede bene, solo che al secondo riavvio dal ssd di destinazione del oS l'installazione procede fino alla maschera di configurazione del computer ma si riavvia non consentendomi di configurarlo, va loop di riavvio. Sono grato in anticipo per il vs aiuto.
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      https://tinyurl.com/rkqmpd9
       
      --OpenCore Folder--
      https://tinyurl.com/y75hqg7z
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By ludufre
      Installing macOS Catalina 10.15.5 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      05/27/2020 20:02h GMT-0
      - Update instructions 10.15.5.
       
      03/24/2020 20:23h GMT-0
      - Update instructions 10.15.4.
       
      01/30/2020 23:54h GMT-0
      - Update instructions 10.15.3.
       
      12/11/2019 03:58h GMT-0
      - Update instructions 10.15.2.
      - Updated EFI folder attached.
       
      11/30/2019 18:03h GMT-0
      - Changed Device -> Graphics platform to fix dual HDMI monitor.
      - Updated EFI folder and config.plist
       
      11/29/2019 21:28h GMT-0
      - Added full EFI folder as requested.
       
      11/27/2019 02:33h GMT-0
      - Added BIOS profiles for ease.
       
      11/25/2019 22:45h GMT-0
      - Fixed wrong ethernet link (IntelMausi.kext).
      - Thanks to @MiMoHo
       
      11/24/2019 04:56h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Work.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Empty
       
      What you need to install
       
      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Catalina install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction  This will take about 30 minutes.
       


      Install bootloader
       
      Download the CloverEFI from official repository (used 5099) and install only with these options on "Install macOS Catalina":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
      - UEFI Drivers - Additional drivers - NvmExpressDxe (If you are going to use NVMe)
       
      FileVault 2
       
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
       
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      OR download attached bellow.
       
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
       
      That's it! FileVault 2 will work without problems.
       

       
       
       
      Make things works
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below according to your processor version.
      - Put all SSDT-*.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.8.0.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Copy the Clover Configurator to flash drive because you will need later.
       
      Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC.kext, SMCProcessor.kext, SMCSuperIO.kext and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/). I used the version 1.0.9.
      - Download the Lilu.kext from here. I used the version 1.3.9.
      - Download the WhateverGreen.kext from here. I used the version 1.3.4.
      - Download the AppleALC.kext from here. I used the version 1.4.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the IntelMausi.kext from here. I used the version 1.0.2.
      - Download the SmallTree-Intel-211-AT-PCIe-GBE.kext attached bellow to enable second ethernet.
       
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
       
      Wifi and Bluetooth (BCM94360CS)
       
      Works out of box (plug 'n' play).
       
       
      Now you can start the installation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is F10 (I use an 8th generation processor, so I don't need to upgrade)
       
      You can configure manually or load my BIOS profile.
       
      Manually:
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: BIOS - CSM Support to Disabled
      - Change value: BIOS - Secure Boot to Disabled
      - Change value: Peripherals - Initial Display to IGP
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Save & Exit Setup
       
      or, BIOS profile
      You can use one of my BIOS profiles attached bellow.
      It's two versions. One stock (Geekbench 4: 5840/27384) and another with overclock [5.0 GHz] (Geekbench 4: 6360/30348)
      - Put the profile in the root of the flash drive at EFI partition.
      - Restart with DEL pressed to enter BIOS setup.
      - Go to Save & Exit.
      - Select Load Profiles.
      - Select last option and then the flasdrive in the list.
      - And finally choose MACOS_STOCK or MACOS_5GHZ.
      - Save & Exit Setup
       
      Then:
      - Now, hold the F12
      - In the list, select your flash drive.
      - Choose the flash drive (white icon).
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press ESC again and select the flash drive.
       
      Choose the internal disk (gray hdd icon) if not already selected.

      The second part of the installation will begin. This will take 16 minutes.

       
      Post installation
       
      Bootloader

      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
       
      Copy the EFI folder to desktop.
       
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
       
      Move the EFI folder from Desktop to EFI partition of the internal disk.
       
      Eject the flash drive.
       
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
      Last thing
       
      Run this command in Terminal to disable hibernation (doesn't work in macOS):
      sudo pmset -a hibernatemode 0  
       
      It's done!
       
       
      System Updates
       
      10.15.2
       
      Before install, update the following kexts:
      - Lilu.kext. I used version 1.4.0.
      - WhateverGreen.kext. I used version 1.3.5.
      - AppleALC.kext. I used version 1.4.4.
      (all download links above)
       
      Download the latest CLOVERX64.efi.zip build. I used version 5100.
      Mount EFI partition and unzip to:
      - /Volumes/EFI/EFI/CLOVER/CLOVERX64.efi
      - /Volumes/EFI/EFI/BOOT/BOOTX64.efi (rename the copy of CLOVERX64.efi to BOOTX64.efi
       
      Install update. Will reboot at least four time.
       
       
      10.15.3
       
      Updated with success without changing anything.
       
       
      10.15.4
       
      Before install, update the following kexts:
      - Lilu.kext. I used version 1.4.2.
      - WhateverGreen.kext. I used version 1.3.7.
      - AppleALC.kext. I used version 1.4.7.
      - VirtualSMC.kext. I used version 1.3.7.
      (all download links above)
       
      Download the latest CLOVER installer. I used version 5107.
      - Install respecting the configuration mentioned above in "Install bootloader" section.
       
      Install update. Will reboot at least four time.
       
       
      10.15.5
       
      - Same as usual, update all Kexts and Clover.
      - Install Update, reboot.
       
      If you like me, I had a problem with two monitors. I needed to roll back two Kexts of video from 10.15.4: FixGraphics10.15.5.zip
      After replace, fix permissions and cache.
       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
       
      Attachments
       
      config.plist v2.zip
      EFI v4.zip
      Filevault 2 additional drivers.zip
      SmallTree-Intel-211-AT-PCIe-GBE.kext.zip
      SSDTs.zip
      MACOS_5GHZ
      MACOS_STOCK
       
       
       
×