Jump to content
MaLd0n

[Guide] El Capitan, Sierra / High Sierra / Mojave / Catalina on Intel 5, 6, 7, 8, 9 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

2,456 posts in this topic

Recommended Posts

Advertisement

none

 

check my signature with z97/h97 series

Can I use your DSDT in your signature for my build? Should I instead edit my DSDT extracted through clover F4 based on yours? What you recommend me to do?

Share this post


Link to post
Share on other sites

 

Hi, @MaLd0n

 

Can you please have a look at my system? Thanks.

 

macOS Sierra 10.12.6 (16G29)

Model: ASUS K52JU

Motherboard: Don't know, maybe HM55 created by ASUS

CPU: Intel® Core™ i3-380M
Memory: 2GB
Graphic: Radeon HD 6370M 512MB

 

Hi MaLd0n,

 

Can you please have a look at my platform?

Thanks.

Share this post


Link to post
Share on other sites

Hey, MaLd0n,

 

 

First of all I want to say its really cool that you're offering to do this for people, thank you so much! Setting up my Hackintosh has been trickier that I expected, but I'm nearly there. The part that's been the hardest for me so far is figuring out how to patch my ddst/ssdt, and knowing which would be better.

 

Anyway, my computer is an Asus VM60 Vivomini PC and I'm trying to run Sierra on it. It's a desktop but it runs on a mobile chipset, so I've heard its better to set this up as a MacBook. Also, from what I've seen it seems the best Intel Platform ID to use for a desktop with integrated mobile graphics is 0x0166000A, do you know if that would be true?

 

Again, thank you very much!

Share this post


Link to post
Share on other sites

Hi!

 

I am in the need of your help please.

 

Can someone please make a dsdt to make the Laptop of my neighbor complete?

Just for your information, the one from the Ideapad 500S - 15ISk is not working as the hardware is diffrent.

 

 

It's a 

 

Lenovo IdeaPad 500S-13ISK

Processor
Intel Core i5-6200U 2.3 GHz 
Graphics adapter
Memory
8192 MB DDR3-1600 single-channel
Display
13.3 inch 16:9, 1920x1080 pixel, LGD048C (LP133WF2-SPL1), IPS, glossy: no
Mainboard
Intel Skylake-U Premium PCH

 

I've uploaded all files here:

 

https://wetransfer.c...12162711/6eda3c

 

Many thanks in advance!!

 

Cheers

 

URBANsUNITED

Share this post


Link to post
Share on other sites

i need work for gain a little money ;P

back for home in a few days

Good luck, friend of Rio de Janeiro. Who writes, is a friend of Salvador, I know how much we have to work in this country.

Share this post


Link to post
Share on other sites

First... ;) 
If you need a full patched DSDT... 
-Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) and tell me what your hardware!
-Post Ioreg, extract with Ioreg Explorer
-Run it, post files generate in your desktop

 

 

Hi MaLd0n,

 

Hoping you can help with sleep, everything else seems to be working fine, but I may have noobed up fixing the DSDT I got elsewhere...

 

Mac OS 10.13

Mobo: GA-P55A-UD3 Rev. 1

CPU: Intel Core i7 860 Socket 1156

Memory: 12Gb (X.M.P 1660MHz)

Graphic: Gigabyte Geforce GTX 1050Ti G1 4Gb
Audio & Microphone: Realtek ALC888S-VD (AZAL)
Network: Realtek RTL8168D/8111D
              BCM943602CS in adapter
Extras: Inateck KTU3FR-5O2I 5-port USB3.0 PCI-E Card
 
DPCIManager ScreenShot in zip
 
If you wouldn't mind making a full Mald0n DSDT for me that would be awesome, then I know I for sure I have a perfect DSDT.
HDMI audio patching using Toleda's script doesn't work to enable, it doesn't see the PEGP@3, changing the script to look for it results in it saying it is patched, but no audio.
 
Just anything you can do would be great, My system works ok now, but there are problems I notice like my keyboard NumPad returns to screensaver when used for my password, the authentication boxes apple sends also have trouble with it, not sure if that is something that can be fixed in a DSDT, I do have a few apple keyboards, the old black keys and white keys from the emac era (I think) and a newer aluminum wired that is in use with my iMac.
 
I game and those can only use 3 keys at a time lol.
 
I did try mixing the patched DSDT from elsewhere with PJALM patches hoping for sleep, but it has not worked out for sleep and I am thinking my issue is either the DSDT or bios settings.
 
I did try to patch my own clean DSDT with patches from MacMan and PJALM, though it worked great (I think, maybe) the audio was garbled and I couldn't fix it properly.
 
Anyhow, Thank you in advance.
 
Also, why one beer? I'll send you enough for a 6 pack of tall boys (16oz, about $10 USD right?) in return for a fully patched system :D

iFrankie.zip

Send me iFrankie.zip

Share this post


Link to post
Share on other sites

Hi MaLd0n,

 

I have been struggling with the update to Sierra for a while now. I've updated from 10.10.5 to 10.12.6 using Rampagedev's DMG. I do run into issues though:

  1. AppleIntelCPUPowermanagement always causes a panic so I had to remove it.
  2. After that, I get panics during boot at different stages. It usually takes 2-3 reboots before things get stable. Once I am fully through the login process, the system works without a glitch.

My config:

  1. GA-X79-UD3 (patched to recognise NVME at boot)
  2. i7 4930k (no OC)
  3. MSI GTX1060 3GB with Nvidia 378.05.05.25f01webdriver
  4. Intel 750 NVME PCIe SSD boot drive using Pikeralpha's patch to use NVME

I had the same issues before I installed the NVME drive. I did an upgrade from 10.10 to 10.12 but I get similar issues on a clean install.

 

Can you help me out here?

 

 

 

 

Toms MacPro.ioreg.zip

EFI.zip

Send me Toms MacPro.zip

Share this post


Link to post
Share on other sites

i need work for gain a little money ;P

back for home in a few days

 

Hi MaLd0n, I forgot to quote you in my first post so you would know I asked for your expertise. :)

 

Added one to it a day or so ago hoping it would notify you, but I doubt it did.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

  • Similar Content

    • By Mieze
      This project is dedicated to the memory of Mausi, the cat I loved more than anybody else.
       

       
      A few days before Christmas I started my latest project, a new driver for recent Intel onboard LAN controllers. My intention was not to replace hnak's AppleIntelE1000e.kext completely but to deliver best performance and stability on recent hardware. That's why I dropped support for a number of older NICs. Currently the driver supports:
       
      5 Series
      82578LM 82578LC 82578DM 82578DC 6 and 7 Series
      82579LM 82579V 8 and 9 Series
      I217LM I217V I218LM I218V I218LM2 I218V2 I218LM3 100 Series (since V2.1.0d0)
      I219LM I219V 200 Series (since V2.3.0d0)
      I219LM I219V 300 Series (since V2.4.0d0)
      I219LM I219V  
      Key Features of the Driver
      Support for multisegment packets relieving the network stack of unnecessary copy operations when assembling packets for transmission. No-copy receive and transmit. Only small packets are copied on reception because creating a copy is more efficient than allocating a new buffer. TCP, UDP and IPv4 checksum offload (receive and transmit). Support for TCP/IPv6 and UDP/IPv6 checksum offload. Makes use of the chip's TCP Segmentation Offload (TSO) feature with IPv4 and IPv6 in order to reduce CPU load while sending large amounts of data (disabled due to hardware bugs). Fully optimized for Sierra (64bit architecture) but should work with older 64bit versions of macOS too, provided you build from source with the appropriate SDK for the target OS. Support for Energy Efficient Ethernet (EEE). VLAN support is implemented but untested as I have no need for it. The driver is published under GPLv2.  
      Current Status
      The driver has been tested successfully with I217V, I218V and 82579V under 10.9.5 and above. The attached archive includes source code as well as a prebuilt binary (debug version) for Mavericks and newer versions of macOS.   Known Issues
      There seem to be problems while using VMware with version 1.x.x of the driver. In case you are affected use version 2.0.0 or newer.  
      FAQ
      Could you add support of for...? Well, you are probably asking me to add support for one of the older NICs like the 82571/2/3/4L or 82583 and the answer will be no as I dropped support for these chips intentionally. They are broken and I lost more than 2 weeks trying to make it work on the 82574L without success. I was asked to add support for I210, I211 and I350 but as these chips have a completely different architecture, which isn't supported by the underlying Linux driver, this is impossible, sorry. Does it work with Snow Leopard or 32 bit kernels? No and I have no plans to make a version for 32 bit kernels or anything older than Lion. WoL from S5 doesn't work with this driver but under Windows it's working. Is this a driver bug? No it isn't, the driver is working as it should because OS X doesn't support WoL from S5.  
      Installation
      Goto /S/L/E and delete AppleIntelE1000e.kext. Recreate the kernel cache. Open System Preferences and delete the corresponding network interface, e. g. en0. Reboot. Install the new driver and recreate the kernel cache. I recommend to use Kext Wizard or a similar utility for the installation. Reboot Open System Preferences again, select Network and check if the new network interface has been created automatically or create it manually now. Configure the interface.  
      Help - I'm getting kernel panics!
      Well, before you start complaining about bugs after you upgraded macOS and ask me to publish a driver update, you should first try to resolve the issue on your own by cleaning the system caches.
      As the driver uses macOS's private network driver interface, which is supposed to be used by Apple provided drivers only, you might run into problems after an OS update because the linker may fail to recognize that IONetworking.kext has been updated and that the driver needs to be linked against the new version (Apple provided drivers avoid this problem because they are always updated together with IONetworking.kext). As a result, the linking process produces garbage and the driver may call arbitrary code when trying to call functions from IONetworking.kext. This usually results in unpredicted behavior or a kernel panic. In order to recover from such a situation, you should clean the System Caches forcing the linker to recreate it's caches:
      Delete all the files in /System/Library/Caches and it's subdirectories but leave the directories and the symbolic links intact. This is very important! Reboot. Recreate the kernel cache. Reboot again.  
      Troubleshooting
      Make sure you have followed the installation instructions especially when you have issues with certain domains while the others are working fine. Use the debug version to collect log data when trying to track down problems. The kernel log messages can be retrieved with "grep kernel /var/log/system.log" in Terminal. Starting from Sierra use "log show --predicate "processID == 0" --debug" in order to retrieve kernel logs. Include the log data when asking for support or giving feedback. I'm an engineer, not a clairvoyant. Don't copy and paste large amounts of log data to your post. Create an archive with the log data and attach it to your post. In case you don't want to make your log data publicly accessible, contact me via PM and I will provide you a mail address to send it directly to me.  Check your BIOS settings. You might want to disable Network Boot and the UEFI Network Stack as these can interfere with the driver. Double check that you have removed any AppleIntelE1000e.kext from your system because it could prevent the driver from working properly. Delete the following files: /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist /Library/Preferences/SystemConfiguration/preferences.plist Verify your bootloader configuration, in particular the kernel flags. Avoid using npci=0x2000 or npci=0x3000.  In Terminal run netstat -s in order to display network statistics. Carefully examine the data for any unusual activity like a high number of packets with bad IP header checksums, etc. In case auto-configuration of the link layer connection doesn't work it might be necessary to select the medium manually in System Preferences under Network for the interface. Use Wireshark to create a packet dump in order to collect diagnostic information. Keep in mind that there are many manufacturers of network equipment. Although Ethernet is an IEEE standard, different implementations may show different behavior causing incompatibilities. In case you are having trouble try a different switch or a different cable. Changelog
      Version 2.5.0 (2019-10-15) Reworked interrupt throttling code and added new configuration parameters. Version 2.4.0 (2018-04-14) Added support for 300 series versions of I219LM and I219V. Updated underlying Linux source code. Version 2.3.0 (2017-06-20) Added support for 200 series versions of I219LM and I219V. Version 2.2.0 (2016-09-23) Disabled TSO to work around a hardware bug. Version 2.1.0 (2016-05-24) Added support for I219LM and I219V Version 2.0.0 (2015-04-22) First official release which is identical to 2.0.0d2 (only the version number has been changed). Version 2.0.0d2 (2015-04-04) Changed the tx descriptor write back policy for 82579, I217 and I218 to prevent random tx deadlocks. Version 2.0.0d1 (2015-03-14) Uses Apple's private driver interface introduced with 10.8. Supports packet scheduling with QFQ Solves the VMware issue. Version 1.0.0d6 (2015-03-04) Reworked TSO6 support to avoid problems with VMware. Wake-on-LAN now working. Version 1.0.0d5 (2015-02-27) Reworked TSO4 support to eliminate the bug of 1.0.0d4. Added some debug code in order to collect information about the VMware related issue. Version 1.0.0d4 (2015-02-25) Set total length field of the IP-header to zero for TSO4 operations. Report EEE activation state in kernel log message when the link has been established. Version 1.0.0d3 (2015-02-11) Reworked media selection and EEE support (EEE is now activated when both link partners support it. It can be disabled selecting the medium manually). Duplex setting for 10/100 MBit connections is now reported correctly. The number of tx descriptors has been reduced from 2048 to 1024. The code has been cleaned up and obsolete files have been removed. Version 1.0.0d2 (2015-01-31) First development release. Getting the Driver
      The source code can be found on GitHub: https://github.com/Mieze/IntelMausiEthernet There is also a prebuilt binary for 10.11 and above in the download section: http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/ Build from Source for 10.8
      Register as a developer on Apple's developer website. A free membership is sufficient. Download a copy of Xcode 5.1.1 and install it on your machine. In the project select 10.8 as the "Base SDK" and the "Deployment Target". Call "Archive" from the menu "Product" and save the built driver. Credits
      Thanks to RehabMan and Yung Raj for running tests and pointing me in the right direction while I was trying to fix TSO. Special thanks to Yung Raj for motivating me when I was about to give up.
    • By hungdv
      Hello guys,
      I was try to install MacOS Mojave on my new machine but no luck. Can anyone show me which guide to fit my system, please?please?please?
      + Mobo: GIGABYTE Z390 AORUS ELITE LGA1151v2
      + CPU: Intel Core i5-9600K 3.7GHz
      + iGPU: Sapphire RX 580 Pulse 8GB
      + Drives: SSD Samsung 970 Pro PCIe NVMe V-NAND M.2 2280 512GB
      + Ram: Crucial Ballistix Sport LT 2x8GB Bus 2666 DDR4
      + PSU: Corsair RM650 80 Plus GOLD
      + Case: Corsair 220T White RGB Airflow Tempered Glass
      + Cooler: Cooler Master HYPER 212 BLACK EDTION
      + Dual Band Network Card Broadcom Bcm94360 867Mbps.
    • By Rajan Pandit
      Hai, I have,
      i5 2500k
      GA-z68 AP D3 Rev.1
      Corsair 8 GM Ram
      Gigabyte Radeon RX 560 OC 4G Graphic Card
      500 GB Samsung SSD EVOf
       
      with this configuration I tried to install Mojave but After Apple Logo there was a black screen
      then nothing... please help
      I have create USB with terminal and Install Clover_v2.4k_r4961-Legacy.pkg to activate boot
      then I have recessary kext to EFI/KEXT/OTHER 
      but I am struck at Black Screen after apple logo
    • By Rajan Pandit
      Hai, I have,
      i5 2500k
      GA-z68 AP D3 Rev.1
      Corsair 8 GM Ram
      Gigabyte Radeon RX 560 OC 4G Graphic Card
      500 GB Samsung SSD EVO
      .. I want to install Mojave on this configuration...
      please help. what I need to do... 
      I have downloaded the Installer from APP Store...
      please help
×