Jump to content
  1. MaLd0n


  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By jlrycm
      Finally I was able to move from Clover to OpenCore 0.5.9 on my hackintosh build. It boots really fast and even with the famous boot chime. I attached the OC config.plist for anyone who wants to give it a try. I followed the Github step-by-step guide:
      Haswell · GitBook
        dortania.github.io My build specs are:
      Gigabyte Z97-HD3 rev. 2.1, i5-4690K, 16 GB RAM, Gigabyte Aorus AMD RX 580 8gb GPU.
      I used OpenCanopy to give a Clover feeling to the OpenCore boot menu (I don’t like list-type boot menus). 
    • By poisson-myfish
      So I have some less powerful hardware, that's why I'm installing High Sierra in 2020. Anyway, I'm trying to boot from the USB and I get the following errors:
      00:000 00:000 OCB: Missing DMG signature, aborting 00:585 00:585 OCB: LoadImage failed - Unsupported That's it. The logs begin and end there. The rest of the file is zeroes.
      Bootloader: OpenCore 0.5.9 Release
      Note: I used SSDTTime to make the DSDT dumps for this exact computer
      Intel Core i3 (Haswell)
      An Intel VGA-Compatible Haswell iGPU
      An nVidia Geforce 920m GPU (part of the reason for installing High Sierra)
      USB: Intel 8 Series USB xHCI HC
      SATA: Intel 8 series SATA Controller
      If you need more details, here's my laptop https://www.asus.com/Laptops/X540LJ/ . I have the 512GB version with 4GB of RAM
      I found a lot of forum posts about people having the same error, except nothing solved mine. Also, I haven't found anything online about the error with the Missing DMG Signature.
      EDIT: If anybody needs my config.plist, feel free to ask for it and I'll happily post it
    • By ludufre
      Installing macOS Big Sur 11.0 DP1 on Gigabyte Z370N WIFI + i7 8700K + UHD 630

      06/28/2020 22:05h GMT-0
      - Replaced detach command when creating ISO.
      - Thanks @ham4ever 
      - Added instruction to run one line at time.
      06/27/2020 02:37h GMT-0
      - iMessage works too. Just not at first boot.
      06/26/2020 18:54h GMT-0
      - First version.
      What works and what does not
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Work.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
      - Fix iMessage (other iServices works perfectly)
      - Nothing
      Bootloaders are currently unable to start the installation.
      The solution is to use a virtual machine and use a physical disk (additional, USB or SATA, NVME) as a target in the installation.
      Change the OpenCore compiled from the source code, and add some entries in NVRAM through config.plist.
      This is not the best solution. But it is the only way at the moment. There are some ready-made images available out there, but I prefer not to use them and create a clean installation.
      What you need to install
      - Running install of macOS
      - Already working OpenCore with this setup
      - Create bootable ISO file
      - Spare Disk/SSD
      - macOS Big Sur DP1 install app
      - Latest OpenCore + Kexts compiled from sources
      - Some KEXTs and SSDT patches
      UEFI configuration
      My BIOS is F10 (I use an 8th generation processor, so I don't need to upgrade)
      You can configure manually or load my BIOS profile.
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: BIOS - CSM Support to Disabled
      - Change value: BIOS - Secure Boot to Disabled
      - Change value: Peripherals - Initial Display to IGP
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Save & Exit Setup
      or, BIOS profile
      You can use one of my BIOS profiles attached bellow.
      It's two versions. One stock and another with overclock [5.0 GHz]
      - Put the profile in the root of the flash drive at EFI partition.
      - Restart with DEL pressed to enter BIOS setup.
      - Go to Save & Exit.
      - Select Load Profiles.
      - Select last option and then the flasdrive in the list.
      - And finally choose MACOS_STOCK or MACOS_5GHZ.
      - Save & Exit Setup

      How create bootable ISO file
      Download Big Sur DP1
      Run this command on Temrinal:
      sudo /System/Library/PrivateFrameworks/Seeding.framework/Resources/seedutil enroll DeveloperSeed Go to System Updater and download the Install macOS Beta app.
      Create ISO
      Then run on Terminal (One line at a time):
      hdiutil create -size 12G -fs hfs+ -volname install -type SPARSEBUNDLE ~/Desktop/install hdiutil attach ~/Desktop/install.sparsebundle sudo /Applications/Install\ macOS\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/install --nointeraction hdiutil detach `diskutil list |grep 'Install macOS Beta' |awk '{print $8}'` -force hdiutil makehybrid -o ~/Desktop/install ~/Desktop/install.sparsebundle rm -rf ~/Desktop/install.sparsebundle
      Now you have install.iso on desktop.
      How create create the virtual machine and install to disk/SSD
      Download and install the trial version of the VMware Fusion from their site. I'm used the version 11.5.5.
      - Create a custom virtual machine

      - Operating System: Apple OS X - macOS 10.15

      - Create a new virtual disk (The size doesn't matter, We'll delete later)

      - Click in "Customize Settings"

      - Save the VM on desktop with name: bigsur

      - Insert the spare disk/SSD on PC (reboot if necessary) and identify what /dev/diskX is.
      You can look on Disk Utility.app:

      - Create VMDK that point to it:
      sudo diskutil unmountDisk diskX /Applications/VMware\ Fusion.app/Contents/Library/vmware-rawdiskCreator create /dev/diskX fullDevice ~/Desktop/bigsur.vmwarevm/physical sata - Edit the virtual machine settings created previously

      - Click in Hard Disk (SATA) and delete it (Remove Hard Disk)

      - Then add the physical disk

      - There's a bug in Fusion. To select the physical.vmdk, right click then "Quick Look", then "Share virtual disk with the virtual machine that created it"

      - Click Apply.

      - Now mount de install.iso

      - Start the VM and install as usual until: Disk Utility, format GUID with APFS (VMware Virtual SATA Hard Drive Media), Install macOS, wait few reboots and stop at first boot wizard.
      This can take up to 45 minutes. It may seem like it is stopped, but it is not.

      - Press Command + Q and shutdown (usually WIN + Q)

      - Close VMware Fusion.
      Copy OpenCore to EFI
      - Mount the EFI with:
      sudo diskutil mount diskXs1  
      - Copy your current working OpenCore EFI to that mounted EFI.
      - Download mine attached or Update your OpenCore, Kexts and driver UEFI.
              - You can use the @MaLd0n script attached to compile all (OlarilaOC.command.zip)
              - If using mine add your MLB, ROM, SystemUUID and SystemSerialNumber. (see how to)
      - Add following items do config.plist:
      NVRAM -> Add -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> boot-args -> -lilubetaall (append)
      NVRAM -> Add -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-basesystem + Data + <00>
      NVRAM -> Add -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-kernel + Data + <00>
      NVRAM -> Delete -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-basesystem
      NVRAM -> Delete -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-kernel

      Boot from the new disk/SSD and finish de first boot wizard.
      And last but not least
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @khamsakamal48, @MaLd0n, @joedm and @vit9696 and all others members involved directly or indirectly.
    • By Preet
      I am getting only one syntax compile error after patching with the rehab man Skylake generic and hp g6 2221ss.
      Error: syntax error, unexpected PARSEOP_ARG1
      Error example on Tony Mac ( Link - https://www.tonymacx86.com/threads/solved-unable-to-compile-dsdt-syntax-error-unexpected-parseop_arg1.201774/)
      I found a guide on using refs.txt but I do not know how to use it with the new maciASL on this GitHub (link -https://github.com/acidanthera/MaciASL/releases). 
      System Info Pavillion AU003tx. (Skylake i5, intel HD520)
      Please respond, I would love to have the battery status working. Thanks in advance!!
    • By deomkds
      Esse post tem o propósito de documentar os patches necessários para a utilização da kext VoodooI2C e seu satélite VoodooI2CHID no notebook Acer Aspire F15 (ACER-F5-573G).
      VoodooI2C é um projeto que adiciona suporte para dispositivos que utilizam o barramento I2C. O trackpad ELAN0501 do notebook Acer Aspire F15 utiliza esse barramento internamente.
      As outras opções para ativar o trackpad neste notebook envolvem usar o VoodooPS2Controller ou o ApplePS2SmartTouchPad. O problema do primeiro é que... bem, ele não funciona. No momento em que o trackpad é tocado, o cursor pula pela tela toda sem parar. Já o segundo é o mais fácil pois funciona bem e é capaz de prover funções de multitoque e gestos. Porém, eu sempre achei alguns gestos do ApplePS2SmartTouchPad meio esquisitos, como a rolagem que não acompanha o toque precisamente como aconteceria em trackpads Synaptics no macOS.
      Então descobri que era possível usar o VoodooI2C com trackpads ELAN e resolvi tentar. Ao contrário do ApplePS2SmartTouchPad, o VoodooI2C necessita de muita configuração prévia, sendo o mais complicado o processo de GPIO pinning, mas fiquei bastante feliz com os resultados. Esse post documenta os patches usados.
      Meu hackintosh é baseado na EFI de johnnywolinger para macOS 10.14. Não o conheço, mas já deixo meus agradecimentos por ter facilitado minha vida. Como estou rodando o Catalina 10.15.5, tive que atualizar algumas kexts (WhateverGreen se não me engano) para evitar um KP durante o boot. A DSDT que eu estou utilizando veio do repositório dele. As únicas alterações que fiz foram os patches necessários ao VoodooI2C.
      1. Baixe o MaciASL neste link.
      2. Abra a sua DSDT nele e aplique os patches [GPIO] GPIO Controller Enable [SKL+] e [Windows] Windows 10 Patch, conforme foto no spoiler. O propósito desses patches é explicado em detalhes no guia de instalação do VoodooI2C. Simplificando, o primeiro patch ativa os interrupts e o segundo permite que o macOS enxergue o dispositivo I2C.
      3. A partir disso, é necessário aplicar os patches específicos de cada computador. No spoiler, eu explico o processo que usei para encontrar as informações. O texto só faz sentido se você já leu o guia de instalação original. Caso não esteja interessado nos detalhes, siga em frente.
      4. Na DSDT, encontre o method _CRS, que está no final do dispositivo TPDE.
      5. Encontrado o Method _CRS, copie o código abaixo.
      Name (SBFG, ResourceTemplate () { GpioInt (Level, ActiveLow, ExclusiveAndWake, PullDefault, 0x0000, "\\_SB.PCI0.GPI0", 0x00, ResourceConsumer, , ) { // Pin list 0x003A } }) Method (_CRS, 0, Serialized) // _CRS: Current Resource Settings { Name (SBFB, ResourceTemplate () { I2cSerialBusV2 (0x0015, ControllerInitiated, 0x00061A80, AddressingMode7Bit, "\\_SB.PCI0.I2C0", 0x00, ResourceConsumer, , Exclusive, ) }) Return (ConcatenateResTemplate (SBFB, SBFG)) } 6. Copiado, volte ao MaciASL e selecione todo o Method _CRS, conforme a foto. Selecione desde o "Method (_CRS" até aquela última chave que está no mesmo nível de Method.

      7. Cole, substituindo todo o Method. Deverá ficar assim depois de colado. Note que temos um item chamado Name SBFG e um chamado Method _CRS.

      8. Se estiver tudo certo, compile a DSDT e coloque na pasta EFI/ACPI/Patched, onde o Clover está instalado.
      Pra finalizar, basta instalar as kexts VoodooI2C e VoodooI2CHID na pasta de kexts do Clover. Ambas podem ser baixadas aqui.
      Se tudo der certo, ao reiniciar, o trackpad deverá estar funcionando corretamente.

      Se isso parece difícil demais, não esquenta. A VoodooI2C nem é tão melhor que a ApplePS2SmartTouchPad assim. Fiz mais por curiosidade do que por necessidade.
      Se você quiser BAIXAR A DSDT PRONTA, acesse o repositório do johnnywolinger. Tem tudo lá.
      Por que usar VoodooI2CHID em vez de VoodooI2CELAN? Basicamente, a segunda não funciona. Eu testei tanto com o pin 0x3A quanto com o pin 0x9A. Aparentemente, ela só funciona com dispositivos ELAN mais antigos.
      Por fim, quero transformar esse patch num patch automático a ser utilizado no MaciASL, só que não sei como faz. Se eu aprender, edito o post.