Jump to content
monto

GTX1060 flickering after sleep on 10.12.4

42 posts in this topic

Recommended Posts

I am on the last few days of my Amazon return period for my Asus GTX 1060 Turbo.  Trying to decide what to do, I contacted Nvidia to see if I could get any glimmer of hope to influence me to keep this GPU.  The tech I spoke to was very helpful, and confirmed they have replicated the problem and are working on it.  Unfortunately, they have not found the source of the problem, and said there is a chance that the issue comes from Mac OS or something "beyond their control".  So, it sounds like there is a possibility that this issue may not be fixed with the next update, if there even is an update.  He did leave me with a bit of hope, though.  He said that since this driver release is a beta, he thinks there is a lot of room for improvement, also adding that he didn't see any reason they won't be fixing it with an update.  So, they seem confident that it will be fixed, provided it's something they can fix on their end.  

 

I have no need for anything more than integrated graphics on Windows, so I have no reason to keep this GPU for now.  To avoid losing $250, I will be returning the 1060 for now and wait it out on Intel HD 630.  I'll be keeping an eye on this, hoping they fix it so I can buy another 1060.

Share this post


Link to post
Share on other sites
Advertisement

just noticed, this also happens when the "pc" is idling (meaning no sleep mode, just sitting on the desktop without screensaver) for around 10 minutes. just went to make me a coffee and after that the cursor is stuttering and arranging windows around takes forever...  logging out and in again fixes this... is this really a nvidia driver related issue which they have to fix? or maybe something else?

Yes, the same! I have a Gigabyte G1 1060, after some time UI could become almost not responsible and jerky, after 10-20 seconds system gets back to normal.

P.S. It is not the same as flickering after a sleep state. All those thing did not happened to me with integrated graphics.

Share this post


Link to post
Share on other sites

I'm experiencing this same issue. After installing the web driver it worked fine but then noticed the screen going bonkers like the computer was trying to format the resolution properly and couldn't find it. Do any of you have a 21:9 Monitor? Mine is a qhd LG 34 inch 34um88-p.

 

It was working fine for over a week. Now the last couple days I get these issues but on an updated 10.12.6.

Share this post


Link to post
Share on other sites

Update:

I've found that when it resumes from sleep and I experience the problem, I can just turn off my ultrawide monitor and power it back on. Is anyone else using an ultrawide 21:9 monitor or just me? Also, I noticed if I can manage to put it back to sleep, and resume it fixes sometimes.

Share this post


Link to post
Share on other sites

I use a simple workaround, by assigning a shortcut key on BTT (assuming any power user would have this utility) with the following scripts. After resume from sleep, all I need to do is to press this custom key (F18) to fix the flickering. 

tell application "System Preferences"

 

set current pane to pane "com.apple.preference.displays"

end tell

 

tell application "System Events"

tell process "System Preferences"

tell window 1

click radio button "Scaled" of radio group 1 of tab group 1

select row 2 of table 1 of scroll area 1 of tab group 1

delay 1

select row 1 of table 1 of scroll area 1 of tab group 1

end tell

end tell

end tell

 

quit application "System Preferences"

Share this post


Link to post
Share on other sites

Hi,

 

I have a similar or same problem on 10.12.6, GT1050, DP 4k, while using some software, e.g. Adobe Illustrator CC2017:  If I use gpu acceleration in this app, the screen will suddenly turn to black. Like the screen was powered off. 

 

Any idea how to fix this?

Share this post


Link to post
Share on other sites

I use a simple workaround, by assigning a shortcut key on BTT (assuming any power user would have this utility) with the following scripts. After resume from sleep, all I need to do is to press this custom key (F18) to fix the flickering. 

 

Thanks for the tip. I came up with the following python script based on your fix:

#! /usr/bin/python

from Quartz import kCGConfigurePermanently
from Quartz.CoreGraphics import CGMainDisplayID, CGDisplayCopyDisplayMode, \
	CGDisplayCopyAllDisplayModes, CGBeginDisplayConfiguration, \
	CGConfigureDisplayWithDisplayMode, CGCompleteDisplayConfiguration

# get the id of the main display
main_disp = CGMainDisplayID()
# get the current resolution settings for the main display
initial_rez = CGDisplayCopyDisplayMode(main_disp)
# get all available resolution settings for the main display
available_rez = CGDisplayCopyAllDisplayModes(main_disp, None)
# pick the first resolution configuration from those available that does not 
# match the current setting
temp_rez = next((rez for rez in available_rez if rez != initial_rez), None)
if temp_rez:
	# set the main display resolution to the temporary configuration
	err, ref = CGBeginDisplayConfiguration(None)
	err = CGConfigureDisplayWithDisplayMode(ref, main_disp, temp_rez, None)
	err = CGCompleteDisplayConfiguration(ref, kCGConfigurePermanently)

	# restore the previous resolution settings
	err, ref = CGBeginDisplayConfiguration(None)
	err = CGConfigureDisplayWithDisplayMode(ref, main_disp, initial_rez, None)
	err = CGCompleteDisplayConfiguration(ref, kCGConfigurePermanently)
else:
	print("Error: no alternate resloution modes available for main display")

Using SleepWatcher from http://www.bernhard-baehr.de/it should be possible to set up a fully automated workaround. I'll try to post a packaged installer for everything once I get it all set up and tested.

Share this post


Link to post
Share on other sites

Can't wait for your package!
The problem persists with the latest version of web driver on 10.13.1. I was under the impression that Nvidia was fully aware of the problem, and working on a solution, some 3 or 4 months ago. It seems to take forever for them to fix this.

Share this post


Link to post
Share on other sites

so have anyone tried the script by Asstastic (snicker)?

 

Worked for me it seems!

Share this post


Link to post
Share on other sites

scratch that :-/ Glitched again, although differently. even with 10.13.2 and updated web drivers

Share this post


Link to post
Share on other sites

I just updated to 10.13.3 with latest web drivers 

http://www.nvidia.com/download/driverResults.aspx/130460/en-us

 

Restarted a couple of times, no flickering glitchy weirdness after log in. Put it to sleep and resumed with no issue. I think this may have fixed it for me :)

[update] January 29th, 2017

I have not had any flickering at all. This fixed the glitchy flicker problem.

 

Now, i just did all the updates like normal, but if you update to 10.13.3 look it up, there are a couple of .efi files that can cause a problem and may need to be removed. Also consider the following:

 

on another 'forum' I saw a mention of this:

"NOTE: Users have reported bugs with the latest drivers for 10.3.3. Temporary method to use older drivers..."

 

Problem 5: Updated OS X and new drivers aren't available yet


Fix: modify the NVDAStartup.kext to force the older drivers to load.



  1. Open up terminal and enter the following command:

    sudo nano /System/Library/Extensions/NVDAStartupWeb.kext/Contents/Info.plist
  2. Enter your password and scroll down to where it says NVDARequiredOS
  3. Change the build number below that to your current build number
  4. Rebuild kernel cache suing the two commands from Problem #4
  5. Reboot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×