Jump to content
neotec00

Acer Aspire V3-772G

25 posts in this topic

Recommended Posts

So I tried to install macOS on my acer using a appstore version of Sierra, now the booting and also the installing went all fine, but I have only 7mb vram, the keyboard/touchpad wasn't working, no sound, ofc no WIFI :P and not even the ethernet was available.

Now i know that is is fairly standard, but i cant get even one of those things to work. I'm not used to macOS not even speaking of hackintosh soooo yea i could use some help :D On the other hand, im not a total computer noob, so given a little instruction i should be able to fix this, i hope.

 

Now to the specs, i have a hw report down in the attachments, you will see that i have two hard drives, a 1TB HDD as well as a 500GB SSD, i want to install Sierra on the 1TB HDD as i'm not using it at the moment.

 

I attached the ACPI tables

 

 

edit: i also have a sierra VM under windows 10 if that is needed

edit 2: i donated to iatkos about 24h ago, so i'll get that in at least 24h 

Acer Aspire V3-772g.HTM

ACPI origin.rar

Share this post


Link to post
Share on other sites
Advertisement

Hello !

 

You need to disable your NVIDIA GPU because of Optimus technology which is not supported in OS X. Since I have the same model, I can tell what you need to do :).

 

NB : All this is based on an excellent guide published by RehabMan on the forum you can't name here. Last time I tried to post a link it was deleted by a moderator so sorry about that but it's all I can do… Just hope the author won't mind.

 

So this is a quick step-by-step guide to patch your Aspire V3-772G DSDT/SSDTs :

 

To begin, you'll need MaciASL and RehabMan Patch repository patch for laptops. You can download MaciASL here and add the repository in its preferences > Sources : http://raw.github.com/RehabMan/Laptop-DSDT-Patch/master

 

You'll also need to copy iasl6,1 binary to /usr/local/bin

 

Assuming MaciASL.app is in your Downloads folder, you should type this in a terminal window :

 

 

sudo cp ~/Downloads/MaciASL.app/Contents/MacOS/iasl61 /usr/local/bin
 

Then you'll have to decompile the ACPI Tables. To do that, copy all SSDTx.aml and DSDT.aml (and JUST theses) in a folder named, say "acpi" on your Desktop. Next, create an empty refs.txt file inside and copy this into it :

 

 

External(_SB_.PCI0.PEG0.PEGP.SGPO, MethodObj, 2)
External(MDBG, MethodObj, 1)
External(_GPE.MMTB, MethodObj, 0)
External(_SB.PCI0.LPCB.H_EC.ECWT, MethodObj, 2)
External(_SB.PCI0.LPCB.H_EC.ECRD, MethodObj, 1)
External(_SB.PCI0.LPCB.H_EC.ECMD, MethodObj, 1)
External(_SB.PCI0.PEG0.PEGP.SGPO, MethodObj, 2)
External(_SB.PCI0.GFX0.DD02._BCM, MethodObj, 1)
External(_SB.PCI0.SAT0.SDSM, MethodObj, 4)
External(_GPE.VHOV, MethodObj, 3)
External(_SB.PCI0.XHC.RHUB.TPLD, MethodObj, 2)
 

Back to the terminal type this :

 

 

cd ~/Desktop/acpi
iasl -da -dl -fe refs.txt *.aml
 

You'll probably have an error because of duplicate SSDTs and that is normal. Just delete SSDT-2x.aml and SSDT-3x.aml and you should be fine and have all ACPI tables ready to patch.

 

More steps to come after you did that :).

Share this post


Link to post
Share on other sites

hi,

thanks for your quick answer, i followed all the steps you posted and everything went fine, but the last command. It allways says it cant find the command, so i concluded it had something to do with the iasl61 not being copied to /usr/local/bin. i have attached some screenshots post-1594735-0-78672500-1491513245_thumb.png, i think it may be just a stupid mistake of mine :P

 

i just noticed i wasnt in the ~/Desktop/acpi/ when executing the command, but the first time i tried, i was definitly in there so i dont think that is the problem

 

 

post-1594735-0-68226900-1491512989_thumb.png

post-1594735-0-02901600-1491513004_thumb.png

Share this post


Link to post
Share on other sites

Alright, I tried with that and it worked I just have, as you said some duplicats I'll get rid of that in a sec

 

Sent from my ONE A2003 using Tapatalk

Yup, got rid of the ssdt-2x and 3x and now it worked like a charm

 

So do you need any output or something?

 

 

And another question, I have installed Sierra using the tool from the forums that are not to be named, but I have not yet used the tool from them to install clover on the HD, at the moment I always boot using my USB clover. When do I need to run that tool, or am I not supposed to?

Share this post


Link to post
Share on other sites

Well that was the easy part :lol: !

 

Now, let's try to post the link I talked about earlier :ninja:

 

Didn't worked :P ! Google this instead : "rehabman guide ssdt dsdt laptop".

 

I strongly think you should read the whole thing . If a moderator read this, please note that it's just a guide that explains how to patch a DSDT and that it's not about using some unsupported tools. I think it's a good reading for anyone who wants to learn. Nothing less, nothing more.

 

Anyway.

 

Here's the list of the patches you'll need in the RehabMan repo. Just apply them to .dsl files, not .aml in the order below  :

 

- For DSDT.dsl :

 

[syn] Remove _DSM methods

[igpu] Rename GFX0 to IGPU

[sys] Fix _WAK Arg0 v2
[sys] HPET Fix
[sys] SMBUS Fix
[sys] IRQ Fix
[sys] RTC Fix
[sys] OS Check Fix (Windows 7, 8, Vista)
[sys] Fix Mutex with non-zero SyncLevel
[sys] Fix PNOT/PPNT
[sys] Add IMEI

[usb] 7-series/8-series USB

[usb] USB3_PRW 0x0D (instant wake)

[bat] Acer Aspire 3820tg

 

Lastly, we need to add the Device HDEF for native AppleHDA audio support. Just copy/paste the following in the upper-right field in MaciASL > Patch button :

#Maintained by: RehabMan for: Laptop Patches
#audio_HDEF-layout3.txt

# Note: Change your layout ID if you need something different
# Note: "hda-gfx" is not needed with Haswell and should probably be removed

#   Inject Audio info
into method label _DSM parent_label HDEF remove_entry;
into device label HDEF insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
    If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n
    Return (Package()\n
    {\n
        "layout-id", Buffer() { 0x1C, 0x00, 0x00, 0x00 },\n
        "PinConfigurations", Buffer() { },\n
        //"MaximumBootBeepVolume", 77,\n
    })\n
}\n
end;

Hit Compile button and you should have no errors. If everything's OK, save your work first in .dsl file format then in .aml file format for use with Clover.

 

For SSDT-8.dsl :

 

[syn] Remove _DSM methods

[igpu] Rename GFX0 to IGPU

[igpu] Rename B0D3 to HDAU

[igpu] Haswell HD4400/4600/5000 EDIT : see post #20

[igpu] Brightness fix (Haswell/Broadwell)

 

Again, hit compile and save.

 

For SSDT-9.dsl :

 

[syn] Remove _DSM methods

[gfx0] Cleanup/Fix Errors (SSDT)

[igpu] Rename GFX0 to IGPU

[gfx0] Disable from _INI (SSDT)

 

Guess what ? Hit compile and save your work :P.

 

Finally you should have 3 fully patched DSDT/SSDT. Name them DSDT.aml, SSDT-1.aml and SSDT-2.aml and place them in CLOVER/ACPI/patched folder.

 

If everything go well, you should have disabled NVIDIA GPU and fully enabled HD 4600.

 

There's a little more work to do with the config.plist and kexts but this should be a good start for now.

Share this post


Link to post
Share on other sites

so i pached my DSDT and SSDT files, compiled (which returned no errors) and placed them in the .../patched folder.....

but i'm still showing both cards after a reboot, and still have 6mb of vram ;(, do i need to tell clover to use the pached files or something? because i dont see that anything has changed. Screenshots below :)

btw i used efi mounter v3 to mount the efi partition of my stick, maybe that has something to do with it?

post-1594735-0-46605700-1491564811_thumb.png

post-1594735-0-00331400-1491564818_thumb.png

post-1594735-0-06073800-1491564824_thumb.png

post-1594735-0-70739300-1491564829_thumb.png

Share this post


Link to post
Share on other sites

OK.

 

Use this one and the attached set of kexts :

 

ACPIBatteryManager.kext
AppleALC.kext
ApplePS2SmartTouchPad.kext
BCM5722D.kext
FakePCIID_Intel_HD_Graphics.kext
FakePCIID_Intel_HDMI_Audio.kext
FakePCIID_XHCIMux.kext
FakePCIID.kext
FakeSMC.kext
IntelGraphicsFixup.kext
Lilu.kext
Shiki.kext
USB_Injector.kext

config.plist.zip

Other.zip

Share this post


Link to post
Share on other sites

ok, now I put the config into clover and that worked fine. I didn't know if I had to use the kexts with kext wizard, so I just put them into the clover/kexts/10.12/ folder, and now my keyboard works :D which is great. But I've still got 7mb vram :(  the HD4600 is now recognised only as "display" and it says: Kernel Extension Info: No Kext Loaded

Share this post


Link to post
Share on other sites

Yes, sorry I forgot to delete SSDT-1.aml and SSDT-2.aml in ACPI > DisableAML.

 

This config.list was meant to be used for the installation and not for regular use ;).

 

You should have NVIDIA GPU disabled and HD 4600 support now.

 

PS : When you put kexts in CLOVER/kexts, you don't need to fix permissions and rebuild cache. That's why Kext Wizard is useless in this case.

Share this post


Link to post
Share on other sites

I'm sorry, but I don't get it, what do I need to do?  :rolleyes:

 

Yes, sorry I forgot to delete SSDT-1.aml and SSDT-2.aml in ACPI > DisableAML.

Share this post


Link to post
Share on other sites

Open your config.plist with Clover Configurator then look for DisableAML in the ACPI section. Click on "-" to delete the two entries and save. Do NOT delete those in SortedOrder.

 

That's it.

Share this post


Link to post
Share on other sites

K so I removed these and now the "display" GPU shows up as the only one, which means the Nvidia is actually disabled, I guess. But I still have 7mb vram.

 

Sent from my ONE A2003 using Tapatalk

Share this post


Link to post
Share on other sites

Great :).

 

FYI, the problem was in the IGPU injection. The fake device ID was missing (0x12, 0x04, 0x00, 0x00 to simulate a HD 4600 desktop ID instead of 0x16, 0x04, 0x00, 0x00 used by HD 4600 mobile).

 

So in the Device (IPGU), you should use this :

 

 

            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                If (LEqual (Arg2, Zero))
                {
                    Return (Buffer (One)
                    {
                         0x03                                           
                    })
                }

                Return (Package (0x08)
                {
                    "device-id",
                    Buffer (0x04)
                    {
                         0x12, 0x04, 0x00, 0x00                         
                    },

                    "AAPL,ig-platform-id",
                    Buffer (0x04)
                    {
                         0x06, 0x00, 0x26, 0x0A                         
                    },

                    "model",
                    Buffer (0x0E)
                    {
                        "Intel HD 4600"
                    },

                    "hda-gfx",
                    Buffer (0x0A)
                    {
                        "onboard-1"
                    }

 

works like a charm, thank you :)


so when I want to have clover on my hdd rather than on the usb-stick, do I just install it, and copy over the modified files?

 

Correct :).

 

PS : If you need to re-install OS X, don't forget to disable the two SSDTs (not the DSDT) otherwise you'll have graphics issues ;).

Share this post


Link to post
Share on other sites

ok, i used thee script and placed the ssdt, but my i ask what it is actually used for? I dont really see a change :P


And another thing: if I want to change the wifi card (bc it's not supported) do I need to rebuild all the dsdts and ssdts?

Sent from my ONE A2003 using Tapatalk

Share this post


Link to post
Share on other sites

ok, i used thee script and placed the ssdt, but my i ask what it is actually used for? I dont really see a change :P

 

You won't notice any difference but this SSDT is needed for these kexts to load :

 


MacBook-Optimus:~ polyzargone$ kextstat | grep -i applelpc
  103    0 0xffffff7f822a7000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) F51595F0-F9B1-3B85-A1C3-F984DAD4107E <102 12 5 4 3>
MacBook-Optimus:~ polyzargone$ kextstat | grep -i acpiplatform
   13    2 0xffffff7f82a3b000 0x60000    0x60000    com.apple.driver.AppleACPIPlatform (5.0) 65E05472-6AE7-3308-8CC8-FA6CB0DB2AEE <12 11 7 6 5 4 3 1>
MacBook-Optimus:~ polyzargone$ kextstat | grep -i x86PlatformShim
  134    1 0xffffff7f817de000 0x7000     0x7000     com.apple.driver.X86PlatformShim (1.0.0) D6D4635C-98C0-31C0-AE82-20D003A58ECF <104 102 88 7 4 3>
MacBook-Optimus:~ polyzargone$ kextstat | grep -i x86PlatformPlugin
  104    1 0xffffff7f817c7000 0x17000    0x17000    com.apple.driver.X86PlatformPlugin (1.0.0) 4D7C495F-B088-3BC7-BE0B-86C0E7978CC0 <102 88 63 19 11 7 6 5 4 3 1>

Without it, you won't have full native PM > x86Platformxxx not loaded :

 


MacBook-Optimus:~ polyzargone$ kextstat | grep -i applelpc
  103    0 0xffffff7f822a7000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) F51595F0-F9B1-3B85-A1C3-F984DAD4107E <102 12 5 4 3>
MacBook-Optimus:~ polyzargone$ kextstat | grep -i acpiplatform
   13    2 0xffffff7f82a3b000 0x60000    0x60000    com.apple.driver.AppleACPIPlatform (5.0) 65E05472-6AE7-3308-8CC8-FA6CB0DB2AEE <12 11 7 6 5 4 3 1>

And another thing: if I want to change the wifi card (bc it's not supported) do I need to rebuild all the dsdts and ssdts?

No as long as you change it for a model that works OOB.

 

If not, you'll find some patches for native WIFI support in the same RehabMan's repo. You may want to have a look at them. I use one for my Atheros AR9285 (no Bluethooth).

 

On the 772G, the device that handles WIFI is located at RP03 > PXSX so you'll need to adapt the patch.

 

Of course, this only works for supported Atheros chipset !

Share this post


Link to post
Share on other sites

ok, so just FYI i encountered some problems with the trackpad when using it for a while. I swapped the provided ApplePS2SmartTouchPad.kext (which was a beta 4.7 i think) with the stable 4.6 version and now it runs smoothly :) links below: http://forum.osxlatitude.com/index.php?/topic/1948-elan-focaltech-and-synaptics-smart-touchpad-driver-mac-os-x/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By cydia2020
      G'day guys,
      I recently bought a Surface Book i5 256GB with dGPU, and I found that there's no tutorial about Hackintosh since it's released, so i am here to be the first (maybe) to try this out
       
      This guide is not being recommended by its author, as the final performance is usually janky and unstable, most fundamental functions of your Surface will not work in Hackintosh, please always consider the consequence of proceeding, you also risk losing your data, again, please proceed with caution
       
      ******謝絕轉載謝謝配合******
      ******Please do not repost, thanks******
      ******転載禁止です。ご協力をお願いします。*******
      This project is deprecated (and it was only meant for 10.11 - 10.12.3) due to hardware availability on my side, no support for future OSes will be provided by me personally and support on current OSes will be limited. Your contributions, testing and guides will be appreciated by the community.
       
      video is up at
       

      Disclaimer: everything is on yourself, please proceed with caution and care
      Works
      Keyboard & Trackpad (No Gestures)(Buggy, when you hold a key, pointer won't move),
      SD card reader,
      USB 3.0 ports,
      Sound
      PCIe SSD
      Intel HD 520 Graphics works perfect on 10.11.4
      DP Video output now works(don't close the lid, it lead to big problems)(after closing the lead with external monitor, when plug in the external monitor, it no longer recognize the internal display, you must unplug the monitor and reboot)
      Long press power key brings up the power menu
      Brightness
      Lid

      Doesn't work
      NVidia dGPU
      Touch Screen (Alex's driver won't work since it's now on HID Camplg ports, which is not open source)
      Wireless (Wi-Fi & Bluetooth)
      Volume rocker
      Battery status

      What Works for 10.12
      Everything for 10.11 :-)

      Bugs For 10.12.3 and below
      Graphics is janky and unstable. and does not work natively, driver patch is needed
       
      Graphics will not work on 10.12.4 as reported for the built-in display, please take notice and do not upgrade
      First Step: Installing a Virtual Machine
      You will need a VM in order to get the thumb drive ready, please install a VM or you can use a real Mac to do this, the installation is not very hard, but do need some times for downloads and other stuff.
      Download VMWare Workstation Pro 12.0 Trial Version Download VMWare Unlocker Download Python Runtime Modify Unlocker Bat file -- In the unlocker installer, there's a win-install.bat file that you can open by CMD, but don't open yet, we need to modify a path in the file, open the file using your favorite text editor, find unlocker.exe in the file, change it to unlocker.py The previous step is redundant  Follow the instruction on unlocker readme file Go to a Apple Store, get a Install App from their computer and convert the BaseSytem.dmg to CDR, or you can just skip those steps to the making USB step Use the converted CDR as install media in VMware Installing OS X as normal Second Step: Prepare to install
      You need an actual Mac to make the install USB or using a VM, both methods are fine, I wouldn't say more about installing a VM on your devices, you can Google that yourself
      You'll need to download the 10.11.x installing App from this link For macOS 10.12 please go to this link to get the preview version You need to open Disk Utility. Select the USB Drive and format it as Mac OS X Extended (Journal-ed), Name it whatever you want, as long as you can remember the name. Now, open the terminal, enter the following text, this will cost you around 4 minutes on a USB 3.0 device and 30 minutes on a USB 2.0 device, go get yourself some drinks For 10.11 sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/PARTITION NAME --applicationpath "/Applicatons/Install OS X El Capitan.app" --nointeraction The previous method won't work on 10.12 anymore, you will get a USB that is not booting, use the guide below Download Clover from Clover Official Download Page Install Clover by choosing "Install UEFI Version only, install to EFI partition, Install Themes, Driver64UEFI(unselect CsmVideoDxe-64) After installing, you should see a Partition called EFI mounted, and it's your thumb drive (Copy the EFI folder from Installing OS X to the EFI Partition) only do this if it didn't do atomically DownloadSurfaceDriver.zip and follow the instruction in the ReadMe.txt to paste the files into your CLOVER folder ++++++++++Notice for 10.12 USB Creation++++++++++
      The pervious way of making the 10.11 drive won't work anymore in 10.12, instead, after downloading the 10.12 install app, you'll need to follow the following steps
      Show hidden files by executing this command defaults write com.apple.finder AppleShowAllFiles YES Navigate to /Application/Install macOS Sierra/Contents/SharedSupport and mount InstallESD.dmg
      Open "Disk Utility", restore the USB drive with Basesystem.dmg (hidden) in the mounted DMG file.
      Copy /Packages in the mounted DMG file to the restored USB's /System/Installation. Delete the old link before proceeding to the copy.
      Copy basesystem.dmg and basesystem.chunklist to the root directory of your USB drive
      Third Step: Installing OS X 10.11

      Now, we can start installing 10.11, you should plug in an external keyboard, mouse, and your thumb drive, after you finish the booting process, you should see the welcome page, choose the language you prefer and proceed the installation
      Go to Windows First, partition your drive for at least 50 GB if you want to keep using, because as I tried before, remapping disk after installing macOS or OS X is extremely HARD, don't try that unless it's necessary, you will risk the integrity of your data by doing that
      Choose Disk Utility, choose your installing partition and click erase, format as OS X Extended (Journal-ed), then, exit Disk Utility and proceed the installation process, you might need to proceed the same process twice to get the full install, so if you didn't saw your OS X drive, please choose install again. (The installation will automatically continue.)

      Or: Installing macOS 10.12
      Please change ig-platform-id to 12345678 before installing the framebuffer kext.
      Things getting a little bit tricky when you're trying to install 10.12 on Surface Book. Since there's still a little bit of problems with the NVMe driver, you will likely get a error message says: unable to unmount volume for repair
      I am not sure if the error spreads largely, but, I experienced it every time I install the 10.12
      The temporary workaround is that to use an external USB hard drive or a SD card, I don't recommend a USB thumb drive unless it's superfast.
       
      Install 10.12 as normal to the external hard drive apply all the combo updates to the external hard drive system Use the recovery environment comes with the Installer (not the hard drive) Open Disk Utilities and restore the whole USB hard drive to the macOS install drive You can apply combo or delta updates as normal, but do not apply big updates that requires a standalone app download, backup and reinstall instead Problems regarding 10.12 installing has been solved, please proceed as normal
       
       
      The Final Process: Make your experience better
      You don't have to patch the keyboard drivers for 10.12.1 and/or above
      For 10.12, please install the kexts in 10.12 "install" folder located in the driver pack
      Make the keyboard works (10.11 only)
      Navigate to InstallHD/System/Library/Extension Copy the IOUSBFamily Kext to your desktop or wherever you like Right click on it and choose show package content, go to /Contents/PlugIns Right click on IOUSBHIDDriver and choose show package content, go to /Contents Open Info.plist using software like: PlistEditor Pro, and xCode Navigate to IOKitPersonalities Copy Generic Keyboard and right click on IOKitPersonalities Select "Paste as a child" Expand Generic Keyboard 2 change the value of bInterfaceProtocol to 0 change the value of bInterfaceSubclass to 3 change USBCompatibilityMatch to YES (doesn't have this on 10.11) save the file and open Kext Utilities Drag and Drop the kext in to it, enter password and after it finished reboot, then you should have a working keyboard Install Clover to SSD
       
       
      To install clover to ssd, you need the CLOVER PKG installer and remeber to update as a new version releases, it might contains bug fixes.
       
       
      Install clover as normal, install to your HACKINTOSH INSTALL DRIVE Use UEFI Boot Version, Install theme, and Driver, unselect CsmVideoDxe PUT THE SURFACE BOOT DRIVER INTO THE DIRECTORY Use BOOTICE x64 Version under windows, mount EFI under windows, Select UEFI tab, add a new boot entry navigate to EFI:\EFI\CLOVER\CLOVERX64.efi, name it clover bootloader (or whatever you like). Go to Surface UEFI, unselect Windows Boot Manager under Boot tab, select and drag CLOVER to the first position of the UEFI boot sequence,  
      NOTICE: DO NOT DELETE "INTERNAL" selection in UEFI setup, or your Surface WILL NOT BOOT (won't happen on newer BIOS)
       
       
      By the way, according to the feedback, there has been some problems with the AppleHDA patch, please install AppleHDA298.kext to S/L/E directly using your kext installer instead of placing it under /CLOVER/kexts, also, please use sRGB as color profile to avoid any grahpics glitch in 10.11.
       
       
      _____________________________________________________________________
       
      You'll need a Wi-Fi dongle to get online or you can use USB Sharing on Android and iOS, don't know whether network sharing on Ubuntu Touch, Windows Phone and Blackberry will work
      You'll also need a Bluetooth dongle to get BT working


       
      __________________________________________________________________________________________________________________________________________
      Thanks to
      LonelyTV
      MeuPRodrigo
      maj1es2tic
      Pike

      and all of you
    • By zcmckenna
      I have been having a pretty major issue with my new Hackintosh lately. It has been displaying broken link images in safari (See image 1). It has also had certain areas of artifacting such as the storyboard in Xcode (See image 2). and finally PDFs have been showing up completely blacked out (See image 3). This has been a big issue for me and I was wondering if any of you have had the same problem and have had any luck fixing it. I have already tried display calibration and switching to integrated graphics. Thanks in advance!
      (See attached for config.plist)
      Specs:
      CPU: i5-8600k
      MB: Gigabyte Z370XP SLI
      GPU: ASUS 1070 Dual
      RAM: 16GB Ballistix (8GB x 2)
      HDD: WD Blue 1TB



      config.plist
    • By ITzTravelInTime
      Hi guys, this thread is to show you a new and open source app, created by me, that I called TINU:
       
      The name means: TINU Is Not #####, the U refers to a popular software that is used to create Mac OS hackintosh installers (that for good reasons is banned on this forum), but the aim of the name is to explain that this app is a totally different thing from that software and works in a totally different way.
       
      This app basically is a graphical interface for the createinstallmedia executable that is inside the Mac OS installer apps, it is capable to create a Mac OS installer on a drive completely vanilla like what you do using the command line method, and also this method is recommended by apple itself.
       
      Allows you to create easily a macOS install media without messing around with command line stuff and without using disk utility, all you need to do is use the app and then install clover on the usb drive once TINU has finished or leave it as is you want to use it on a Mac.
       
      Features:
        - Simple to use UI that allows you to easily start the macOS install media creation process   - It can work with every Mac OS installer app that has the createinstallmedia executable inside of it's resources folder (including also beta and newly released installers)   - You can use any drive or partition you want that can be erased and is at least 7 GB of size   - Works on Mac OS recovery, so you can create a macOS install media from a bootable macOS installer or from the macOs recovery   - All vanilla, the macOS install medias created with this tool are 100% vanilla, just like you created them using the command line "createinstallmedia" method   - Open source, you will know what this program does on your computer and also you can create your own version by downloading and playing with the source code   - Does not requires to do anything of special first, just open the program   - No need to go in disk utility first, TINU can format your drive for you   - Uses recent and more modern APIs and SDKs and Swift 3 language   - Transparent graphics style available (use alt + s on the keyboard or View->Use transparent style)   - Works using the latest versions of macOS and will also support newer Mac installers out of the box without needing for an update    Features that I'd like to add in the future:    - Advanced section, to customize your macOS install media   - Installer customization: Kernelcache/prelinkedknerel and boot files replacement (a feature that can be handy while dealing with old Macs or with beta installers when you need to mod or change the boot files some times)   - Install clover and configure clover   - Install kexts inside the kexts folder of clover   - Clover drivers customization   - Use custom dsdt in clover   - integrated pre-made clover config templates database from a remote and open repository   - Support for other languages, at least Italian   Rquirements:  - A computer that runs Mac OS X Yosemite or a more recent version (Mac OS X El Capitan is required to use TINU in a macOS recovery or installer)  - A drive or a free partition of at least 7 GB that you want to turn into a macOS/Mac OS X installer  - A copy of a macOS/Mac OS X installer app (Maveriks or newer versions are supported) in the /Applications folder or in the root of any storage drive in your machine (excepted the drive or volume you want to turn into your macOS install media)   Note that this app is under the GNU GPL v3 license so any reuse of the source code must follow the license's terms   TINU 1.1 Stable release:    - Download available here:    https://github.com/ITzTravelInTime/TINU/releases    - Source code:     https://github.com/ITzTravelInTime/TINU   TINU 2.0 pre-release:    - Source code:    https://github.com/ITzTravelInTime/TINU/tree/development    - Download available here:    https://dl.dropboxusercontent.com/s/nvzss51qcieynve/TINU.zip     Frequently asked questions about TINU: https://github.com/ITzTravelInTime/TINU/wiki/FAQs     NOTE: if you have problems with your USB installer of 10.13.4 or newer version not being detected by clover you have to use the latest clover and if it still does not detectets your usb installer you have to remove the invivible file called .IAPhysicalMedia located into the root of the usb installer. This issue is caused by a changement in the apple's createinstallmedia, don't blame TINU for that, tinu does only uses the installer creation method from apple, which has been changed, causing this problem for hackintosh users, this issue should be resolved in the latest versions of clover which will no longer require that you do changements to let your usb dive to be detected, a setting to do this fix automatically in tinu is also comeing in a new pre-release of TINU 2 I leave also some screenshots as well








    • By JDizz
      #UPDATE AS OF APRIL 27, 2018 Thursday, 3:53 PM EST

      SIMPLE INSTRUCTIONS
      After you figure out how to get High Sierra 10.13 or 10.13.4 installed to a USB with Clover Bootloader, and you're loaded onto MacOS High Sierra:

      Download Clover Configurator and MOUNT your partition and OPEN it to reveal your EFI folder. Delete it.
      Simply download the attached ZIP and unzip it by double clicking it. Then copy and paste the EFI folder you unzipped to the location of your mounted partition.

      Done. Enjoy. Special thanks to Jake Lo !


      WORKING [Dell M6800 - High Sierra 10.13.4]
      Sleep/Wake WHILE THE POWER CORD IS PLUGGED IN (Not from closing the screen down, but from clicking the Apple logo and sleep or by timer).
      Wi-Fi (AirPort Extreme) via Broadcom BCM43xx.
      2 USB ports on the LEFT side as USB 2.0/3.0 and the 1 USB 2.0/eSATA on the back.
      KeyBoard.
      TouchPad (With MultiTouch - Fully functional)
      iMessage, iCloud, FaceTime, AppStore work perfectly.
      NVIDIA Graphics work perfectly thanks to the Lilu and NvidiaGraphicsFixUp kext. THIS FIXES THE BLACK OR BLANK SCREEN PROBLEM.
      DVD-Drive/Burning if you even care to use CD, DVD disk.
      Bluetooth (Works even with Apple HomePod =] )
      Ethernet/RJ-45
      2 USBs on right side as USB 2.0/3.0
      Native Sound (On board Speakers and can adjust sound with buttons)
      SD Card Readers
      Adjusting Brightness (Download an app from the AppStore called Brightness Slider -OR- use Night Shift [will not adjust brightness, but will be bearable]).


      NOT WORKING [Dell M6800 - High Sierra 10.13.4]
      Headphone Jack (Excessive Static)
×