Jump to content
spakk

TASK FORCE - [AMD] to missing SSE4.1 Instruction set - older CPUs on macOS Sierra (10.12.x)

270 posts in this topic

Recommended Posts

Advertisement

if i put my kernel into working system, not installer, it always gets this kernel panic when it boots into white screen:

post-1299088-0-39713000-1510807555_thumb.jpg

 

the last messages from system log:


Nov 15 18:21:18 iMac com.apple.xpc.launchd[1] (com.apple.imfoundation.IMRemoteURLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit
Nov 15 18:21:18 iMac com.apple.xpc.launchd[1] (com.apple.imtranscoding.IMTranscoderAgent): Unknown key for integer: _DirtyJetsamPriority
Nov 15 18:21:18 iMac com.apple.xpc.launchd[1] (com.apple.imtranscoding.IMTranscoderAgent): Unknown key for integer: _DirtyJetsamMemoryLimit
Nov 15 18:21:18 iMac com.apple.xpc.launchd[1] (com.apple.imdmessageservices.IMDMessageServicesAgent): Unknown key for integer: _DirtyJetsamMemoryLimit

Share this post


Link to post
Share on other sites

@ydeng

Amazingly, your code seems to work, in part
I've integrated your emu into the last El Capitan Source and built a new kernel.
then I’ve noticed that the system was booted with "opemu ud2" error loop,

but at the end has reached the desktop.
then came the black screen followed by error loops. This is why i write partially.

 

I'm trying to build a new one and will report my new results.

Share this post


Link to post
Share on other sites

@ydeng

Amazingly, your code seems to work, in part

I've integrated your emu into the last El Capitan Source and built a new kernel.

then I’ve noticed that the system was booted with "opemu ud2" error loop,

but at the end has reached the desktop.

then came the black screen followed by error loops. This is why i write partially.

 

I'm trying to build a new one and will report my new results.

Here's the latest code with debug prints.  I don't know how to make progress anymore.

opemu.zip

Share this post


Link to post
Share on other sites
I think I'll try first with  El Capitain and if it succeeds then with sierra.

my last kernel has not achieved the hoped result. I will make further attempts tomorrow.

Share this post


Link to post
Share on other sites

yes it boots, but does not olow that's what it has become. A new art


:hysterical:


that's el capitan not sierra


After booting with the old El Capitan kernel, my desktop picture looks like this.(Pic.4)

1517850966542-307767381.jpg

15178511577782126091517.jpg

1517851403820-1243771530.jpg

15178525401651814201766.jpg

Share this post


Link to post
Share on other sites

If you don't know how to continue i tell to you to double check all the code and then try to make it more simple and then try to implement some functions to check that all the operations are done correctly, maybe something can go wrong and you will not see it, and also a network or serial debugger can be useful to read all the debug prints while they are hidden 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Sinn
      Hi
       
      After months again i want to install 10.10. I don't have old pendrive so i need to create new one. After created usb installation stick,change kernel and change some files in Extra folder i started to boot it up. Im stucked on "invalid kernel opcode (64 bit): 44 0f b6 1f 4c 8d 7f 01 41 83" What i shoud to do ? 
       
      AMD FX 8350
      Gigabyte Motherboard
      16 Gb of ram
      gtx 650ti
       
      Thanks in advance
×