Jump to content
Allan

macOS Sierra 10.12.4 (16E195) - Final Release - Updated

54 posts in this topic

Recommended Posts

I do not feel better performance

Just a difference for the processor load which is a bit more important the next 5 minutes the boot

It's a pity...

Maybe in the next macOS version, we'll see good news about this.

 

I hope  -_-

Share this post


Link to post
Share on other sites
Advertisement

Hi,

just updated !

All fine here, i have only re-applied the Toleda Patch to AppleHDA for Alc 889 and VGA patch to Intel HD3000.

No Night Shift ... at the moment .

I'm looking for a solution ...

 

Hint : easy solution ---> i have changed my smbios.plist from iMac12,1 to iMac13,1 --> now night shift is enabled ...

 

BTW : we could use F.lux - free app on not supported macs

https://justgetflux.com

Share this post


Link to post
Share on other sites

udpate just now. does the apple loading status bar, gets to the end... black screen. no change for 10 minutes.

 

HD6870... wonder if it's the issue. going to do some further testing.

 

HD6870 here too, and same experience from a fresh 10.12.2 install onwards.

It's random, the OS does boot behind the black screen. I restart it with the keyboard when it happens.

Share this post


Link to post
Share on other sites

It's a pity...

Maybe in the next macOS version, we'll see good news about this.

 

I hope  -_-

well we should .7 was major .8 was minor .9 was minor .10 was major .11 minor .12 minor so .13 should be major and if it turns into 11.0 that will be over the top

Share this post


Link to post
Share on other sites

No luck here.

 

After the upgrade my hackintosh takes several minutes to boot to finally give a completely yellow screen. Used Carbon Copy Cloner to restore to 10.12.3.

 

I'm using a AMD Radeon HD 7750 with a custom kext in Clover.  

Share this post


Link to post
Share on other sites

For those booting to a black screen..   just just HDMI cable in than disconnect...   work for me.

Share this post


Link to post
Share on other sites

Upgraded my machine yesterday, the only post installation I had done is to rerun Toleda's script to fix the audio. Also edited Clover config to MacPro6,1 to enable night shift.

Somehow I feel this version is snappier than before.

Share this post


Link to post
Share on other sites

HD6870 here too, and same experience from a fresh 10.12.2 install onwards.

It's random, the OS does boot behind the black screen. I restart it with the keyboard when it happens.

 

 

Hi,

just updated !

All fine here, i have only re-applied the Toleda Patch to AppleHDA for Alc 889 and VGA patch to Intel HD3000.

No Night Shift ... at the moment .

I'm looking for a solution ...

 

Hint : easy solution ---> i have changed my smbios.plist from iMac12,1 to iMac13,1 --> now night shift is enabled ...

 

BTW : we could use F.lux - free app on not supported macs

https://justgetflux.com

 

 

For those booting to a black screen..   just just HDMI cable in than disconnect...   work for me.

in my radeon hd 6670
my 10.12.3 has random black log in screen problem.
my 10.12.4 the cursor random disappear in log in screen problem.
my 10.12.5 does not have above problems.

Share this post


Link to post
Share on other sites

No Web-Drive.

System Software Overview:

System Version: macOS 10.12.4 (16E195)

 Kernel Version: Darwin 16.5.0

Boot Volume: Mac

Boot Mode: Normal

User Name:

Secure Virtual Memory: Enabled

System Integrity Protection: Enabled

post-1172925-0-97393000-1491216445_thumb.png

post-1172925-0-81243300-1491216453_thumb.png

post-1172925-0-72715100-1491216468_thumb.png

post-1172925-0-29043300-1491216477_thumb.png

Share this post


Link to post
Share on other sites

I don't know if injection of FakeCPUID is still needed.  Will check when Darwin sources are released.

Followup: Apple released the xnu sources to Darwin 16.5. There's no mention of kabylake, so faking CPUID to skylake still necessary in 10.12.4

Share this post


Link to post
Share on other sites

HD6870 here too, and same experience from a fresh 10.12.2 install onwards.

It's random, the OS does boot behind the black screen. I restart it with the keyboard when it happens.

 

indeed, it is booting beyond the black screen because it goes out of verbose mode console and into the black screen when booting -v, so we know it's not crashing.

 

are you saying you got it to boot to a regular log-in screen after many attempts?

 

 

For those booting to a black screen..   just just HDMI cable in than disconnect...   work for me.

 

so just plug in an HDMI cable and then disconnect?

Share this post


Link to post
Share on other sites

Works fine here on my laptop (using MBP9,1). Didn't have to do anything.

Nice to know!

 

Now I feel more tranquil to upgrade to Sierra soon...

 

Thank you so much Riley  ;)

Share this post


Link to post
Share on other sites

For those booting to a black screen..   just just HDMI cable in than disconnect...   work for me.

 

tried this, did not work for me. I am using DVI for display.

 

I plugged HDMI cable in before booting, and unplugged at black screen, didn't fix.

I plugged HDMI cable in at the black screen and waited, and unplugged, didn't fix.

 

hmmmmmm

Share this post


Link to post
Share on other sites

tried this, did not work for me. I am using DVI for display.

 

I plugged HDMI cable in before booting, and unplugged at black screen, didn't fix.

I plugged HDMI cable in at the black screen and waited, and unplugged, didn't fix.

 

hmmmmmm

There may be an issue with older clover bootloaders there are recommendations to upgrade to clover bootloader 4045? Or the latest in order to be able to properly inject kext fixes/injections.

 

Normally, I don't use inject ATI for my RX 480 but in 12.4 I need to in order to avoid blackscreen after boot. Maybe inject ATI will help if your not doing so now, and update clover bootloader.

 

I also noticed my AMD 5450 which used to get native support no longer does, I need to add ID to info.plist in AMD5000Controllerkext and 3000kext. It worked fine up until the 12.3 betas. It seems they have changed a lot in 12.4 it's possible the older cards that had support may need kext fixes or possibly they may need IGPU as primary boot like the newer AMD cards, hopefully not.

Share this post


Link to post
Share on other sites

There may be an issue with older clover bootloaders there are recommendations to upgrade to clover bootloader 4045? Or the latest in order to be able to properly inject kext fixes/injections.

 

Normally, I don't use inject ATI for my RX 480 but in 12.4 I need to in order to avoid blackscreen after boot. Maybe inject ATI will help if your not doing so now, and update clover bootloader.

 

I also noticed my AMD 5450 which used to get native support no longer does, I need to add ID to info.plist in AMD5000Controllerkext and 3000kext. It worked fine up until the 12.3 betas. It seems they have changed a lot in 12.4 it's possible the older cards that had support may need kext fixes or possibly they may need IGPU as primary boot like the newer AMD cards, hopefully not.

 

i can access EFI from my windows install by using diskpart to mount the drive. Can I just pop the new clover CLOVERX64.efi file into the EFI\CLOVER folder and try again, or do I need to replace a lot more files?

 

 

Share this post


Link to post
Share on other sites

There may be an issue with older clover bootloaders there are recommendations to upgrade to clover bootloader 4045? Or the latest in order to be able to properly inject kext fixes/injections.

 

 

I used BD Utility to create a windows bootable USB EFI drive, and then I copied my config into there along with the associated drivers, using the newest Clover 4049, and it booted fine!

 

Thanks for your advice.

 

I was concerned about updating, but now I'll just move the EFI folder I just configured over to my Local EFI folder and keep this one as a spare bootable on my desk.

Share this post


Link to post
Share on other sites

I used BD Utility to create a windows bootable USB EFI drive, and then I copied my config into there along with the associated drivers, using the newest Clover 4049, and it booted fine!

 

Thanks for your advice.

 

I was concerned about updating, but now I'll just move the EFI folder I just configured over to my Local EFI folder and keep this one as a spare bootable on my desk.

 

I have found that if you run clover install twice (2X) it will load it in the EFI Backups folder on main partition.    If you check after installing clover in the EFi boot partition that the old clover folder gets moved to the EFI Backups folder.    Check to see if the Backup folder has clover 4049 if it has a lower or older version you can install again the same way and it will appear in the backups folder.    you can just delete the old one(S) that appear.    That way if you need to boot into recovery disk you have the same clover configuration.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Allan
      The macOS Mojave final release it's out!
       
       
       
       
      Some of the new things on this system.
      Dark mode:

      
      Desktop Stacks:
      large.mp4
       
       
      More improvements with screenshots:
      large2.mp4
       
       
      And others very important:
      Better Control of Your Data Enhanced Tracking Prevention
      Automatic Strong Passwords
       
      As you guys are doing tests with the betas versions, maybe in this version all the things are going to be more stable.
      Cross your fingers!! 
       
      USB Installation using 'createinstallmedia' way:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB Source: Apple

      View full article
    • By Allan
      The macOS Mojave final release it's out!
       
       
       
       
      Some of the new things on this system.
      Dark mode:

      
      Desktop Stacks:
      large.mp4
       
       
      More improvements with screenshots:
      large2.mp4
       
       
      And others very important:
      Better Control of Your Data Enhanced Tracking Prevention
      Automatic Strong Passwords
       
      As you guys are doing tests with the betas versions, maybe in this version all the things are going to be more stable.
      Cross your fingers!! 
       
      USB Installation using 'createinstallmedia' way:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB Source: Apple
    • By NyssSun
      Hello everyone, as you can see in the title, I'm having problems with the graphics driver card (I think).
      Because when I log in for example, the screen start showing to me like some blank lines and then they go away.
      I think it could be some problem related to drivers, but when I go to (Apple Icon), About this Mac it told me the right graphics card, Gigabyte 210 1024MB.
      What could I do to solve this problem ?, when I browse in the internet it happens those glitches in my screen.
      If you want the specifications of my computer are these:
      HP Compaq 8000 elite sff
      Intel Core Duo E7500
      Gigabyte GeForce 210
      4GB RAM 1333MHz
      Thank you for all your help, regards.
       
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771     First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771     Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Install Clover UEFI in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace Folder CLOVER INSTALLATION.zip   --Install Sierra and boot into system!   --Install Clover UEFI and replace with my folder  CLOVER POST INSTALLATION.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches!   If you need DSDT edit... Run it RunMe.app   --DSDT My DSDT DSDT.ASUS H61M-A MaLd0n.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -EHCx -LPC -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -PNLF Clear NVRAM, Purge and Kextcache
          --FakeSMC http://www.hwsensors.com/releases --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
×