Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kushwavez
      MOBO: GIGABYTE Z77P-D3
      CPU: Intel Core i7-3770 Quad (Ivy Bridge) 3,4 GHz
      RAM: 8 GB (4+4) KINGSTON 1333MHz
      Audio: HD Audio (ALC888)
      Ethernet: Realtek8111
      Graphics: HD 4000 and(or) RX 5700 8 GB
      SSD: KINGSTON 240GB SSDNow mSata
      HDD: 1: 500 GB SAMSUNG 2: 1 TB Western Digital
       
      Running: macOS Catalina 10.15.1 - Windows 10
       
      Bios settings:
      UEFI - ON CSM: Disabled AHCI Integrated Graphics: AUTO Primary Graphics: iGFX Memory: 1024M DVMT: MAX Working
      Everything (App Store, Messenger, FaceTime, etc.)  
      Not working
      For AirDrop and Handoff you need a compatible Broadcom Wifi+Bluetooth card. I bought a BCM94360 card with a PCI-E adapter, it's OOB. Currently waiting for arrive, will report back.  
      Issues
      Sometimes I hear crackling sound (just on Catalina 10.15.1, didn't happen on 10.15 or before) If you don't have this issue please let me know.  
      Before updating to newer versions, update your kexts! (and Clover if necessary)
      Generate a new serial with Clover Configurator
      Download the Clover folder: Z77P-D3-catalina.zip
       
      - SMBIOS: iMac13,2: iMac (27-inch, Late 2012)
      - ig-platform-id: 0x0166000b
       
      - There is no need for Whatevergreen.kext 
      - The HD 4000 is working with- or without a graphics card (headless with IntelQuickSync)
      - RX 5700 (ASUS RX 5700 GAMING OC 8 G) working OOB, just delete WhateverGreen.kext (causes black screen)
       
      Triple-Boot Win 10 and Linux (in my case it's Manjaro) (on one drive)
      Make sure your drive is in GPT and you're using UEFI If you have Win 10 installed then: Open diskmgmt (Disk Management), then Shrink your existing Win 10 partition to create two new for Mac and (if you want) for Linux If you have Mac installed: Create a new partition for Linux and (or) Windows in FAT Simply format that partition in Linux, Windows, or Mac installer, then install the OS Copy your working Clover folder to the system's EFI drive If it's automatically booting to Win, open cmd in administrator and write: bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi That's it, automatically booting to Clover and you can select your OS If your Linux doesn't show up in Clover make sure you have GUI/Scan/Linux=Yes in config.plist  
      Mount your EFI on Windows:
      Open CMD in administrator and write: mountvol b: /s Use Explorer++ or TotalCommander in administrator to manage the folder Pictures:

       



    • By ezyrdr
      hallo hallo!
      I've been here on since snow leopard days, but still, im less than a rookie when it comes to hackintoshing! im just format it, copy it, install it dude-like! ahajajahaa sorry but I've been gettin this arb_buffer not present in my whatevergreen or don't know what OpenGL driver...steam games like Dying Light aren't playable since mojave 14.2 (no video, black screen) and several other opengl apps wont behave correctly at all...soo i only got you people to givme any idea of what am i doin wrong here with my installation, cause i got latest whatevergreen, as you could see from the capture im sending ... maybe i should go for a better video card?? i was thinkin buying a RX 590 8GB from Sapphire would kinda do de trick...but if a got a prob with my installation, most likely not uh!? ahaaja well thats from me for now, hope you guys are havin it this holidays with fam & loved ones, and are safe & witta rockin piece of hackintosh to play around with catalina, which is pretty cool system for me right now!
      HAPPY HOLIDAYS EVERYONE & BE SAFE!!!    ~_^

      ~edit~
      maybe i misconfigured ATI enabling in CloverEditor over the config file?!
    • By Bazza08
      Hi Guys I have been trying to get my hackintosh to work using High Sierra... My Build is:--
       
      Asus Z87-K Mother board
      Intel i5 processor
      8 gig of Memory
      Nvidia Geforce GT 730 4gb DDR3 
      500gb SSD hard drive 
      I can get it up and running if I take Graphics card out and use Internal graphics, but when I have my graphics card in the only way I can get it to work is to use boot flag nv_disabe=1 .... and the graphics are rubbish..... I am trying to get it working by creating my own DSDT file..
       
      what I have tried is to download and used  RwPortableX64V1.7 to extract 4 SSDT.aml files and one DSDT.aml ... I was looking on this forum for any clues what to do next
      but I a am afraid I am stuck... I have uploaded the files I extracted from  RwPortableX64V1.7
       
      Any Help would be appreciated 
       
      Bazza
      DSDT.aml
      SSDT-1.aml
      SSDT-3.aml
      SSDT.aml
      SSDT-2.aml
    • By JochiePiet
      Hi,
       
      I have recently installed Mojave. Went flawlessly. Then I upgraded to Catalina 10.15.1. Went almost flawlessly as well. The only problem I have detected so far is a problem with the sleep/wake cycle. It is possible to let the computer fall asleep, but no wake up then. Hard reset required.
      In the process of investigating I discovered that it is impossible to safe boot into safe mode. So I downgraded to Mojave, only to discover that the safe boot problem wast there too.
       
      These are my specs:
      Motherboard Gigabyte GA H77 D3H  rev 2.0
      MacOS Catalina Version 10.15.1 (Build 19B88)
      Kernel                         Darwin 19.0.0 x86_64
      RAM                            4.00 GB
      Model Identifier        iMac14,2
      CPU                            Intel(R) Core(TM) i3-3225 CPU @ 3.30GHz
      Intel Generation      Ivy Bridge
       
      This is the output I get trying to boot with Clover and the bootflags: -v -x (I have also tried -v -x -f and UseKernelCache=no):
       

       
      Thank you so much in advance!
    • By ludufre
      Installing macOS Catalina 10.15.1 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      11/30/2019 18:03h GMT-0
      - Changed Device -> Graphics platform to fix dual HDMI monitor.
      - Updated EFI folder and config.plist
       
      11/29/2019 21:28h GMT-0
      - Added full EFI folder as requested.
       
      11/27/2019 02:33h GMT-0
      - Added BIOS profiles for ease.
       
      11/25/2019 22:45h GMT-0
      - Fixed wrong ethernet link (IntelMausi.kext).
      - Thanks to @MiMoHo
       
      11/24/2019 04:56h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Work.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Empty
       
      What you need to install
       
      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Catalina install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction  This will take about 30 minutes.
       


      Install bootloader
       
      Download the CloverEFI from official repository (used 5099) and install only with these options on "Install macOS Catalina":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
      - UEFI Drivers - Additional drivers - NvmExpressDxe (If you are going to use NVMe)
       
      FileVault 2
       
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
       
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      OR download attached bellow.
       
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
       
      That's it! FileVault 2 will work without problems.
       

       
       
       
      Make things works
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below according to your processor version.
      - Put all SSDT-*.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.8.0.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Copy the Clover Configurator to flash drive because you will need later.
       
      Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC.kext, SMCProcessor.kext, SMCSuperIO.kext and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/). I used the version 1.0.9.
      - Download the Lilu.kext from here. I used the version 1.3.9.
      - Download the WhateverGreen.kext from here. I used the version 1.3.4.
      - Download the AppleALC.kext from here. I used the version 1.4.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the IntelMausi.kext from here. I used the version 1.0.2.
      - Download the SmallTree-Intel-211-AT-PCIe-GBE.kext attached bellow to enable second ethernet.
       
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
       
      Wifi and Bluetooth (BCM94360CS)
       
      Works out of box (plug 'n' play).
       
       
      Now you can start the installation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is F10 (I use an 8th generation processor, so I don't need to upgrade)
       
      You can configure manually or load my BIOS profile.
       
      Manually:
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: BIOS - CSM Support to Disabled
      - Change value: BIOS - Secure Boot to Disabled
      - Change value: Peripherals - Initial Display to IGP
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Save & Exit Setup
       
      or, BIOS profile
      You can use one of my BIOS profiles attached bellow.
      It's two versions. One stock (Geekbench 4: 5840/27384) and another with overclock [5.0 GHz] (Geekbench 4: 6360/30348)
      - Put the profile in the root of the flash drive at EFI partition.
      - Restart with DEL pressed to enter BIOS setup.
      - Go to Save & Exit.
      - Select Load Profiles.
      - Select last option and then the flasdrive in the list.
      - And finally choose MACOS_STOCK or MACOS_5GHZ.
      - Save & Exit Setup
       
      Then:
      - Now, hold the F12
      - In the list, select your flash drive.
      - Choose the flash drive (white icon).
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press ESC again and select the flash drive.
       
      Choose the internal disk (gray hdd icon) if not already selected.

      The second part of the installation will begin. This will take 16 minutes.

       
      Post installation
       
      Bootloader

      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
       
      Copy the EFI folder to desktop.
       
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
       
      Move the EFI folder from Desktop to EFI partition of the internal disk.
       
      Eject the flash drive.
       
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
      Last thing
       
      Run this command in Terminal to disable hibernation (doesn't work in macOS):
      sudo pmset -a hibernatemode 0  
       
      It's done!
       
       
      System Updates
       
      Will be added here.
       

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
       
      Attachments
       
      config.plist v2.zip
      EFI v2.zip
      Filevault 2 additional drivers.zip
      SmallTree-Intel-211-AT-PCIe-GBE.kext.zip
      SSDTs.zip
      MACOS_5GHZ
      MACOS_STOCK
       
       
       
×