Jump to content
MaLd0n

[Guide] Sierra / High Sierra on Gigabyte GA H110M-S2 / DSDT

140 posts in this topic

Recommended Posts

Now have a Olarila app, just download app and clover folder for your Chipset!
 

Install MacOS with Olarila Image, Step by Step, Install and Post Install

 

https://olarila.com/forum/viewtopic.php?f=50&t=8685

 
20151106112558_big.png
 
First...
If you need DSDT edits for SkyLake, KabyLake or CoffeeLake...
-Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen)
-Post Ioreg, extract with Ioreg Explorer
-Run it, post files generated in your desktop
gathering.gif
Installation
 
--Create a bootable copy of macOS Sierra
Check out the link
 
--Create a bootable copy of macOS HighSierra
Check out the link
 
--Install Clover in USB stick
 
--Replace with my Clover folder 
 
--Install Sierra/High Sierra and boot into system!
 
Post Installation
 
--Install Clover in HDD/SSD and replace with my folder
 
--Reboot and activate video!
 
-Nvidia WebDriver Sierra
-Nvidia WebDriver High Sierra
-Cuda
 
--DSDT
My DSDT with Skylake patches
Patches
-FIX ERRORS AND WARNINGS
-HPET
-SATA
-DMAC
-SLPB
-DARWIN
-LPC
-XHCI
-PLUGIN TYPE
-HDAS to HDEF
-HDEF
-RTC
-IRQs
-SBUS
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-LAN
-USBX
-PMCR
-EC
-PNLF
-HDMI
--FakeSMC
--Audio
--USB
--LAN
 
-Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
 
Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!
 
We're all here to have fun and learn from each other!
 
ENJOY!

 

Share this post


Link to post
Share on other sites
Advertisement

Ofc

 

The mobo is low price but amazin'.

 

Sleep, etc etc. All is fine.

 

DSDT + SSDT pike + Kexts inside folder ;)

Thanks, appreciated your job and fast answer.

Share this post


Link to post
Share on other sites

hi everybody.

I've some question about this topic.

 

1) how's possible to use this MB to make an Hackintosh... without HDMI and DVI??  :surprised:

 

2) more important for me: I had a similar MB (h110m-S2H with hdmi and dvi) and installed my Hack without problems. I bought a new one (and i bought the same RAM, processor, ssd, etc...) for a friend but it has F20 BIOS instead F4 of the previous.  It does not wont boot!!! No way.  :(

 

What can I do? SSDT way? or Clover? (Gigabyte says that I can't downgrade BIOS to F4...)

 

Thanks for your help.

 

m.

Share this post


Link to post
Share on other sites

boot with usb stick and send me files

-Post ur full Clover folder with original tables, press F4 in Clover Boot Screen, files generate in Clover/Acpi/origin
-Post Ioreg, extract with Ioreg Explorer
-Run it, post files generate in ur desktop
 
up here if u have problem

Share this post


Link to post
Share on other sites

My Config.

 

    Gigabyte GA-H110M-S2

    I am using msi nvidia geforce gtx 750 ti 

   Bios F20

 

Sir,

 

    I installed Mac Sierra 10.12 and I installed WebDriver-367.15.10.05f01.pkg 

 

My config.plist

 

nada_drv=1. dart=0 inject kexts=Yes

inject System Id=Yes

NvidiaWeb=Yes 

 

 

But Still booting Graphics Disabled showing Graphics Display 7 MB

 

Sir Please Help me

Share this post


Link to post
Share on other sites

My Config.

 

    Gigabyte GA-H110M-S2

    I am using msi nvidia geforce gtx 750 ti 

    Intel Core i5 -6500 CPU

   Bios F20

 

Sir,

 

    I installed Mac Sierra 10.12.5 and I installed WebDriver-378.05.05.15f01.pkg

 

 

Graphics Card is Detected but Memory is showing 0 MB and installed sound driver  ALC887/888b but no sound output device is detecting 

 

Sir Please Help me, I am attaching my clover folder with generated table by using F4 Key 

CLOVER.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r5050 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r5050 for VMware.zip". Mount Clover-v2.5k-5050-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By arsradu
      Hi guys,
       
      So, this little tutorial is meant to help people fix a new issue with Mojave: opening jpg files (looks like it happens with larger files, not so much with smaller ones) using Quick Look (on spacebar key pressed) or Preview app, using the dedicated GPUs.
      The issue is that, when trying to open jpg files (for some reason, it doesn't occur with pngs), the pop-up window would remain in an endless loop. And from that point forward, any other app trying to open the same file will either become unresponsive (in the case of the Preview app) or just stay in endless loop (in case of Quick Look)
       
      As a workaround, in case the tutorial below doesn't work for you, you can use Grab (built-in app in MacOS) to open said files.
       
      This issue DOES NOT occur using the iGPU. So...if you're comfortable using the iGPU, just switch to that and you should be good to go. You don't need this tutorial.
       
      This tutorial is based on @Cyberdevs' research and testing on this topic (especially useful if you're using an RX series AMD video card), and my own very limited time testing this on my rig. I just thought it would be useful to create a new thread for it so that people can discuss this particular issue here.

       
      With that being said, I'll just move on to the actual tutorial.
       
      New (probably better) method.
       
      Switch your SMBIOS in Clover config in regards to the dedicated GPU you're using, instead of the CPU. Take a look here and choose the corresponding SMBIOS closest to your hardware.
      Yeah, that's it.
       
      In case you lose CPU PM with this method, there are multiple ways to fix that, and they do not make the object of this thread.  It worked perfectly fine for me though and I didn't need to change anything else.
       
      Alternatively, you can also try one of the MacPro SMBIOSes, such as MacPro5,1 or MacPro6,1. It was tested multiple times and it showed good results. 
      Keep in mind that choosing these will most likely not show you an iGPU in System Report, since those machines generally (probably all of them) use Xeon CPUs with no iGPUs either.
       
      /!\NOTE: There have been reports saying that using this method (switching SMBIOS to a MacPro one) with newer versions of MacOS may cause iTunes to crash.
      So...keep that in mind and better try some of the other methods mentioned here.
       
      A simple Lilu plugin
       
      Thanks to vulgo for the plugin and @Matgen84 for sharing and testing it, we now have yet another possible solution to this issue. It's a Lilu plugin (which means that it requires Lilu.kext in order to work) it's called NoVPAJpeg, and it can be downloaded from here.
      You use it as a regular kext, alongside Lilu. I prefer (and recommend) using it within the EFI folder, in Clover/kexts/Other. But if you want to use it in S/L/E, that should work just fine.
       
      More info can be found in this post here.
       
      UPDATE:
       
      According to Vulgo, NoVPAJpeg.kext is now deprecated.
      In case its functionality is needed, use WhateverGreen.kext and add the following boot arguments:
      shikigva=32 shiki-id=Mac-7BA5B2D9E42DDD94 In case you wanna try alternative medicine  ...
       
      The main thing we need to do is actually very simple: we need to enable the iGPU (integrated GPU) by default, in BIOS, while actually being connected to the dedicated GPU.
       
      For ATI GPUs (curtesy of @Cyberdevs' post here).
       
      The discreet GPU should be set as primary in BIOS and your displays should be connected to your discreet GPU
      The iGD/iGPU/iGFX must be enabled in BIOS/UEFI as the secondary GPU.
       
      I removed the DSDT Reconfigured the config.plist to and removed some flags which weren't needed because of the DSDT added the InjectATI + Ornioco Framebuffer (I removed the Orinoco framebuffer because of some weird glitches but it might be useful for other AMD GPUs if you inject the correct framebuffer according to your GPU. No need to inject anything for nVidia GPUs unless your GPU needs it) Added the InjectIntel + ig-platform-id for my intel HD530 (for intel HD 530 I use the 0x19120001 ig-platform-id)  
      Steps 5 to 7 might not be necessary I just did them anyway, if anyone succeeded to get quicklook working without those steps let me know so I can exclude those steps.

           Also confirmed to work with AMD R9 270X on a SandyBridge rig (without an iGPU) using WhateverGreen + Lilu kexts, which also helped to solve the transparency issue along with the Quick Look problem, it also resolved the buggy Screen Capture (Command+Shift+5) issue as well. 
       
          Also, do:
      nvram cleanup kextcache & prelinked kernel rebuild reboot  More info on that here.
       
       
      For NVIDIA GPUs (tested on my old MSi GTX 650)
       
      This is what I needed for my NVIDIA GPU and the MSI motherboard in the signature (*since then, I upgraded my GPU to my current RX 580). Your milage may vary, depending on your hardware. But, the idea should be the same regardless.
       
         For MSi motherboads (check out my motherboard details in the signature)
       
      Set your BIOS to use PEG (dedicated GPU) so you can boot.
      Since you're reading this, chances are that you're already connected to the dedicated GPU and the BIOS is set to PEG. So just go into BIOS and see if you're using the iGPU or the dedicated (PEG) graphics device by default.
      If you're already using this, skip to Step 3 (the part AFTER Reboot). Reboot (I think you don't necessarily need to boot into the OS...but you do need to reboot at least until Clover UI) Reboot back into BIOS and set it from PEG to IGD (integrated graphics) WITHOUT removing the cable. Save Reboot again.  
         The result should be that the OS is tricked into thinking you're booting with the IGPU when in fact you're using the dedicated GPU.
       
         For Gigabyte motherboards
       
         Set:
      Peripherals -> Initial Display Output -> iGFX Chipset -> Internal Graphics -> Enabled
           DVMT Pre-Allocation -> default 64M.
           DVMT Total Gfx Mem -> default 256M Save Reboot  
         You should do this with the cable connected to the dedicated GPU.
       
      You will also need to patch the iGPU from Clover config.
      1. Graphics -> Inject Intel (UNCHECK Inject Nvidia or ATI if it's checked).
      2. ig-platform-id (in my case for Intel HD 4600 Desktop) it was: 0x0d220003
       
      And use IntelGraphicsFixup.kext (now included into WhateverGreen.kext) in Clover/kexts/Other. In my particular case, without the kext, I would get freezes in Safari.
       
      Another way to activate the iGPU while having the dGPU set as primary is by going into BIOS/SAG/Graphics Configuration/iGPU and setting Multi-Monitor to [Enabled], all the rest remains on [Auto], and set Inject/Intel to [True] in Clover config.*.
       
      Thanks to @gjw for the tip.
       
      *Motherboard dependent. But the multi-monitor option might be the same regardless of manufacturer.
       
       
      This might be a bug with Mojave and it could be fixed by Apple in the future. but in the meantime, feel free to use this if it helps you fix the issue.
       
      For HP motherboards (including laptops), so far no solution, unless the BIOS somehow allows to switch from dGPU to iGPU and vice-versa.
       
      Cheers!
    • By Pedro Diniz
      Hello Friends, how are ya?

      Could you help me with a problem?

      I followed some guides like: https://www.insanelymac.com/forum/topic ... coffeelake -dsdt /

      and the installation of high Sierra 10.13.6 (17G8030) and nvidia webdrivers (correspondent to OS version) went smoothly, the problem starts when I try to boot the GPU.

      Hardware:
      MOBO: Aorus B360M gaming 3 (rev.1)
      CPU: i5 8400
      GPU: GTX 1060 OC Galax redblack

      BIOS:
      Fast boot - disabled
      windows 8/10 features - other os
      lan pxe - disabled
      storage boot option - UEFI
      other pci devices - UEFI
       
      Initial display output - PCie 1 slot
      Intel's Platform Trust Technology (PTT) - disabled
      sata mode selection - AHCI
      XHCI hand off - enabled
      VT-d - disabled
      internal graphics - auto


      The problem is:
      I can log into the system normally without using my nvidia GPU but when I boot the system with the flags for webdrivers to work I fall into the login screen but it keeps flashing, I can see the mouse and I can move it but the screen flashes and the following error appears when the screen goes "black": IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0. I searched for this error on the internet and tried to solve but to no avail so far.

      If someone can help me I would be extremely grateful! thanks in advance!

      Clover file attached.
      CLOVER.zip
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      *Use this folder with FULL DSDT PATCHED
      EFI CLOVER Z390 DESIGNARE.zip
       
      ---OPENCORE FOLDER---
      *Use this folder with FULL DSDT PATCHED
      EFI OPENCORE Z390 DESIGNARE.zip
       
      ---DSDT patch requests is here---
       
      https://olarila.com/forum/viewtopic.php?f=19&t=1131
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×