Jump to content
MaLd0n

[Guide] Sierra / High Sierra on Gigabyte GA H110M-S2 / DSDT

140 posts in this topic

Recommended Posts

Now have a Olarila app, just download app and clover folder for your Chipset!
 

Install MacOS with Olarila Image, Step by Step, Install and Post Install

 

https://olarila.com/forum/viewtopic.php?f=50&t=8685

 
20151106112558_big.png
 
First...
If you need DSDT edits for SkyLake, KabyLake or CoffeeLake...
-Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen)
-Post Ioreg, extract with Ioreg Explorer
-Run it, post files generated in your desktop
gathering.gif
Installation
 
--Create a bootable copy of macOS Sierra
Check out the link
 
--Create a bootable copy of macOS HighSierra
Check out the link
 
--Install Clover in USB stick
 
--Replace with my Clover folder 
 
--Install Sierra/High Sierra and boot into system!
 
Post Installation
 
--Install Clover in HDD/SSD and replace with my folder
 
--Reboot and activate video!
 
-Nvidia WebDriver Sierra
-Nvidia WebDriver High Sierra
-Cuda
 
--DSDT
My DSDT with Skylake patches
Patches
-FIX ERRORS AND WARNINGS
-HPET
-SATA
-DMAC
-SLPB
-DARWIN
-LPC
-XHCI
-PLUGIN TYPE
-HDAS to HDEF
-HDEF
-RTC
-IRQs
-SBUS
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-LAN
-USBX
-PMCR
-EC
-PNLF
-HDMI
--FakeSMC
--Audio
--USB
--LAN
 
-Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
 
Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!
 
We're all here to have fun and learn from each other!
 
ENJOY!

 

Share this post


Link to post
Share on other sites
Advertisement

Ofc

 

The mobo is low price but amazin'.

 

Sleep, etc etc. All is fine.

 

DSDT + SSDT pike + Kexts inside folder ;)

Thanks, appreciated your job and fast answer.

Share this post


Link to post
Share on other sites

hi everybody.

I've some question about this topic.

 

1) how's possible to use this MB to make an Hackintosh... without HDMI and DVI??  :surprised:

 

2) more important for me: I had a similar MB (h110m-S2H with hdmi and dvi) and installed my Hack without problems. I bought a new one (and i bought the same RAM, processor, ssd, etc...) for a friend but it has F20 BIOS instead F4 of the previous.  It does not wont boot!!! No way.  :(

 

What can I do? SSDT way? or Clover? (Gigabyte says that I can't downgrade BIOS to F4...)

 

Thanks for your help.

 

m.

Share this post


Link to post
Share on other sites

boot with usb stick and send me files

-Post ur full Clover folder with original tables, press F4 in Clover Boot Screen, files generate in Clover/Acpi/origin
-Post Ioreg, extract with Ioreg Explorer
-Run it, post files generate in ur desktop
 
up here if u have problem

Share this post


Link to post
Share on other sites

My Config.

 

    Gigabyte GA-H110M-S2

    I am using msi nvidia geforce gtx 750 ti 

   Bios F20

 

Sir,

 

    I installed Mac Sierra 10.12 and I installed WebDriver-367.15.10.05f01.pkg 

 

My config.plist

 

nada_drv=1. dart=0 inject kexts=Yes

inject System Id=Yes

NvidiaWeb=Yes 

 

 

But Still booting Graphics Disabled showing Graphics Display 7 MB

 

Sir Please Help me

Share this post


Link to post
Share on other sites

My Config.

 

    Gigabyte GA-H110M-S2

    I am using msi nvidia geforce gtx 750 ti 

    Intel Core i5 -6500 CPU

   Bios F20

 

Sir,

 

    I installed Mac Sierra 10.12.5 and I installed WebDriver-378.05.05.15f01.pkg

 

 

Graphics Card is Detected but Memory is showing 0 MB and installed sound driver  ALC887/888b but no sound output device is detecting 

 

Sir Please Help me, I am attaching my clover folder with generated table by using F4 Key 

CLOVER.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Pentothal.Z
      Hello all,
      I have a working hackintosh....ok.....but it takes a lot to boot and according to the boot.log there are a few problems.
      One of them is a black screen that stays on for a long time.
      I would like to ask anyone in this community some help to fine tune my machine.
      Boot.log and config.plist attached


      Any help would be appreciated.
      bootlog.txt
      config.plist
    • By metaphysician
      hi folks! i'm just checking for opinions here on a Clover based install of High Sierra. currently i can't boot directly from the internal drive on my hackbook, an ASUS ROG GL502-VS laptop (with the replaced WiFi card), though i can boot from the USB bootloader/installer

      i installed 10.13.6 fine using a prepared vanilla installer on HFS+ (not APFS), but my configuration is somewhat unusual. i have two drives. the first SSD has the Windows system, the second has two partitions with the 2nd partition holding the macOS system. when i ran Clover installer i could not use the UEFI option to copy to the EFI partition because it couldn't find one on that drive. so it installed the EFI folder on the root of the macOS partition instead.
       
      however, after a bit of tinkering around, i found out that there is an existing EFI partition on the primary drive called SYSTEM. it has a EFI folder and underneath that is a Windows folder, a Boot folder, and one called APPLE. i can mount this partition with Clover Configurator and copy files to it, but i don't know if this is a good or risky solution. i was thinking i would manually copy the CLOVER folder and the uefi64.boot file to this partition , making sure not to overwrite anything existing. using the UEFI setup, i can create a boot path from the SYSTEM partition to the Clover boot file, but i'm just curious if this is a useful solution or not, and i don't want to ruin the existing Windows 10 installation for sure. any advice appreciated!
    • By Slice
      OK, 4988 released.
      Now, @vector sigma, what have we do to update translations?
    • By fusion71au
      Clover r4989 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4989 for VMware.zip". Mount Clover-v2.4k-4989-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
×