Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

4,890 posts in this topic

Recommended Posts

Advertisement
55 minutes ago, Babiloe said:

Sent me files

http://www40.zippyshare.com/v/LCJKwAAF/file.html

 

Optimus type MX150 Nvidia and UHD 620 5917 not 5916...

So I think I can run 620 intel only as rehab man told. dO I need change dsdt or IGPu dsl to 5917 instead of 5916? 

http://www83.zippyshare.com/v/rjEL3O5F/file.html

VoodooI2CELAN.kext.zip

what ur audio codec?

41 minutes ago, petr said:

installation finally started but after HDD SETUP AND MAC HIGH SIERRA INSTALLATION ON, it will write recovery server could not be contacte .... 

Check procedure, is a two stages installation

22 minutes ago, YoYelloW said:

Tried all teh combinations from there, no luck :s you got any idea what to do next?

no ideaBluetoothDevBroadcomInjector.kext.zip

Share this post


Link to post
Share on other sites
45 minutes ago, MaLd0n said:

Voodooi2CELAN.kext is the core  kext for /S/L/E ?

Keyboard and Keypad dead now...luckily I have bluetooth key and mouse

here the symptoms

	log show --predicate 'process == "kernel"' --start "2018-03-23 00:15:00" > voodooi2clog.txt
	 
018-03-23 00:25:31.344338+0700 0x549      Default     0x0                  0      0    kernel: (kernel) VoodooGPIOSunrisePointLP::Loading GPIO Data for SunrisePoint-LP
2018-03-23 00:25:31.344455+0700 0x549      Default     0x0                  0      0    kernel: (kernel) VoodooGPIOSunrisePointLP::VoodooGPIO Init!
2018-03-23 00:25:31.344459+0700 0x549      Default     0x0                  0      0    kernel: (kernel) VoodooGPIOSunrisePointLP::VoodooGPIO Initializing Community 0
2018-03-23 00:25:31.344503+0700 0x549      Default     0x0                  0      0    kernel: (kernel) VoodooGPIOSunrisePointLP::VoodooGPIO Initializing Community 1
2018-03-23 00:25:31.344534+0700 0x549      Default     0x0                  0      0    kernel: (kernel) VoodooGPIOSunrisePointLP::VoodooGPIO Initializing Community 2
2018-03-23 00:25:31.344646+0700 0x130      Default     0x0                  0      0    kernel: (kernel) VoodooGPIOSunrisePointLP::GPIO Controller is already awake! Not reinitializing.
2018-03-23 00:25:31.346286+0700 0x553      Default     0x0                  0      0    kernel: (AppleHDAController) Sound assertion in AppleHDAController at line 436
2018-03-23 00:25:31.346291+0700 0x553      Default     0x0                  0      0    kernel: (AppleHDAController) Sound assertion in AppleHDAController at line 385
2018-03-23 00:25:31.347913+0700 0x543      Default     0x0                  0      0    kernel: (IOBluetoothHostControllerUSBTransport) **** [IOBluetoothHostControllerUSBTransport][start] -- completed -- result = TRUE -- 0x3800 ****
2018-03-23 00:25:31.353306+0700 0x536      Default     0x0                  0      0    kernel: (kernel) VoodooI2CPCIController::pci8086,9d61 Starting I2C controller
2018-03-23 00:25:31.353345+0700 0x536      Default     0x0                  0      0    kernel: (kernel) VoodooI2CPCIController::pci8086,9d61 Set PCI power state D0
2018-03-23 00:25:31.353361+0700 0x534      Default     0x0                  0      0    kernel: (AppleOnboardSerial) Identified Serial Port UA00 at 0x7f9102d000(<private>)
2018-03-23 00:25:31.353380+0700 0x536      Default     0x0                  0      0    kernel: (kernel) VoodooI2CPCIController::pci8086,9d61 Publishing nub
2018-03-23 00:25:31.354978+0700 0x542      Default     0x0                  0      0    kernel: com_apple_driver_eficheck::probe(LPCB)
2018-03-23 00:25:31.355141+0700 0x542      Default     0x0                  0      0    kernel: (kernel) SuperIODevice: [Fatal] found unsupported chip! ITE sequence ID=0xffff, Winbond sequence ID=0xffff
2018-03-23 00:25:31.355156+0700 0x542      Default     0x0                  0      0    kernel: com_apple_driver_eficheck::start(LPCB) <1>
2018-03-23 00:25:31.356854+0700 0x563      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerDriver::pci8086,9d61 Probing controller
2018-03-23 00:25:31.356870+0700 0x563      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerDriver::pci8086,9d61 Found valid Synopsys component, continuing with initialisation
2018-03-23 00:25:31.357102+0700 0x563      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerNub::pci8086,9d61 SSCN not implemented in ACPI tables
2018-03-23 00:25:31.357113+0700 0x563      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerNub::pci8086,9d61 FMCN not implemented in ACPI tables
2018-03-23 00:25:31.357118+0700 0x563      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerDriver::pci8086,9d61 Warning: Error getting bus config, using defaults where necessary
2018-03-23 00:25:31.357133+0700 0x562      Default     0x0                  0      0    kernel: IOSerialBSDClient: not registry member at registerService()
2018-03-23 00:25:31.359014+0700 0x563      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerDriver::pci8086,9d61 Publishing device nubs
2018-03-23 00:25:31.359017+0700 0x532      Default     0x0                  0      0    kernel: (kernel) VoodooI2CPCIController::pci8086,9d60 Starting I2C controller
2018-03-23 00:25:31.359026+0700 0x563      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerDriver::pci8086,9d61 Found I2C device: ELAN1300
2018-03-23 00:25:31.359080+0700 0x532      Default     0x0                  0      0    kernel: (kernel) VoodooI2CPCIController::pci8086,9d60 Set PCI power state D0
2018-03-23 00:25:31.359119+0700 0x532      Default     0x0                  0      0    kernel: (kernel) VoodooI2CPCIController::pci8086,9d60 Publishing nub
2018-03-23 00:25:31.363895+0700 0x56d      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerDriver::pci8086,9d60 Probing controller
2018-03-23 00:25:31.363907+0700 0x56d      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerDriver::pci8086,9d60 Found valid Synopsys component, continuing with initialisation
2018-03-23 00:25:31.364027+0700 0x56d      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerNub::pci8086,9d60 SSCN not implemented in ACPI tables
2018-03-23 00:25:31.364039+0700 0x56d      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerNub::pci8086,9d60 FMCN not implemented in ACPI tables
2018-03-23 00:25:31.364044+0700 0x56d      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerDriver::pci8086,9d60 Warning: Error getting bus config, using defaults where necessary
2018-03-23 00:25:31.364070+0700 0x56d      Default     0x0                  0      0    kernel: (kernel) VoodooI2CControllerDriver::pci8086,9d60 Publishing device nubs

Error getting bus config I think....I uploaded the log...

Because I removed AppleHPM.kext and AppleIntelLpssi2c.kext and AppleIntelLpssi2controller.kext from /S/L/E? trying put back there on...

HDaudio As windows said. conexant but what cx series I don't know...

Conexxant Smart Audio HDHDAUDIO\FUNC_01&VEN_14F1&DEV_1F72&SUBSYS_10431C50&REV_1000

voodooi2clog.txt

Edited by Babiloe

Share this post


Link to post
Share on other sites
24 minutes ago, Babiloe said:

Voodooi2CELAN.kext is the core  kext for /S/L/E ?

As windows said. conexant but what cx series I don't know...


Conexxant Smart Audio HDHDAUDIO\FUNC_01&VEN_14F1&DEV_1F72&SUBSYS_10431C50&REV_1000

try in clover/kexts/other, if dont work, put in l/e or s/l/e

Share this post


Link to post
Share on other sites
5 minutes ago, MaLd0n said:

try in clover/kexts/other, if dont work, put in l/e or s/l/e

it is already on /S/L/E.

BTW, you have also Voodooi2c,kext on clover/kexts/other on clover zippyshare 

 

Share this post


Link to post
Share on other sites
4 minutes ago, Babiloe said:

it is already on /S/L/E.

BTW, you have also Voodooi2c,kext on clover/kexts/other on clover zippyshare 

 

yes, 3 kext voodooL2C pack + DSDT patches

Share this post


Link to post
Share on other sites
58 minutes ago, MaLd0n said:

yes, 3 kext voodooL2C pack + DSDT patches

Looks like I need to go back to my patched DSDT.aml in clover. somehow I can't get the i2c touchpad go. fn key not functional.

Definitely need VoodooPS2controller.kext to get back keyboard.

Need sleep now. Thank you.

 

Share this post


Link to post
Share on other sites
8 minutes ago, Babiloe said:

Looks like I need to go back to my patched DSDT.aml in clover. somehow I can't get the i2c touchpad go. fn key not functional.

Definitely need VoodooPS2controller.kext to get back keyboard.

Need sleep now. Thank you.

 

don't need, just tell me what not work and we add in new patched DSDT

send me files with my app

RunMe.app.zip

Share this post


Link to post
Share on other sites
1 hour ago, MaLd0n said:

don't need, just tell me what not work and we add in new patched DSDT

send me files with my app

RunMe.app.zip

Fn not working,so including brightness and keyboard light, not test wake / lid yet

battery ok

elan touchpad not work, now I am using 1.0.4 elan 1300 driver on S L E

sound I use voodoohda, applealc not worked. but still on clover by the time this run me app

 

http://www51.zippyshare.com/v/VymsqaYn/file.html

 

Share this post


Link to post
Share on other sites
1 hour ago, Babiloe said:

Fn not working,so including brightness and keyboard light, not test wake / lid yet

battery ok

elan touchpad not work, now I am using 1.0.4 elan 1300 driver on S L E

sound I use voodoohda, applealc not worked. but still on clover by the time this run me app

 

http://www51.zippyshare.com/v/VymsqaYn/file.html

 

try it instead voodoops2controller

Babiloe.zip

u debug keys for brughtness key? if yes, tell me what _Qxx

BTW, u can use only DSDT + SSDT PNLF ;)

8 minutes ago, Thomas126 said:

Holy you really are the best. Thanks a lot mate. Is that Beer link still up to date?

Hey, Thomas!

Yes, is up to date. xD

Share this post


Link to post
Share on other sites
9 minutes ago, MaLd0n said:

try it instead voodoops2controller

Babiloe.zip

u debug keys for brughtness key? if yes, tell me what _Qxx

BTW, u can use only DSDT + SSDT PNLF ;)

Hey, Thomas!

Yes, is up to date. xD

How come the latest webdirvers are working so bad?

Share this post


Link to post
Share on other sites
4 hours ago, Thomas126 said:

How come the latest webdirvers are working so bad?

is very strange, after 10.13.3, web drivers die lol

 

Share this post


Link to post
Share on other sites

MaLd0n

Thank you very much OSX :-) Can I switch Intel HD 530 to GeForce GTX 950A 4GB? Intel 530 is fully functional with a resolution of 1920x1024 but I can not switch to 4K :-(

 

Share this post


Link to post
Share on other sites
On 3/21/2018 at 7:22 PM, MaLd0n said:

8700K

Ok so monday I get these parts:

ASUS PRIME H270-PRO

i3-7100

NVidia GT 1030

I downloaded the folder at post n. 1

Just create USB key and then drop Clover into EFI?

Thanks a lot!

Edited by zzmadd

Share this post


Link to post
Share on other sites

Hi masters of the hack universe¡¡

I need to resolve certain issues with usb volumes that always mounted, if I unmount then return to be mounted.

The low speed I get with the m2 ssd. 150mb as you can see en speedtest.

Another question for ask is the temperature the is rendering, 80º is normal? I use normal cooler like NOX Hummer 212. I see systems that has this and work better.

 

for secondary improvements a question about if is better for performance add the Igpu to my setup. i work with only Nvidia gpu, and for example bruce test takes 43 sec.

I read similar configs like me and betters times.

Mobo Asus Z170-A Bios version 2202

CPU I7 6700 4GHZ

GPU Nvidia GTX 980 4gb

RAM 16GB CRUCIAL DDR4 2133

hd1 system boot. crucial m2 CT275MX300SSD4

HD2 MEDIA STORAGE. CRUCIAL CT500MX500SSD1

I included my bios settings and the send.app files.

https://drive.google.com/open?id=1FEx_EHc_ohavRnzGPYbW4FqIgeoJtpCl

thank you for your support and knowledge.

 

 

180323163834.jpg

180323164407.jpg

180323164351.jpg

180323164334.jpg

180323164324.jpg

180323164312.jpg

180323164204.jpg

180323164150.jpg

180323164124.jpg

180323164057.jpg

180323164042.jpg

180323163955.jpg

180323163941.jpg

180323163934.jpg

180323163918.jpg

m2 crucial.jpg

ssd crucial.jpg

CINEBENCH.jpg

GEEKBENCH.jpg

Share this post


Link to post
Share on other sites
5 hours ago, petr said:

MaLd0n

Thank you very much OSX :-) Can I switch Intel HD 530 to GeForce GTX 950A 4GB? Intel 530 is fully functional with a resolution of 1920x1024 but I can not switch to 4K :-(

 

Optimus? No u need use IntelHD

https://github.com/PMheart/CoreDisplayFixup

3 hours ago, zzmadd said:

Ok so monday I get these parts:

ASUS PRIME H270-PRO

i3-7100

NVidia GT 1030

I downloaded the folder at post n. 1

Just create USB key and then drop Clover into EFI?

Thanks a lot!

Yes, install clover and replace folder in usb stick

Share this post


Link to post
Share on other sites
22 minutes ago, Fr0d0 said:

Hi masters of the hack universe¡¡

I need to resolve certain issues with usb volumes that always mounted, if I unmount then return to be mounted.

The low speed I get with the m2 ssd. 150mb as you can see en speedtest.

Another question for ask is the temperature the is rendering, 80º is normal? I use normal cooler like NOX Hummer 212. I see systems that has this and work better.

 

for secondary improvements a question about if is better for performance add the Igpu to my setup. i work with only Nvidia gpu, and for example bruce test takes 43 sec.

I read similar configs like me and betters times.

Mobo Asus Z170-A Bios version 2202

CPU I7 6700 4GHZ

GPU Nvidia GTX 980 4gb

RAM 16GB CRUCIAL DDR4 2133

hd1 system boot. crucial m2 CT275MX300SSD4

HD2 MEDIA STORAGE. CRUCIAL CT500MX500SSD1

I included my bios settings and the send.app files.

https://drive.google.com/open?id=1FEx_EHc_ohavRnzGPYbW4FqIgeoJtpCl

thank you for your support and knowledge.

 

 

180323163834.jpg

180323164407.jpg

180323164351.jpg

180323164334.jpg

180323164324.jpg

180323164312.jpg

180323164204.jpg

180323164150.jpg

180323164124.jpg

180323164057.jpg

180323164042.jpg

180323163955.jpg

180323163941.jpg

180323163934.jpg

180323163918.jpg

m2 crucial.jpg

ssd crucial.jpg

CINEBENCH.jpg

GEEKBENCH.jpg

replace, reboot, new dump

http://www117.zippyshare.com/v/fliDeMhE/file.html
 

Share this post


Link to post
Share on other sites
On 3/23/2018 at 5:25 AM, MaLd0n said:

try it instead voodoops2controller

Babiloe.zip

u debug keys for brughtness key? if yes, tell me what _Qxx

BTW, u can use only DSDT + SSDT PNLF ;)

Hey, Thomas!

Yes, is up to date. xD

keyboard and elan still can't work, but sound works via appleALC, no need voodoohda, battery works updating...

keyboard dead  without voodoops2controller..

 

uploading the runme result...

http://www68.zippyshare.com/v/vzmRWBgt/file.htmlI will try with voodoops2 instead for testing fn keys

 

I dont know what Qx.. I just use this patch on maciasl, how to find out?

Fn Brightness Keys Patch.txt

FnKeys as Function Keys Patch.txt

KeyboardBacklight Patch 4.txt

ZenBooks LidSleep and ScreenBackLight Patch.txt

 

 

I have tried modded gpio pin for elan 1300 kext that perfect run under my dsdt using voodooi2c.kext and voodooi2chid.kext. Strange it not succeed on your dsdt.

	    Scope (_SB.PCI0.I2C1)
    {
        Device (ETPD)
        {
            Name (SBFG, ResourceTemplate ()
            {
                GpioInt (Level, ActiveLow, ExclusiveAndWake, PullDefault, 0x0000,
                    "\\_SB.PCI0.GPI0", 0x00, ResourceConsumer, ,
                    )
                    {   // Pin list
                        0x0055
                    }
            })
            Name (_ADR, One)  // _ADR: Address
            Name (ETPH, Package (0x16)
            {
                "ELAN1200", 
                "ELAN1201", 
                "ELAN1203", 
                "ELAN1200", 
                "ELAN1201", 
                "ELAN1300", 
                "ELAN1301", 
                "ELAN1300", 
                "ELAN1301", 
                "ELAN1000", 
                "ELAN1200", 
                "ELAN1200", 
                "ELAN1200", 
                "ELAN1200", 
                "ELAN1200", 
                "ELAN1203", 
                "ELAN1203", 
                "ELAN1201", 
                "ELAN1300", 
                "ELAN1300", 
                "ELAN1200", 
                "ELAN1300"
            })
            Name (FTPH, Package (0x05)
            {
                "FTE1001", 
                "FTE1200", 
                "FTE1200", 
                "FTE1300", 
                "FTE1300"
            })
            Method (_HID, 0, NotSerialized)  // _HID: Hardware ID
            {
                If (And (TPDI, 0x04))
                {
                    Return (DerefOf (Index (ETPH, TPHI)))
                }
	                If (And (TPDI, 0x10))
                {
                    Return (DerefOf (Index (FTPH, TPHI)))
                }
	                Return ("ELAN1010")
            }
	            Name (_CID, "PNP0C50")  // _CID: Compatible ID
            Name (_UID, One)  // _UID: Unique ID
            Name (_S0W, 0x03)  // _S0W: S0 Device Wake State
            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                If (LEqual (Arg0, ToUUID ("3cdff6f7-4267-4555-ad05-b30a3d8938de") /* HID I2C Device */))
                {
                    If (LEqual (Arg2, Zero))
                    {
                        If (LEqual (Arg1, One))
                        {
                            Return (Buffer (One)
                            {
                                 0x03                                           
                            })
                        }
                        Else
                        {
                            Return (Buffer (One)
                            {
                                 0x00                                           
                            })
                        }
                    }
	                    If (LEqual (Arg2, One))
                    {
                        Return (One)
                    }
                }
                Else
                {
                    Return (Buffer (One)
                    {
                         0x00                                           
                    })
                }
            }
	            Method (_STA, 0, NotSerialized)  // _STA: Status
            {
                If (LOr (LNotEqual (TPIF, One), LAnd (DSYN, One)))
                {
                    Return (Zero)
                }
	                Return (0x0F)
            }
	            Method (_CRS, 0, Serialized)  // _CRS: Current Resource Settings
            {
                Name (SBFB, ResourceTemplate ()
                {
                    I2cSerialBusV2 (0x0015, ControllerInitiated, 0x00061A80,
                        AddressingMode7Bit, "\\_SB.PCI0.I2C1",
                        0x00, ResourceConsumer, , Exclusive,
                        )
                })
                Return (ConcatenateResTemplate (SBFB, SBFG))
            }
        }
    }
	

 

 

EDIT: keyboard WITH VOODOOPS2Controller.kext, appleps2touch kext removed...

a. Fn keys works

b. Backlight LCD works

c. Battery works

d. Audio works

e. Lid works/ when I closed it black..., lcd off, good..

f. when I put fn+f1 it to sleep... but when I click power, screen just black.., that key for hibernate or sleep, mackintosh can't hibernate right?

g. fn keyboard light not working.

h. elan 1300 still not working

 

I have edit your DSDT.aml with KeyboardBacklit Patch 4.txt below and now the Keyboard light works.

Please help me with the ELAN 1300.

 

DSDT.aml

Edited by Babiloe

Share this post


Link to post
Share on other sites

Hello All,

Does anyone have a Custom SSDT for USBInjectAll.kext for a Gigabyte Z370 Gaming 7 MB they can share? I'm having challenges with my Corsair Link waking my rig up from sleep within 2-3 seconds after it "goes under".

Thanks!
Lam

Share this post


Link to post
Share on other sites
13 hours ago, Babiloe said:

keyboard and elan still can't work, but sound works via appleALC, no need voodoohda, battery works updating...

keyboard dead  without voodoops2controller..

 

uploading the runme result...

http://www68.zippyshare.com/v/vzmRWBgt/file.htmlI will try with voodoops2 instead for testing fn keys

 

I dont know what Qx.. I just use this patch on maciasl, how to find out?

Fn Brightness Keys Patch.txt

FnKeys as Function Keys Patch.txt

KeyboardBacklight Patch 4.txt

ZenBooks LidSleep and ScreenBackLight Patch.txt

 

 

I have tried modded gpio pin for elan 1300 kext that perfect run under my dsdt using voodooi2c.kext and voodooi2chid.kext. Strange it not succeed on your dsdt.

 


	    Scope (_SB.PCI0.I2C1)
    {
        Device (ETPD)
        {
            Name (SBFG, ResourceTemplate ()
            {
                GpioInt (Level, ActiveLow, ExclusiveAndWake, PullDefault, 0x0000,
                    "\\_SB.PCI0.GPI0", 0x00, ResourceConsumer, ,
                    )
                    {   // Pin list
                        0x0055
                    }
            })
            Name (_ADR, One)  // _ADR: Address
            Name (ETPH, Package (0x16)
            {
                "ELAN1200", 
                "ELAN1201", 
                "ELAN1203", 
                "ELAN1200", 
                "ELAN1201", 
                "ELAN1300", 
                "ELAN1301", 
                "ELAN1300", 
                "ELAN1301", 
                "ELAN1000", 
                "ELAN1200", 
                "ELAN1200", 
                "ELAN1200", 
                "ELAN1200", 
                "ELAN1200", 
                "ELAN1203", 
                "ELAN1203", 
                "ELAN1201", 
                "ELAN1300", 
                "ELAN1300", 
                "ELAN1200", 
                "ELAN1300"
            })
            Name (FTPH, Package (0x05)
            {
                "FTE1001", 
                "FTE1200", 
                "FTE1200", 
                "FTE1300", 
                "FTE1300"
            })
            Method (_HID, 0, NotSerialized)  // _HID: Hardware ID
            {
                If (And (TPDI, 0x04))
                {
                    Return (DerefOf (Index (ETPH, TPHI)))
                }
	                If (And (TPDI, 0x10))
                {
                    Return (DerefOf (Index (FTPH, TPHI)))
                }
	                Return ("ELAN1010")
            }
	            Name (_CID, "PNP0C50")  // _CID: Compatible ID
            Name (_UID, One)  // _UID: Unique ID
            Name (_S0W, 0x03)  // _S0W: S0 Device Wake State
            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                If (LEqual (Arg0, ToUUID ("3cdff6f7-4267-4555-ad05-b30a3d8938de") /* HID I2C Device */))
                {
                    If (LEqual (Arg2, Zero))
                    {
                        If (LEqual (Arg1, One))
                        {
                            Return (Buffer (One)
                            {
                                 0x03                                           
                            })
                        }
                        Else
                        {
                            Return (Buffer (One)
                            {
                                 0x00                                           
                            })
                        }
                    }
	                    If (LEqual (Arg2, One))
                    {
                        Return (One)
                    }
                }
                Else
                {
                    Return (Buffer (One)
                    {
                         0x00                                           
                    })
                }
            }
	            Method (_STA, 0, NotSerialized)  // _STA: Status
            {
                If (LOr (LNotEqual (TPIF, One), LAnd (DSYN, One)))
                {
                    Return (Zero)
                }
	                Return (0x0F)
            }
	            Method (_CRS, 0, Serialized)  // _CRS: Current Resource Settings
            {
                Name (SBFB, ResourceTemplate ()
                {
                    I2cSerialBusV2 (0x0015, ControllerInitiated, 0x00061A80,
                        AddressingMode7Bit, "\\_SB.PCI0.I2C1",
                        0x00, ResourceConsumer, , Exclusive,
                        )
                })
                Return (ConcatenateResTemplate (SBFB, SBFG))
            }
        }
    }
	

 

 

 

EDIT: keyboard WITH VOODOOPS2Controller.kext, appleps2touch kext removed...

a. Fn keys works

b. Backlight LCD works

c. Battery works

d. Audio works

e. Lid works/ when I closed it black..., lcd off, good..

f. when I put fn+f1 it to sleep... but when I click power, screen just black.., that key for hibernate or sleep, mackintosh can't hibernate right?

g. fn keyboard light not working.

h. elan 1300 still not working

 

I have edit your DSDT.aml with KeyboardBacklit Patch 4.txt below and now the Keyboard light works.

Please help me with the ELAN 1300.

 

DSDT.aml

ohhhh

checkMaLd0n 2018-03-24 às 13.02.14.png

missing 0x00150000 and 0x00150001, the patch from repo remove devices

where u found this patch? i think the repo L2C is not update

7 hours ago, lambusser said:

Hello All,

Does anyone have a Custom SSDT for USBInjectAll.kext for a Gigabyte Z370 Gaming 7 MB they can share? I'm having challenges with my Corsair Link waking my rig up from sleep within 2-3 seconds after it "goes under".

Thanks!
Lam

just edit UsbInjectAll and use flag uia_exclude=XXXX

EXAMPLE

Unused Ports, uxcluded with flag
uia_exclude=HS01;HS02;HS03;HS04;HS05;HS06;HS10;HS11;SSP1;SSP2;SSP6
 
Used Ports
HS07, HS08, HS09, HS12, HS13, HS14, SSP3, SSP4, SSP5

2 hours ago, alex9440 said:

Hi MaLd0n! What does it mean? Graphics I have completely got started or not?5ab65806b22a9_2018-03-2416_50_10.png.0d80b0a62b7e576363677d61c4da27f1.png

MaLd0n 2018-03-24 às 13.08.18.pngi have it and full work

MaLd0n 2018-03-24 às 13.09.02.png

Share this post


Link to post
Share on other sites
16 minutes ago, MaLd0n said:

Оооо

проверитьMaLd0n 24.03.2018 в 13.02.14.png

отсутствует 0x00150000 и 0x00150001, патч от устройств удалить репо

где и нашел этот патч? я думаю, что L2C репо не обновляется

просто редактировать UsbInjectAll и использовать uia_exclude флаг = XXXX

ПРИМЕР

Неиспользуемые порты, uxcluded с флагом
uia_exclude = HS01; HS02; HS03; HS04; HS05; HS06; HS10; HS11; SSP1; SSP2; SSP6
 
используемые порты
HS07, HS08, HS09, HS12, HS13, HS14, SSP3, SSP4, SSP5

MaLd0n 24.03.2018 в 13.08.18.pngУ меня есть это и полная работа

MaLd0n 24.03.2018 в 13.09.02.png

just do not understand what it means: GVA info: Successfully connected to the Intel plugin, offline Gen95

Снимок экрана 2018-03-24 в 19.22.34.png

Share this post


Link to post
Share on other sites
On 3/20/2018 at 3:37 PM, MaLd0n said:

CLOVER.zip

RX 580 now, nvidia provide a bad driver, i changed ;)

 

Looks great, thanks!

One more.. Is it OK that there is not the IMEI Controller driver?5ab714af73063_2018-03-2506_16_02.thumb.png.499b045189bce6b68b96ffc9bceba8d7.png

And another one. I have a wireless keybord with "FN"key and multimedia keys under F1-12 keys with "FN"pressing. How can I enable that option like on original Mac?

5ab7153d4fb00_2018-03-2506_16_13.png.fec57c79c8622c83431dfb7a85ea5659.png

New "Send me"zip https://drive.google.com/file/d/1pf8vr4x0KNn2-yHGHMWLcBM8agH-Z0em/view?usp=sharing

Edited by iSoul01

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By glasgood
      CLOVER DUAL BOOT MOJAVE & WINDOWS 10 GUIDE 
       

       
       
      INCLUDES  MBR / LEGACY BIOS  TO  GPT / EFI CONVERSION
      USING MBR2GPT TOOL
       
       
      PREREQUISITE: Two physical discs ( SSD’s or HDD’s )
       
       
       
       
       
      STEP 1 - Clover dual boot configuration 
       
      Open config.plist with Clover Configurator
       
      Boot
       Legacy = PBR Timeout = True ( will remove the Timeout countdown, from Clover boot menu)  

       
      GUI 
      Scan / Custom
       Entries = True  Tool = True  Legacy = False ( removes extra Windows 10 entries )  
      Hide Volume
      - Preboot ( macOS Preboot )
      - Recovery ( macOS Recovery )
       

       
      So at boot you will have two options: boot macOS Mojave or Windows 10 
       
       
       
       
       
       
       
      ————————————————————
       
       
      STEP 2 - Using a drive without Windows 10 installed
       
      Disconnect system drive that contains your macOS Mojave install from computer ( This is so that Windows does not overwrite existing macOS Mojave boot loader )
       
      Proceed with a Windows 10 UEFI install.  
      After installation reconnect macOS Mojave Drive, the Windows installation should now be detected and usable in Clover. 
      If Windows 10 is not detected or able to boot,  then verify you installed Windows 10 as UEFI and not MBR ---->  ( Read step 2 - For a drive with Windows 10 installed )
       
       
      OR
       
       
       
      STEP 2 - Using a drive with Windows 10 already installed
       
      Verify your Windows install is  GPT / UEFI or MBR / Legacy BIOS.   
      If Windows install is GPT UEFI then Windows 10 install is ready to use at Clover boot menu, you should be able to boot into Windows directly from Clover boot screen. 
       

       
       
      But if  Windows drive is detected at Clover boot screen, but when booting Windows you get a black screen with a cursor on the top left,
      then this is most likely because Windows drive is MBR ( Legacy BIOS ).  You can easily convert MBR to GPT using  Windows MBR2GPT tool ( this saves hours work having to reinstall Windows 10 and setting up all your applications again  ) 
       
      If Windows 10 install is MBR / Legacy BIOS  then simply convert to GPT / UEFI  following instructions below ( read video summary and view video )
       
       
      ** To use Windows 10  MBR2GPT tool  you must have Windows 10 version 1703 ( creators update  ) or later and less than 3 partitions on 
      the Windows 10 drive **
       
      Video summary:
       
      Confirm Windows 10 drive is MBR Legacy BIOS ( in Windows Disk Management ) Reboot into Windows PE ( Advanced Startup ) Convert from MBR Legacy BIOS to GPT UEFI ( using commands below ) mbr2gpt /validate mbr2gpt /convert Restart Verify Windows 10 drive has changed to GPT UEFI ( in Windows Disk Management )  
       
       
       
      After conversion Windows 10 is ready to use at the Clover boot menu 
       
       
    • By SepehrM
      I'm trying to install High Sierra 10.13.3 on an ASUS N552VW laptop, and I get stuck after this message:
      "could not recover SATA HDD after 5 attempts, terminating" 
      And some other warnings afterwards.
      Specs:
      CPU: Intel Skylake 6700HQ 2.6GHz
      RAM: 16GB DDR4
      2TB HDD + 128GB SSD
      GPU: Intel HD Graphics 530 + Nvidia GTX960m
      I'm installing using a 16GB USB3 flash drive on one of HDD volumes (UEFI Mode)
       
      I uploaded the verbose log and clover config.plist
      config-new.plist

    • By gk12345
      hello to everyone, i managed to install mojave on my asus ux303ub with i5 cpu and now sleep does not work when i press sleep display turns black and pc stays on and then i have to force shut down by holding power button in order to restart pc ,by the way i used the clover folder from a guide on the internet, any help would be appreciated, thanks
    • By Bahaa
      Need help here
      My graphic card is detached 7mb
      and I try a lot of solution and no one work 
      can any one help
       

    • By Gracie
      Hello, insanely kind people! 
      I had full working Speedstep on my system with El Capitan, but after installing Mojave i cant make it working again!
      Help me please. Actually system is working only with NullCPUPowerManagement.kext. As soon as i remove it from Extensions directory i've got kernel panic at the boot.
      I tried to put SSDT.aml from my previous ElCapitan clover, tried to make new by different utilities, but still no luck.

      My system is:
      Pentium G3258
      Asus Z97-K USB 3.1
      Nvidia GTX 670


      i''m attaching my new clover.plist of Mojave and old El Capitan one, which makes Speedstep fully working and overclocking my little Pentium from 3.2 to 4.5GHz. Now i see huge speed loss without SpeedStep on Mojave  Please help, anybody! Also im attaching my working SSDT.aml from El Capitan.
      El Capitan SSDT.aml
      El Capitan config.plist
      Mojave config.plist
×