Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

4,545 posts in this topic

Recommended Posts

Sir your sends patches I apply

down below

 

 

EC0 to EC

4543 305f

4543 5f5f

 

GFX0 to IGPU

47465830

49475055

 

HDAS to HDEF

48444153

48444546

 

HECI to IMEI

48454349

494d4549

strange

try disable patches

Tanx,Did I need ssdt.aml ?

don't need

Share this post


Link to post
Share on other sites
Advertisement

Hi Sir I try fresh install without patches but same restart again and again  with  IOPPF XCPM  

 

my EFI.zip attached

EFI.zip

Share this post


Link to post
Share on other sites

Hello again MaLd0n

I have a new problem with my system. It doesn't SHUTDOWN instead of this, it reboots.

Also the Photoshop working slow.

All these  on ASUS z170i Pro gaming

There is my files.  In CLOVER  there is a DSDT I used,  and a new tables in ACPI/origin.

Would you like to see what is wrong?

 

 

 

Send me Mitropoli’s iMac.zip

CLOVER.zip

Share this post


Link to post
Share on other sites

hello maldonado

 

Could you help me with the USB electric properties of the iMac 18.3 in IOUSBHostFamily.kext

 

Thank you.

send me files, run it and wait generate all files i need

RunMe.app.zip

Hi Sir I try fresh install without patches but same restart again and again  with  IOPPF XCPM  

 

my EFI.zip attached

for install use simple folder, don't use many kexts, dsdt full patched etc, just a simple config for up install

Hello again MaLd0n

I have a new problem with my system. It doesn't SHUTDOWN instead of this, it reboots.

Also the Photoshop working slow.

All these  on ASUS z170i Pro gaming

There is my files.  In CLOVER  there is a DSDT I used,  and a new tables in ACPI/origin.

Would you like to see what is wrong?

shutdown is a simple patch and u can use in dsdt or clover

try it

config.plist.zip

update ur IntelFix kext

IntelGraphicsFixup.kext.zip

Share this post


Link to post
Share on other sites

Thanks Maldonado, I downloaded DarwinDumper iMac 18.3 from AppleLife and found what I need.

Thanks for your time

Good!

Enjoy!

Share this post


Link to post
Share on other sites

good

attachicon.gifCLOVER.zip

native gfxo device is a intelhdgraphics, patch rename gfx0(intelhd) to igpu and whatevergreen rename pegp(radeon) to gfx0 ;)

mvne still slowing the whole system, so I just removed it. is it possible to return wake up by keyboard\mouse? My case has a power button underneath the bottom, so it's not too handy to turn it on after sleep

Share this post


Link to post
Share on other sites

necesitas mantener toda la carpeta, tener una copia de seguridad de tu carpeta anterior y nueva

 

, necesitar limpiar tu sistema, tener archivos muy malos

Ya tengo el archivo Clover que me enviaste corriendo. Adjunto la carpeta y el resto para que puedan decirme cómo optimizar el sistema operativo. Gracias

Clover.zip

Share this post


Link to post
Share on other sites

mvne still slowing the whole system, so I just removed it. is it possible to return wake up by keyboard\mouse? My case has a power button underneath the bottom, so it's not too handy to turn it on after sleep

About nvme, idk, never see it, is strange.

 

Yes, i'm back for home in two days, i'll check for u.

Ya tengo el archivo Clover que me enviaste corriendo. Adjunto la carpeta y el resto para que puedan decirme cómo optimizar el sistema operativo. Gracias

Clover.zip

K

Share this post


Link to post
Share on other sites

Hallo

 

can't get audio device recognised

U need check what u audio codec and see what layout-id work for ur codec with AppleAlc

Share this post


Link to post
Share on other sites

U need check what u audio codec and see what layout-id work for ur codec with AppleAlc

okay

 

howto

 

thanks

post-91866-0-30734900-1518028127_thumb.png

post-91866-0-95959700-1518028740_thumb.png

Share this post


Link to post
Share on other sites

Now u need check in Applealc what layout-ids work for u. I'm not in home now, access only in cel phone

Share this post


Link to post
Share on other sites

phy, i think is about lan or wifi

 

cpu, need check if others members have same problem

 

agpm, check inside cpu in ioreg if agpm is load

attachicon.gifMaLd0n 2018-02-05 às 21.30.20.png

 

PCI, dsdt

 

SSDT only sandy bridge or new, old processors just use Generate P and C States in config.plist

 

OK THANX

Share this post


Link to post
Share on other sites

@MaLd0n I'm from China,Poor foreign language,Google translation now used。

 

The following is my Hackintosh platform:

CPU:i7 8700k

MB:Asrock Z370 Extreme4

RAM:G.skill DDR4 3200 8G*2

GPU:AMD 370X 4G

 

I will not compile DSDT, I extracted DSDT clover guide, I hope you can help me compiler, thank you.

 

I now have a problem sleeping, sleep will always restart and enter the system, usb I do not know is not right, I hope these problems can be solved in the DSDT, thank you

 

Attach Files is run me app to Files

Send me Visins-iMac.zip

Share this post


Link to post
Share on other sites

Hi MaLd0n! Thanks for all the great help on here!

 

I tried following your instructions several times and get this error below trying to install Sierra from my Clover USB. I used your attached EFI folder for my USB Installer. 

 

I have attached the Origin from my ACPI from Clover by pressing F4 to see if there is anything you can try to help me with I would sure appreciate it.

 

My Hardware

---------------------------------------------------------------

Gigabyte X299 UD4 Motherboard. Latest F5 BIOS

i9-7900x CPU

Nvidia 970 Video Card

SSD

 

 

 

Error%20Hackintosh.jpg

origin.zip

Share this post


Link to post
Share on other sites

@MaLd0n I'm from China,Poor foreign language,Google translation now used。

 

The following is my Hackintosh platform:

CPU:i7 8700k

MB:Asrock Z370 Extreme4

RAM:G.skill DDR4 3200 8G*2

GPU:AMD 370X 4G

 

I will not compile DSDT, I extracted DSDT clover guide, I hope you can help me compiler, thank you.

 

I now have a problem sleeping, sleep will always restart and enter the system, usb I do not know is not right, I hope these problems can be solved in the DSDT, thank you

 

Attach Files is run me app to Files

CLOVER.zip

Hi MaLd0n! Thanks for all the great help on here!

 

I tried following your instructions several times and get this error below trying to install Sierra from my Clover USB. I used your attached EFI folder for my USB Installer. 

 

I have attached the Origin from my ACPI from Clover by pressing F4 to see if there is anything you can try to help me with I would sure appreciate it.

 

My Hardware

---------------------------------------------------------------

Gigabyte X299 UD4 Motherboard. Latest F5 BIOS

i9-7900x CPU

Nvidia 970 Video Card

SSD

 

 

 

Error%20Hackintosh.jpg

i think u need a fakecpuid, 10.13.4 beta have a full support for u now

Share this post


Link to post
Share on other sites

 

i think u need a fakecpuid, 10.13.4 beta have a full support for u now

 

OK so I need to find 10.13.4 beta? I was able to download 10.13.3.02 from the AppStore but not sure how to get the 10.13.4 beta. 

Share this post


Link to post
Share on other sites

create usb stick with 10.13.3 and update after install

use voodootscsync with correct iocpunumber, if u need a fakecpuid use KernelCpu in clover

Share this post


Link to post
Share on other sites

create usb stick with 10.13.3 and update after install

use voodootscsync with correct iocpunumber, if u need a fakecpuid use KernelCpu in clover

 

OK, I was trying regular Sierra (not High) but I will make a 10.13.3 now

 

Do I us voodosync on the UBS Installer or after installation?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By FZSX
      Hello, im FZ, been in hackintosh community since mac os X lion years. Please consider me noob. i have helped hackintoshed pc of my friends and family. i ran el capitan, sierra, high sierra on below spec.
      I lost some interest in hackintoshing from past 1 year now im back again cuz of mojave.
      Lets start.
       
      I posted this issue in Nvidia Topic for discussion but decided not to post until i could get some bug log out of it... but. eh.
       
      Well ive Kepler based gt 710 card.
      Issues:
      Black Screen when booting with default drivers or nvda_drv=1 mode
      OR
      White/Grey Screen with 1 sec mouse movement then freezed keyboard and mouse with nv_disable=1.
        
      Tested:
      tried numerous ways to boot Mojave but does not works such as >
      High Sierra/Sierra default Apple geforce nvda kexts, High Sierra Web Drivers, various clover configs, display edids, HDMI dvi port tests... so on.
       
      Specs:
      Tri Boot Setup:
      Windows 10, Sierra(gt 710 works OOB, or with Web Drivers too), Mojave.
      ASUS P5G41TM LX
      Core2Duo E8500
      Gigabyte Nvidia Geforce GT 710 2GB
       
       
      I couldn't managed to get logs as half part of installation is still incomplete i.e Mojave installed from USB to HDD after but cant get into login/setup screen due to above mentioned black screen issue.
       
      I will try to be as detailed as possible.
       
      i had no mac device or any macos dmg/iso to install mojave so performed some steps in windows.
       
      Steps i performed:
      1. I downloaded Mojave 10.14.1 iso file from Olarila.com which is a complete raw image of Mojave USB stick as the post title says **The image is clean, without any mod with Clover bootloader, essentials kexts and patches inside Clover folder**. Which comes with this OLIRALA_MOJAVE_USB_EFI.zip which i backed up(see attachment OLIRALA_MOJAVE_USB_EFI.zip)
      2. made usb in windows with win32diskimager
      3. booted from usb and got kernel panic 
      4. swapped usb EFI folder with Olarila Clover EFI for LGA 775 (see attachment CLOVER.LGA775.OLARILA.zip)
      5. booted from usb susccesfully till install screen but throws macOs Mojave could not be installed on this computer
      6. i was fed up trying workarounds , i knew i need newer mac ids in clover config.plist to make it install 
      7. i downloaded Olarila Sierra from same site flashed in another usb stick and it worked out of box without messing any kext or kind.
      8. added SMBIOS iMac13,1 in config.plist with clover configurator. 
      9. booted from usb and succesfully installed Mojave with HFS+ partition on MBR partitioned HDD(dual booting with windows 10) 
      10. booted from usb to complete partial installation of Mojave but got black screen. 
       
      For getting all kernel, bug, kext logs i tried Problem Reporting script of Black Dragon which requires active internet connection which is not possible, I tried to mod the script to run local but im not good at bash and it went in errors. I will do provide mojave logs manually from single user -x mode if i can.
      https://github.com/black-dragon74/OSX-Debug
       
      some other files
      DSDT.aml.zip
      preboot.log
      currentCloverEFI.zip
         
    • By Macpro3.1
      Hi,
       
      Im glad to be a part of this forum. Just signed up 20 mins ago.

      I have an old macpro 2008 fully loaded using yosemite 10.10.5.
       
      I would not like to touch that OSX version but been curious with mojave on hackintosh PC.
       
      i also have a low/mid range gaming windows PC.
       
      My specs for my W7/10 dual boot (same SSD) windows PS are as follows:


      Motherboard: Asus P8B75-V
      Intel i7 3770k
      8GB DDR3 1600mhz RAM
      Antec HCG 620W PSU
      Asus GTX 560 DC
      Corsair Force GT 120GB SSD
       
      Built everything in mid 2012.
       
      Will these hardware lets me install Mojave? If not, whats the max OSX i can install? 
      Then worst case, will i be able to install atleast yosemite 10.10?
      I dont mind if i get Nullcpupowermanagement and not be able to use my bios C1 packages and sleep or any intel speedstep as i dont use them anyways in my windows OS.
      i just need it to work smoothly with MB audio built-in, wifi, ethernet, Usb port 2.0 and 3.0.
      im not a gamer but likes to use Logic pro X.
       
       
      was thinking of using the W10 partition for the hackintosh OSX but if possible, i could use a 64GB USB 3.0 thumbdrive.
       
      Thanks in advance.
       
       
       
       
       
       
       
       
       
       
    • By vythanh156
      Hello Everyone !
      I successfully instant Mojave on my Pc. Everything works fine except sleep. When I click sleep, it instantly sleep and restart right after cpu fan stop. I attached the MadLon Run Me here. Hope someone can help.
      I did delete PowerManager in Library/Preferences but still no hope
      My spec: 
      Asrock z370 itx Gaming 
      i5 8600k 
      32GB corsair LPX
      Samsung 950 nvme
       
      The problem may because I changed my MSI z370 a-pro atx to Asrock itx. Before that the system runned perfectly fine with the MSI mainboard. 
       
      Send me Thucs-iMac.zip
    • By pmidmaker
      Hello friends,
       
      I've installed OSx 10.4 in my laptop but I have the following component not working after installing Clover
       
      Laptop: Dell Vostro 15 3549
      Intel HD Graphics 5500, not working at all
      Wireless: Dell wireless 1705.802.11 
      Trackpad and keyboard: ???
      Sound: Realtek High Definition ALC3234
      Battery
       
      Very appreciate if someone can help me
       
      Br.
       
       
       
×