Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

4,841 posts in this topic

Recommended Posts

Advertisement
10 hours ago, jamvybz said:

thanks again, just an update thanks to you i got macos installed the reason why it wasn't working whit the dsdt seemed to be because of the USB but i got it working i just need to get my iGPU to work now . its a UHD 630 cant seem to get it working 

Send me Hps-iMac.zip

DSDT.aml.zip

video check here

 

Share this post


Link to post
Share on other sites

HI Mald0n,

Could you please patch my dsdt. My Mobo Gigabyte b250-hd3p + i5 6500

 

I use your clover directory to install Mojave.

Should I install/remove some kext ?

Thanks

 

CLOVER.extract.zip

Edited by barnum

Share this post


Link to post
Share on other sites
2 hours ago, MaLd0n said:

DSDT.aml.zip

video check here

thanks i was trying to use the FB-Patcher but i didnt have any luck but i didn't have the link to the read up so im gonna do that now .oh and tried using the new dsdt that you just sent but the system wouldn't boot idk if it has anything to do with the debug lilu and boot flags that i just added 

 

Share this post


Link to post
Share on other sites
1 hour ago, jamvybz said:

 

it seems like the system not booting has nothing to do with the dsdt it just seem not not boot anytime i try someone new like a new kext but it takes for ever to start boot again it just keeps restart im lost to whats going on.

20190112_132627.jpg

Edited by jamvybz

Share this post


Link to post
Share on other sites
8 hours ago, barnum said:

HI Mald0n,

Could you please patch my dsdt. My Mobo Gigabyte b250-hd3p + i5 6500

 

I use your clover directory to install Mojave.

Should I install/remove some kext ?

Thanks

 

CLOVER.extract.zip

u can use it without any problem, check in nioreg what lan kext is load and use only correct ket for ur lan

7 hours ago, jamvybz said:

it seems like the system not booting has nothing to do with the dsdt it just seem not not boot anytime i try someone new like a new kext but it takes for ever to start boot again it just keeps restart im lost to whats going on.

 

u need create a correct patch for u

Share this post


Link to post
Share on other sites

okay, I managed to solve the problem, which seems to be with the installer USB I created. I downloaded and used the Olarilla image (thanks Mald0n!!:)), and everything worked perfectly pretty much from that point on. I have USB, Sleep, and the basic GPU detected. sorry about my panic earlier! 

 

a few questions though:

1. having a weird issue where I get the EFI partition for the boot drive showing up and then sometime after booting (maybe and hour or two?) it unexpectedly dismounts that partition as well as another mounted drive. the rest of the drives are untouched. it shouldn't be normally showing the EFI partition I would think. have you heard of this?

 

2. the system shows I have a 650Ti card but the menu bar isn't transparent, and the System Profiler does not show the 'QE' designation that I remember. I upgraded from Yosemite and it seems like Quartz Extreme is being replaced by Metal. So should the menu bar normally be transparent if the card is fully recognized?

 

3. i have software on other drives that needs to run under Yosemite, but I'm not sure what needs to be done to the kexts or the Clover boot configuration to do this. i seem to remember that you could have different folders for different OS versions to load specific kexts. i know there is a strong tendency to always go for the latest and greatest, but what forum area should I post on to be able to switch between 10.13 and 10.10? 

 

4. any easy way to get ALC1220 audio drivers to work? the system doesn't show anything. would prefer without DSDT if possible, but happy to use it if I need to.

Share this post


Link to post
Share on other sites

HI Mald0n,

Could you please patch my dsdt.

 

My Hardware:

Motherboard: Gigabyte Z270M-D3P

CPU: i5 6600k HD 530

Graphics: NVIDIA GTX 760 (planned)

 

Thanks a lot in advance!

Send me Denniss-iMac.zip

Edited by DJ_Mic

Share this post


Link to post
Share on other sites
15 minutes ago, DJ_Mic said:

HI Mald0n,

Could you please patch my dsdt.

 

My Hardware:

Motherboard: Gigabyte Z270M-D3P

CPU: i5 6600k HD 530

Graphics: NVIDIA GTX 760 (planned)

 

Thanks a lot in advance!

Send me Denniss-iMac.zip

DSDT.aml.zip

Share this post


Link to post
Share on other sites
On 1/13/2019 at 1:45 AM, MaLd0n said:

u can use it without any problem, check in nioreg what lan kext is load and use only correct ket for ur lan

u need create a correct patch for u

I use it and it work well but can you patch my DSDT ?

 

Thanks

 

Edited by barnum

Share this post


Link to post
Share on other sites
On 1/14/2019 at 1:56 AM, MaLd0n said:

I plugged in my GTX 760 and i got this error.

IMG_3669.JPG

 

Could you fix maybe also shutdown kernel panic? Every time I restart, I get a error message on boot, that the system could not shutdown correctly.

 

Can you fix maybe my USB ports too? Tried the Intel FB-Patch, but can't get any USB 3 device working.

Edited by DJ_Mic

Share this post


Link to post
Share on other sites

Hi

This is really valuable article for me

Actually I am beginner on hackintosh build and I tried over 1 week but failed.

 

I am using special one

Motherboard: ONDA B150S QG

CPU: i5 6400 skylake

Intel UHD 520

Sound: Realtek ALC662

 

I was trying install mac High Sierra 10.13.4

 

This is urgent and serious and pliz pliz pliz help me :help:

 

can you guide me how to configure hackintosh?

picturemessage_kpfslaqj.mzl.png

picturemessage_puc1npgi.lri.png

Edited by Poo Zhang
attached more detail

Share this post


Link to post
Share on other sites
1 hour ago, Poo Zhang said:

Hi

This is really valuable article for me

Actually I am beginner on hackintosh build and I tried over 1 week but failed.

 

I am using special one

Motherboard: ONDA B150S QG

CPU: i5 6400 skylake

Intel UHD 520

Sound: Realtek ALC662

 

I was trying install mac High Sierra 10.13.4

 

This is urgent and serious and pliz pliz pliz help me :help:

 

can you guide me how to configure hackintosh?

picturemessage_kpfslaqj.mzl.png

picturemessage_puc1npgi.lri.png

follow first post

Share this post


Link to post
Share on other sites
8 hours ago, MaLd0n said:

follow first post

I have followed but when click `install from Mac Sierra` it shows console and some operations were progressed

and then black screen

I think there is a problem in my Clover

I have used clover that you posted on first post

have you got any idea?

I am not sure how to generate SSDT and DSDT with picker-alpha

I have no knowledge about this stuff :unsure:

If would be great if you generate Clover so that I can only copy paste :D

 

Thanks

Edited by Poo Zhang

Share this post


Link to post
Share on other sites
1 hour ago, Poo Zhang said:

I have followed but when click `install from Mac Sierra` it shows console and some operations were progressed

and then black screen

I think there is a problem in my Clover

I have used clover that you posted on first post

have you got any idea?

I am not sure how to generate SSDT and DSDT with picker-alpha

I have no knowledge about this stuff :unsure:

If would be great if you generate Clover so that I can only copy paste :D

 

Thanks

You need to make a Signature so that people know what sort of HW you have.

Then somebody may be able to help you further.

Share this post


Link to post
Share on other sites

Hey Maldon, Needing help with your magic again lol. New board and CPU and RAM. All is currently working flawless. But nothing in PCI devices is showing. Ive Attached your debugging files. 

Many thanks as always. :)

Send me iMac.zip

Share this post


Link to post
Share on other sites
4 hours ago, tikizondo94 said:

Hey Maldon, Needing help with your magic again lol. New board and CPU and RAM. All is currently working flawless. But nothing in PCI devices is showing. Ive Attached your debugging files. 

Many thanks as always. :)

Send me iMac.zip

DSDT.aml.zip

Check a correct config for ur hardware in my clover folder serier 10/20/30

https://olarila.com/files/Clover.Folder/CLOVER.SERIES.100.200.300.zip

Share this post


Link to post
Share on other sites

Hey Maldon, Needing help for patching my DSDT. can't sleep and USB 3.0 got limits, etc.

 

My Hardware

 

Board : ASrock Z170 Pro 4

CPU : Intel Core i3 6100 3.70GHz

Memory : 12 GB 2400Mhz @3slots 4GB

GPU : Intel HD Graphics 530

Storage : INTEL SSD 120GB

Audio Related ALC 892

LAN : Intel i219V

Wireless LAN : TP LINK TL-WN7200ND

Mac OS : Mojave 10.14.2

 

thanks a lot.

Send me Aris-iMac.zip

Edited by ariqk88

Share this post


Link to post
Share on other sites
6 hours ago, ariqk88 said:

Hey Maldon, Needing help for patching my DSDT. can't sleep and USB 3.0 got limits, etc.

 

My Hardware

 

Board : ASrock Z170 Pro 4

CPU : Intel Core i3 6100 3.70GHz

Memory : 12 GB 2400Mhz @3slots 4GB

GPU : Intel HD Graphics 530

Storage : INTEL SSD 120GB

Audio Related ALC 892

LAN : Intel i219V

Wireless LAN : TP LINK TL-WN7200ND

Mac OS : Mojave 10.14.2

 

thanks a lot.

Send me Aris-iMac.zip

DSDT.aml.zip

--USB Fix
https://olarila.com/forum/viewtopic.php?p=65287#p65287

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ltooz_audis
      I always want to have a long lasting battery ultrabook to install Mojave on. I was looking at Dell XPS 13 but its design is not very good with the camera and other problems. HP Spectre x360 is a nice design but the wifi module is soldered on board. The Envy 13" is the best one in the bunch for MacOS Mojave. I would not use any other macOS besides Mojave, it's the best one so far. If you can't get it done with macOS Mojave, you don't do it correctly, it's much more refined and given than older macOS's.
      I wanted the 8th generation because of the 4 cores which is almost 1.5 times faster than this 7th generation i7-7500u, but the price is too high. I picked up this one on Craigslist for $400. I've just ordered the 500GB NVME WD Black for $104 and DW1560 for $29. So, the perfect MacBook Pro 14,2 is less than $600 that last 5-6 hours with Mojave and 8-9 hours on Windows 10. The bench mark is the same as the real MacBookPro 14,2. BTW, this is the first try, there will be on going testing and confirming. 250GB hard drive is hardly enough for dual boot Windows and Mac. You need at least 500GB, I don't use Windows at all, so I'll partition 200GB for Windows and 300GB for Mojave.
      All new HP laptops will have kernel panic if using Clover to boot UEFI, at least a fix was found. I'll have more videos and info when I have time to write them. Watch the videos and ask questions if you have any problems.
      1. Clover 4558 - Lilu.kext (1.3.3) - AppleALC.kext (1.3.1) - Whatevergreen.kext (1.2.3) - USBInjectAll.kext (0.6.5) - Fakesmc.kext (6.25-332-gf3a8525c.1758) - ACPIBatteryManager.kext (1.81.4) - AHCIPortInjector.kext - BrcmFirmwareRepo.kext (2.2.7) - BrcmPatchRAM2.kext (2.2.7) - CodecCommander.kext (2.6.2) - FakePCIID_Broadcom_WiFi.kext (1.3.9) - FakePCIID_Intel_HD_Graphics.kext (1.3.9) - FakePCIID.kext (1.3.9) - SSDT-AUIC-ALL.aml - SSDT-USBX.aml - SSDT-PNLF.aml - SSDT-PluginType1.aml - PreLoader.efi.
      2. For the keys F2 & F3 to work with backlight slider - the Fakesmc.kext version is important for some reasons, I'm still trying to find out why.
      The touchscreen actually works without the voodooI2C kexts, just need to patch the clover.
       
      I've been playing with the laptop for over a week now. Ordered the WD 500GB WDS500G2X0C from Amazon for $104, the 256GB is too small for dual booting Windows 10 & Mojave. It's really plug and play.
       
      Hardware - needed to make this a perfect macbook Pro14,2.
      1. DW1560 BCM94352Z - make sure it has 2 notches - Tape the 2 right pins on the 4 pins tab for it to work without a hitch on both Windows 10 and Mojave. You can buy from Ebay cheaper but you have to wait for months.
      2. 500GB NVMe SSD m.2 connector M is a must for dual boot - the cheaper one will be slower - Crucial NVMe 500GB is $25 less than WD.
      3. NOVOO USB-C to HDMI hub that works and inexpensive.
       
      Let's start to get this Kaby Lake working on the HP - I believe HP has the same components for similar configuration on different models. In order to get Mojave to work on Intel Laptop, we need a few important components - Sound is important (look for Realtek - ALC295) - Ethernet if any -Realtek - Trackpad  and TouchScreen (Synaptics or Elan).
       
      REPLACE VNMe SSD HARD DRIVE and DW1560 BCM94352Z
       
      The current BIOS is F22, the newest one is F27 but I don't want to update since it's working well. Since I don't really need the original Windows 10 with Junk software in it, I install the latest Windows 10 using Media Creation USB Boot Drive. The important thing is we have to prepare the SSD correctly or our EFI folder will only be set at 100MB which is not enough to install Clover or any other boot loaders. So instead of letting the Windows installer to create the EFI folder automatically, we can set the size ourselves using "diskpart" command. In order to use diskpart, we need to boot with Windows 10 USB installer (hit F9 then select UEFI USB installer) - select system repair and not installation - then select command prompt, from here we can create EFI folder and MSR for Windows installer to install. The product ID is already in the UEFI bios, so we don't really have to manually activate the Windows 10.

       
       
      diskpart
      select disk 0
      clean
      convert gpt
      create partition efi=300 !!! you can change it from 300MB to any size.
      format quick fs=fat32 label="EFI"
      create partition msr size=16
      exit

      After exit, reboot with the USB installer again in UEFI mode, select the custom. The Windows installer will select the 300MB EFI folder we've just created.
       
       
      How to fix KP on Clover UEFI Boot.
       
       
      This is the macBook Pro 14,2 from HP 13-ad010nr
       
       
       
      Louis
       
    • By yehia2amer
      Problem:
      When I Attempt to wake my Machine from sleep, the screen stays black, although the computer is obviously awake !
      This Machine has a 1300W Power Supply So Sleep is Very Useful.
       
      I Tried:
      1) FIX_WAK and FixShutdown as per Clover Wiki.
      2) Although I am using "SAPPHIRE Radeon PULSE RX 580 8GB GDDR5", which Should be completely Supported by Mojave, I Also changed the Part Number to "113-4E353BU-O4E" as per this Guide: http://www.xlr8yourmac.com/archives/feb18/RadeonRX-580_MacPro.html. The GPU is working GREAT without even Clover Inject
      3) Tried to Run this command: disablehibernate.command.zip
      4) Tried darkwake=0 to 10
      5) Disabled wake on USB & Wake on LAN (BIOS)
       
      Logs:
      sudo pmset -g
      System-wide power settings: Currently in use: hibernatemode 0 disksleep 10 womp 0 networkoversleep 0 sleep 0 Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage autorestart 0 gpuswitch 2 displaysleep 10 pmset -g assertions
      2019-02-19 18:51:04 +0200 Assertion status system-wide: BackgroundTask 1 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 1 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 56(powerd): [0x0000001700088000] 00:13:44 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" pid 100(hidd): [0x00000025000980a7] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968578.17" Timeout will fire in 600 secs Action=TimeoutActionRelease pid 200(mds_stores): [0x0000034e000b8279] 00:00:00 BackgroundTask named: "com.apple.metadata.mds_stores.power" Kernel Assertions: 0x4=USB id=502 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d130000 owner=USB Keyboard id=503 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d120000 owner=Lenovo Optical Mouse Idle sleep preventers: IODisplayWrangler  
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors
      RAM: 128 GB 1333 MHz DDR3 ECC Memory
      GPU: SAPPHIRE Radeon PULSE RX 580 8GB GDDR5
      Chipset: Intel C602
      Audio: Realtek ALC3220 (ALC280) High Definition Audio
      SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  
      Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210 
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      for more info:
       
      Any Help will be appreciated, Thanks !
       
      Send me Yehias-Mac-Pro.zip
    • By yehia2amer
      Dell Precision T7610 Workstation
      Hackintosh GUIDE (Work in Progress)
       
                        
      Introduction: 
      Hi Everyone,
      This Workstation used to be a Beast with Dual CPUs and tons of RAM, I Know it is now normal to get that much cores in a Desktop but it is still a very decent machine for me (As a Programmer), and I thought it would be a good idea to Install MacOS as the Daily Driver Rather than Linux and It turns out to be a very Great Experience (with Some Challenges ).
       
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors RAM: 128 GB 1333 MHz DDR3 ECC Memory GPU: SAPPHIRE PULSE Radeon RX 580 8GD5 Chipset: Intel C602 Audio: Realtek ALC3220 (ALC280) High Definition Audio SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      Working:
      Both "Xeon E5-2680 v2" and all cores with Power Management and P-States (using VoodooTSCSync & ssdtPRGen.sh) ATI Radeon HD 4870 (Vanilla) Realtek ALC3220 (ALC280)  (using VoodooHDA till Now - it is partially working with AppleALC using layout-id 13) LSI 2308 SAS (using AstekFusion2) Intel 82579 Network Controller (Vanilla) Intel I210 Network Controller (IntelMausiEthernet) USB 2.0  
      Not Working:
      NEC USB3.0 xHCI Controller (Renesas Electronics uPD720201 & uPD720202) Sleep  
      https://github.com/yehia2amer/Dell-Precision-T7610-Workstation-Hackintosh-Guide
    • By wen1
      Work in progress
       
      This is mini guide and config files for installing Mojave on a Dell XPS 13 9370.
       
      I took inspiration from sensibleJoe at on reddit
       
      My laptop's specs
       
      i7-8550U Intel HD 620 Graphics UHD Display 256GB Samsung NVMe SSD PM961 Killer 1435 Wifi  
      Here is what works
       
      Intel HD Graphics  Sleep Sound & Mic USB Wifi (Internal Killer Wifi will not work) Bluetooth Power Management Battery Management Screen Brightness Control  
      What does not work
       
      Internal Wifi Camera SD Card reader  
       
       
      I followed the vanilla guide here to create the Mac OS Mojave install USB. I used Mac OS 10.14.3.
       
      Here are some rough steps
       
      1. Create the USB installer for Mojave. You can use apple's own instructions
      2. Once the installer USB creation is complete, Install the latest version of clover to the USB disk with the following options 
      Install Clover for UEFI booting only
      Install Clover to the ESP
       
      Leave everything else as default (minimal install without a bunch of drivers)
       
      3. Then mount the EFI folder on the USB drive and replace the files in the config folder with the ones from the attached zip file over writing the files already there. This config is specifically for Dell XPS 13 9370.
      4. Go into the UEFI/BIOS on the laptop, Make sure your SATA mode is set to AHCI (And not Raid). Save and Exit
      5. Boot with the USB disk and install Mojave
      6. After the install is complete, Use the USB to boot again but this time boot into the newly installed Mojave partition.
      7. Install Clover on to the SSD with the same options as before.
      8. Then copy the config files to the EFI folder on the SSD overwriting the config folder there.
      9. Acquire the backlight AppleBacklightFixup.kext from here and install to /Library/Extensions (Thanks to Rehabman for the kext)
      10. Reboot.
       
      EDIT: V4 fixes many things, like powermanagement, backlight control etc. you also need to install AppleBacklightFixup.kext to /Library/Extensions
       
       
      CLOVER-v4.zip
    • By mhendawy
      Hello There,
       
          I had Mojave 10.14.2 over HP ProBook 450 G4 and most probably all functions are working except an issue that when I connecting the device to HDMI it reboots. although the EFI is fully patched [ DSDT & SSDT] and the behavior of sleep\wakeup please find all the attached problem files.
       
      Thanks 
      PrF.zip
×