Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

4,366 posts in this topic

Recommended Posts

Advertisement
9 hours ago, Sorex said:

Hello MaLd0n,

 

Could you please make DSDT edits for my new Skylake desktop Lenovo M910t 

 

RunMe files:

https://www96.zippyshare.com/v/5bgqAiga/file.html
 

Thank you very much in advance!

https://www33.zippyshare.com/v/R8ITEQAL/file.html
 

Share this post


Link to post
Share on other sites
Posted (edited)

MAld0n, I can't post a new topic on post installation forum. is it on maintenance?

now i can post the topic into post installation problem...

 


Notebook Asus X550VX i7 - 7700hq
GTX950MX - UHD630
A1718086 - 025510ec ALC255 that works only on VoodooHDA 
RTL8111 LAN

Hwinfo
https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL

 

Not work:
1. White Screen Wake up
EDID not a asolution
IOREG output http://www.mediafire.com/file/u7odzbaxa7bbb6a/ioregSaved.txt and EDID
http://www.mediafire.com/file/hqlapgf4luwchdf/DisplayProductID-69c.plist

Image
https://ibb.co/faL5wx

2. Battery info status bar sometimes goes on / off like battery has off
3. Crackle Sound using   earphone using VoodooHDA
       Still investigation using patched iomatch voodooha info.plist
       The sound card can’t be using AppleALC, no sound came out using layout 3, 13, 17, 18, 27, 28, 99


I have your (Mald0n) DSDT

 

http://www.mediafire.com/file/lmp5yy65rblx9ne/DSDTtitomaldon2.dsl

 

I have re-patched again for FnKeys and Brighness Key

http://www.mediafire.com/file/5rs93ij0wco99s6/DSDTtitomaldon2editv2.aml



 
codec dump linux
https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view
 
 
latest debug
http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip
 
clover and kext
https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL
 

Edited by Babiloe

Share this post


Link to post
Share on other sites

MaLd0n i created my hackintosh but at pci device not show up all device, can help me to makae DSDT

 

My hackintosh specification:

ASUS Z270 MAXIMUS IX CODE BIOS 1301

Core i5 7600K overclock 4.8Ghz

Memory 16GB

AMD RADEON RX 560

Use pci card broadcom wifi & bluetooth

 

DSDT and clover compile RunMe.app

 

 

Share this post


Link to post
Share on other sites

Thank you, thank you, thank you!!  I've been trying to reinstall Sierra on my Hackintosh for months but finally succeeded by using this link.  I can't believe it.  I'll delete the Chopintosh install in a few days after finalizing this install.

Share this post


Link to post
Share on other sites
15 minutes ago, santes said:

Recently i am having some issue with screen flickering...i had this in past but rarely came....but now its everyday issue... so plz anyone help me... 

 

You has installed IntelGraphicsFixup.kext and lilu.kext ?

Share this post


Link to post
Share on other sites
1 hour ago, rubahgeni said:

MaLd0n i created my hackintosh but at pci device not show up all device, can help me to makae DSDT

 

My hackintosh specification:

ASUS Z270 MAXIMUS IX CODE BIOS 1301

Core i5 7600K overclock 4.8Ghz

Memory 16GB

AMD RADEON RX 560

Use pci card broadcom wifi & bluetooth

 

DSDT and clover compile RunMe.app

 

 

https://www100.zippyshare.com/v/bXi8t5Ri/file.html
 

Share this post


Link to post
Share on other sites
2 hours ago, rubahgeni said:

 

You has installed IntelGraphicsFixup.kext and lilu.kext ?

Already have All required Kext

Share this post


Link to post
Share on other sites
4 minutes ago, santes said:

Already have All required Kext

 

Did you use a Kext Installer?

Share this post


Link to post
Share on other sites
4 hours ago, Mikentosh2016 said:

 

Did you use a Kext Installer?

no.. i put in EFI folder 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, santes said:

no.. i put in EFI folder

 

 

What about /System/Library/Extensions?

Edited by Mikentosh2016
More line space.

Share this post


Link to post
Share on other sites
22 hours ago, santes said:

Already have All required Kext

This issue seems like from hardware accelaration.
Has you installed shiki.kext to?

Shiki v2.2.6
Disabled hardware accelerated renderer hacks on 10.13.4 and newer (Apple fix)

Share this post


Link to post
Share on other sites
30 minutes ago, rubahgeni said:

MaLd0n, can you help me to create DSDT?

 

Hardware Specification

Motherboard ASUS Z170i STRIX

Processor Intel core i5 6600K 4,6Ghz

16 GB

AMD RADEON RX560

 

This is DSDT and compile with runme.app

https://www61.zippyshare.com/v/cih2UHkl/file.html
 

Share this post


Link to post
Share on other sites

Hello MaLd0n:

The following is my Hackintosh platform:

CPU:i7 8400

MB:Galaxy B360M-M.2

RAM:G.skill DDR4 2133 8G

Audio:Alc 662-VD

 

Trouble for me to make DSDT, thanks
The ALC662-VD does not work. Injecting 5,7,11,12,13 does not work. How can I get him to work? AppleALC does not support ALC662-VD?

 

Attach Files is run me app to Files

 

https://drive.google.com/open?id=1Sh0DKBTEVj25Dw0QCZxCYApANgmw5Vxf

Share this post


Link to post
Share on other sites
5 hours ago, visin said:

Hello MaLd0n:

The following is my Hackintosh platform:

CPU:i7 8400

MB:Galaxy B360M-M.2

RAM:G.skill DDR4 2133 8G

Audio:Alc 662-VD

 

Trouble for me to make DSDT, thanks
The ALC662-VD does not work. Injecting 5,7,11,12,13 does not work. How can I get him to work? AppleALC does not support ALC662-VD?

 

Attach Files is run me app to Files

 

https://drive.google.com/open?id=1Sh0DKBTEVj25Dw0QCZxCYApANgmw5Vxf

send me new files after reboot

CLOVER.zip

u can try...

MaLd0n 2018-04-29 às 10.39.11.png

Share this post


Link to post
Share on other sites
5 minutes ago, rubahgeni said:

MaLd0n, i use this clover sleep can work perfect but when shutdown my hackintosh always restart.

I try use FixShutdown, SlpSMiAtWake but this issue can't solved.

 

What is solution for shutdown issue?

DSDT.aml.zip

Share this post


Link to post
Share on other sites
Posted (edited)

 

23 hours ago, MaLd0n said:

send me new files after reboot

CLOVER.zip

u can try...

MaLd0n 2018-04-29 às 10.39.11.png

I used the clover you provided and found the following questions:

1. Look at DSDT. There is a mistake.

1717479639_2018-04-294_18_12.png.00c7841b72135d3e3fe51b8c0c38976d.png

2, PCI devices are only EMI Controller and UHD 630.

830462746_2018-04-294_18_28.png.3e71fb2900450de2b0628acd6c2f39ef.png

3, There are problems to turn off and restart.

(1) no power is cut off, the machine is still running, but there is no image on the monitor.

(2) the restart state is the same as the shutdown, and the monitor has no image.

4, Audio still do not work, I injected 5, 7, 11, 12, 13, no effect, I checked the information, some solution is in the DSDT Patch, I put it below, you see if there is any use.

(1)HDEF_Patch

#Automatically adjusted by AppleHDA Patcher.app
# original by RehabMan


#   Inject Audio info
into method label _DSM parent_label HDEF remove_entry;
into device label HDEF insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
    If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n
    Return (Package()\n
    {\n
        "AAPL,slot-name", Buffer() { "Built in" },\n
        "layout-id", Buffer() { 0x05, 0x00, 0x00, 0x00 },\n
        "device_type", Buffer() { "Audio Controller" },\n
        "built-in", Buffer() { 0x00 },\n
        "PinConfigurations", Buffer() { },\n
        "hda-gfx", Buffer() { "onboard-1" }\n
    })\n
}\n
end

(2)IRQ_Fix

{\rtf1\ansi\ansicpg936\cocoartf1561\cocoasubrtf200
{\fonttbl\f0\fswiss\fcharset0 Helvetica;}
{\colortbl;\red255\green255\blue255;}
{\*\expandedcolortbl;;}
\paperw11900\paperh16840\margl1440\margr1440\vieww10800\viewh8400\viewkind0
\pard\tx566\tx1133\tx1700\tx2267\tx2834\tx3401\tx3968\tx4535\tx5102\tx5669\tx6236\tx6803\pardirnatural\partightenfactor0

\f0\fs24 \cf0 #Maintained by: RehabMan for: Laptop Patches\
#system_IRQ.txt\
\
# This can fix non-working audio and also has an affect on HPET.\
#\
# Use this if you have issues with patched AppleHDA (required on almost all laptops)\
# or if you have issues with HPET (restart after wake).\
\
# IRQ fix\
into device name_hid PNP0000 code_regex IRQNoFlags\\s\\(\\)\\n\\s+\\\{(\\d+)\\\} remove_matched;\
into device name_hid PNP0100 code_regex IRQNoFlags\\s\\(\\)\\n\\s+\\\{(\\d+)\\\} remove_matched;\
into device name_hid PNP0B00 code_regex IRQNoFlags\\s\\(\\)\\n\\s+\\\{(\\d+)\\\} remove_matched;\
into device name_hid PNP0103 code_regex IRQNoFlags\\s\\(\\)\\n\\s+\\\{.*\\\} removeall_matched;\
into device name_hid PNP0103 code_regex Name\\s\\(([^,]+),\\sResourceTemplate\\s\\(\\).*\\n\\s+\\\{((?:.|\\n)*)\\\}\\) replace_matched\
begin\
Name (%1, ResourceTemplate()\\n\
\{\\n\
    IRQNoFlags() \{ 0, 8, 11, 15 \}\\n\
%2\
\})\\n\
end;}

I got the Codec#0 of the audio, but I didn't compile AppleALC.

codec#0


Verbs from Linux Codec Dump File: codec#0

Codec: Realtek ALC662 rev3   Address: 0   DevID: 283903586 (0x10ec0662)

   Jack   Color  Description                  Node     PinDefault             Original Verbs
--------------------------------------------------------------------------------------------------------
    1/8   Black  Speaker at Ext Rear         18 0x12   0x411111f0   01271cf0 01271d11 01271e11 01271f41
    1/8   Green  Line Out at Ext Rear        20 0x14   0x01014010   01471c10 01471d40 01471e01 01471f01
 Analog UNKNOWN  Speaker at Ext N/A          21 0x15   0x4017c040   01571c40 01571dc0 01571e17 01571f40
    1/8   Black  Speaker at Ext Rear         22 0x16   0x411111f0   01671cf0 01671d11 01671e11 01671f41
 Mic at Ext Rear    0x18 0x18                        27365408 01871c20 01871d90     01871ea1 01871f01  
 Mic at Ext Front    0x19 0x19                        44142625 01971c21 01971d90     01971ea1 01971f02  
 Line In at Ext Rear    0x1a 0x1a                        25243695 01a71c2f 01a71d30     01a71e81 01a71f01  
 HP Out at Ext Front    0x1b 0x1b                        35733535 01b71c1f 01b71d40     01b71e21 01b71f02  
    1/8   Black  Speaker at Ext Rear         28 0x1c   0x411111f0   01c71cf0 01c71d11 01c71e11 01c71f41
Optical UNKNOWN  Mic at Ext N/A              29 0x1d   0x40a5c641   01d71c41 01d71dc6 01d71ea5 01d71f40
    1/8   Black  Speaker at Ext Rear         30 0x1e   0x411111f0   01e71cf0 01e71d11 01e71e11 01e71f41
--------------------------------------------------------------------------------------------------------


   Jack   Color  Description                  Node     PinDefault             Modified Verbs
--------------------------------------------------------------------------------------------------------
    1/8   Green  Line Out at Ext Rear        20 0x14   0x01014010   01471c10 01471d40 01471e01 01471f01
 Analog UNKNOWN  Speaker at Ext N/A          21 0x15   0x4017c040   01571c40 01571dc0 01571e17 01571f40
 Mic at Ext Rear    0x18 0x18                        27365408 01871c20 01871d90     01871ea1 01871f01  
 Mic at Ext Front    0x19 0x19                        44142625 01971c30 01971d90     01971ea1 01971f01  
 Line In at Ext Rear    0x1a 0x1a                        25243695 01a71c50 01a71d30     01a71e81 01a71f01  
 HP Out at Ext Front    0x1b 0x1b                        35733535 01b71c60 01b71d40     01b71e21 01b71f01  
Optical UNKNOWN  Mic at Ext N/A              29 0x1d   0x40a5c641   01d71c70 01d71dc0 01d71ea5 01d71f40
--------------------------------------------------------------------------------------------------------

I re run send_Me

https://drive.google.com/open?id=16LHBuWvxh-HYT3gT1HqxRtw-WnqoTsaH

 

 

Edited by visin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Luan Eduardo
      Installing macOS Mojave 10.14 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      10/17/2018 08:12h GMT-0
      - Fix Kexts permissions commands adjusted.
      - Removed FrameBuffer patch that is not needed.
      - Added audio solution and HDMI.
      - Unfortunately DisplayPort does not work.
      - Replaced Wifi/BT with DW1560 (BCM94352Z)
       
      10/11/2018 04:15h GMT-0
      - Added USB 3.0 patch.
      - Adjusted some steps.
      - Changed text formatting.
       
      10/11/2018 03:42h GMT-0
      - Added missing UEFI configuration.
       
      10/07/2018 00:36h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor ->  Work. All SpeedStep stages.
      - Video Card ->  Work. QE/CI and Metal.
      - Chipset ->  Work.
      - HDMI (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Not work.
      - Audio ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Work. Replaced.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Not work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
       
       
      Todo
       
      - Make audio work.
      - Make HDMI audio work.
      - Test DisplayPort.
      - Make second ethernet work.
      - Replace Wifi/Bluetooth.
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ .app/Contents/Resources/createinstallmedia --volume /Volumes/Install--nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the CloverEFI (used 4674) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - ApfsDriverLoader-64
      - UEFI Drivers - AptioMemoryFix64


       
       
      Make things works

      Will be created a partition named EFI and mounted in Desktop. Edit the /Volumes/EFI/CLOVER/config.plist inside this new partition, open with Clover Configurator (used 5.2.1.0)
       
      Full UHD630 Acceleration
       
      config.plist (Clover Configurator): 
       
      - Uncheck: Acpi - Fixes - FixDisplay
      - Uncheck: Acpi - Fixes - AddHDMI
       
      - Change value: Gui - Screen Resolution to 3840x2160 (Your screen resolution, mine is 4k)
      - Change value: Rt Variables - CsrActiveConfig to 0x3
      - Select value: SMBIOS - Up/Down arrows - iMac18,1 - Intel Core i5-7360U @ 2.30Ghz (I know, it's not our processor, but is that option)
       
       
      Download those Kexts and put in /EFI/CLOVER/kexts/10.14/
       
      - Download the Lilu.kext from here. I used the version 1.2.7.
      - Download the WhateverGreen.kext. I used the version 1.2.3.RELEASE.
       
       
      All USBs (2.0, 3.0, Type-C, internal)
       
      config.plist (Clover Configurator): 
       
      - Add value: Kernel and Kext Patches - KextsToPatch:
                       Name*: com.apple.driver.usb.AppleUSBXHCI
                       Find* [HEX]: 83FB0F0F 83030500 00
                       Replace* [HEX]: 83FB0F90 90909090 90
                       Comment: disable port limit in XHCI kext (credit PMHeart)
                       MathOS: 10.14.x

       
       
      Sleep/Wake
       
      config.plist (Clover Configurator): 
       
      - Check: Boot - Arguments - dart=0
       
       
      Audio onboard and HDMI
       
      config.plist (Clover Configurator): 
       
      - Change: Device - Audio Injection - layout-id to 7
       
      Download those Kexts and put in /EFI/CLOVER/kexts/10.14/
       
      - Download the Lilu.kext from here. I used the version 1.2.7. (already installed above)
      - Download the AppleALC.kext from here. I used the version 1.3.2.
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Download those Kexts and put in /EFI/CLOVER/kexts/10.14/
       
      - Download the FakePCIID.kext and FakePCIID_Broadcom_WiFi.kext from here. I used the version 2018-1014.
      - Download the BrcmFirmwareRepo.kext, BrcmPatchRAM.kext and BrcmNonPatchRAM.kext from here. I used the version 2018-0505.
       
       
      Mandatory Kexts
       
      Download those Kexts and put in /EFI/CLOVER/kexts/10.14/
       
      - Download the FakeSMC.kext from here. I used the version 2018-0915.
      - Download the IntelMausiEthernet.kext from here. I used the version 2018-0424.
       
       
      Put the Clover installer on the flash drive too.
       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: Periphelrals - Initial Display to IGP
      - Change value: Periphelrals - USB Configuration - XHCI Hand-off to ENABLE
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Change value: Chipset - DVMT Pre-Allocated to 128M
      - Change value: Chipset - Wake On Lan to DISABLE
      - Save & Exit Setup
       
      - Now, hold the F12
      - In the list, select your flash drive.
      - It will show twice. One with UEFI prefix and another without.
      - Select with UEFI prefix. Ie.: "UEFI: Sandisk Cruzer"
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "HD".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the config.plist inside your destination disk EFI parittion with config.plist inside flash card EFI partition.

      The flash drive EFI partition is unmounted. Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 1.
       
      Last step
       
      Copy all Kexts from flash drive to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/10.14/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -system-prelinked-kernel sudo kextcache -system-caches Restart the system.
       
       
      It's done!

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
       
    • By am_yvr
      Asus Prime B360M-A or Asus Prime H310M-E :

      Which of these two motherboards would give less hassle in a Hackintosh build - requiring fewer after install fixes/updates to get everything working in Mojave or High Sierra?
       
      These are the only two Asus models that I can afford, fit the form factor in my build, and already have had a BIOS upgrade by Asus to 9th-generation - if I want to replace the CPU with an i9 in the future (for now I'll be using i7-8700 or even i3-8350k but I want to future proof a bit)
       
      Thanks guys!
    • By thomazella
      Hi guys. Just wanted to say this is my new favorite forum for mac hacks

      I'm trying to get mojave to work, and using the guide's (moderator made, on the front page) clover folder I ALMOST got it! T.T

      There's something still wrong tho. lol.

      - Install to a HDD formated as case-sensitive APFS goes black at 2 minutes remaining. Is it supposed to fill the progress bar 100%? If so then I have a problem.
      - Assuming the install went well, I tried to boot to "MacOS Prebooter" from clover screen and got that error.

      I have a Z170m ASUS, awesome board. I'm sure it can be done. With Intel 6700k.
      Latest clover. Guide's clover config!!

      What do you guys think?
      - mobo config problem
      - other hardware thing (I have many harddrives connected?)
      - clover config
      - need some driver/kext
      - something else

      THANK YOU!

      PS: I've tried upgrading with the App store download on a Sierra system to arrive in the same screen, with the same error.
      I'll also spend some time today searching the forums. Just busy atm, and thanks for any help or tips!!

×