Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

4,842 posts in this topic

Recommended Posts

Advertisement
11 hours ago, MaLd0n said:

is a very strange, i don't have idea

BTW, what did you do to fix the Shut Down issue?

Edited by zzmadd

Share this post


Link to post
Share on other sites
7 hours ago, ryanonit said:

Hi MaLd0N.

I am a very noob on Hackintosh so I tried to follow a build for people's recommendation.

My spec is

Gigabyte Z370 Aorus Gaming 7

8700K

Samsung NVME 960 Pro 512GB

Crucial DDR4 2133 8GB x 2

ASUS AC68 Wifi

Corsair HX850 Powersupply

Cooler Master LiquidMaster 280 Pro

3TB WD & Seagate Sata HDD

Samsung 840 Pro 250GB

 

BIOS SETTINGS

Fast Boot : Disabled

PAN PXE Boot Option ROM : Disabled

Storage Boot Option Control : UEFI

Trusted Computing -> Security Device Support : Disabled

Network Stack : Disabled

Legacy USB Support : Auto

XHCI Hand-off : Enabled

Wake on LAN : Disabled

Vt-d : Disabled (Enable it?)

IOAPIC 24-119 : Enabled

Integrated Graphics : Enabled ( Disable it?)

 

 

I just copied and pasted someone's EFI folder and somehow it works

but it is a bit laggy

RAM is 16GB but show as 32GB

Also can I delete 'Install from HACKINTOSH(My HDD name)' option from booting?

I tried to attach but file is bigger than 10MB so I created a link to download.

https://www.dropbox.com/s/17jh1v39o1h6lfu/EFI.zip?dl=0

Would you please have a look?

 

Thank you.

u need post a ful dump, check first post

Share this post


Link to post
Share on other sites

 

Wow, thanks for all you do Maldon!

GA-Z170ZP-SLI, i5-6700k, Asus RX460 4gb working perfectly 10.13.4 thanks to this wonderful guide! Only issue is USB 3.0 is not working, only USB 2.0. Wondering if you can help? I have attached my clover and RunMe results.

Thanks Maldon!!!!!!

Clover
https://drive.google.com/file/d/11o3VUUV7_iZTVNjRf-lqHOzK_XBYHSHu/view?usp=sharing

RunMe Results
https://drive.google.com/file/d/11AYox5CIqLfbI9l9Zl7dM0bcq-tc6O7B/view?usp=sharing

 

Edited by bocajoe

Share this post


Link to post
Share on other sites
14 minutes ago, bocajoe said:

 

Wow, thanks for all you do Maldon!

GA-Z170ZP-SLI, i5-6700k, Asus RX460 4gb working perfectly 10.13.4 thanks to this wonderful guide! Only issue is USB 3.0 is not working, only USB 2.0. Wondering if you can help? I have attached my clover and RunMe results.

Thanks Maldon!!!!!!

Clover
https://drive.google.com/file/d/11o3VUUV7_iZTVNjRf-lqHOzK_XBYHSHu/view?usp=sharing

RunMe Results
https://drive.google.com/file/d/11AYox5CIqLfbI9l9Zl7dM0bcq-tc6O7B/view?usp=sharing

 

need a new patch

com.apple.driver.usb.AppleUSBXHCI

837D940F 0F839704 0000

837D940F 90909090 9090

USB 10.13.4+ by PMHeart

10.13.x

Share this post


Link to post
Share on other sites
3 hours ago, MaLd0n said:

need a new patch

 

837D940F 0F839704 0000

837D940F 90909090 9090

USB 10.13.4+ by PMHeart

10.13.x

Thank you Maldon.

Not sure if I did it right... but I opened my config.plist in clover configurator and copied and pasted 

837D940F 0F839704 0000

837D940F 90909090 9090

USB 10.13.4+ by PMHeart

10.13.x

in com.apple.driver.usb.AppleUSBXHCI (see pic below). I also checked and unchecked infoPlistPatch but still no USB 3.0. Any ideas? I attached my config.plist if it helps.

Specs: GA-Z170XP-SLI, i5-7600k, Asus RX460 4GB, 17,1 SMBIOS

Screen Shot 2018-03-30 at 7.52.45 PM.png

config.plist.zip

Edited by bocajoe

Share this post


Link to post
Share on other sites
19 hours ago, MaLd0n said:

u need post a ful dump, check first post

How do I get full dump?

Please let me know how I get it.

Edited by ryanonit

Share this post


Link to post
Share on other sites
18 minutes ago, ryanonit said:

How do I get full dump?

Shutdown your PC, turn on and press F4 key when you watched the Clover bootloader screen. Then mount the EFI partition and go to /EFI/EFI/CLOVER/ACPI/origin/ put this folder on a .zip file and post it here.

Share this post


Link to post
Share on other sites

Hackintosh Specs:

GA-Z270X Ultra Gaming MB

i7-7700K @ 4.8Ghz

32 GB Crucial Ballistix DDR4 Ram

Gigabyte Aorus GTX 1080Ti 11 GB

1 TB Samsung 960 EVO NVME Drive - MacOS 

1 TB Samsung 850 EVO SSD- Storage

3 TB WD Black- Time Machine Backups

Broadcom Wifi/BT Card BCM94360CD

EVGA Supernova G3 850 W PSU

Corsair H100i v2 Water Cooler

MaLd0n  I wanted to know if a DSDT could be created for my system board mainly for additional stability. 

SendMe results

https://www.dropbox.com/s/5m5srk2k5mz8hg4/Send me Seans-Hack-Pro.zip?dl=0

Config plist attached as well

Thank you in advance.

config.plist

Edited by rob88v

Share this post


Link to post
Share on other sites
16 hours ago, bocajoe said:

Thank you Maldon.

Not sure if I did it right... but I opened my config.plist in clover configurator and copied and pasted 

837D940F 0F839704 0000

837D940F 90909090 9090

USB 10.13.4+ by PMHeart

10.13.x

in com.apple.driver.usb.AppleUSBXHCI (see pic below). I also checked and unchecked infoPlistPatch but still no USB 3.0. Any ideas? I attached my config.plist if it helps.

Specs: GA-Z170XP-SLI, i5-7600k, Asus RX460 4GB, 17,1 SMBIOS

Screen Shot 2018-03-30 at 7.52.45 PM.png

config.plist.zip

extract original tables with F4 key in clover boot screen and run my app after it, send me files

Share this post


Link to post
Share on other sites
3 hours ago, rob88v said:

Hackintosh Specs:

GA-Z270X Ultra Gaming MB

i7-7700K @ 4.8Ghz

32 GB Crucial Ballistix DDR4 Ram

Gigabyte Aorus GTX 1080Ti 11 GB

1 TB Samsung 960 EVO NVME Drive - MacOS 

1 TB Samsung 850 EVO SSD- Storage

3 TB WD Black- Time Machine Backups

Broadcom Wifi/BT Card BCM94360CD

EVGA Supernova G3 850 W PSU

Corsair H100i v2 Water Cooler

MaLd0n  I wanted to know if a DSDT could be created for my system board mainly for additional stability. 

SendMe results

https://www.dropbox.com/s/5m5srk2k5mz8hg4/Send me Seans-Hack-Pro.zip?dl=0

Config plist attached as well

Thank you in advance.

config.plist

CLOVER.zip

Share this post


Link to post
Share on other sites

MaLd0n Hello! I added his BCM943602CS Broadcom Wireless WiFi Card do I need to change something in the DSDT?   For some reason, was off a very long and appeared hanging system! And I can not raise HD630, IQSV  does not work do not know what it can be the result of something messed up can be ! :wallbash:Can I ask you to look at my files? Sorry for my bad english!!:blush::(

Share this post


Link to post
Share on other sites
11 hours ago, MaLd0n said:

extract original tables with F4 key in clover boot screen and run my app after it, send me files

Hello Maldon! And thanks for taking the time to help. Below is my results of RunMeApp for my problem with USB 3.0 not working in 10.13.4.

https://drive.google.com/file/d/15rjjUGOtbzLO0Bz6x2NSagNCcAfTj2O3/view?usp=sharing

Specs: GA-Z170ZP-SLI, i5-6700k, Asus RX460 4gb

Edited by bocajoe

Share this post


Link to post
Share on other sites
44 minutes ago, bocajoe said:

Hello Maldon! And thanks for taking the time to help. Below is my results of RunMeApp for my problem with USB 3.0 not working in 10.13.4.

https://drive.google.com/file/d/15rjjUGOtbzLO0Bz6x2NSagNCcAfTj2O3/view?usp=sharing

Specs: GA-Z170ZP-SLI, i5-6700k, Asus RX460 4gb

take a shot

DSDT.aml.zip

use usb patch limit port for 10.13.4

Share this post


Link to post
Share on other sites
6 hours ago, p4antonio said:

Hello MaLd0n

can you check if the EFI is well created?

thank you.

PC configuration: Pentium 4560 / GA-B250M-DS3H  / Ram 2x8Gb DRR4 2400Mhz / Asus gtx 660 ti 2gb.

installed:OS X 10.12.6 (16G29).

I am attaching you to RunMe.

https://drive.google.com/open?id=1avdABvxnG6rqymjeM5uHs3e6bCW93l71

http://www17.zippyshare.com/v/85WBmV4t/file.html
 

10 hours ago, alex9440 said:

MaLd0n Hello! I added his BCM943602CS Broadcom Wireless WiFi Card do I need to change something in the DSDT?   For some reason, was off a very long and appeared hanging system! And I can not raise HD630, IQSV  does not work do not know what it can be the result of something messed up can be ! :wallbash:Can I ask you to look at my files? Sorry for my bad english!!:blush::(

just plug

Share this post


Link to post
Share on other sites
10 hours ago, MaLd0n said:

take a shot

DSDT.aml.zip

use usb patch limit port for 10.13.4

Thank you Maldon. I tried your DSDT and USB 3 NOW WORKS!!!!!!!!!!!

The only other issue I am having is when the computer goes to sleep it will not wake by pressing a key on the keyboard or moving the mouse... but pressing the power button on the computer will wake the machine. I hope you can help.

I would like to PayPal you something for ALL the help you have given me and others, it is greatly appreciated!

I have attached my RunMe results and my EFI folder.

SPECS: GA-Z170XP-SLI, i5-6700k, Asus RX60 4GB Video Card, SMBIOS 17,1

EFI Folder: https://drive.google.com/file/d/1MtP8oNsFTT3PjKk93So3Fz_IMehacHIx/view?usp=sharing

Run Me Results: https://drive.google.com/file/d/1y2-qxmmb2Biz4RxbCVqigh4MtZkXtYGf/view?usp=sharing

Share this post


Link to post
Share on other sites
12 minutes ago, bocajoe said:

Thank you Maldon. I tried your DSDT and USB 3 NOW WORKS!!!!!!!!!!!

The only other issue I am having is when the computer goes to sleep it will not wake by pressing a key on the keyboard or moving the mouse... but pressing the power button on the computer will wake the machine. I hope you can help.

I would like to PayPal you something for ALL the help you have given me and others, it is greatly appreciated!

I have attached my RunMe results and my EFI folder.

SPECS: GA-Z170XP-SLI, i5-6700k, Asus RX60 4GB Video Card, SMBIOS 17,1

EFI Folder: https://drive.google.com/file/d/1MtP8oNsFTT3PjKk93So3Fz_IMehacHIx/view?usp=sharing

Run Me Results: https://drive.google.com/file/d/1y2-qxmmb2Biz4RxbCVqigh4MtZkXtYGf/view?usp=sharing

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Hi MaLd0n, good news, since updating to 10.13.4 no more freezing, I changed my SMBIOS to 18,2. Since updating though, I notice today I have USB port problem. I tried implementing fix, but it does not recognize an external Pioneer BDL drive that my MBP sees or an external drive, this is plugging into USB ports at the front of the tower, rear do not work either. Here is a link to my clover folder.

https://www.dropbox.com/s/hpqefs6kwhv5oap/CLOVER.zip?dl=0

Thank you!

Share this post


Link to post
Share on other sites
4 minutes ago, ashman1970 said:

Hi MaLd0n, good news, since updating to 10.13.4 no more freezing, I changed my SMBIOS to 18,2. Since updating though, I notice today I have USB port problem. I tried implementing fix, but it does not recognize an external Pioneer BDL drive that my MBP sees or an external drive, this is plugging into USB ports at the front of the tower, rear do not work either. Here is a link to my clover folder.

https://www.dropbox.com/s/hpqefs6kwhv5oap/CLOVER.zip?dl=0

Thank you!

Arquivo Comprimido.zip

Share this post


Link to post
Share on other sites
5 hours ago, MaLd0n said:

Thank you Maldon. USB 3 still working great. As far as sleep goes with that DSDT when the computer goes to sleep it immediately powers itself back on. I researched it and I think its because of my Corsair H100i Liquid Cooler has a data cable that is causing it to wake it back up. I've read where you can disable the H100i port in a SSDT-UIAC but that is well beyond what I can do.

Ran a couple of test that show possible sleep issues:

  • pmset -g log: Idle sleep preventers: IODisplayWrangler
  • pmset -g assertions: IODisplayWrangler
  • log show --style syslog | fgrep "Wake reason”: XHC

I have my EFI and RunMe results below if that helps:

Specs: GA-Z170XP, i5-6700k, Asus RX460 4GB

EFI: https://drive.google.com/drive/folders/1YADUNBWtk37uSCclE17-ElV9HnEQmmMv?usp=sharing

RunMe Results: https://drive.google.com/file/d/1f5knq3Spenq5RfDzQQmDhyuDkMCqaTtW/view?usp=sharing

Edited by bocajoe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By karthiksh1989
      can somebody walkthrough with the mojave installation guide?
      i have a mac high sierra 13.6 version on my macbook pro and want to install mojave on my desktop
      Exact config is Gigabyte gaming wifi 7 motherboard amy ryzen 7 2nd gen 2700X processor Gigabyte G1 8GB grapgic card VEGA 64
      running 2 nvme Samsung 256gb cards and 1 intel 180gb ssd internal and 1tb WD HDD, with 64 GB 3200Mhz Ram
       
      https://wa.me/919611736534 (whatsapp)
    • By ltooz_audis
      I always want to have a long lasting battery ultrabook to install Mojave on. I was looking at Dell XPS 13 but its design is not very good with the camera and other problems. HP Spectre x360 is a nice design but the wifi module is soldered on board. The Envy 13" is the best one in the bunch for MacOS Mojave. I would not use any other macOS besides Mojave, it's the best one so far. If you can't get it done with macOS Mojave, you don't do it correctly, it's much more refined and given than older macOS's.
      I wanted the 8th generation because of the 4 cores which is almost 1.5 times faster than this 7th generation i7-7500u, but the price is too high. I picked up this one on Craigslist for $400. I've just ordered the 500GB NVME WD Black for $104 and DW1560 for $29. So, the perfect MacBook Pro 14,2 is less than $600 that last 5-6 hours with Mojave and 8-9 hours on Windows 10. The bench mark is the same as the real MacBookPro 14,2. BTW, this is the first try, there will be on going testing and confirming. 250GB hard drive is hardly enough for dual boot Windows and Mac. You need at least 500GB, I don't use Windows at all, so I'll partition 200GB for Windows and 300GB for Mojave.
      All new HP laptops will have kernel panic if using Clover to boot UEFI, at least a fix was found. I'll have more videos and info when I have time to write them. Watch the videos and ask questions if you have any problems.
      1. Clover 4558 - Lilu.kext (1.3.3) - AppleALC.kext (1.3.1) - Whatevergreen.kext (1.2.3) - USBInjectAll.kext (0.6.5) - Fakesmc.kext (6.25-332-gf3a8525c.1758) - ACPIBatteryManager.kext (1.81.4) - AHCIPortInjector.kext - BrcmFirmwareRepo.kext (2.2.7) - BrcmPatchRAM2.kext (2.2.7) - CodecCommander.kext (2.6.2) - FakePCIID_Broadcom_WiFi.kext (1.3.9) - FakePCIID_Intel_HD_Graphics.kext (1.3.9) - FakePCIID.kext (1.3.9) - SSDT-AUIC-ALL.aml - SSDT-USBX.aml - SSDT-PNLF.aml - SSDT-PluginType1.aml - PreLoader.efi.
      2. For the keys F2 & F3 to work with backlight slider - the Fakesmc.kext version is important for some reasons, I'm still trying to find out why.
      The touchscreen actually works without the voodooI2C kexts, just need to patch the clover.
       
      I've been playing with the laptop for over a week now. Ordered the WD 500GB WDS500G2X0C from Amazon for $104, the 256GB is too small for dual booting Windows 10 & Mojave. It's really plug and play.
       
      Hardware - needed to make this a perfect macbook Pro14,2.
      1. DW1560 BCM94352Z - make sure it has 2 notches - Tape the 2 right pins on the 4 pins tab for it to work without a hitch on both Windows 10 and Mojave. You can buy from Ebay cheaper but you have to wait for months.
      2. 500GB NVMe SSD m.2 connector M is a must for dual boot - the cheaper one will be slower - Crucial NVMe 500GB is $25 less than WD.
      3. NOVOO USB-C to HDMI hub that works and inexpensive.
       
      Let's start to get this Kaby Lake working on the HP - I believe HP has the same components for similar configuration on different models. In order to get Mojave to work on Intel Laptop, we need a few important components - Sound is important (look for Realtek - ALC295) - Ethernet if any -Realtek - Trackpad  and TouchScreen (Synaptics or Elan).
       
      REPLACE VNMe SSD HARD DRIVE and DW1560 BCM94352Z
       
      The current BIOS is F22, the newest one is F27 but I don't want to update since it's working well. Since I don't really need the original Windows 10 with Junk software in it, I install the latest Windows 10 using Media Creation USB Boot Drive. The important thing is we have to prepare the SSD correctly or our EFI folder will only be set at 100MB which is not enough to install Clover or any other boot loaders. So instead of letting the Windows installer to create the EFI folder automatically, we can set the size ourselves using "diskpart" command. In order to use diskpart, we need to boot with Windows 10 USB installer (hit F9 then select UEFI USB installer) - select system repair and not installation - then select command prompt, from here we can create EFI folder and MSR for Windows installer to install. The product ID is already in the UEFI bios, so we don't really have to manually activate the Windows 10.

       
       
      diskpart
      select disk 0
      clean
      convert gpt
      create partition efi=300 !!! you can change it from 300MB to any size.
      format quick fs=fat32 label="EFI"
      create partition msr size=16
      exit

      After exit, reboot with the USB installer again in UEFI mode, select the custom. The Windows installer will select the 300MB EFI folder we've just created.
       
       
      How to fix KP on Clover UEFI Boot.
       
       
      This is the macBook Pro 14,2 from HP 13-ad010nr
       
       
       
      Louis
       
    • By yehia2amer
      Problem:
      When I Attempt to wake my Machine from sleep, the screen stays black, although the computer is obviously awake !
      This Machine has a 1300W Power Supply So Sleep is Very Useful.
       
      I Tried:
      1) FIX_WAK and FixShutdown as per Clover Wiki.
      2) Although I am using "SAPPHIRE Radeon PULSE RX 580 8GB GDDR5", which Should be completely Supported by Mojave, I Also changed the Part Number to "113-4E353BU-O4E" as per this Guide: http://www.xlr8yourmac.com/archives/feb18/RadeonRX-580_MacPro.html. The GPU is working GREAT without even Clover Inject
      3) Tried to Run this command: disablehibernate.command.zip
      4) Tried darkwake=0 to 10
      5) Disabled wake on USB & Wake on LAN (BIOS)
       
      Logs:
      sudo pmset -g
      System-wide power settings: Currently in use: hibernatemode 0 disksleep 10 womp 0 networkoversleep 0 sleep 0 Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage autorestart 0 gpuswitch 2 displaysleep 10 pmset -g assertions
      2019-02-19 18:51:04 +0200 Assertion status system-wide: BackgroundTask 1 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 1 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 56(powerd): [0x0000001700088000] 00:13:44 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" pid 100(hidd): [0x00000025000980a7] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968578.17" Timeout will fire in 600 secs Action=TimeoutActionRelease pid 200(mds_stores): [0x0000034e000b8279] 00:00:00 BackgroundTask named: "com.apple.metadata.mds_stores.power" Kernel Assertions: 0x4=USB id=502 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d130000 owner=USB Keyboard id=503 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d120000 owner=Lenovo Optical Mouse Idle sleep preventers: IODisplayWrangler  
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors
      RAM: 128 GB 1333 MHz DDR3 ECC Memory
      GPU: SAPPHIRE Radeon PULSE RX 580 8GB GDDR5
      Chipset: Intel C602
      Audio: Realtek ALC3220 (ALC280) High Definition Audio
      SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  
      Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210 
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      for more info:
       
      Any Help will be appreciated, Thanks !
       
      Send me Yehias-Mac-Pro.zip
    • By yehia2amer
      Dell Precision T7610 Workstation
      Hackintosh GUIDE (Work in Progress)
       
                        
      Introduction: 
      Hi Everyone,
      This Workstation used to be a Beast with Dual CPUs and tons of RAM, I Know it is now normal to get that much cores in a Desktop but it is still a very decent machine for me (As a Programmer), and I thought it would be a good idea to Install MacOS as the Daily Driver Rather than Linux and It turns out to be a very Great Experience (with Some Challenges ).
       
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors RAM: 128 GB 1333 MHz DDR3 ECC Memory GPU: SAPPHIRE PULSE Radeon RX 580 8GD5 Chipset: Intel C602 Audio: Realtek ALC3220 (ALC280) High Definition Audio SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      Working:
      Both "Xeon E5-2680 v2" and all cores with Power Management and P-States (using VoodooTSCSync & ssdtPRGen.sh) ATI Radeon HD 4870 (Vanilla) Realtek ALC3220 (ALC280)  (using VoodooHDA till Now - it is partially working with AppleALC using layout-id 13) LSI 2308 SAS (using AstekFusion2) Intel 82579 Network Controller (Vanilla) Intel I210 Network Controller (IntelMausiEthernet) USB 2.0  
      Not Working:
      NEC USB3.0 xHCI Controller (Renesas Electronics uPD720201 & uPD720202) Sleep  
      https://github.com/yehia2amer/Dell-Precision-T7610-Workstation-Hackintosh-Guide
    • By wen1
      Work in progress
       
      This is mini guide and config files for installing Mojave on a Dell XPS 13 9370.
       
      I took inspiration from sensibleJoe at on reddit
       
      My laptop's specs
       
      i7-8550U Intel HD 620 Graphics UHD Display 256GB Samsung NVMe SSD PM961 Killer 1435 Wifi  
      Here is what works
       
      Intel HD Graphics  Sleep Sound & Mic USB Wifi (Internal Killer Wifi will not work) Bluetooth Power Management Battery Management Screen Brightness Control  
      What does not work
       
      Internal Wifi Camera SD Card reader  
       
       
      I followed the vanilla guide here to create the Mac OS Mojave install USB. I used Mac OS 10.14.3.
       
      Here are some rough steps
       
      1. Create the USB installer for Mojave. You can use apple's own instructions
      2. Once the installer USB creation is complete, Install the latest version of clover to the USB disk with the following options 
      Install Clover for UEFI booting only
      Install Clover to the ESP
       
      Leave everything else as default (minimal install without a bunch of drivers)
       
      3. Then mount the EFI folder on the USB drive and replace the files in the config folder with the ones from the attached zip file over writing the files already there. This config is specifically for Dell XPS 13 9370.
      4. Go into the UEFI/BIOS on the laptop, Make sure your SATA mode is set to AHCI (And not Raid). Save and Exit
      5. Boot with the USB disk and install Mojave
      6. After the install is complete, Use the USB to boot again but this time boot into the newly installed Mojave partition.
      7. Install Clover on to the SSD with the same options as before.
      8. Then copy the config files to the EFI folder on the SSD overwriting the config folder there.
      9. Acquire the backlight AppleBacklightFixup.kext from here and install to /Library/Extensions (Thanks to Rehabman for the kext)
      10. Reboot.
       
      EDIT: V4 fixes many things, like powermanagement, backlight control etc. you also need to install AppleBacklightFixup.kext to /Library/Extensions
       
       
      CLOVER-v4.zip
×