Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave / Catalina on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

5,240 posts in this topic

Recommended Posts

Advertisement

Check

 

Use a fresh install with ur nvidia GPU, use nv_disable=1

 

after install system, install Clover with these options

MaLd0n 2017-04-23 às 13.49.40.png

https://sourceforge.net/projects/cloverefiboot/files/Installer/Clover_v2.4k_r4061.zip/download

 

replace folder

 

install pascal web driver 10.12.4

https://images.nvidia.com/mac/pkg/378/WebDriver-378.05.05.05f02.pkg

 

if u need use voodootscsync

Share this post


Link to post
Share on other sites

hey @mald0n back with my z270 itx ac posting the files you said you need  for the DSDT :D :D

I didn't use VoodooTSCSync with my 7700k after all as it didn't seem to be needed for my installation to go OK but changed the SMBIOS because with 17,1 after installing web drivers, on boot the screen would go black.thanks a lot for help files uploaded in one zip here http://www.mediafire.com/file/ilsal3v2b2cx0ay/Archive.zip plzif you could also patch thunderbolt to work it would be lovely! :) thanks a lot for your help 

edit: forgot to press F4 and origin folder will be empty check here http://www.mediafire.com/file/cv3mlo3hoj0d3zc/origin.zip

Share this post


Link to post
Share on other sites

@MaLd0n firstly thanks for your work! so, tried your Clover folder aaaand :( cpu related kernel panic as it seems (rebooted 2-3 times same thing )) 

then though I tried changing on the clover boot screen the DSDT name to DSDT1 (so clover won't find the dsdt) and the pc booted normally with the iMac 17,1 smbios as it seems with sound not working :/ 

should a post the new ioreg?since the DSDT seems to be the problem :/ 

thanks a lot for your help as always!!!!

EDIT:I posted the new IOREG just in case it is needed. :Dhttp://www.mediafire.com/file/cjd9xa6aur1zh0e/Jim%E2%80%99s_iMac.ioreg 

Share this post


Link to post
Share on other sites

First of all, thank so much for your work and this post.  I skimmed through the whole thread, don't see anyone else having this problem.  So I can only assume I'm making a rookie mistake.  Every time I try to install Sierra, I end up booting right back into El Capitan.

 

I have a GA-Z270MX and 7700k

 

I followed instructions precisely, I think.  Created the installer USB with the script, but I used the second version.  Installed clover on USB with UEFI options and OSXAptioFixDRV.  Then I copied your installation clover folder to my USB EFI.  Booted from USB into installer.  It ran for about 15 minutes then rebooted with no warning.  I selected boot option to boot from USB again, this time booting into Mac OS X on my system drive.  And every time I try this, I am still running El Cap.  Did I make an obvious mistake?

Share this post


Link to post
Share on other sites

Thanks for the quick reply!!!  Ok, you're right, I had a windows drive connected.  I disconnected it and also changed BIOS to boot USB so I don't have to catch it on my own.  I am doing the install again right now.  Just wanted to clarify, the steps I described is the correct procedure, then?  And my mobo and CPU are fine as long as I'm using your clover folder?  

EDIT: You were right, it was the hard drive.  I am booted back into Mac and it is now installing properly so far.  That was easy, thanks!

Share this post


Link to post
Share on other sites

mobo is Gigabyte Z270MX Gaming 5

CPU is i7-6700k

Graphics card is GTX 980Ti

 

Thanks!

U need test audio, serie 20 have many problems with audio

CLOVER.zip

 

send me new ioreg after reboot with new files

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By hungdv
      Hello guys,
      I was try to install MacOS Mojave on my new machine but no luck. Can anyone show me which guide to fit my system, please?please?please?
      + Mobo: GIGABYTE Z390 AORUS ELITE LGA1151v2
      + CPU: Intel Core i5-9600K 3.7GHz
      + iGPU: Sapphire RX 580 Pulse 8GB
      + Drives: SSD Samsung 970 Pro PCIe NVMe V-NAND M.2 2280 512GB
      + Ram: Crucial Ballistix Sport LT 2x8GB Bus 2666 DDR4
      + PSU: Corsair RM650 80 Plus GOLD
      + Case: Corsair 220T White RGB Airflow Tempered Glass
      + Cooler: Cooler Master HYPER 212 BLACK EDTION
      + Dual Band Network Card Broadcom Bcm94360 867Mbps.
    • By Rajan Pandit
      Hai, I have,
      i5 2500k
      GA-z68 AP D3 Rev.1
      Corsair 8 GM Ram
      Gigabyte Radeon RX 560 OC 4G Graphic Card
      500 GB Samsung SSD EVOf
       
      with this configuration I tried to install Mojave but After Apple Logo there was a black screen
      then nothing... please help
      I have create USB with terminal and Install Clover_v2.4k_r4961-Legacy.pkg to activate boot
      then I have recessary kext to EFI/KEXT/OTHER 
      but I am struck at Black Screen after apple logo
    • By Rajan Pandit
      Hai, I have,
      i5 2500k
      GA-z68 AP D3 Rev.1
      Corsair 8 GM Ram
      Gigabyte Radeon RX 560 OC 4G Graphic Card
      500 GB Samsung SSD EVO
      .. I want to install Mojave on this configuration...
      please help. what I need to do... 
      I have downloaded the Installer from APP Store...
      please help
    • By ScoobDoob69
      Hi, everyone so I am currently dual-booting Windows 10 and Linux Mint. I would like to add Mojave and triple boot (without formatting/losing all data from windows and linux).
       
      My Current Specs:
      CPU: Intel Core i7-2600 (not k) Sandy Bridge
      GPU: Aorus Radeon RX570 4GB
      Motherboard: Intel SWQ6710H
      HDD: 4TB Western Digital Blue WD40EZRZ
      Ram: 20GB DDR3 Total (2x 8GB + 2x 2GB)
       
      1. Is it possible to install Mojave on my HDD without wiping Windows 10 or Linux Mint?
      2. What guide is most ideal for my situation? 
       
      If you need any additional information or details, I am more than happy to provide that. I tried multiple guides months ago and could not get the installation to work. 
       
       
×