Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave / Catalina on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

5,392 posts in this topic

Recommended Posts

So I don't need a small graphic card like an NVidia GTX 710?

Other posts I read on Tony were finding difficult to make work the Integrated Graphics 630 build into the i3-8100.

A Board like the Gigabyte Z370P D3 would work no problem with 8th Gen CPUs?

Thanks a lot!

yes, work good

 

sorry for everyone, the tutorial is great :-)

I only have a problem with ssd, the speed of writing is slow...
any suggestion?
configuration 
ga h110m s2h
WDC WDS120G2G0A-00JH30   
result is the same with apfs and hfs...wite and whiteout trim...

 

send me files, i'll check

RunMe.app.zip

 

Model : WD Green
Capacity : 120 Gb
Interface : Sata 6.0 Gb / S
Reading Speed : 540 Mb / S
Writing Speed : 430 Mb / S
 
for 66 dollars what you want ?

 

:lol:  :lol:  :lol:

mobo ga-z170x-gaming 7 with i7 7700k

 

Thank you  :)

CLOVER.zip

Share this post


Link to post
Share on other sites
Advertisement

hello MaLd0n

or installed High Sierra on these components:

 

Cpu i7 6600K

Asus Maximus viii Hero

8+8 DDR4 2400Mhz

Gigabayte RX560 2Gb.

 

can you check whether or not the efi is created well and more?

thank you.

 

 

Thanks a lot of work

Share this post


Link to post
Share on other sites

try

attachicon.gifDSDT.aml.zip

 

run in terminal

log show --style syslog | fgrep "Wake reason"

paste result here

2018-02-21 09:13:56.350861-0800  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:02:01.536873+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:13:06.320573+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:20:13.516259+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:27:24.217995+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:29:11.068225+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:30:45.649732+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:32:20.254424+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:33:33.285650+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:36:42.305234+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:38:19.373541+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:40:56.260835+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:42:45.756784+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:43:55.646243+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 21:49:43.929725+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-21 23:42:39.374137+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-22 00:01:10.428774+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-22 00:04:23.872435+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-22 00:06:56.424912+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-22 00:08:23.623763+0300  localhost kernel[0]: (AppleACPIPlatform) Wake reason: XHC
2018-02-22 00:08:23.623764+0300  localhost kernel[0]: (AppleACPIPlatform) Wake reason: XHC
2018-02-22 00:08:37.357846+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-22 00:09:58.457751+0300  localhost kernel[0]: (AppleACPIPlatform) Wake reason: XHC
2018-02-22 00:09:58.457752+0300  localhost kernel[0]: (AppleACPIPlatform) Wake reason: XHC
2018-02-22 00:10:13.149240+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-22 08:56:11.223338+0300  localhost kernel[0]: (AppleTopCaseHIDEventDriver) [HID] [ATC] AppleDeviceManagementHIDEventService::processWakeReason Wake reason: Host (0x01)
2018-02-22 23:17:04.378850+0300  localhost kernel[0]: (AppleACPIPlatform) Wake reason: XHC
2018-02-22 23:17:04.378851+0300  localhost kernel[0]: (AppleACPIPlatform) Wake reason: XHC


Share this post


Link to post
Share on other sites

hello MaLd0n

you can control this pc from the living room. thank you.

 

Cpu i5 7500

Gigabayte GA-H270N-WIFI

4+4GB ddr4 2400mhz.

 

 

Edited by p4antonio

Share this post


Link to post
Share on other sites

Hi MaLd0n,

 

Please can you take a look at my Clover config.plist, ACPI dumps and the rest of the folder and tell me if everything is OK. I am pretty good with this but have no idea how to patch DSDT & SSDT.

 

Thank you.

Send me.zip

Share this post


Link to post
Share on other sites

Hi MaLd0n,

 

Please can you take a look at my Clover config.plist, ACPI dumps and the rest of the folder and tell me if everything is OK. I am pretty good with this but have no idea how to patch DSDT & SSDT.

 

Thank you.

CLOVER.zip

new SEND_ME after reboot with new files

Share this post


Link to post
Share on other sites

attachicon.gifCLOVER.zip

new SEND_ME after reboot with new files

 

MaLd0n,

 

Thank you! that populated the PCI devices section of system profiler, please see IOReg & screenshot.

 

The DSDT did all this?

 

All I need to get working now is Bluetooth (was was working with Sierra then stopped with HS)

 

Thank you again

brams

post-943-0-84447600-1519492869_thumb.png

Send me after reboot.zip

Share this post


Link to post
Share on other sites

MaLd0n,

 

Thank you! that populated the PCI devices section of system profiler, please see IOReg & screenshot.

 

The DSDT did all this?

 

All I need to get working now is Bluetooth (was was working with Sierra then stopped with HS)

 

Thank you again

brams

what bluetooth u have?

check it

BT.zip

Hi MaLd0n! I assembled a new system based on I5-7400 and H270M-DS3N, could I help with DSDT?

CLOVER.zip

new SEND_ME after reboot

Share this post


Link to post
Share on other sites

what bluetooth u have?

check it

attachicon.gifBT.zip

 

Hi MaLd0n,

 

OK I think the DSDT is fine then and I can continue as I am?

 

OK tried those Bluetooth kexts,  didn't work, reading a bit about it I think its a common problem it worked fine in Sierra without any special kind of settings or magic.  Its no big deal I can live without it for now.  In case you are interested I grabbed these details:

 

Details are (from Windows):

 

Qualcomm Atheros QCA61x4A Bluetooth 4.1
 
USB\VID_0B05&PID_1825&REV_0001
 
\_SB.PCI0.XHC.RHUB.HS11
 
Thanks

Share this post


Link to post
Share on other sites

OK I think the DSDT is fine then and I can continue as I am?

Yes, same files for ElCapitan, Sierra e High Sierra

Qualcomm Atheros QCA61x4A Bluetooth 4.1

 
USB\VID_0B05&PID_1825&REV_0001
 
\_SB.PCI0.XHC.RHUB.HS11

need check it, but i think work ;)

Many thanks, but how to register USB 2.0,

and when you switch to sleep, you panic and restart

USB 2 work inside USB 3 BUS

and when you switch to sleep, you panic and restart

post one photo

Share this post


Link to post
Share on other sites

Yes, same files for ElCapitan, Sierra e High Sierra

 

need check it, but i think work ;)

 

USB 2 work inside USB 3 BUS

 

post one photo

He just falls asleep, and immediately goes into reboot and there were several beeps of the BIOS

 

 

Отправлено с моего iPhone используя Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      Catalina 10.15.4 - Windows 10
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) No problem so far ASUS HyperKit with a KINGSTON NVMe SSD - 250 GB  
      What is not working:
      -  
       
      Not tested:
      VideoProc says that Hardware Decoding\Encoding is fully supported and enabled on both HD 530 and RX 5700 but I didn't test it Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: Primary Display: Auto iGPU Multi-monitor: Enabled RC6(Render Standby): Enabled DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: Intel SpeedStep: Enabled CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5107): Click here -> asus-z170_clover_5107.zip  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:
       

       




       
       
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Notes:
       
      2020.03.26: Updated to 10.15.4 -> Updated WhateverGreen, Lilu -> Updated Clover to v5107
      2020.03.23: Removed "EmuVariableUefi.efi" -> deleted, caused false nvram map, now it's native, updated Clover to v5106
      2020.02.11: Updated to 10.15.3 -> No problem when/after installing
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
    • By innerd
      Salve, ho da poco aggiornato il bios del notebook in firma alla versione 304, ma dopo averlo fatto non sono piu riuscito a farlo avviare.
      Ho cancellato il dsdt e gli ssdt (eccetto quello delle porte usb e pnlf, il resto ho utilizzato ssdttime con il nuovo dump).
      Credo che si blocchi nel momento in cui dovrebbe apparire la mela (con verbose) e quindi all'inizializzazione della igpu. Avendo il dubbio fosse un problema di framebuffer diverso (volevo anche creare una fake imei ma non ho trovato nessuna guida al riguardo) ho cancellato le vecchie proprietà nel config e provato manualmente tutti i valori mobile con igfxframe come flag, 2 volte sono stato fortunato con 0x1612002 ma senza riuscire a farlo partire piu di quelle poche volte. Con un framebuffer mobile e in safe mode riesco ad entrare ma in nessun altro modo, avete consigli?
      CLOVER.rar
    • By midi-sama
      After a long time of cooking this computer up with a lot of stuff, I'm finally releasing my guide for this P50 with OpenCore.
       
      Lenovo ThinkPad P50 macOS Install with OpenCore
       
      This thread may be used for questions/corrections/additions. Good Luck.
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9600K, 9700K, 9900K, 9900KS
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Reference RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      Current EFIs 
      Updated 26/03/2020
      PLEASE NOTE - You MUST update to the latest Clover EFI before updating to 10.15.4 or you may find your unable to update.
       
      Clover EFI Updated 26/03/20 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
      Clover Z390 Master Vega Navi EFI 260320.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      Clover Z390 Master Polaris EFI 260320.zip - R5XX Polaris DSDT EFI
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - OpenCore No DSDT and Done the way OpenCore intended it (03/03/2020)
       

      Alternative EFI 2 - N-D-K Fork of OpenCore (03/03/2020)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Disabled
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on Catalina 10.15.4 and Clover EFI 5104 (Catalina Patcher)
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman Voodoo PS2 Controller (here) acidanthera AppleALC (here) acidanthera Lilu (here) acidanthera VirtualSMC (here) acidanthera SMCBatteryManager (here) acidanthera SMCLightSensor (here) acidanthera WhateverGreen (here) Mieze Realtek RTL8111 (here)
×