Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave / Catalina on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

5,100 posts in this topic

Recommended Posts

Hey MaLd0n, Awesome guide, thank you so much, here are my clover files+ACPI+IORegistry.
My specs are the following:

 

Mobo: GA-Z270-HD3P Rev 1.0 Bios F7

CPU: i5 7500

GFX: Gigabyte GT 1030 OC 2GB
Ram: 1x16GB

Storage: Kingston SSD 120GB for system and i will throw in another 2TB HDD as soon as I'm done with the system setup

 

I installed El Captain 1st and then upgraded using the app store so that i can have the final update of Sierra with kabylake support, after installing Sierra, i removed fakeCPU ID, and changed my smbios to 18,2 as that specific model uses the same CPU that i have at the moment, so i don't really understand, do i need any PM hacks, or is my CPU OOB?

Here are the files you requested, can't wait to have this beast up and running, I've been on 10.8.5 on a C2Q Q6600 for the past couple of years.... lol (might upgrade it to El Captain using your other guide :)

Send to Maldon.zip

Share this post


Link to post
Share on other sites
Advertisement

Hi. I just built the pc in the signature.

I installed high sierra, so if you can't help me can you please show where are the patches you list in the first post?

It works, but i thinks it's not perfect and i'm not able to edit my dsdt properly as i did with my laptop.

Thanks!

CLOVER.zip

Paolo’s iMac.ioreg.zip

Send me Paolo’s iMac.zip

Share this post


Link to post
Share on other sites

Thanks for your guide. I, too would like to know about your patches. If you could post them I would try to patch my own myself. :)

 

 

Board: Z270N Gaming 5

Ram: 16gb

CPU: 7700k

GPU: MSI 1060 6gb OC

 

Attached is the disassembled (and assembled) DSDT and SSDTs along with my Clover sans the theme folder.

Thank you for taking the time to look at it.

GA-z270n gaming 5 -TrustAugustus.zip

TrustAugustus iMac IOREG.zip

Share this post


Link to post
Share on other sites

So I followed everything and have a working system!

I dont suite understand the DSDT, but I have done everything else.

 

MOBO: GA-Z270X-UD5

CPU: i7700k

GPU: 1080 Ti

 

OS: 10.12.6

 

Clover Folder:

https://www.dropbox.com/s/ynraiilcxezaqwg/CLOVER.zip?dl=0

 

"Send me file"

https://www.dropbox.com/s/9oku4sftx9hjduc/Send%20me%20superflex%E2%80%99s%20iMac.zip?dl=0

 

Ioregistry:

https://www.dropbox.com/s/n98vs3wc1w5om76/ioregistry.ioreg?dl=0

 

thank you so very much for making this possible!

 

 

Edit. The only issue im experiencing, is that 1 disk doesnt show up after reboot. When i shut down, and power on again, all disks are back.. How come?

Share this post


Link to post
Share on other sites

Hi it would be awesome if you could help me out as well.

 

On High Sierra

 

I got a i7 7700k @5100mhz on a

GA z270-UD5.   F5 BIOS

16gig 3000mhz

and a 

GTX1070

 

Getting some proper mA to the USB would be epic.

 

I hope I added all necessary files.

 

Mille Grazie

CLOVER.zip

Send me test’s iMac.zip

SSDT 7700k 5.1ghz.zip

IOREG test’s iMac.zip

Share this post


Link to post
Share on other sites

Hi sir Maldon

 

I built a hackintosh

my specs MB GA-B250M-D3H

Cpu Core i5 7500 intel HD 630

send me clover UEFI for installation macOS Sierra and 

post installation advise

 

Thanks in Advance.

Share this post


Link to post
Share on other sites

Hi Maldon,

 

you dont need to do the DSDT edits like this editing the actual file.  Clover has sections in it called drop dsdt tables and then patch each item from the clover config.plist file alone.  just an update for people who keep posting their dsdt's and you dont need to edit every dsdt file people post.

 

What program and patches are you using to do the patches?

Share this post


Link to post
Share on other sites

Hi Maldon,

 

you dont need to do the DSDT edits like this editing the actual file.  Clover has sections in it called drop dsdt tables and then patch each item from the clover config.plist file alone.  just an update for people who keep posting their dsdt's and you dont need to edit every dsdt file people post.

 

What program and patches are you using to do the patches?

lol

clover have a very basic patches, all hacks need a good edited DSDT ;)

check clover page and see slice talkin' about it

create patches with datasheet, ioreg and tables real macs and tests, many tests and time.

see u

I am having trouble with my new setup. 

I have a 7600K, MSI Z270 Gaming M5, GTX 1070.

I am unable to see SATA or NVMe drives. That and I cannot get the Nvidia Web Drivers to load. 

 

I've tried a handful of patches, SSDT-SATA from Rehabman, SATA-200-Unsupported.kext, and a handful others. The SATA controller is 8086:A282, which is apparently unsupported. I'm at my wits end as my first hackintosh with my skylake went beautifully. Hopefully someone can help me out here.

 

Here are the support files. I appreciate anyone's help they can offer!

Nvme, use pike patches

CLOVER superchase9000.zip

dear Mald0n please help me with DSDT,

my info

i5 7500

ASUS B250-Plus

GTX1060 6G

 

this is my files

if u use HS, check patch USB for HS in config.plist

CLOVER angel88.zip

Hey MaLd0n, thank you for your work , it helped me a lot. I use your DSDT file on my hackintosh, but I thought maybe I need a patch because I don't have the same MotherBoard. Here is my config : 

 

MB : MSI Z270 SLI Plus

CPU : Intel 7700K 4.2 GHz

GPU : Inno3D GeForce GTX 1060 6GB

RAM : Kingston HyperX Fury 2x8 Gb in 2666MHz

OSX : 10.12.6

 

The DSDT is a thing a don't understand so much , so I just take your file and put it into ACPI/Origin

 

Thank You.

i need ur table

check first post

 

Hi MaLd0n here is my zip file and please help me on the DSDT. I couldn't get my sound to work.

 

Thanks

 

my pc is as blow:

 

MB: MSI-Z270-TOMAHAWK-OPT-BOOST Bios 3.10

CPU: i7-6700K

RAM:16G x2

VGA: Nvidia GTX750 TI

Sound: ALC892

 

CLOVER Li Tan.zip

if dont work need use other id

Hey again MaLd0n, I just have issues with my ALC1220 audio. I try all way to get it : Lilu , VoodooHDA , Toleda's way. And there is nothing who works. If you can help me it will be nice. 

 

MB : MSI Z270 SLI Plus

CPU : Intel 7700K 4.2 GHz

GPU : Inno3D GeForce GTX 1060 6GB

RAM : Kingston HyperX Fury 2x8 Gb in 2666MHz

OSX : 10.12.6

 

Thank you ! 

CLOVER Delecta.zip

Hello MaLd0n, thanks for this guide.

 

I have a problem with speed of the lan controller, if i transfert a big file from my nas the data speed is average 22MB/s, but the lan negotiation is 1000 in the Sierra setting and the led of my gibagit switch is green (1000).

 

If i transfert the same file with Windows  or Ubuntu the data speed is 80-90MB/s.

 

I have used the kext in first page:

http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/

 

My mainboard is GA Z270 Gaming K3

 

You can help me please?  ^_^

;) done

Hi Maldon,

 

I'm getting ready to go to High Sierra.

can I leave you here the clover to make it compatible?

 

My specs :

 

- Asus Rog Strix Z270G Gaming

- i7-7700K

- 16GB DDR4

- Nvidia 1080ti

- Wifi+Bt Broadcom BCM943602CS with pci card

- Nvme Samsung 256GB

 

 

At this time I am using the DSDT.aml from the old main board Z270i Strix...

 

:)

 

Thnks Sir!

just use usb port limit for high sierra and update kexts like applealc ;)

Hello Maldon,

 

 

All resolved. Fix DSDT. I put my clover configuration with DSDT and SSDT

 

 

I have

GA-z270x-ud5

32Gb Memory

500 SSD 850 EVO M2

255 SSD 830 

GC-Alpine ridge

radeon 580x 4gb

LG 5K with full 5k resolution + webcam + sounds + mic

all USB3/USB2 port working

Bluetooth and Wifi Works

DSDT.marlboro Lights.zip

Hi again MaLd0n. I changed some hardware in my rig. Could you do your magic?

 

Asus Z270M-plus

Intel 7600K

Geforce 1060 3GB

 

Amazing work! Thanks in advance!

 

EDIT. I managed to edit my DSDT after reading a lot. Thanks anyway!

DSDT.lolost.zip

Hey MaLd0n, Awesome guide, thank you so much, here are my clover files+ACPI+IORegistry.

My specs are the following:

 

Mobo: GA-Z270-HD3P Rev 1.0 Bios F7

CPU: i5 7500

GFX: Gigabyte GT 1030 OC 2GB

Ram: 1x16GB

Storage: Kingston SSD 120GB for system and i will throw in another 2TB HDD as soon as I'm done with the system setup

 

I installed El Captain 1st and then upgraded using the app store so that i can have the final update of Sierra with kabylake support, after installing Sierra, i removed fakeCPU ID, and changed my smbios to 18,2 as that specific model uses the same CPU that i have at the moment, so i don't really understand, do i need any PM hacks, or is my CPU OOB?

 

Here are the files you requested, can't wait to have this beast up and running, I've been on 10.8.5 on a C2Q Q6600 for the past couple of years.... lol (might upgrade it to El Captain using your other guide :)

 

attachicon.gifSend to Maldon.zip

CLOVER SLim Nasr.zip

welcome

Hi. I just built the pc in the signature.

I installed high sierra, so if you can't help me can you please show where are the patches you list in the first post?

It works, but i thinks it's not perfect and i'm not able to edit my dsdt properly as i did with my laptop.

Thanks!

Check usb port limit patch in config.plist

CLOVER Paolo7297.zip

Thanks for your guide. I, too would like to know about your patches. If you could post them I would try to patch my own myself. :)

 

 

Board: Z270N Gaming 5

Ram: 16gb

CPU: 7700k

GPU: MSI 1060 6gb OC

 

Attached is the disassembled (and assembled) DSDT and SSDTs along with my Clover sans the theme folder.

Thank you for taking the time to look at it.

CLOVER TrustAugustus.zip

So I followed everything and have a working system!

I dont suite understand the DSDT, but I have done everything else.

 

MOBO: GA-Z270X-UD5

CPU: i7700k

GPU: 1080 Ti

 

OS: 10.12.6

 

Clover Folder:

https://www.dropbox.com/s/ynraiilcxezaqwg/CLOVER.zip?dl=0

 

"Send me file"

https://www.dropbox.com/s/9oku4sftx9hjduc/Send%20me%20superflex%E2%80%99s%20iMac.zip?dl=0

 

Ioregistry:

https://www.dropbox.com/s/n98vs3wc1w5om76/ioregistry.ioreg?dl=0

 

thank you so very much for making this possible!

 

 

Edit. The only issue im experiencing, is that 1 disk doesnt show up after reboot. When i shut down, and power on again, all disks are back.. How come?

CLOVER lecycliste.zip

Hi it would be awesome if you could help me out as well.

 

On High Sierra

 

I got a i7 7700k @5100mhz on a

GA z270-UD5.   F5 BIOS

16gig 3000mhz

and a 

GTX1070

 

Getting some proper mA to the USB would be epic.

 

I hope I added all necessary files.

 

Mille Grazie

CLOVER blackbird_n1.zip

Hi sir Maldon

 

I built a hackintosh

my specs MB GA-B250M-D3H

Cpu Core i5 7500 intel HD 630

send me clover UEFI for installation macOS Sierra and 

post installation advise

 

Thanks in Advance.

same procedure

CLOVER majoract100.zip

use 10.12.6 or High Sierra

Hi MaLd0n. If you would be so kind as to help me I would really appreciate it! Thanks for all that you do around here. My build is in my signature.  :)

CLOVER leon.blackmail.zip

--------------------------------------------------------------

 

tomorrow i'll check others topics

see around guys/ladies

Share this post


Link to post
Share on other sites

 

just use usb port limit for high sierra and update kexts like applealc ;)

 

 

Please I have updated the bios and the old dsdt I had done was for a different motherboard (before I had z270i I Z270G)

 

I'd ask the courtesy to give me a new dsdt as follows (see my signature)

 

- Mobo : Asus Z270G

- Video : Nvidia 1080Ti

- Wifi+BT : pci card 

 

currently with the config of clover I can use HighSierra but I notice a slight "lag" and do not know what is due 

 

 

THHHHAAAAANKS!

 

PS: in the folder of clover (in origin) all aml extracted with F4

CLOVER.zip

Send me iMac di UltraLaser.zip

Share this post


Link to post
Share on other sites

 

Hello MaLd0n !
I have changed the motherboard with Gigabyte GA Z270 Gaming K3 + Gtx 1070 .Please help me.
thank you very much. ( High Sierra )

PS:in the folder of clover (in origin)all aml extracted with F4 

 


High’s iMac.ioreg


 

    RunMe.app - Send me High’s iMac.zip

EFI.zip

High’s iMac.ioreg.zip

Send me High’s iMac.zip

Share this post


Link to post
Share on other sites

Please I have updated the bios and the old dsdt I had done was for a different motherboard (before I had z270i I Z270G)

 

I'd ask the courtesy to give me a new dsdt as follows (see my signature)

 

- Mobo : Asus Z270G

- Video : Nvidia 1080Ti

- Wifi+BT : pci card 

 

currently with the config of clover I can use HighSierra but I notice a slight "lag" and do not know what is due 

 

 

THHHHAAAAANKS!

 

PS: in the folder of clover (in origin) all aml extracted with F4

CLOVER UltraLaser.zip

 

Hello MaLd0n !
I have changed the motherboard with Gigabyte GA Z270 Gaming K3 + Gtx 1070 .Please help me.
thank you very much. ( High Sierra )

PS:in the folder of clover (in origin)all aml extracted with F4 

 

High’s iMac.ioreg

 

    RunMe.app - Send me High’s iMac.zip

 

CLOVER gagaraz.zip

Share this post


Link to post
Share on other sites

Hi MaLd0n. I Updated Bios to version F7( High Sierra) .If you would be so kind  to help me . Thanks in Advance

Archive.zip

Share this post


Link to post
Share on other sites

 

Thanks again, i shall give it a try later tonight and let you know how it goes with bench scores.

 

Keep an eye on your 775 El Capitan guide, i shall upgrade my old machine as soon as this one is up and running :D:yes:  :angel_not: 

Share this post


Link to post
Share on other sites

Hi MaLd0n. I Updated Bios to version F7( High Sierra) .If you would be so kind  to help me . Thanks in Advance

if u have a stable system and bios, dont need update bios, just gain ur money and enjoy ur hack :D

DSDT.IUTniun.zip

Thanks again, i shall give it a try later tonight and let you know how it goes with bench scores.

 

Keep an eye on your 775 El Capitan guide, i shall upgrade my old machine as soon as this one is up and running :D:yes:  :angel_not:

welcome

enjoy

Share this post


Link to post
Share on other sites

Hi again!

Everything works perfectly except for a couple of things. 

The computer seems to wake itself randomly and stick on a black screen. I then have to force reset  and when I reset it is in hibernate at the clover menu. 

Also, my thunderbolt device seems to only work sometimes, and I need to power it on right as I power on the computer.

Is there anything I can do to fix these issues?

Thank you!

Share this post


Link to post
Share on other sites

if u have a stable system and bios, dont need update bios, just gain ur money and enjoy ur hack :D

attachicon.gifDSDT.IUTniun.zip

welcome

enjoy

You are amazing, thank you very much.

Share this post


Link to post
Share on other sites

lol

clover have a very basic patches, all hacks need a good edited DSDT ;)

check clover page and see slice talkin' about it

create patches with datasheet, ioreg and tables real macs and tests, many tests and time.

see u

Nvme, use pike patches

attachicon.gifCLOVER superchase9000.zip

if u use HS, check patch USB for HS in config.plist

attachicon.gifCLOVER angel88.zip

i need ur table

check first post

attachicon.gifCLOVER Li Tan.zip

if dont work need use other id

attachicon.gifCLOVER Delecta.zip

;) done

just use usb port limit for high sierra and update kexts like applealc ;)

attachicon.gifDSDT.marlboro Lights.zip

attachicon.gifDSDT.lolost.zip

attachicon.gifCLOVER SLim Nasr.zip

welcome

Check usb port limit patch in config.plist

attachicon.gifCLOVER Paolo7297.zip

attachicon.gifCLOVER TrustAugustus.zip

attachicon.gifCLOVER lecycliste.zip

attachicon.gifCLOVER blackbird_n1.zip

same procedure

attachicon.gifCLOVER majoract100.zip

use 10.12.6 or High Sierra

attachicon.gifCLOVER leon.blackmail.zip

--------------------------------------------------------------

 

tomorrow i'll check others topics

see around guys/ladies

Hi! i tried and got the screen attached repeating continuosly... I don't know what to do...

Can you send me the patches you use? I cannot find them...

Thanks a lot!

post-969329-0-06699300-1507847597_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Mald0n!

 

the system is almost perfect! does not work only the sleep mode (stop)

What could it be? Anyway thank you so much for everything!

what happens with sleep?

try a darkwake?

Hi again!

Everything works perfectly except for a couple of things. 

The computer seems to wake itself randomly and stick on a black screen. I then have to force reset  and when I reset it is in hibernate at the clover menu. 

Also, my thunderbolt device seems to only work sometimes, and I need to power it on right as I power on the computer.

Is there anything I can do to fix these issues?

Thank you!

disable auto sleep

TH, hot plug dont work, power ur computer with device connect

Hi! i tried and got the screen attached repeating continuosly... I don't know what to do...

Can you send me the patches you use? I cannot find them...

Thanks a lot!

use a fresh install, just install clover and replace folder

MaLd0n You are amazing!!!

attachicon.gif未命名.jpeg

welcome

enjoy

Share this post


Link to post
Share on other sites

is a kext inject problems, use kexts in LIbrary/Extensions

 

Hmmm very strange, I tried without dsdt.aml and the sound card is seen. Might be something in dsdt.aml?

else: could you tell me what is the kext to patch for my ahci controller? :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tonyx86
      I was inspired by @duduclx post for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5.  Everything works perfectly except for sleep.  I'm starting this thread hoping to help others install Mojave on their E6410s and to diagnose and resolve the sleep issue.  This thread is not currently intended to be an installation guide and is better suited to the intermediate/advanced hackintosher.  Eventually, it may evolve into a guide.
       
      I started with this thread (Many thanks, @duduclx !!!) and ended up with the system captured in the attached files.  The keys were to change the LPCB._DSM.Name to "3b09" and remove all CLOVER configs not necessary for Mojave, plus some other items mentioned below.
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) MacOS: Mojave 10.14.5 (APFS) (Patched with DosDude Mojave Patcher 1.3.3) MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09") Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 5, not the original version), USBInjectAll (with custom SSDT-UIAC) Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext) CLOVER (Legacy): R4961  
      Configuration items that may be different from what you have seen in other E6410 configurations
      LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2 ECDV renamed to EC so that AppleBusPowerController loads AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads  No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states) DSDT patched to include HDAU device (device-id 0x0be3)  
      What is NOT working:
      Sleep (display goes blank, but power light stays on.  System cannot wake and must be forced off with power button) Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings.  The slider appears in Display settings (because of the backlight DSDT injection in AGP.VID._DSM), but the slider doesn't work (yet).  Haven't spent time to figure this out, but would love help. Graphics Power Management - AGPM loads (because 10de,0a29 device is injected), but there's no evidence that 3100m frequency and voltage is changing.
        What is NOT tested:
      SD Card Slot Smartcard Reader eSata (I have this disabled in my BIOS) Firewire Port (it does appear in the Network settings, just haven't tried it) Microphone Jack PC Card Slot (I have this disabled in my BIOS) Camera (I have this disabled in my BIOS)  
      What IS working:
      Everything else not mentioned above.   Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long Shutdown is fast Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher) Brightness (adjusted with brightness keys on keyboard) works perfectly Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext. Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext) Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout." Ethernet port (with IntelMausiEthernet.kext) Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext) Optical Drive External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: @PlutoDelic) for working external VGA display. Headphone jack Display Port (tested using DP > HDMI adapter)  
      Known issues and their solutions
      AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  This has been completed and tested, but does not fix the sleep behavior.  This fix is not reflected in the attached files. ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement.  I've implemented and tested this on my system.  The ALPS version of VoodooPS2Controller.kext mixes up a few keys.  Need to switch the Command and Option keys (System Preferences > Keyboard > Modifier Keys) and change keyboard type to ISO European.  The updated VoodooPS2Controller.kext is not reflected in the attached files. This proposed configuration uses an injected device-id (10de,0a29) for NVidia 3100m to get AGPM to load.  While I haven't observed any performance differences, a better approach may be to inject AGPM properties for device 10de,0a6c (the actual device-id for the 3100m).  This AGPM method is discussed later in this thread.  I have briefly tested this "FakeSMC.kext method" for injecting AGPM attributes without any noticeable changes in laptop/graphics behavior and have not updated attached files to reflect this change. IOHWControl is not loaded under AGPM (Should be AGP > VID > NVDA,Display-A@0 > NVDATesla > AGPM > gpu-control > IOHWControl as viewed in IORegistryExplorer).  It is loaded on a real MacBookPro6,2 running Mojave and is loaded on this Dell Latitude E6410 running High Sierra.  If I "Inject NVidia" via CLOVER, IOHWControl loads properly.  I have made this change and am testing it on my system, but have not updated the attached configuration files. The Dell Latitude DSDT (BIOS A17) has a bug in Method (GNOT).  In the method, the expression  If (LOr (LGreater (OSYS, 0x07D0), LLess (OSYS, 0x07D6))) always evaluates to TRUE, so the patched DSDT has no dependency on the value of OSYS.  I suspect that LOr should be replaced with LAnd, so that this expression is TRUE for variants of Windows 2001 and False for any other OS.  While this may have no affect on MacOS, it makes one wonder how such an obvious bug made it through Dell QA and is still present in BIOS A17.  Also makes one wonder whether the sleep problem (which no one has solved) was fixed in Windows to address another DSDT bug. The DSDT patch that duduclx refers to as "Intel GMA Ready" in his El Capitan Guide is not applied correctly to the DSDT attached to this post.  Somehow, the contents of patched _DSM are located in the PCI0.VID device instead of in Method (_DSM) within the PCI0.VID device.  MaciASL didn't complain about this, so it went unnoticed, but it doesn't appear to have had any affect.  I have completely removed this "Intel GMA Ready" patch from my DSDT since it is not necessary for Dell Latitude E6410's with NVidia 3100m, but have not updated the attached DSDT. The assigned value of ACOS in the DSDT is conditional on the operating system.  There is no condition for "Darwin."  The solution is to add a condition for "Darwin" (making it equivalent to one of the defined operating systems (e.g. Linux, Win7, etc), analogous to the assignment of OSYS.  I made this change in my DSDT (not yet reflected in the attached files), but have not observed any behavioral differences (sleep or otherwise).  EDIT: Another way to handle this might be to override _OSI with XOSI (defined in a custom SSDT).  Still learning about XOSI and haven't yet drawn a conclusion.  I'm currently experimenting with ACOS and OSYS equivalent to Win7 and Linux (manually patched in my DSDT which has not yet been updated as a new attachment to this post). The portType of the Internal Bluetooth device is portType=0 which, according to Rehabman's comments in SSDT-UIAC-All.dsl, is an external USB 2 port.  I believe that this should be an internal USB port (portType=2).  My custom SSDT-UIAC.dsl is wrong.  I just learned through trial and error that the HUB1 and HUB2 definitions in Rehabman's SSDT-UIAC-ALL.dsl apply to the ports on the EHCx USB hubs.  The solution is to include the HUB1 definition in SSDT-UIAC.dsl and change portType to 2 for HP15.  I have not attached an updated SSDT-UIAC.dsl to this first post, but my current EFI includes an updated SSDT-UIAC.dsl with ports HP15, 16 17 and 18 set to internal (portType = 2).  This change doesn't appear to affect/fix sleep, but it may prevent instant wake if we get sleep working.  
      Brief Installation Guide (for the experienced Hackintosher):
      Follow duduclx's guide for BIOS config Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh). Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist Install MacOS to your SSD.  When you run DosDude's Mojave Patcher, DO NOT install LegacyUSBInjector.kext - you're going to use Rehabman's USBInjectAll.kext. Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original) Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys).  Also change keyboard type to ISO European to fix the [ ` ~ ] key (to the left of the "1" (one) key. Install VoodooHDA Install HWMonitor application  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z  


      CLOVER.zip
    • By fusion71au
      Clover r4989 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4989 for VMware.zip". Mount Clover-v2.4k-4989-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By Nobody.OSC
      I have installed MacOS Mojave successfully. But have some serious issue with graphics and apps freezing.
      1. Almost every apps freeze at some point. even System Preference freeze whenever click on any option. then either have to quit or force quit.
      2. When using any apps or loading something, that apps window stuck on screen, it doesn't go even after Killing the apps. Also when write something in Terminal, text not appear on terminal screen. if click inside the Terminal again, then all text show up suddenly. A lot of others weird problem happen.
      Also most time when booting, apple logo and loading bar stuck on screen. If write password blindly and press Enter, then Desktop screen comes.
      3. Sometimes machine turn off directly and then restart itself.

      My laptop configuration:
      Model: ASUS X510UQ
      CPU: Core i5-7200U
      GPU: Intel HD620 - 1920x1080 + Nvdia 940MX
      Chipset: Intel(R) Xeon(R) E3 - 1200
      Storage: 120GB SATA SSD + 1TB HDD

      @ I'm Using CLover Bootloader
      @ Disabled Nvdia with SSDT patching.
      @ System Updated to 10.14.5

      Here is the attachment of my "EFI + System Log + Installed Extensions + kextstat result":
      All Files.zip
    • By zZHAMIDZz
      hi guys,
      I'm beginner to hackintosh and i planning to buy new rig , but i don't know which of this two case is better for mojave
      case 1:
      CPU: i5 8400,
      Motherboard: Gigabyte h310m-s2h
      GPU: Intel uhd 630
      ram: hyperx fury 8gb 2400 ddr4
      ssd: adata su650 240gb

      case 2: 
      CPU: i5 6600,
      motherboard: asus z170-a
      GPU: hd 530
      ram: hyperx fury 8gb 2400 ddr4
      ssd: adata su650 240gb
       
      which is better ?
      my priority is first case because of cpu but i had heard h310 motherboard not working with hackintosh and I can't buy b360 or better , because it's too expensive in my country.
      My monitor just have vga , can I use HDMI to vga adaptor ? is it work ? or does it need to upgrade ?

      Thanks for your help.
×