Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave / Catalina on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

5,428 posts in this topic

Recommended Posts

33 minutes ago, fryysyd said:

@MaLd0n Hi ! Moderators

Can you help me add SAPPHIRE NITRO+ RX590 8G graphics card information to dsdt?
The graphics card is currently driven normally. The "About This Machine" graphics card can correctly display the RX590, but open "VideoProc" to view the hard solution. The graphics card item shows N/A. After seeing someone add a video card name with SSDT, "VideoProc" will show the name of the video card, so I would like to ask you to help add it!
In addition, because of the upgrade to 10.4.4, RX590 can open the hard solution separately, so the integrated graphics output in the motherboard BIOS settings is turned off, but the system reports - PCI information, IMEI Controller shows No, can you make it Yes?
At present, the machine Sleep and wakes up, USB, Graphics hard solution, CPU frequency conversion and HDMI audio output are normal!

 

I look forward to your reply! Thanks!

Send me iMac18.3.zip

use only it with last clover version, enable IntelHD in bios for IntelQuickSync

CLOVER.zip

Share this post


Link to post
Share on other sites
Advertisement

 

Hello, I'm new to this hackintosh, and after reading several articles and trying to install it on my PC, I have been unable to make an error or errors that I have not been able to solve.

I would need some help if possible, my team is this:


Intel i5 6600

Msi z170a pc mate

16gb RAM

Rx570 4gb (use HDMI cable)

Samsung Evo 960 m.2 240gb (Windows 10)

SSD Ocz trion 100 120gb (I want to install it here)

Box nx Hummer zs white USB 3.0

Monitor benq 24" normal range


If anyone can help me I appreciate it. If you need any more information, tell me and I post it.


Thanks and best regards

Share this post


Link to post
Share on other sites
7 hours ago, dfdfdf said:

 

Hello, I'm new to this hackintosh, and after reading several articles and trying to install it on my PC, I have been unable to make an error or errors that I have not been able to solve.

I would need some help if possible, my team is this:


Intel i5 6600

Msi z170a pc mate

16gb RAM

Rx570 4gb (use HDMI cable)

Samsung Evo 960 m.2 240gb (Windows 10)

SSD Ocz trion 100 120gb (I want to install it here)

Box nx Hummer zs white USB 3.0

Monitor benq 24" normal range


If anyone can help me I appreciate it. If you need any more information, tell me and I post it.


Thanks and best regards

check here

https://olarila.com/forum/viewtopic.php?f=50&t=8685

Share this post


Link to post
Share on other sites
On 30/3/2019 at 18:09, MaLd0n said:

Hello thank you very much. I have managed to install it very well thanks to its link.

I only have a couple of little things that I have not gotten.

 

- I use the HDMI cable to connect to the monitor and I do not know why I get the image as purple (with a lot of blue), however, if I use the dvi, the colors are normal. The audio with the HDMI is normal, but by dvi I had to use the output of the board and kext and the sound is low, although sufficient. I've tried 5 different hdmi cables and nothing.

 

-I can not install the clover on the SSD to boot from there, if I succeed, but I do not get the options of Mac os, only Windows. I did tests, and I had to reinstall Mac os, because something changed and I did not upload anything.

 

Total, that started it from the USB of olarila, I have it put back on the computer board and that's it.

 

We'll see if I'll keep trying things. I feel English, it's a translator.

 

Greetings. ;)

Share this post


Link to post
Share on other sites
4 hours ago, dfdfdf said:

Hello thank you very much. I have managed to install it very well thanks to its link.

I only have a couple of little things that I have not gotten.

 

- I use the HDMI cable to connect to the monitor and I do not know why I get the image as purple (with a lot of blue), however, if I use the dvi, the colors are normal. The audio with the HDMI is normal, but by dvi I had to use the output of the board and kext and the sound is low, although sufficient. I've tried 5 different hdmi cables and nothing.

 

-I can not install the clover on the SSD to boot from there, if I succeed, but I do not get the options of Mac os, only Windows. I did tests, and I had to reinstall Mac os, because something changed and I did not upload anything.

 

Total, that started it from the USB of olarila, I have it put back on the computer board and that's it.

 

We'll see if I'll keep trying things. I feel English, it's a translator.

 

Greetings. ;)

post ur files

--Run_Me
RunMe.app
https://www.youtube.com/watch?v=k9wmIfGLe3A

Share this post


Link to post
Share on other sites

Asus ROG Strix H370-F Gaming

i7 8700 (non k!)

16x2 G.Skill

NVMe SSD 960 EVO M.2 500GB (System)
WD Blue SSD 1TB (Data)

Not using a GFX card, i'm using this for my studio, however, using internal graphics makes the screen glitchy only when i connect more than one screen to it, if i only connect one, it ends up in black screen after boot process.

I managed to instal the os, clover and your files with the glitchy screen, here are the results to runme.app

 

 

Send me Akrams-iMac.zip

Share this post


Link to post
Share on other sites
11 hours ago, mR.GeeK said:

Asus ROG Strix H370-F Gaming

i7 8700 (non k!)

16x2 G.Skill

NVMe SSD 960 EVO M.2 500GB (System)
WD Blue SSD 1TB (Data)

Not using a GFX card, i'm using this for my studio, however, using internal graphics makes the screen glitchy only when i connect more than one screen to it, if i only connect one, it ends up in black screen after boot process.

I managed to instal the os, clover and your files with the glitchy screen, here are the results to runme.app

 

 

Send me Akrams-iMac.zip

use only it with last clover version

CLOVER.zip

Clover_v2.4k_r4918.pkg.zip

Share this post


Link to post
Share on other sites
36 minutes ago, P1aton0FF said:

Hi MaLd0n
Can you help me please. Neither can I make 3 monitors work on the HD530...
I have asus q170s1 (2xHDMI & 1xDP) and i5 6400t

What is wrong with me?)

THX!

 

Send me.zip

DSDT.aml.zip

https://translate.google.com/translate?js=n&sl=auto&tl=en&u=https://blog.daliansky.net/Intel-FB-Patcher-tutorial-and-insertion-pose.html

usb

https://olarila.com/forum/viewtopic.php?f=62&t=6539

Share this post


Link to post
Share on other sites
16 hours ago, MaLd0n said:

CLOVER.zip

use it with last clover version, enable IGPU in bios/uefi

Hi, perfect. Now it works correctly. Thank you very much for all the info and help that you have given me.  ;)

Edited by dfdfdf

Share this post


Link to post
Share on other sites

A question. Is it possible to avoid seeing the lines that are loading before the Mac logo appears? It's not that it's annoying, but if they can be hidden, the better. I think it will have to be some modification in the config.plist, but I do not see which one exactly.

 

Pd.: It was a matter of removing -v in the boot of the config.plist.

Edited by dfdfdf
Info

Share this post


Link to post
Share on other sites
18 hours ago, MaLd0n said:

use only it with last clover version

CLOVER.zip

Clover_v2.4k_r4918.pkg.zip

 

Thank you so much, the graphics glitch is gone, but the gfx ports are not working, they only work when i have dvi and hdmi connected, and only hdmi works, if i have one of them only connected, nothing works, and when i'm in the os, if i remove the dvi after booting, the whole system hangs.
Frame buffer is not detected.

Network seems to work, but it won't go online, even after i apply manual DHCP.

 

The iGFX connectors are three, DVI+HDMI+DP.

 

Apart from that, i think everything else works, even sleep.

Edited by mR.GeeK
duplicate post

Share this post


Link to post
Share on other sites
24 minutes ago, dfdfdf said:

A question. Is it possible to avoid seeing the lines that are loading before the Mac logo appears? It's not that it's annoying, but if they can be hidden, the better. I think it will have to be some modification in the config.plist, but I do not see which one exactly.

you can use clover configurator and remove verbose mode:

1.go to boot section

2.remove boot argument (-v)

3.save

Share this post


Link to post
Share on other sites
2 hours ago, mR.GeeK said:

you can use clover configurator and remove verbose mode:

1.go to boot section

2.remove boot argument (-v)

3.save

Thanks. ;)

Share this post


Link to post
Share on other sites

Hello everyone,
I have problems with USB 3.0 ports and with the video card that works only with HDMI and I would like to connect another monitor.
This is my configuration:
MOBO MSI Z170A M5
Intel i7 4Ghz CPU
RAM 16Gb
Radeon RX 560 4GB video card

Mac OS Mojave 10.4.4
I attach my config.plist
Thank you in advance

config.plist

Edited by kastersoft

Share this post


Link to post
Share on other sites
5 hours ago, kastersoft said:

Hello everyone,
I have problems with USB 3.0 ports and with the video card that works only with HDMI and I would like to connect another monitor.
This is my configuration:
MOBO MSI Z170A M5
Intel i7 4Ghz CPU
RAM 16Gb
Radeon RX 560 4GB video card

Mac OS Mojave 10.4.4
I attach my config.plist
Thank you in advance

config.plist

https://olarila.com/forum/viewtopic.php?f=62&t=6539

Share this post


Link to post
Share on other sites
44 minutes ago, kastersoft said:

Thank you Thank you Thank you Thank you:thumbsup_anim:

but is this speed normal?

if u dont have a good usb stick, yes

Share this post


Link to post
Share on other sites

Hey,

 

I run the F4 in Clover and the Run_Me.App. Can you check if my config and Clover is right? (If you have time ofc) Used Vanilla Install and clover 4917. (Z370 Krait Gaming)

 

Send me Artur-Pc.zip

Edited by Bierbaron

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
        Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By slapbass_
      Hello friends and teachers of the blessed hackintosh, I hope you are well .......... I want to ask you please, can someone of you help me with my blessed laptop? ..... Some things are missing to activate for example: - brightness indicator: when you press the button, the indicator does not appear on the screen increasing or decreasing brightness. - battery indicator: when connecting the charger, you must activate the beam and go up, from bottom to top when charging, right? but it DOESN'T move - the laptop camera is NOT activated - Bluetooth NOT activated - SD card reader NOT activated optimize the laptop so that it starts when starting the system in less time. why is it taking a minute and 5 seconds (more or less)..... I will be infinitely grateful to you dear friends, Here is my RunMe from my LAPTOP regards blessings Here are my specs: Dell Inspiron 14 5000 series (5458) - Intel (R) Core (TM) i5-5200U CPU at 2.20GHz - Ram 4GB » - Intel HD Graphics 5500 - PCI Network: Intel Dual Band Wireless-AC 3160 AC HMC WiFi WiFi Adapter Realtek RTL8139 / 810x Fast Ethernet Adapter - Audio Intel Broadwell HDMI @ Intel Broadwell - Mini HD Audio Realtek ALC255 @ Intel Wildcat Point-LP PCH High definition ......... I would infinitely appreciate your help friends regards blessings My RunMe-my friends.zip
×