Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave / Catalina on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

5,377 posts in this topic

Recommended Posts

Advertisement
17 hours ago, MaLd0n said:

check if video work

CLOVER.zip

Nope.

I get "no signal" if platform-id 59120000 fake id 59128086

With fakeid 1912 and 3E92 and any platform-id - is loaded, but "Graphics driver failed to load: could not register with framebuffer driver".

Have a panic if platform-id 59120003.

Platform Platform-ID 3e920003 Fake ID empty - loading, but "Graphics driver failed to load: could not register with framebuffer driver".

I tried 18.1, 18.2, 18.3...

Tried BBCoffee630.kext, AppleIntelKBLGraphicsFramebufferInjector_3e9x.kext - without results. 

Send me Aleksandrs-iMac.zip

Share this post


Link to post
Share on other sites

@ Madlon

 

here is the runme zip file,

can you verify the dsdt and patch it for me?

I'm running 10,13,6 on msi z170a gaming m7 with an i5 7600k on stock (planning overclock later)

there's one 16gb memory stick and booting of an ssd

Send me Marcs-iMac.fritz.box.zip

greetings

 

Edited by josephien
donated 10$

Share this post


Link to post
Share on other sites
6 hours ago, P1aton0FF said:

Nope.

I get "no signal" if platform-id 59120000 fake id 59128086

With fakeid 1912 and 3E92 and any platform-id - is loaded, but "Graphics driver failed to load: could not register with framebuffer driver".

Have a panic if platform-id 59120003.

Platform Platform-ID 3e920003 Fake ID empty - loading, but "Graphics driver failed to load: could not register with framebuffer driver".

I tried 18.1, 18.2, 18.3...

Tried BBCoffee630.kext, AppleIntelKBLGraphicsFramebufferInjector_3e9x.kext - without results. 

Send me Aleksandrs-iMac.zip

try, put two files in clover/acpi/patched

remove all flags etc about video

Arquivo Comprimido.zip

24 minutes ago, josephien said:

@ Madlon

 

here is the runme zip file,

can you verify the dsdt and patch it for me?

I'm running 10,13,6 on msi z170a gaming m7 with an i5 7600k on stock (planning overclock later)

there's one 16gb memory stick and booting of an ssd

Send me Marcs-iMac.fritz.box.zip

greetings

 

DSDT.aml.zip

Share this post


Link to post
Share on other sites
5 hours ago, fryysyd said:

@MaLd0n

 

Send me iMac.zip

 

Hello, moderator, dsdt can also add SSD, HDD and wireless network card information, thank you very much!

u have a very wrong config

DSDT.aml.zip

 

use

 

change EC0 to EC
4543305f
45435f5f

change GFX0 to IGPU
47465830 
49475055 

change HDAS to HDEF
48444153 
48444546 

change HECI to IMEI
48454349 
494d4549 

change SAT0 to SATA
53415430 
53415441 

change GLAN to GIGE
474c414e
47494745

Share this post


Link to post
Share on other sites

 in the recent past (sierra onwards) I was forced to use F6 bios, even making sure to hex edit my mac address in!  No matter what I tried couldn't boot without F6 bios.  it would be fine if it wasn't so prone to BOOT entry issues etc....

 

I saw your thread method, and wanted to give it a try..Im booting into Mojave and High Sierra (albeit in safe mode) using newest BIOS! I  just need a little help getting DSDT patched.  I ran the sendme.app and my hardware info is below.  Hope this is sufficient if not I will add anything else I may need.  Sincere thanks for any help I may receive! 

=====================================

 

HW SPECS:

Motherboard: Gigabyte Z170XPSLI rev1.0

firmware: newest (22f)

cpu: Intel i5 6500 3.2ghz --> ssdtprgen.sh generated ssdt.aml attatched

GFX: NVIDIA GTX1060 6gb / edit:  no longer worried about intelHD gfx

misc:

USB-inject 100 series: I have already made a custom patched USB-inject ssdt that I use with usb-inject-all.kext I can attach that as well. (SSDT-UIAC.aml)

 

Not sure what the most efficient setup is for me anymore so at the very least a customized DSDT and any important flags / patches / settings for clover that will probably go a long way for me.  Thanks again for any help!

 

ssdt.aml

SSDT-UIAC.aml

Send me Carloss-iMac.zip

Edited by macw00t
edit..figured out some things and have decided I only need to try and create a custom DSDT for my needs, focusing on 10.13.6. also edited for brevity, readability etc

Share this post


Link to post
Share on other sites

Hi, need bit help or pointing into the right direction. I'm trying patch Lenovo 720 battery and seems suitable patch is already available for Lenovo 480, seems exactly the same bits 16 and 32.

After patching DSDT i'm getting errors, can't compile. Another problem is nvram, brightness is always after reboot 3/4 of max. Tried Aptiomemorifix and now Aptiofixdrv + emuvariable, deleted early nvram.plist , but still the same, always 3/4 of brightness. Attached clover folder, ioreg and lenovo480_patch for the battery. Help appreciated.

Hardware:

Lenovo 720

i5-7200

8 gb ram

256gb nvme ssd

HD620, 1080p

Sierra 10.12.6.

files.zip

Share this post


Link to post
Share on other sites
9 hours ago, macw00t said:

 in the recent past (sierra onwards) I was forced to use F6 bios, even making sure to hex edit my mac address in!  No matter what I tried couldn't boot without F6 bios.  it would be fine if it wasn't so prone to BOOT entry issues etc....

 

I saw your thread method, and wanted to give it a try..Im booting into Mojave and High Sierra (albeit in safe mode) using newest BIOS! I  just need a little help getting DSDT patched.  I ran the sendme.app and my hardware info is below.  Hope this is sufficient if not I will add anything else I may need.  Sincere thanks for any help I may receive! 

=====================================

 

HW SPECS:

Motherboard: Gigabyte Z170XPSLI rev1.0

firmware: newest (22f)

cpu: Intel i5 6500 3.2ghz --> ssdtprgen.sh generated ssdt.aml attatched

GFX: NVIDIA GTX1060 6gb / edit:  no longer worried about intelHD gfx

misc:

USB-inject 100 series: I have already made a custom patched USB-inject ssdt that I use with usb-inject-all.kext I can attach that as well. (SSDT-UIAC.aml)

 

Not sure what the most efficient setup is for me anymore so at the very least a customized DSDT and any important flags / patches / settings for clover that will probably go a long way for me.  Thanks again for any help!

 

ssdt.aml

SSDT-UIAC.aml

Send me Carloss-iMac.zip

CLOVER.zip

Share this post


Link to post
Share on other sites
3 hours ago, striimer said:

Hi, need bit help or pointing into the right direction. I'm trying patch Lenovo 720 battery and seems suitable patch is already available for Lenovo 480, seems exactly the same bits 16 and 32.

After patching DSDT i'm getting errors, can't compile. Another problem is nvram, brightness is always after reboot 3/4 of max. Tried Aptiomemorifix and now Aptiofixdrv + emuvariable, deleted early nvram.plist , but still the same, always 3/4 of brightness. Attached clover folder, ioreg and lenovo480_patch for the battery. Help appreciated.

Hardware:

Lenovo 720

i5-7200

8 gb ram

256gb nvme ssd

HD620, 1080p

Sierra 10.12.6.

files.zip

DSDT.aml.zip

apple battery patch manual way ;) 

Share this post


Link to post
Share on other sites
5 hours ago, MaLd0n said:

DSDT.aml.zip

apple battery patch manual way ;) 

Attached dsdt did not cure the battery percentage, it's still "X" on titlebar.

When i use my DSDT (not battery patched), then at least charging status was recognised, if AC adapter plugged or not, took 2 screenshots. When i'm using MaLd0n patched DSDT, battery status and charging status are unknown, took third screenshot.

Screen Shot 2018-08-25 at 11.38.08.png

Screen Shot 2018-08-25 at 11.39.35.png

Screen Shot 2018-08-25 at 11.59.20.png

Edited by striimer

Share this post


Link to post
Share on other sites
6 hours ago, MaLd0n said:

apply a battery patch, have a guide for it, RM made a good guide

Seems not easy, i'll better donate, can you patch the dsdt ?

Edited by striimer

Share this post


Link to post
Share on other sites
18 hours ago, MaLd0n said:

 

Just a quick reply to say its working great!  Many Thanks for the help; your modern install method(s) are the top tier especially for us scrub hackintoshers!  (Now to go help myself and see if i can learn some more and maybe try patching the raw DSDT myself to see if I can get it to match yours ;) )...Cheers!

Screen Shot 2018-08-25 at 5.18.37 PM.png

Screen Shot 2018-08-25 at 5.25.28 PM.png

Share this post


Link to post
Share on other sites
28 minutes ago, macw00t said:

 

Just a quick reply to say its working great!  Many Thanks for the help; your modern install method(s) are the top tier especially for us scrub hackintoshers!  (Now to go help myself and see if i can learn some more and maybe try patching the raw DSDT myself to see if I can get it to match yours ;) )...Cheers!

Screen Shot 2018-08-25 at 5.18.37 PM.png

Screen Shot 2018-08-25 at 5.25.28 PM.png

just enjoy!

Share this post


Link to post
Share on other sites
On 8/22/2018 at 3:29 PM, MaLd0n said:
On 8/22/2018 at 3:19 PM, Mikentosh2016 said:

I found the issue.

 

 

FireWire board failure.pdf

wow

 

Received / installed the card today and Time Machine backed 4Gb in a short time.

 

Thanks MaLd0n, for your help.

 

 

FireWire card.jpg

Edited by Mikentosh2016

Share this post


Link to post
Share on other sites
4 hours ago, Mikentosh2016 said:

wow

I spoke too soon.  I contacted OWC to determine if the RAID also experienced burned electronics but while I'm waiting for their reply, can you take another look at my Send me iMac? 

About FireWire.jpg

FireWire.JPG

5 hours ago, Mikentosh2016 said:

wow

 

And the Send me iMac

 

https://www59.zippyshare.com/v/kLIWMtS1/file.html

Share this post


Link to post
Share on other sites
On 8/24/2018 at 11:11 PM, MaLd0n said:

u have a very wrong config

DSDT.aml.zip

 

use

 

change EC0 to EC
4543305f
45435f5f

change GFX0 to IGPU
47465830 
49475055 

change HDAS to HDEF
48444153 
48444546 

change HECI to IMEI
48454349 
494d4549 

change SAT0 to SATA
53415430 
53415441 

change GLAN to GIGE
474c414e
47494745

@MaLd0n  thank you for your help! I have modified it as you said.
Config.plist. However, there is a problem with sleep awakening at present. It seems to be related to USB. I have used the USB related patch, but the problem remains. So would you like to ask if you have SSDT-UIAC.aml from ASUS ROG STRIX Z370-I GAMING?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tonyx86
      *** I have started another thread for installing Catalina on the Dell Latitude E6410.  If you were thinking of installing Mojave, but would prefer to skip right to Catalina, click here. ***
       
      I was inspired by @duduclx post here for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5 and subsequently 10.14.6.  Everything works perfectly (including sleep).  I'm starting this thread hoping to help others install Mojave on their E6410s.  A brief installation guide is provided later in this first post.  The interested reader is encouraged to read the other posts in this thread to see how this solution evolved and to learn additional tips/details not provided in this first post (including dual-booting with macOS and Windows).
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) MacOS: Mojave 10.14.6 (APFS) (Patched with DosDude Mojave Patcher 1.3.3) MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09") Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 6 developed by @Dr. Hurt and compiled by @bronxteck), not the original version), USBInjectAll (with custom SSDT-UIAC), VoodooSDHC.kext (configured as shown here). Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext) CLOVER (Legacy): R4961  
      Configuration items that may be different from what you have seen in other E6410 configurations
      Addition of _OFF and _ON methods to _PTS and _WAK methods respectively (to control discrete graphics in order to enable sleep/wake) LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2 ECDV renamed to EC so that AppleBusPowerController loads AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states) DSDT patched to include HDAU device (device-id 0x0be3)  
      What is NOT working:
      Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings. Graphics Power Management - AGPM loads (because 10de,0a29 device is injected), but there's no evidence that 3100m frequency and voltage is changing.
        What is NOT tested:
      Smartcard Reader eSata (I have this disabled in my BIOS) Firewire Port (it does appear in the Network settings, just haven't tried it) Microphone Jack PC Card Slot (I have this disabled in my BIOS)  
      What IS working:
      SLEEP IS WORKING! Everything else not mentioned above.   Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long Shutdown is fast Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher) Brightness (adjusted with brightness keys on keyboard) works perfectly Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext. Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext) Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout." Ethernet port (with IntelMausiEthernet.kext) Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext) Optical Drive External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: here) for working external VGA display. Headphone jack Display Port (tested using DP > HDMI adapter) Camera SD Card Reader  
      Known issues and their solutions (These issues have all been resolved, with the solutions incorporated into the attached config files.  The issues are listed here for historical purposes and no further work is needed unless stated otherwise).
      Laptop does not sleep on lid close.  Solution is to add Notify (LID0) code to Method (BTNV) in the DSDT.  This is solved in the attached DSDT. Leaving this for historical purposes, but the CLOVER USBFix is no longer necessary after finding that I had incorrectly applied the DSDT _DSM patch for Device (EHC1).  The CLOVER USBFix is not needed after fixing the DSDT..  AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  Thank you, @feartech, for this tip. ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement.  I've implemented and tested this on my system.  The ALPS version of VoodooPS2Controller.kext mixes up a few keys.  Need to switch the Command and Option keys (System Preferences > Keyboard > Modifier Keys) and change keyboard type to ISO European. This configuration (captured in the attached config files) uses an injected device-id (10de,0a29) for NVidia 3100m to get AGPM to load.  While I haven't observed any performance differences, a better approach may be to inject AGPM properties for device 10de,0a6c (the actual device-id for the 3100m).  This AGPM method is discussed later in this thread.  I have briefly tested this "FakeSMC.kext method" for injecting AGPM attributes without any noticeable changes in laptop/graphics behavior. IOHWControl is not loaded under AGPM (Should be AGP > VID > NVDA,Display-A@0 > NVDATesla > AGPM > gpu-control > IOHWControl as viewed in IORegistryExplorer).  It is loaded on a real MacBookPro6,2 running Mojave and is loaded on this Dell Latitude E6410 running High Sierra.  If I "Inject NVidia" via CLOVER, IOHWControl loads properly. The Dell Latitude DSDT (BIOS A17) has a bug in Method (GNOT).  In the method, the expression  If (LOr (LGreater (OSYS, 0x07D0), LLess (OSYS, 0x07D6))) always evaluates to TRUE, so the patched DSDT has no dependency on the value of OSYS.  I suspect that LOr should be replaced with LAnd, so that this expression is TRUE for variants of Windows 2001 and False for any other OS.  While this may have no affect on MacOS, it makes one wonder how such an obvious bug made it through Dell QA and is still present in BIOS A17.  Also makes one wonder whether the sleep problem (which no one has solved) was fixed in Windows to address another DSDT bug. The assigned value of ACOS and OSYS in the DSDT are conditional on the operating system.  There is no condition for "Darwin."  The solution is to add a condition for "Darwin" (making it equivalent to one of the defined operating systems (e.g. Linux, Win7, etc).  The attached config hard-codes ACOS and OSYS values equivalent to those for Linux.  Another way to handle this (different from the method employed in the attached config files) might be to override _OSI with XOSI (defined in a custom SSDT). The portType of the Internal Bluetooth device is portType=0 which, according to Rehabman's comments in SSDT-UIAC-All.dsl, is an external USB 2 port.  This should be an internal USB port (portType=2).  I learned through trial and error that the HUB1 and HUB2 definitions in Rehabman's SSDT-UIAC-ALL.dsl apply to the ports on the EHCx USB hubs.  The solution is to include the HUB1 definition in SSDT-UIAC.dsl and change portType to 2 for HP15.  This change doesn't appear to affect/fix sleep, but it may prevent instant wake if we get sleep working. There are minor differences between a real MacBookPro6,2 IORegistry dump and this HackBookPro6,2 IORegistry dump that can be resolved with simple DSDT edits.  I am now running with these changes, but haven't found these changes to make any difference in operational behavior.
      Rename Device (AC) -> Device (ADP1) Remove UID from Device (HPET) Add compatible ID "PNP0C01" to Device (HPET) Change ADP1:_STA from 0x0F to 0xFFFFFFFF Enable Ambient Light Sensor and renamed to Device (ALS0) from Device (ALS) Add compatible ID "smc-als" to ALS0 Rename LID -> LID0 Change "name" definitions to Buffers in _DSM methods Rename Device (PBTN) to PWRB Rename Device (SBTN) to (SLPB) Change HDAU.hda-gfx from "onboard-1" to "onboard-2" Change GFX0.hda-gfx from "onboard-1" to "onboard-2" Sleep / Wake does not work with the basic DSDT edits.  I have discovered that Sleep / Wake can be made to work by adding discrete graphics _OFF and _ON methods to _PTS and _WAK methods respectively (borrowed the concept and code from a working E6430 DSDT: Credit here: https://osxlatitude.com/forums/topic/9248-working-sleep-on-intel-hd-and-nvidia-nvs-on-dell-latitude-e6430-optimus-enabled-or-disabled/page/6/. The Clover boot arg should be changed to "darkwake=0" for reasons explained by @holyfield in this thread.  Leaving this for historical purposes: LCD screen is blank when waking laptop by opening lid (screen is not blank when waking with power button).  Solution is to add darkwake=8 to CLOVER boot args.  Thank you @Hervé for this tip.  
      Brief Installation Guide:
      Configure BIOS (version A17) as follows (leave default unless listed here): Boot Sequence: USB, Internal HDD, CD/DVD, Modular Bay HDD; Boot List Option: Legacy; Integrated NIC: Enabled; Parallel Port: Disabled; Serial Port: Disabled; SATA Operation: AHCI; Misc Devices: Enable Modular Bay, Camera, External USB, Microphone, Media Card and 1394; Latitude ON Reader: Disabled; Keyboard Illumination: Auto ALS and Input; Ambient Light Sensor: Enabled; OROM Keyboard Access: Disable; TPM Security: Disable; Computrace: Deactivate; CPU XD Support: Enable; Performance: Enable all options; Power Management: Disable Wake on AC, Disable Wake on LAN/WAN, Express Charge: Standard, Charge Behavior: Enabled; Keypad: Fn Key Only; Mouse/Touchpad: Touchpad/PS-2 Mouse; USB Emulation: Enable Legacy; Fn Key Emulation: Disabled; Fastboot: Thorough; Virtualization: Enable Intel Virtualization, Disable VT for Direct I/O, Disable Trusted Execution; Wireless Switch: Bluetooth and WLAN; Wireless Device Enable: Bluetooth and WLAN;  Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh). Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist Install MacOS to your SSD.  When you run DosDude's Mojave Patcher, DO NOT install LegacyUSBInjector.kext - you're going to use Rehabman's USBInjectAll.kext.  Also, do not install the DosDude SIP kext (you're using CLOVER to manage SIP). Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original), VoodooSDHC.kext (configured as shown here). Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys).  Also change keyboard type to ISO European to fix the [ ` ~ ] key (to the left of the "1" (one) key. Install VoodooHDA Install HWMonitor application  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z After applying Mojave updates, HWMonitor may not display discrete graphics attributes.  On systems with multiple displays, a second (or third display) may not be active after applying the Mojave update.  The solution to this is to run "sudo kextcache -i /" (in a terminal window) and reboot.  This will usually fix the issue.  If the issue is not fixed, run DosDude's Post Install Utility, apply the Legacy Graphics Patch, reboot and then run "sudo kextcache -i /" if necessary.  
      Credits
      In addition to those mentioned in this first post and in subsequent posts in this thread, much of this solution for the Latitude E6410 was made possible by the numerous contributions of @RehabMan.  I hope he's doing well, wherever he is.  Hopefully he has long since forgotten what a PIA I was (and still am) as I was (and still am) learning hackOS.  
       
       


      E6410-Mojave-6v3.zip
    • By headkaze
      English: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md
      Russian: https://www.applelife.ru/threads/intel-hd-graphics-3000-4000-4400-4600-5000-5500-5600-520-530-630.1289648/
      Chinese: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.cn.md
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9600K, 9700K, 9900K, 9900KS
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 04/02/2020
      EFI Update - 04/02/2020 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
      AG Clover Z390 Master Navi Vega EFI.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      AG Clover Z390 Master Polaris EFI.zip - RX5XX Polaris DSDT EFI
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - OpenCore No DSDT and Done the way OpenCore intended it (04/02/2020)
       

      Alternative EFI 2 - N-D-K Fork of OpenCore (04/02/2020)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      Catalina 10.15.3 - Windows 10
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) No problem so far ASUS HyperKit with a KINGSTON NVMe SSD - 250 GB  
      What is not working:
      -  
       
      Not tested:
      VideoProc says that Hardware Decoding\Encoding is fully supported and enabled on both HD 530 and RX 5700 but I didn't test it Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: Primary Display: Auto iGPU Multi-monitor: Enabled RC6(Render Standby): Enabled DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: Intel SpeedStep: Enabled CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5098): Click here -> ASUS-Z170_catalina.zip  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:
       

       




       
       
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Notes:
       
      2020.02.11: Updated to 10.15.3 -> No problem when/after installing
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
×