Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave / Catalina on mobos Serie 100 / 200 / 300 / SkyLake / KabyLake / CoffeeLake DSDT

5,393 posts in this topic

Recommended Posts

Advertisement
11 hours ago, MaLd0n said:

is a very strange, i don't have idea

BTW, what did you do to fix the Shut Down issue?

Edited by zzmadd

Share this post


Link to post
Share on other sites
7 hours ago, ryanonit said:

Hi MaLd0N.

I am a very noob on Hackintosh so I tried to follow a build for people's recommendation.

My spec is

Gigabyte Z370 Aorus Gaming 7

8700K

Samsung NVME 960 Pro 512GB

Crucial DDR4 2133 8GB x 2

ASUS AC68 Wifi

Corsair HX850 Powersupply

Cooler Master LiquidMaster 280 Pro

3TB WD & Seagate Sata HDD

Samsung 840 Pro 250GB

 

BIOS SETTINGS

Fast Boot : Disabled

PAN PXE Boot Option ROM : Disabled

Storage Boot Option Control : UEFI

Trusted Computing -> Security Device Support : Disabled

Network Stack : Disabled

Legacy USB Support : Auto

XHCI Hand-off : Enabled

Wake on LAN : Disabled

Vt-d : Disabled (Enable it?)

IOAPIC 24-119 : Enabled

Integrated Graphics : Enabled ( Disable it?)

 

 

I just copied and pasted someone's EFI folder and somehow it works

but it is a bit laggy

RAM is 16GB but show as 32GB

Also can I delete 'Install from HACKINTOSH(My HDD name)' option from booting?

I tried to attach but file is bigger than 10MB so I created a link to download.

https://www.dropbox.com/s/17jh1v39o1h6lfu/EFI.zip?dl=0

Would you please have a look?

 

Thank you.

u need post a ful dump, check first post

Share this post


Link to post
Share on other sites

 

Wow, thanks for all you do Maldon!

GA-Z170ZP-SLI, i5-6700k, Asus RX460 4gb working perfectly 10.13.4 thanks to this wonderful guide! Only issue is USB 3.0 is not working, only USB 2.0. Wondering if you can help? I have attached my clover and RunMe results.

Thanks Maldon!!!!!!

Clover
https://drive.google.com/file/d/11o3VUUV7_iZTVNjRf-lqHOzK_XBYHSHu/view?usp=sharing

RunMe Results
https://drive.google.com/file/d/11AYox5CIqLfbI9l9Zl7dM0bcq-tc6O7B/view?usp=sharing

 

Edited by bocajoe

Share this post


Link to post
Share on other sites
14 minutes ago, bocajoe said:

 

Wow, thanks for all you do Maldon!

GA-Z170ZP-SLI, i5-6700k, Asus RX460 4gb working perfectly 10.13.4 thanks to this wonderful guide! Only issue is USB 3.0 is not working, only USB 2.0. Wondering if you can help? I have attached my clover and RunMe results.

Thanks Maldon!!!!!!

Clover
https://drive.google.com/file/d/11o3VUUV7_iZTVNjRf-lqHOzK_XBYHSHu/view?usp=sharing

RunMe Results
https://drive.google.com/file/d/11AYox5CIqLfbI9l9Zl7dM0bcq-tc6O7B/view?usp=sharing

 

need a new patch

com.apple.driver.usb.AppleUSBXHCI

837D940F 0F839704 0000

837D940F 90909090 9090

USB 10.13.4+ by PMHeart

10.13.x

Share this post


Link to post
Share on other sites
3 hours ago, MaLd0n said:

need a new patch

 

837D940F 0F839704 0000

837D940F 90909090 9090

USB 10.13.4+ by PMHeart

10.13.x

Thank you Maldon.

Not sure if I did it right... but I opened my config.plist in clover configurator and copied and pasted 

837D940F 0F839704 0000

837D940F 90909090 9090

USB 10.13.4+ by PMHeart

10.13.x

in com.apple.driver.usb.AppleUSBXHCI (see pic below). I also checked and unchecked infoPlistPatch but still no USB 3.0. Any ideas? I attached my config.plist if it helps.

Specs: GA-Z170XP-SLI, i5-7600k, Asus RX460 4GB, 17,1 SMBIOS

Screen Shot 2018-03-30 at 7.52.45 PM.png

config.plist.zip

Edited by bocajoe

Share this post


Link to post
Share on other sites
19 hours ago, MaLd0n said:

u need post a ful dump, check first post

How do I get full dump?

Please let me know how I get it.

Edited by ryanonit

Share this post


Link to post
Share on other sites
18 minutes ago, ryanonit said:

How do I get full dump?

Shutdown your PC, turn on and press F4 key when you watched the Clover bootloader screen. Then mount the EFI partition and go to /EFI/EFI/CLOVER/ACPI/origin/ put this folder on a .zip file and post it here.

Share this post


Link to post
Share on other sites

Hackintosh Specs:

GA-Z270X Ultra Gaming MB

i7-7700K @ 4.8Ghz

32 GB Crucial Ballistix DDR4 Ram

Gigabyte Aorus GTX 1080Ti 11 GB

1 TB Samsung 960 EVO NVME Drive - MacOS 

1 TB Samsung 850 EVO SSD- Storage

3 TB WD Black- Time Machine Backups

Broadcom Wifi/BT Card BCM94360CD

EVGA Supernova G3 850 W PSU

Corsair H100i v2 Water Cooler

MaLd0n  I wanted to know if a DSDT could be created for my system board mainly for additional stability. 

SendMe results

https://www.dropbox.com/s/5m5srk2k5mz8hg4/Send me Seans-Hack-Pro.zip?dl=0

Config plist attached as well

Thank you in advance.

config.plist

Edited by rob88v

Share this post


Link to post
Share on other sites
16 hours ago, bocajoe said:

Thank you Maldon.

Not sure if I did it right... but I opened my config.plist in clover configurator and copied and pasted 

837D940F 0F839704 0000

837D940F 90909090 9090

USB 10.13.4+ by PMHeart

10.13.x

in com.apple.driver.usb.AppleUSBXHCI (see pic below). I also checked and unchecked infoPlistPatch but still no USB 3.0. Any ideas? I attached my config.plist if it helps.

Specs: GA-Z170XP-SLI, i5-7600k, Asus RX460 4GB, 17,1 SMBIOS

Screen Shot 2018-03-30 at 7.52.45 PM.png

config.plist.zip

extract original tables with F4 key in clover boot screen and run my app after it, send me files

Share this post


Link to post
Share on other sites
3 hours ago, rob88v said:

Hackintosh Specs:

GA-Z270X Ultra Gaming MB

i7-7700K @ 4.8Ghz

32 GB Crucial Ballistix DDR4 Ram

Gigabyte Aorus GTX 1080Ti 11 GB

1 TB Samsung 960 EVO NVME Drive - MacOS 

1 TB Samsung 850 EVO SSD- Storage

3 TB WD Black- Time Machine Backups

Broadcom Wifi/BT Card BCM94360CD

EVGA Supernova G3 850 W PSU

Corsair H100i v2 Water Cooler

MaLd0n  I wanted to know if a DSDT could be created for my system board mainly for additional stability. 

SendMe results

https://www.dropbox.com/s/5m5srk2k5mz8hg4/Send me Seans-Hack-Pro.zip?dl=0

Config plist attached as well

Thank you in advance.

config.plist

CLOVER.zip

Share this post


Link to post
Share on other sites

MaLd0n Hello! I added his BCM943602CS Broadcom Wireless WiFi Card do I need to change something in the DSDT?   For some reason, was off a very long and appeared hanging system! And I can not raise HD630, IQSV  does not work do not know what it can be the result of something messed up can be ! :wallbash:Can I ask you to look at my files? Sorry for my bad english!!:blush::(

Share this post


Link to post
Share on other sites
11 hours ago, MaLd0n said:

extract original tables with F4 key in clover boot screen and run my app after it, send me files

Hello Maldon! And thanks for taking the time to help. Below is my results of RunMeApp for my problem with USB 3.0 not working in 10.13.4.

https://drive.google.com/file/d/15rjjUGOtbzLO0Bz6x2NSagNCcAfTj2O3/view?usp=sharing

Specs: GA-Z170ZP-SLI, i5-6700k, Asus RX460 4gb

Edited by bocajoe

Share this post


Link to post
Share on other sites
44 minutes ago, bocajoe said:

Hello Maldon! And thanks for taking the time to help. Below is my results of RunMeApp for my problem with USB 3.0 not working in 10.13.4.

https://drive.google.com/file/d/15rjjUGOtbzLO0Bz6x2NSagNCcAfTj2O3/view?usp=sharing

Specs: GA-Z170ZP-SLI, i5-6700k, Asus RX460 4gb

take a shot

DSDT.aml.zip

use usb patch limit port for 10.13.4

Share this post


Link to post
Share on other sites
6 hours ago, p4antonio said:

Hello MaLd0n

can you check if the EFI is well created?

thank you.

PC configuration: Pentium 4560 / GA-B250M-DS3H  / Ram 2x8Gb DRR4 2400Mhz / Asus gtx 660 ti 2gb.

installed:OS X 10.12.6 (16G29).

I am attaching you to RunMe.

https://drive.google.com/open?id=1avdABvxnG6rqymjeM5uHs3e6bCW93l71

http://www17.zippyshare.com/v/85WBmV4t/file.html
 

10 hours ago, alex9440 said:

MaLd0n Hello! I added his BCM943602CS Broadcom Wireless WiFi Card do I need to change something in the DSDT?   For some reason, was off a very long and appeared hanging system! And I can not raise HD630, IQSV  does not work do not know what it can be the result of something messed up can be ! :wallbash:Can I ask you to look at my files? Sorry for my bad english!!:blush::(

just plug

Share this post


Link to post
Share on other sites
10 hours ago, MaLd0n said:

take a shot

DSDT.aml.zip

use usb patch limit port for 10.13.4

Thank you Maldon. I tried your DSDT and USB 3 NOW WORKS!!!!!!!!!!!

The only other issue I am having is when the computer goes to sleep it will not wake by pressing a key on the keyboard or moving the mouse... but pressing the power button on the computer will wake the machine. I hope you can help.

I would like to PayPal you something for ALL the help you have given me and others, it is greatly appreciated!

I have attached my RunMe results and my EFI folder.

SPECS: GA-Z170XP-SLI, i5-6700k, Asus RX60 4GB Video Card, SMBIOS 17,1

EFI Folder: https://drive.google.com/file/d/1MtP8oNsFTT3PjKk93So3Fz_IMehacHIx/view?usp=sharing

Run Me Results: https://drive.google.com/file/d/1y2-qxmmb2Biz4RxbCVqigh4MtZkXtYGf/view?usp=sharing

Share this post


Link to post
Share on other sites
12 minutes ago, bocajoe said:

Thank you Maldon. I tried your DSDT and USB 3 NOW WORKS!!!!!!!!!!!

The only other issue I am having is when the computer goes to sleep it will not wake by pressing a key on the keyboard or moving the mouse... but pressing the power button on the computer will wake the machine. I hope you can help.

I would like to PayPal you something for ALL the help you have given me and others, it is greatly appreciated!

I have attached my RunMe results and my EFI folder.

SPECS: GA-Z170XP-SLI, i5-6700k, Asus RX60 4GB Video Card, SMBIOS 17,1

EFI Folder: https://drive.google.com/file/d/1MtP8oNsFTT3PjKk93So3Fz_IMehacHIx/view?usp=sharing

Run Me Results: https://drive.google.com/file/d/1y2-qxmmb2Biz4RxbCVqigh4MtZkXtYGf/view?usp=sharing

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Hi MaLd0n, good news, since updating to 10.13.4 no more freezing, I changed my SMBIOS to 18,2. Since updating though, I notice today I have USB port problem. I tried implementing fix, but it does not recognize an external Pioneer BDL drive that my MBP sees or an external drive, this is plugging into USB ports at the front of the tower, rear do not work either. Here is a link to my clover folder.

https://www.dropbox.com/s/hpqefs6kwhv5oap/CLOVER.zip?dl=0

Thank you!

Share this post


Link to post
Share on other sites
4 minutes ago, ashman1970 said:

Hi MaLd0n, good news, since updating to 10.13.4 no more freezing, I changed my SMBIOS to 18,2. Since updating though, I notice today I have USB port problem. I tried implementing fix, but it does not recognize an external Pioneer BDL drive that my MBP sees or an external drive, this is plugging into USB ports at the front of the tower, rear do not work either. Here is a link to my clover folder.

https://www.dropbox.com/s/hpqefs6kwhv5oap/CLOVER.zip?dl=0

Thank you!

Arquivo Comprimido.zip

Share this post


Link to post
Share on other sites
5 hours ago, MaLd0n said:

Thank you Maldon. USB 3 still working great. As far as sleep goes with that DSDT when the computer goes to sleep it immediately powers itself back on. I researched it and I think its because of my Corsair H100i Liquid Cooler has a data cable that is causing it to wake it back up. I've read where you can disable the H100i port in a SSDT-UIAC but that is well beyond what I can do.

Ran a couple of test that show possible sleep issues:

  • pmset -g log: Idle sleep preventers: IODisplayWrangler
  • pmset -g assertions: IODisplayWrangler
  • log show --style syslog | fgrep "Wake reason”: XHC

I have my EFI and RunMe results below if that helps:

Specs: GA-Z170XP, i5-6700k, Asus RX460 4GB

EFI: https://drive.google.com/drive/folders/1YADUNBWtk37uSCclE17-ElV9HnEQmmMv?usp=sharing

RunMe Results: https://drive.google.com/file/d/1f5knq3Spenq5RfDzQQmDhyuDkMCqaTtW/view?usp=sharing

Edited by bocajoe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

  • Similar Content

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9600K, 9700K, 9900K, 9900KS
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Reference RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      Current EFIs 
      Updated 06/04/2020
      PLEASE NOTE - You MUST update to the latest Clover EFI before updating to 10.15.4 or you may find your unable to update.
       
      Clover EFI Updated 06/04/20 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
      Clover Z390 Master Navi Vega 19,1 EFI 060420.zip - Vega, Navi (5700, 5700XT etc), Radeon VII DSDT EFI
      Clover Z390 Master Polaris 19,1 EFI 060420.zip - R5xx Polaris DSDT EFI
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - OpenCore v0.5.7, No DSDT and Done the way OpenCore intended it (06/04/2020)
       

      Alternative EFI 2 - N-D-K OpenCore v0.5.7 (06/04/2020)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       

       

       

       

       

       

       

       
    • By MaLd0n
      Install MacOS with Olarila Image, Step by Step, Install and Post Install  
      https://www.olarila.com/topic/5794-hackintosh-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Install Sierra/High Sierra and boot into system!   Post Installation   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.GA H110M-S2.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By cixque
      CLOVER.zipCLOVER.zipDell Venue 11 Pro 7140
      ------------
      Specification
       
       
      Intel Core M 5Y71
       
      Intel HD Graphics 5300
       
      Intel Broadwell-U motherboard
       
      8GB Ram
       
      256GB SSD
       
      Dell DW1850e WWAN + GNSS GPS
       
      Intel Wireless 7265 + Intel Bluetooth
       
      NFC
       
       
      …..
       
       
       
       
       
      Mojave 10.14.6
       
      What works
      Native Power Manager (Generate Plugin type) Full Graphics with QE/CL Brightness (Add PNLF in Config.plist or DSDT Patch) — (Brightness slide bar) Touch Screen, and Pen (DSDT Patch + Voodoo I2C, I2CHID satellite KEXT) HDMI output with hot plug (Lilu + WhateverGreen) HDMI Audio with hot plug (Lilu + AppleALC) no Layout-id needed Front and Rear Cameras MicroSD slot - O2 Micro (I use Adding Arbitrary under Devices in Config file Method) Ref, Post #6 by Jake Jo https://osxlatitude.com/forums/topic/7346-applesdxc-driverdsdt-patch-for-o2-micro-sd-card-readers/ Battery Indicator (ACPIbattery by Rehabman) ——>To utilise both battery, SSDT (by Rehabman) is needed in order to combine 2 batteries as one.
      Travel Keyboard Dell K12a001 (USBinjectall KEXT) Native Keyboard keys (Brightness, volume keys) WWAN card Dell DW1850e (OOB) Bluetooth -------------------
       
      What doesn’t work
       
       
      Sleep Wake — I have no idea how to fix it as it is required DSDT patch I guess. GPS NFC Audio ---> Realtek I2S Audio (PG0.35 for DELL)
       
      In DSDT entries is HDAUDIO\\FUNC_01&VEN_10EC&DEV_0282&SUBSYS_00000000&REV_1000\ Which indicates ALC282
       
      Audio ALC3263 (As it shown in BIOS) - Broadwell rt286 - Card1/Codec#0 (Utilised in I2S Mode) there is nowhere in BIOS to change to HDA mode). Drop OEM HDA and Fix HDA don’t do anything, still show 3 HDMI Audio outputs. If there is a DSDT patch to force HDA Audio mode, Please do enlighten me.
      As a result Internal Speaker, Internal Mic, and Headphone Jack doesn’t work.
       
      Touchpad on Travel Keyboard Dell K12a001 (Should work with DSDT Patch with pin configuration) I have no idea how. Obviously, Intel Wireless 7265 AC. For experimental purpose. https://github.com/daliansky/XiaoMi-Pro-Hackintosh/issues/330 — Knock yourself out. I managed to get it work for awhile but the real problem is kernel panic so I gave up. Ordering compatible card instead. ------------------
       
      Config.plist got it from Rehabman laptop config.
       
       
      BIOS version A20
       
      Enable:
       
      - Legacy Boot Rom
       
      Disable:
       
      - Secure Boot
       
      - TPM 2.0
       
      - Vt-d
       
      ------------
       
      SMBIOS - I use MacBook8,1. —- MacBookAir7,1-7,2 (Min Freq is at 1.2 GHz) MacBookPro12,1 Min Freq is at 800 Mhz and it is the default this cpu should be. Again, there is a way to set it right somewhere in this forum.
       
      ------------
       
      -->> DSDT Windows 8 patch
       
      System sees only one I2C Controller which control Touch Screen.
      Touch Screen registers as Magic Trackpad 2.
      Pen as Mouse
       
      -->> DSDT Windows 8.1 Patch
       
      System sees two I2C Controllers which control Touch Screen and Accelerometer.
      Touch Screen registers as Magic Trackpad 2.
      Pen as Mouse
       
      OOO>>> With Windows 8.1 patch which it should run with this one because it can see more of HID devices and controllers.
       
      Problem is Accelerometer (SHUB).
      Device can automatically rotate screen as it should be BUT it flips the screen wildly even with slightly movement. It stops only when device stays completely still. Eventually it breaks internal screen graphic. It becomes grabble. I restored internal screen graphic by connecting it to external monitor and set rotation of external screen to 0 degree. Then it is back to normal. (I guess it conflict with rotation setting) I disable SHUB in DSDT.
       
      ---------------------
       
      During Installation process Full Graphic acceleration can be activated straight away by Lilu and Whatevergreen. AppStore, iMessage and, FaceTime activate by NullEthernet and SSDT by Rehabman USBInjectAll needed for keyboard and other usb peripherals. Use other tool to keep certain ports active as Rehabman mention this KEXT is not good for a long run. Please do Correct me if I did something worng. Or any suggestions to make this thing runs better.
      CLOVER.zip
      IOReg_SysReport.zip
    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      Catalina 10.15.4 - Windows 10
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) No problem so far ASUS HyperKit with a KINGSTON NVMe SSD - 250 GB  
      What is not working:
      -  
       
      Not tested:
      VideoProc says that Hardware Decoding\Encoding is fully supported and enabled on both HD 530 and RX 5700 but I didn't test it Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: Primary Display: Auto iGPU Multi-monitor: Enabled RC6(Render Standby): Enabled DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: Intel SpeedStep: Enabled CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5107): Click here -> asus-z170_clover_5107.zip  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:
       

       




       
       
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Notes:
       
      2020.03.26: Updated to 10.15.4 -> Updated WhateverGreen, Lilu -> Updated Clover to v5107
      2020.03.23: Removed "EmuVariableUefi.efi" -> deleted, caused false nvram map, now it's native, updated Clover to v5106
      2020.02.11: Updated to 10.15.3 -> No problem when/after installing
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
×