Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave / Catalina on mobos Serie 100 / 200 / 300 / 400 SkyLake / KabyLake / CoffeeLake / CometLake DSDT

5,426 posts in this topic

Recommended Posts

if u use HighSierra, check patch usb in config.plist for HS

attachicon.gifCLOVER.zip

why u dont use on the fly patch instead terminal command? :|

 

just remove _prw from devices, is a very old problem and patch

attachicon.gifCLOVER.zip

attachicon.gifCLOVER.zip

attachicon.gifCLOVER.zip

attachicon.gifDSDT.leeroye.zip

 

Thanks for your reply Mald0n, first time I put your DSDT and after reboot I was stucked on the first lines with the symbols: ++++++++++++++++++++++++++++++++++++++

 

Later, I try to "replicate" your configurations one by one and doing some reboots. Now seems that all works well, but I don't see too much difference between with DSDT and w/o DSDT. Could you post the changes that you made? and... Is there any way to check fixes of DSDT? I mean, for example, sleep/wake are not working at the moment.

Share this post


Link to post
Share on other sites
Advertisement

Hi MaLd0n,

Thanks for the new Clover folder, but there was no change, the video coming from the monitor after 50% is cut off when mac-os is loading.

 
I replaced the bootx64.efi file in my old clover 4184 folder. I can do normal boot like this, otherwise I can not get display without doing nv_disable = 1.

Share this post


Link to post
Share on other sites

Thanks for your reply Mald0n, first time I put your DSDT and after reboot I was stucked on the first lines with the symbols: ++++++++++++++++++++++++++++++++++++++

is a clover driver, use OsxAptioFixDrv-64.efi or 2

 

u need to check what probvelm cause sleep fail

log show --style syslog | fgrep "Wake reason"

 

Hi MaLd0n,

 

Thanks for the new Clover folder, but there was no change, the video coming from the monitor after 50% is cut off when mac-os is loading.

 
I replaced the bootx64.efi file in my old clover 4184 folder. I can do normal boot like this, otherwise I can not get display without doing nv_disable = 1.

 

use search forum for video problem in sierra 10.12.6

Share this post


Link to post
Share on other sites

use voodoohda

is not a solution ... sound have a delay ... strange is how it is change ...when is on hdmi , when on dp ... 

Share this post


Link to post
Share on other sites

is not a solution ... sound have a delay ... strange is how it is change ...when is on hdmi , when on dp ... 

yes

the problem is web driver, if u use serie 9xx nvidia e.g, work perfect

read about it

Share this post


Link to post
Share on other sites

is a clover driver, use OsxAptioFixDrv-64.efi or 2

 

u need to check what probvelm cause sleep fail

log show --style syslog | fgrep "Wake reason"

use search forum for video problem in sierra 10.12.6

 

The log is empty. I click on the sleep, the computer sleeps well and later, I click on the mouse but the computer doesn't wake (black screen and finally, it restarts).

 

About .efi files, I have OsxAptioFixDrv-64 and OsxAptioFix2Drv-64 on the same folder because someone tell me that Clover takes only one and not cause any problem. Is it right?

 

Thanks Mald0n!  :)

Share this post


Link to post
Share on other sites

Hi,

 

I am trying to to resolve my sleep/wake issue on HS (17A405) and I am falling to get a DSDT which works. 

 

My sleep/wake is intermittent, sometime it works but more often than not, when the OS goes to sleep, the machine stays on ( I can hear the fan, the case light are on...) but the display is off and it's impossible to wake the rig. 

 

Beside this issue everything works, Audio, graphic with 2x GPU SLI mode, ethernet (no wifi), USB3. CPU (ssdt generated) 

 

Can anybody help me to get a DSDT for my system?

 

As suggested by MaLd0n in the first post, I have attached my clover order  and the IOREG  Run it output. 

 

Cheers Guys!!

 

 

 

-----------------------------------------------------------------------------------------------------------

 

Asrock Z270 Super Carrier //  i7 7700k @ 4.2Ghz // 2x NVIDIA GeForce GTX 1080 8 GB (SLI) // Crucial MX300 1TB SSD

Send me Mourrr iMac.zip

CLOVER.zip

Share this post


Link to post
Share on other sites

The log is empty. I click on the sleep, the computer sleeps well and later, I click on the mouse but the computer doesn't wake (black screen and finally, it restarts).

 

About .efi files, I have OsxAptioFixDrv-64 and OsxAptioFix2Drv-64 on the same folder because someone tell me that Clover takes only one and not cause any problem. Is it right?

 

Thanks Mald0n!  :)

check in boot what driver clover use, use only one

 

sleep problem, try with darkwake options

Hi Mr Maldon,

 

Thank you really for your help and your knowledge, my DSDT is perfect one my hackintosh, thank you again :thumbsup_anim:

Welcome

Enjoy

Hi,

 

I am trying to to resolve my sleep/wake issue on HS (17A405) and I am falling to get a DSDT which works. 

 

My sleep/wake is intermittent, sometime it works but more often than not, when the OS goes to sleep, the machine stays on ( I can hear the fan, the case light are on...) but the display is off and it's impossible to wake the rig. 

 

Beside this issue everything works, Audio, graphic with 2x GPU SLI mode, ethernet (no wifi), USB3. CPU (ssdt generated) 

 

Can anybody help me to get a DSDT for my system?

 

As suggested by MaLd0n in the first post, I have attached my clover order  and the IOREG  Run it output. 

 

Cheers Guys!!

 

 

 

-----------------------------------------------------------------------------------------------------------

 

Asrock Z270 Super Carrier //  i7 7700k @ 4.2Ghz // 2x NVIDIA GeForce GTX 1080 8 GB (SLI) // Crucial MX300 1TB SSD

ASROCK have serious problem with sleep

CLOVER.zip

Thanks Maldon works fine on the Machine

Welcome!

Enjoy!

Share this post


Link to post
Share on other sites

check in boot what driver clover use, use only one

 

sleep problem, try with darkwake options

 

I deleted OsxAptioFixDrv-64.efi

Also, I tried all the darkwake flags, and with darkwake=1/2/8 wake works but without graphics acceleration and with some black rendering. I attached a video for you.

 

Really thanks for your replies, I will send you some beers soon for this help  :wink_anim:

darkwake-video.zip

Share this post


Link to post
Share on other sites

Hi Sir MALDON

 

My Specs

 

Laptop

 

Acer Aspire ES 15 ES1-572-321G (core i3 7100u)

 

intel HD 620

 

Ram 4GB DDR4 2400mhz 

 

1tb hard drive sata

 

Usb not booting acpi and usb errors
 

 

iam installing Mac os Sierra 10.12.5 plz help me
 

under clover/acpi/origin DSDT and SSDT

 

my CLOVER>zip Attached

 
 
 

CLOVER.zip

Share this post


Link to post
Share on other sites

Hey there, MaLd0n!

 

So I am trying to disable my discrete graphics on my high sierra install since I am unable to boot into it with my discrete card plugged in. Taking out my card every time I want to boot into Windows isn't an ideal situation :P

 

I am currently using a mish mash of things which can be found in my attachment.

 

My questions are: With the DSDT I downloaded from here - do I need all of the patches inside of config.plist? Did I even stick the DSDT in the right spot? (/EFI/Clover/ACPI/Patched) How would I go about disabling my discrete graphics card?

 

Thanks!

 

MB: GA-Z270X-Gaming K5, Proc: i7 7700K, iGFX: Intel 630, dGFX: XFX Radeon R9 390

Share this post


Link to post
Share on other sites

Hi Mald0n,

 

I need a new DSDT I think, I tried to patch myself but since I updated my BIOS but the online patches are no longer available. I never really got the onboard audio working and used USB instead, hopefully you can help, I attached the Send me files.

 

Thanks!

Send me hayaku.zip

Share this post


Link to post
Share on other sites

check in boot what driver clover use, use only one

 

sleep problem, try with darkwake options

Welcome

Enjoy

ASROCK have serious problem with sleep

attachicon.gifCLOVER.zip

Welcome!

Enjoy!

Thanks MaLd0n, yeah gave it a go, no joy! seems I gonna have to invest in a Gigabyte board! 

Share this post


Link to post
Share on other sites

 

First...
If you need DSDT edits for SkyLake, KabyLake or Coffee Lake...
-Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen)
-Post Ioreg, extract with Ioreg Explorer
-Run it, post files generate in your desktop
Installation
 
--Create a bootable copy of macOS Sierra
Check out the link
 
--Create a bootable copy of macOS HighSierra
Check out the link
 
--Install Clover in USB stick
 
--Replace with my Clover folder 
 
--Install Sierra/High Sierra and boot into system!
Post Installation
 
--Install Clover in SSD and replace with my folder
 
*Check USB port limit patch in config.plist
 
--Reboot and activate video!
 
-Nvidia WebDriver Sierra
-Nvidia WebDriver High Sierra
-Cuda
 
Bingo!
 
My mobo is Gigabyte GA Z270 Gaming K3, if you have other mobo, post your files here, i apply all patches for you! Read above! 
--DSDT mobo GA Z270 Gaming K3
My DSDT with patches for KabyLake
 
Patches
-FIX ERRORS AND WARNINGS
-HPET
-SATA
-DMAC
-SLPB
-DARWIN
-LPC
-XHCI
-PLUGIN TYPE
-HDAS to HDEF
-HDEF
-RTC
-IRQs
-SBUS
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-LAN
-USBX
-PMCR
-IMEI
-EC
-PNLF
-HDMI NVIDIA / ATI
--SSDT
Generate your SSDT for PM, use ssdtPRGen by Piker-Alpha
run in terminal
curl -o ~/ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/Beta/ssdtPRGen.sh
chmod +x ~/ssdtPRGen.sh
sudo ~/ssdtPRGen.sh
 
--install Lan driver by Mieze
 
-Atheros
 
-Intel
 
-Realtek
 
--Links
 
-Audio
 
-USB
 
It's time to Rockattachicon.gifguitar.gif
 
-Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
 
Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!
 
We're all here to have fun and learn from each other!
 
ENJOY!

 

hello mald0n can you help me to fix my dsdt and ssdt, and I got a problem to disable Nvidia , this is my clover, ioreg, and zip from runme,app 

thank you mald0n

Robby's MacBook.zip

Share this post


Link to post
Share on other sites

Hello MaLd0n,

 

I'm with a GA z270X UD5 + i7700 + Nvidia 1030.

Get a lot of problems with sleep/wake, slow boot.

Tried to patch DSDT myself with no luck ... just want to optimize my Hackint0sh to be quicker and more realiable than my 7 years old iMac:-)

 

Can you have a look at my attached files,

 

Thks a lot,

 

Cheers,

Greg

Send me Greg’s iMac.zip

ssdtPRGen.zip

Clover.zip

Share this post


Link to post
Share on other sites

Hi Mald0n,

 

I need a new DSDT I think, I tried to patch myself but since I updated my BIOS but the online patches are no longer available. I never really got the onboard audio working and used USB instead, hopefully you can help, I attached the Send me files.

 

Thanks!

need untouched DSDT

hello mald0n can you help me to fix my dsdt and ssdt, and I got a problem to disable Nvidia , this is my clover, ioreg, and zip from runme,app 

thank you mald0n

Check ur ioreg

I think in RP01/PEGP

Check

SSDT-Disable_DGPU.aml.zip

Share this post


Link to post
Share on other sites

Hello MaLd0n,

 

I'm with a GA z270X UD5 + i7700 + Nvidia 1030.

Get a lot of problems with sleep/wake, slow boot.

Tried to patch DSDT myself with no luck ... just want to optimize my Hackint0sh to be quicker and more realiable than my 7 years old iMac:-)

 

Can you have a look at my attached files,

 

Thks a lot,

 

Cheers,

Greg

Clover.zip

Hi MaLd0n,

 

Thank you for starting this helpful thread and taking the time to help others. Would you be so kind and have a look at my DSDT and SSDTs. Any help would be highly appreciated. My Specs are:

MB: GA-Z270N-WIFI

CPU: Core i7 7700

GPU: 1030GT

 

Thanks!

CLOVER.zip

Used 200//MOBO EFI FOLDER.

 

Hangs On Apple Logo.

 

Please Help . I Have Updated my signature :)

Use -v and post a photo

Share this post


Link to post
Share on other sites

Hi Mald0n,

 

Sorry about that, I have attached the clover/acpi/origin folder it should be what you need, I checked the DSDT and it looks like original.

 

Thanks  :lol:

shazeal.zip

sorry. but this error is coming.

 

NDVgBJvg.jpg

what system version? what smbios?

Share this post


Link to post
Share on other sites

Hi Sir MALDON

My Specs

Laptop

Acer Aspire ES 15 ES1-572-321G

(core i3 7100u)

intel HD 620

Ram 8GB DDR4 2400mhz 

1tb hard drive sata

 

Usb not booting acpi and usb errors

 

iam installing Mac os Sierra 10.12.5 plz help me
 

under clover/acpi/origin DSDT and SSDT

 

my CLOVER.zip Attached

CLOVER.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9400K, 9600K, 9700K, 9900K, 9900KS (All KF Models work but use SMBios iMacPro1,1 instead)
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, RX 5500, 5500 XT, 5600, 5600 XT, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Reference RX 5700 XT (connected to the monitor via the DisplayPort)
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO Plus 1TB NVMe SSD macOS Catalina 
      • Samsung 970 EVO 1TB NVMe SSD Windows 10 Pro
      • ABWB BCM94360CS2 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11e or Higher to use any of these EFI's, The DSDT is not designed for any other Bios revision
      Z390AORUSMASTER.zip  - Aorus Z390 Master Bios Firmware F11e 
       
      CLOVER & OPENCORE EFIs 
      Current EFIs Updated 04/08/2020
       
       
      Clover EFI Update v5120 - 04/08/2020 - Use with Bios revision F11e or Higher Only or Replace with the older F11c/F10 DSDT if you don't want to update the bios
       
      EFI Clover VEGA Navi 030820.zip - Vega, Navi (5700, 5700XT etc), Radeon VII DSDT SMBios 19,1 EFI
      EFI Clover Polaris NVIDIA 030820.zip - RX500 Polaris Series (RX590, 580, 570 etc) SMBios 19,1 EFI
       
      Please Note - I have now set KernelPM to No as standard so if you don’t have a unlocked MSR or not using my MSR Unlocked Bios Profile then go into the Clover Config.plist and set KernelPM to Yes or you won’t be able to boot up. An even better fix would be to unlock your MSR using my profile method.
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
       
       
      OpenCore EFI Update v0.6.0 - 04/08/2020
      Myself and @texem have now created a OpenCore EFI done the way the OpenCore Devs intended it to be made, There is no DSDT in use so you can use this EFI on any supported GPU and the SSDTs have been made so they will not be used in any other Operating System apart from MacOS.
       
      OpenCore 060 Z390 Master 19,1 030820.zip - OpenCore v0.6.0, SMBios iMac19,1
      OpenCore 060 Z390 Master 1,1 030820.zip - OpenCore v0.6.0, SMBios iMacPro1,1 (IGPU Disabled)
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
      Note 2 - Do not try to carry across your old OpenCore Config.plist to the new EFI as to many changes have occurred in 0.6.0 so please use the new Config.plist instead.
       
       
      PlistEdit Pro.zip - PlistEdit Pro (use to edit OpenCore)
       
      Using PlistEdit Pro add your details by modifying the following 

       
      PLEASE NOTE - These EFIs are setup to be used with your msr Unlocked so make sure you use the F11e Unlocked Profile but if for any reason you can not unlock MSR then just modify following in the OpenCore config.plist :
      
       
       
       
      CFG Unlock (MSR) F11e BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Z390AORUSMASTER.zip  - Aorus Z390 Master Bios Firmware F11e 
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11e)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled (Disabled If Using SMBios 1,1)
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       

       

       

       

       

       

       

       
       
    • By fusion71au
      Making a High Sierra USB Installer Entirely From Scratch in Windows
      This is a proof of concept tutorial, to show it's possible to create a vanilla High Sierra installer, entirely from scratch, in Windows (even without App Store downloaded "Install macOS High Sierra.app" from a real Mac ).  @PikeRAlpha's link to Apple's Software Catalog provides us with all the URLs necessary to download the needed files directly from Apple instead of some dubious source from the internet...
       

      Pre-Requisites
      8GB or larger USB drive.  Edit: Recommend 16GB or larger for macOS Catalina 10.16 Boot Disk Utility v2.1.2017rev021b from @CVAD TransMac (free 15 day trial) Paragon Hard Disk Manager Free Download Installer Files Directly from Apple
      1)  Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist (Hint - search page for "InstallESD" to find its URL and others nearby)

      to a folder named "SharedSupport" on your Windows NTFS drive.  A browser download manager (eg Chrono for Chrome, dTA for FireFox) is handy since InstallESD is >4GB ---> allows you to pause/resume interrupted download...

      2)  Rename InstallESDDmg.pkg to InstallESD.dmg
      3)  Edit InstallInfo.plist with WordPad/text editor to remove the chunklistURL and chunklistid keys for InstallESD, and renaming it from InstallESDDmg.pkg to InstallESD.dmg (example of edited file attached to this post)...
      Note:  You can verify the SHA1 checksum of your InstallESD.dmg and BaseSystem.dmg with the correct ones at this website.
      Boot Disk Utility to format the Installer USB and Restore OS X Base System HFS partition
      1.  Format USB with BDU & latest Clover ---> creates boot files in CLOVER partition + second FAT partition
      2.  Extract 4.hfs from \SharedSupport\BaseSystem.dmg with BDU --> save to it's local folder
      3.  Restore 4.hfs to USB second partition with BDU --->  2nd partition becomes bootable "OS X Base System"
      Paragon Hard Disk Manager to extend HFS Partition to its Full Extent
      Open Paragon Partition Manager Free and resize the second partition of the USB drive to the full size allowed.  Don't forget to apply the changes at the end...
      Transmac to Copy "SharedSupport" folder to OS X Base System
      1.  Open the TransMac program and navigate to the HFS+ Volume/Install macOS High Sierra.app/Contents folder.  Right click anywhere in the empty space on the RHS pane and select "Copy Here"...
      2.  In the next stage, select the "SharedSupport" folder we created above as the "Files and Folders to be copied to the Mac Volume"...
       
      Clover Settings
      Clover configuration is required now.  The default config.plist (in the Clover FAT32 partition of the USB) maybe sufficient to boot your machine if you’re lucky.  If not, the hackintosh-vanilla-desktop-guide has some good explanations on the various settings available and also offers sample configuration files based on CPU type.  Also, look at the Clover Wiki, Clover Instructions and Clover Configuration Thread for pointers and edit /EFI/Clover/config.plist accordingly with Wordpad or Notepad.
      The location of the important configuration files for Clover are summarized below
      config.plist--->EFI/CLOVER folder DSDT.aml with or without SSDT.aml--->EFI/CLOVER/ACPI/patched (don't need one if your DSDT is auto patched by Clover in config.plist) Kexts eg FakeSMC, NullCPUPowerManagement --->EFI/CLOVER/kexts/<osx version> or /Other. NB BootDiskUtility by default already has FakeSMC.kext installed here.  You may need to add VoodooPS2Controller for your laptop keyboard/trackpad to work. If UEFI booting, you will most likely need one of the OsxAptioFixDrv-64 drivers copied from /EFI/CLOVER/drivers-off/drivers64UEFI to /EFI/CLOVER/drivers64UEFI. If you want to use the installer to run High Sierra in Windows on VMware, you can follow my guide to set up the Virtual Machine and replace Clover's default config with EFI_Clover for VMware (which is compatible to run in VMware).  In the screenshots below, I have attached the USB Installer (in this case PhysicalDrive7) to my macOS Virtual Machine.  Reboot the system to the USB installer to install High Sierra ...
      What happens if we don't have access to TransMac or Paragon Hard Disk Manager?
      Not a problem, as long as we get "OS X Base System" bootable, we can launch terminal from the Utilities Menu to copy the SharedSupport folder over to the Installer app.  In essence, we will build the full installer app = 5GB+ on the target HD eg "Macintosh HD", by copying both the "small" installer app = 15MB (on "OS X Base System") and the SharedSupport folder from the NTFS volume (mounted in this example on /Volumes/DATA)...
      -bash-3.2# cd / -bash-3.2# cp -R Install\ macOS\ High\ Sierra.app /Volumes/Macintosh\ HD/ -bash-3.2# cp -R /Volumes/DATA/SharedSupport /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/  
      ...then start installation with the startosinstall utility...
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD --converttoapfs NO --applicationpath /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app  
      The above steps can be automated with the attached "startosinstall.command" script, which will assemble "Install macOS High Sierra.app" on "Macintosh HD" and launch the startosinstall utility targeting the "Macintosh HD" volume.  Copy/download to "Macintosh HD", then run in terminal (after attaching DATA USB with /Shared Support folder)...
      cd "/Volumes/Macintosh HD" chmod +x startosinstall.command ./startosinstall.command Updated Download Links for macOS Mojave 10.14.6_18G103
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      Note: In Mojave, Apple has removed the --converttoapfs NO and --applicationpath arguments from the startosinstall utility....
       
      eg to use startosinstall for the above section "What happens if we don't have access to TransMac or Paragon Hard Disk Manager?", the syntax is now
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ Mojave.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD  
      This basically means that for Mojave, the default installation will always convert the target volume to the apfs file system.
       
      Updated Download Links for macOS Catalina 10.15.6_19G73
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      startosinstall.command.zip
      InstallInfo.plist_edited_10.13.6.zip
      InstallInfo.plist_edited_10.14.6.zip
      InstallInfo.plist_edited_10.15.6.zip
    • By imacosiris
      Hi guys
      I already have a Hack running HighSierra and Clover.
      But I think to move to Open Core and install macOS Catalina.
      I just wonder if any one have any experience with this model of Gigabyte motherboard.
      I must add I use this hack as server to share videos no need audio for example, only network and storage
       
      My config is as follow
      Motherboard: gigabyte ga-h97m-d3h
      Processor : Intel i3 3,69 Mhz
      Memory : 32 GB 1600 Mhz DDR3
      Video Card: NVIDIA GeForce GT 710 (Nvidia Web Driver 387.10.10.10.40.105)
       
      System identify as iMac (27-inch, Late 2013) 
      Current version 10.13.6
       
      Boot drive SSD Kingston HyperX Savage SHSS37A120G
       
      Any advice ??
      Br
    • By Lakkantha
      i install mac Catalina osx but can't boot without fake intel inject. And no audio or wifi. Can you help to make my clover config please
      Efi folder
       


    • By rawmassen
      Hi there,
       
      If anyone could help I'd be very grateful, I'm trying to move from Clover to OC but have hit a brick wall for the last 2 days.
       
      It's an ACPI table error: SB_.PCIO.XHC_RHUB.HS11, Namespace lookup failure.
       


      Skylake Build:
      OpenCore 0.5.9
      Mojave 10.14.6, iMac17,1
      Asus Maximus Hero VIII
      6700K
       
      I've attached the config.plist and ACPI folder.
       
      EFI Drivers: OpenRuntime.efi and HfsPlus.efi
      Kexts: IntelMausi, Lilu, VirtualSMC, Whatevergreen
       
      Things I've tried...
       
      1) Clearing NVRAM (as it was previously booted by Clover)
       
      2) Hackintool USB Mapping: both the SSDT files and the USBPorts.kext
       
      3) USBInjectAll.kext (with and without SSDT files)
       
      4) SSDT-RHUB.aml. This seems to be directly involved, spent a long time with this but with no luck.
       
      I followed this guide:
       
      https://dortania.github.io/Getting-Started-With-ACPI/Universal/rhub-methods/manual.html
       
      Everything is XHC in my DSDT, except these definitions at the top (line 72 and 73):
       
          External (_SB_.PCI0.XHC_.DUAM, MethodObj)    // Warning: Unknown method, guessing 0 arguments     External (_SB_.PCI0.XHC_.RHUB.INIR, MethodObj)    // Warning: Unknown method, guessing 0 arguments  
      So I edited the SSDT-RHUB.dsl to this:
       
      /* * Goal of this SSDT is to shut off the RHUB to force macOS into * manually building ports when the ACPI is screwed up */ DefinitionBlock ("", "SSDT", 2, "DRTNIA", "RhubOff", 0x00001000) { External (_SB_.PCI0.XHC.RHUB, DeviceObj) // Full pathing to RHUB, change to yours Scope (_SB.PCI0.XHC.RHUB) // Full pathing to RHUB, change to yours { Method (_STA, 0, NotSerialized) { If (_OSI ("Darwin")) { Return (Zero) // This disables the device only in macOS } Else { } } } } Which results in this AML version:
      DefinitionBlock ("", "SSDT", 2, "DRTNIA", "RhubOff", 0x00001000) { External (_SB_.PCI0.XHC_.RHUB, DeviceObj) Scope (_SB.PCI0.XHC.RHUB) { Method (_STA, 0, NotSerialized) // _STA: Status { If (_OSI ("Darwin")) { Return (Zero) } Else { } } } } But I get the same error. 
       
      I'm at a complete loss, can anyone help?
       
       
      config.plist
      ACPI.zip
×