Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave / Catalina on mobos Serie 100 / 200 / 300 / 400 SkyLake / KabyLake / CoffeeLake / CometLake DSDT

5,426 posts in this topic

Recommended Posts

i think yes, check forum search, have many good tutorials about it

i dont use two systems in same HDD/SSD

Share this post


Link to post
Share on other sites
Advertisement
what ur audio codec?
Hi MaLd0n, my audio codec is Realtek ALC S1220A in config.plist devices audio/inject I tried different ID for S1220A=7,1,2,5 etc.

I have update AppleAlc to last version but not work.

Share this post


Link to post
Share on other sites

I finally got it working using this fix. Thanks tho.

 

AHCI is of course needed. But that is standard for every mac OSX/ macOS installation since forever. I guess you skipped some tutorials before installing for the first time ;)

Glad that it works now though

Hey MaLd0n is there anyway to install OSX beside Windows without deleting windows? Or is there a sure way to backup windows and then restore it after installing OSX?

create a new partition on your windows hard drive, install macOS on that partition. Select your installation from the clover bootloader during boot.

There are tons of tutorials in this forum and online. You are quicker by just searching than posting here and waiting for answers to basic questions...

Share this post


Link to post
Share on other sites
what ur audio codec?

Hi MaLd0n, my audio codec is Realtek ALC S1220A in config.plist devices audio/inject I tried different ID for S1220A=7,1,2,5 etc.

I have update AppleAlc to last version but not work.

inject ids in clover, reboot and test

DSDT.aml.zip

i thought last night i have attach the file :P

here's my file compressed in one zip...

attachicon.gifrequested.zip

id 3 work for audio?

CLOVER.zip

Share this post


Link to post
Share on other sites
Hi MaLd0n with your last dsdt the audio works perfectly, I just modified in config.plist the audio-inject with 11.
Good job! Thanks for what you do!
 
It still does not work:
Graphics card is recognized but not work in multi-display, only the Display port works. HDMI and DVI are not working.

 

Sleep mode does not work because the system reboots

Share this post


Link to post
Share on other sites

Success! I an now dual booting Windows 10 and OSX Sierra without any flash drives or external drives! Now I just need to fix a couple graphic issues and try to fix Wi-Fi. Thank you all who helped!

 

Sent from my SM-G920V using Tapatalk

Share this post


Link to post
Share on other sites

 

Hi MaLd0n with your last dsdt the audio works perfectly, I just modified in config.plist the audio-inject with 11.
Good job! Thanks for what you do!
 
It still does not work:
Graphics card is recognized but not work in multi-display, only the Display port works. HDMI and DVI are not working.

 

Sleep mode does not work because the system reboots

 

graphics card is a clover config

 

sleep, try a darkwake option in config.plist

Share this post


Link to post
Share on other sites
Hello MaLd0n,

Please help me with my DSDT/SSDTs. I have only tried Clover ACPI fixes..

 

- No webcam, midi, surround / multichannel, brightness hotkeys, no usb CP210x USB to UART Bridge Virtual COM Port (VCP) recognition

- Howto disable discrete graphics dual-GPU laptop for power saving since it¨s not supported ?, Native Power Management ?

- Get the right audio layout, not only built-in Line Output (2nd) etc. Just to name a few on my long wish list  :lol:

 

Hardware:

 

MSI GE72VR (MS-179B.3) 7RF 272NE Apache Pro (laptop) : Bios E179BIMS.309, EC-Firmware 179BEMS1.107

i7-7700HQ (4 Cores) / HM175

GeForce® GTX 1060 with 3GB GDDR5 1920x1080

32GB Crucial DDR4 2400MHz SODIMM

Samsung 960 EVO 1TB M.2 NVMe SSD & WD Blue 1TB 2.5" SATA SSD

Qualcomm Atheros Killer™ E2500 PCIe GBE

Broadcom BCM94352Z M.2/NGFF 802.11AC 867Mbps Bluetooth 4.0 WIFI (Ordered, not arrived)...)

Realtek ALC899 (ALC898! -GR ? ) 7.1+2ch DAC (Nahimic 360⁰ Audio Enhancer 2 , Dynaudio 2.1 Speakers; 4x 2W Speakers +1x 3W Subwoofer)

steelSeries PS/2 Keyboard

Synaptics PS/2 & SMBus Multi-Touch Touchpad

HL-DT-ST GUD0N SATA Int. DVD±RW (±R DL) / DVD-RAM

1x HDMI 1.4 (4K @ 30Hz)

1x Mini DisplayPort 1.2

1x Headset ESS SABRE HiFi AMP + Gold Flash jacks (SPDIF)

1x Microphone jack

USB (1 USB Asmedia 3.1 Type-C • 2 USB 3.0 • 1 USB 2.0)

Realtek RTS5129 Card Reader (SD/​SDHC/​SDXC)

BisonCam, NB Pro Webcam HD type (30fps@720p) + Int. Mic

 

 

Clover v2.4k r4128 / macOS 10.12.6 (16G29) / MacBookPro13,3

 

 

 

Any help or clue would be much appreciated  :yes:

 

Attached are hopefully the files needed. Has added an additional F4 dump from Clover boot screen of my DSDT/SSDTs where nothing is marked under the ACPI tab in Clover Configurator Vibrant edition version 4.46.0

 

 

Thank you!

Share this post


Link to post
Share on other sites

Hello MaLd0n,

Please help me with my DSDT/SSDTs. I have only tried Clover ACPI fixes..

 

- No webcam, midi, surround / multichannel, brightness hotkeys, no usb CP210x USB to UART Bridge Virtual COM Port (VCP) recognition

- Howto disable discrete graphics dual-GPU laptop for power saving since it¨s not supported ?, Native Power Management ?

- Get the right audio layout, not only built-in Line Output (2nd) etc. Just to name a few on my long wish list :lol:

 

Hardware:

 

MSI GE72VR (MS-179B.3) 7RF 272NE Apache Pro (laptop) : Bios E179BIMS.309, EC-Firmware 179BEMS1.107

i7-7700HQ (4 Cores) / HM175

GeForce® GTX 1060 with 3GB GDDR5 1920x1080

32GB Crucial DDR4 2400MHz SODIMM

Samsung 960 EVO 1TB M.2 NVMe SSD & WD Blue 1TB 2.5" SATA SSD

Qualcomm Atheros Killer™ E2500 PCIe GBE

Broadcom BCM94352Z M.2/NGFF 802.11AC 867Mbps Bluetooth 4.0 WIFI (Ordered, not arrived)...)

Realtek ALC899 (ALC898! -GR ? ) 7.1+2ch DAC (Nahimic 360⁰ Audio Enhancer 2 , Dynaudio 2.1 Speakers; 4x 2W Speakers +1x 3W Subwoofer)

steelSeries PS/2 Keyboard

Synaptics PS/2 & SMBus Multi-Touch Touchpad

HL-DT-ST GUD0N SATA Int. DVD±RW (±R DL) / DVD-RAM

1x HDMI 1.4 (4K @ 30Hz)

1x Mini DisplayPort 1.2

1x Headset ESS SABRE HiFi AMP + Gold Flash jacks (SPDIF)

1x Microphone jack

USB (1 USB Asmedia 3.1 Type-C • 2 USB 3.0 • 1 USB 2.0)

Realtek RTS5129 Card Reader (SD/​SDHC/​SDXC)

BisonCam, NB Pro Webcam HD type (30fps@720p) + Int. Mic

 

 

Clover v2.4k r4128 / macOS 10.12.6 (16G29) / MacBookPro13,3

 

 

 

Any help or clue would be much appreciated :yes:

 

 

Attached are hopefully the files needed. Has added an additional F4 dump from Clover boot screen of my DSDT/SSDTs where nothing is marked under the ACPI tab in Clover Configurator Vibrant edition version 4.46.0

 

 

Thank you!

need tests

in many cases, we need a native support, usb 3,1, card reader, etc ;)

CLOVER.zip

Hello MaLd0n,

 

Please help me out.

I installed High Sierra. I have only the intel hd 630. the gt710 gave me a black screen.

I hope you have all the files you need. For now I can live with the hd 630 if I can get it working fully.

 

TIA

- SMBIOS : iMac18,3
- KERNEL AND KEXT PATCHES : remove FakeCPUID
- DEVICES : Remove “Add Properties” for IntelGFX
- GRAPHICS : “ig-platform-id” changed to 0x59120000
- DEVICES : “Fake ID” for IntelGFX changed to 0x59128086
- BOOT : Add “-disablegfxfirmware” under Custom Flags

Share this post


Link to post
Share on other sites

need tests

in many cases, we need a native support, usb 3,1, card reader, etc ;)

attachicon.gifCLOVER.zip

 

 

 

 

 

Thank you very much MaLd0n, for DSDT and SSDT-DGPU :)

 

 

GeForce® GTX 1060 is turned off :yes:

 

Don't believe Bison Electronics Inc (Bison) BisonCam, NB Pro Webcam HD is with a microphone, so that microphone probably belongs to the Realtek ALC899 DAC as the rest of the audio equipment. What can I do to get the internal microphone working, audio out on all 5 speakers and preferably with output from the Internal Speakers output instead of Line Output (2nd)? :rolleyes:

 

Made a mistake :blush: when posting this in the 200 series forum, after receiving this email from MSI :

 

From: MSI OCSS <msihelp@msi.com>

Reply-To: "msihelp@msi.com" <msihelp@msi.com>

Date: Monday, 31 July 2017 at 02:34

 

Ticket:

Do I have 100 or 200 series motherboards?

 

Hello,

 

Your laptop is 100 series motherboard.

Your chipset is Intel® HM175.

 

Best regards,

MSI Notebook Technical Application Department

 

 

Will of course test more on USB, but it may be wrong to use the XHCI-200 Series-injector.kext on 100 series? :angel:

 

 

Thank you for super support :wink_anim:

Share this post


Link to post
Share on other sites

serie 100? remove XHCI-200-series-injector.kext ;) dont need

 

for mic/audio u need test other id ;)

Thank you for your quick reply :)

 

 

 

My ID´s shows this :

 

1 No internal microphone signal, audio on multiple stereo speakers, output --> LineOut (2nd)

2 No internal microphone signal, audio on front right stereo speakers, output --> LineOut (2nd)

3 No internal microphone signal, no audio

5 No internal microphone signal, no audio

7 No internal microphone signal, audio on multiple stereo speakers, output --> LineOut (2nd)

11 Internal microphone signal, audio on back left subwoofer speaker, output --> Internal Speakers

13 Internal microphone signal, no audio

28 No internal microphone signal, no audio

 

Guess I have to change DSDT layout-id from 1 to 11 and read about aggregate devices with Audio MIDI Setup ?

 

Laptop speaker layout and different audio codecs, have had sound all the time so which one do I have?

Share this post


Link to post
Share on other sites
Is a SSDT for power management on a laptop necessary? Having made one with Piker Alpha's ssdtPRG, tested with AppleIntelInfo to see if there are any differences with and without this SSDT, also compiled Intel's PowerGadget, with similarly erratic results.

 

Have read that with proper power management sleep function seems better, hope this does not complicate what you did with my DSDT?

 

Attached are the 2 compiled files as .zip

Share this post


Link to post
Share on other sites

is a 898, not 889

 

ill check it

Edited the DSDT, changed layout-id to 13, and display name of the PCI card to 898 assuming it was a typo since vendor and device ID where the same.

 

Thank You  :) 

 

 

 

Thanks, 
 
Used tiny SSDT method to inject HWPEnable & Piker's MSR 0xE2 lock patch, do you recommend adjusting X86PlatformPlugin ?

MacBookPro14,3 @ 3800 HWP/3900 HWP/4100 HWP

Share this post


Link to post
Share on other sites

Will do :star_sunglasses: , Thank You @MaLd0n  :)

 

 

 

 


Laptop: #1: MSI GE72VR 7RF-272NE, i7-7700HQ/HM175, HD630 1920x1080 With MaLd0nified Differentiated System Description Table/Secondary System Description Tables  ;)

Laptop: #2: Lenovo ThinkPad T460 20FMS1A00, i5-6200U/Intel SoC, HD520 1920x1080

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9400K, 9600K, 9700K, 9900K, 9900KS (All KF Models work but use SMBios iMacPro1,1 instead)
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, RX 5500, 5500 XT, 5600, 5600 XT, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Reference RX 5700 XT (connected to the monitor via the DisplayPort)
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO Plus 1TB NVMe SSD macOS Catalina 
      • Samsung 970 EVO 1TB NVMe SSD Windows 10 Pro
      • ABWB BCM94360CS2 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11e or Higher to use any of these EFI's, The DSDT is not designed for any other Bios revision
      Z390AORUSMASTER.zip  - Aorus Z390 Master Bios Firmware F11e 
       
      CLOVER & OPENCORE EFIs 
      Current EFIs Updated 04/08/2020
       
       
      Clover EFI Update v5120 - 04/08/2020 - Use with Bios revision F11e or Higher Only or Replace with the older F11c/F10 DSDT if you don't want to update the bios
       
      EFI Clover VEGA Navi 030820.zip - Vega, Navi (5700, 5700XT etc), Radeon VII DSDT SMBios 19,1 EFI
      EFI Clover Polaris NVIDIA 030820.zip - RX500 Polaris Series (RX590, 580, 570 etc) SMBios 19,1 EFI
       
      Please Note - I have now set KernelPM to No as standard so if you don’t have a unlocked MSR or not using my MSR Unlocked Bios Profile then go into the Clover Config.plist and set KernelPM to Yes or you won’t be able to boot up. An even better fix would be to unlock your MSR using my profile method.
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
       
       
      OpenCore EFI Update v0.6.0 - 04/08/2020
      Myself and @texem have now created a OpenCore EFI done the way the OpenCore Devs intended it to be made, There is no DSDT in use so you can use this EFI on any supported GPU and the SSDTs have been made so they will not be used in any other Operating System apart from MacOS.
       
      OpenCore 060 Z390 Master 19,1 030820.zip - OpenCore v0.6.0, SMBios iMac19,1
      OpenCore 060 Z390 Master 1,1 030820.zip - OpenCore v0.6.0, SMBios iMacPro1,1 (IGPU Disabled)
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
      Note 2 - Do not try to carry across your old OpenCore Config.plist to the new EFI as to many changes have occurred in 0.6.0 so please use the new Config.plist instead.
       
       
      PlistEdit Pro.zip - PlistEdit Pro (use to edit OpenCore)
       
      Using PlistEdit Pro add your details by modifying the following 

       
      PLEASE NOTE - These EFIs are setup to be used with your msr Unlocked so make sure you use the F11e Unlocked Profile but if for any reason you can not unlock MSR then just modify following in the OpenCore config.plist :
      
       
       
       
      CFG Unlock (MSR) F11e BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Z390AORUSMASTER.zip  - Aorus Z390 Master Bios Firmware F11e 
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11e)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled (Disabled If Using SMBios 1,1)
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       

       

       

       

       

       

       

       
       
    • By fusion71au
      Making a High Sierra USB Installer Entirely From Scratch in Windows
      This is a proof of concept tutorial, to show it's possible to create a vanilla High Sierra installer, entirely from scratch, in Windows (even without App Store downloaded "Install macOS High Sierra.app" from a real Mac ).  @PikeRAlpha's link to Apple's Software Catalog provides us with all the URLs necessary to download the needed files directly from Apple instead of some dubious source from the internet...
       

      Pre-Requisites
      8GB or larger USB drive.  Edit: Recommend 16GB or larger for macOS Catalina 10.16 Boot Disk Utility v2.1.2017rev021b from @CVAD TransMac (free 15 day trial) Paragon Hard Disk Manager Free Download Installer Files Directly from Apple
      1)  Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist (Hint - search page for "InstallESD" to find its URL and others nearby)

      to a folder named "SharedSupport" on your Windows NTFS drive.  A browser download manager (eg Chrono for Chrome, dTA for FireFox) is handy since InstallESD is >4GB ---> allows you to pause/resume interrupted download...

      2)  Rename InstallESDDmg.pkg to InstallESD.dmg
      3)  Edit InstallInfo.plist with WordPad/text editor to remove the chunklistURL and chunklistid keys for InstallESD, and renaming it from InstallESDDmg.pkg to InstallESD.dmg (example of edited file attached to this post)...
      Note:  You can verify the SHA1 checksum of your InstallESD.dmg and BaseSystem.dmg with the correct ones at this website.
      Boot Disk Utility to format the Installer USB and Restore OS X Base System HFS partition
      1.  Format USB with BDU & latest Clover ---> creates boot files in CLOVER partition + second FAT partition
      2.  Extract 4.hfs from \SharedSupport\BaseSystem.dmg with BDU --> save to it's local folder
      3.  Restore 4.hfs to USB second partition with BDU --->  2nd partition becomes bootable "OS X Base System"
      Paragon Hard Disk Manager to extend HFS Partition to its Full Extent
      Open Paragon Partition Manager Free and resize the second partition of the USB drive to the full size allowed.  Don't forget to apply the changes at the end...
      Transmac to Copy "SharedSupport" folder to OS X Base System
      1.  Open the TransMac program and navigate to the HFS+ Volume/Install macOS High Sierra.app/Contents folder.  Right click anywhere in the empty space on the RHS pane and select "Copy Here"...
      2.  In the next stage, select the "SharedSupport" folder we created above as the "Files and Folders to be copied to the Mac Volume"...
       
      Clover Settings
      Clover configuration is required now.  The default config.plist (in the Clover FAT32 partition of the USB) maybe sufficient to boot your machine if you’re lucky.  If not, the hackintosh-vanilla-desktop-guide has some good explanations on the various settings available and also offers sample configuration files based on CPU type.  Also, look at the Clover Wiki, Clover Instructions and Clover Configuration Thread for pointers and edit /EFI/Clover/config.plist accordingly with Wordpad or Notepad.
      The location of the important configuration files for Clover are summarized below
      config.plist--->EFI/CLOVER folder DSDT.aml with or without SSDT.aml--->EFI/CLOVER/ACPI/patched (don't need one if your DSDT is auto patched by Clover in config.plist) Kexts eg FakeSMC, NullCPUPowerManagement --->EFI/CLOVER/kexts/<osx version> or /Other. NB BootDiskUtility by default already has FakeSMC.kext installed here.  You may need to add VoodooPS2Controller for your laptop keyboard/trackpad to work. If UEFI booting, you will most likely need one of the OsxAptioFixDrv-64 drivers copied from /EFI/CLOVER/drivers-off/drivers64UEFI to /EFI/CLOVER/drivers64UEFI. If you want to use the installer to run High Sierra in Windows on VMware, you can follow my guide to set up the Virtual Machine and replace Clover's default config with EFI_Clover for VMware (which is compatible to run in VMware).  In the screenshots below, I have attached the USB Installer (in this case PhysicalDrive7) to my macOS Virtual Machine.  Reboot the system to the USB installer to install High Sierra ...
      What happens if we don't have access to TransMac or Paragon Hard Disk Manager?
      Not a problem, as long as we get "OS X Base System" bootable, we can launch terminal from the Utilities Menu to copy the SharedSupport folder over to the Installer app.  In essence, we will build the full installer app = 5GB+ on the target HD eg "Macintosh HD", by copying both the "small" installer app = 15MB (on "OS X Base System") and the SharedSupport folder from the NTFS volume (mounted in this example on /Volumes/DATA)...
      -bash-3.2# cd / -bash-3.2# cp -R Install\ macOS\ High\ Sierra.app /Volumes/Macintosh\ HD/ -bash-3.2# cp -R /Volumes/DATA/SharedSupport /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/  
      ...then start installation with the startosinstall utility...
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD --converttoapfs NO --applicationpath /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app  
      The above steps can be automated with the attached "startosinstall.command" script, which will assemble "Install macOS High Sierra.app" on "Macintosh HD" and launch the startosinstall utility targeting the "Macintosh HD" volume.  Copy/download to "Macintosh HD", then run in terminal (after attaching DATA USB with /Shared Support folder)...
      cd "/Volumes/Macintosh HD" chmod +x startosinstall.command ./startosinstall.command Updated Download Links for macOS Mojave 10.14.6_18G103
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      Note: In Mojave, Apple has removed the --converttoapfs NO and --applicationpath arguments from the startosinstall utility....
       
      eg to use startosinstall for the above section "What happens if we don't have access to TransMac or Paragon Hard Disk Manager?", the syntax is now
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ Mojave.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD  
      This basically means that for Mojave, the default installation will always convert the target volume to the apfs file system.
       
      Updated Download Links for macOS Catalina 10.15.6_19G73
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      startosinstall.command.zip
      InstallInfo.plist_edited_10.13.6.zip
      InstallInfo.plist_edited_10.14.6.zip
      InstallInfo.plist_edited_10.15.6.zip
    • By imacosiris
      Hi guys
      I already have a Hack running HighSierra and Clover.
      But I think to move to Open Core and install macOS Catalina.
      I just wonder if any one have any experience with this model of Gigabyte motherboard.
      I must add I use this hack as server to share videos no need audio for example, only network and storage
       
      My config is as follow
      Motherboard: gigabyte ga-h97m-d3h
      Processor : Intel i3 3,69 Mhz
      Memory : 32 GB 1600 Mhz DDR3
      Video Card: NVIDIA GeForce GT 710 (Nvidia Web Driver 387.10.10.10.40.105)
       
      System identify as iMac (27-inch, Late 2013) 
      Current version 10.13.6
       
      Boot drive SSD Kingston HyperX Savage SHSS37A120G
       
      Any advice ??
      Br
    • By Lakkantha
      i install mac Catalina osx but can't boot without fake intel inject. And no audio or wifi. Can you help to make my clover config please
      Efi folder
       


    • By rawmassen
      Hi there,
       
      If anyone could help I'd be very grateful, I'm trying to move from Clover to OC but have hit a brick wall for the last 2 days.
       
      It's an ACPI table error: SB_.PCIO.XHC_RHUB.HS11, Namespace lookup failure.
       


      Skylake Build:
      OpenCore 0.5.9
      Mojave 10.14.6, iMac17,1
      Asus Maximus Hero VIII
      6700K
       
      I've attached the config.plist and ACPI folder.
       
      EFI Drivers: OpenRuntime.efi and HfsPlus.efi
      Kexts: IntelMausi, Lilu, VirtualSMC, Whatevergreen
       
      Things I've tried...
       
      1) Clearing NVRAM (as it was previously booted by Clover)
       
      2) Hackintool USB Mapping: both the SSDT files and the USBPorts.kext
       
      3) USBInjectAll.kext (with and without SSDT files)
       
      4) SSDT-RHUB.aml. This seems to be directly involved, spent a long time with this but with no luck.
       
      I followed this guide:
       
      https://dortania.github.io/Getting-Started-With-ACPI/Universal/rhub-methods/manual.html
       
      Everything is XHC in my DSDT, except these definitions at the top (line 72 and 73):
       
          External (_SB_.PCI0.XHC_.DUAM, MethodObj)    // Warning: Unknown method, guessing 0 arguments     External (_SB_.PCI0.XHC_.RHUB.INIR, MethodObj)    // Warning: Unknown method, guessing 0 arguments  
      So I edited the SSDT-RHUB.dsl to this:
       
      /* * Goal of this SSDT is to shut off the RHUB to force macOS into * manually building ports when the ACPI is screwed up */ DefinitionBlock ("", "SSDT", 2, "DRTNIA", "RhubOff", 0x00001000) { External (_SB_.PCI0.XHC.RHUB, DeviceObj) // Full pathing to RHUB, change to yours Scope (_SB.PCI0.XHC.RHUB) // Full pathing to RHUB, change to yours { Method (_STA, 0, NotSerialized) { If (_OSI ("Darwin")) { Return (Zero) // This disables the device only in macOS } Else { } } } } Which results in this AML version:
      DefinitionBlock ("", "SSDT", 2, "DRTNIA", "RhubOff", 0x00001000) { External (_SB_.PCI0.XHC_.RHUB, DeviceObj) Scope (_SB.PCI0.XHC.RHUB) { Method (_STA, 0, NotSerialized) // _STA: Status { If (_OSI ("Darwin")) { Return (Zero) } Else { } } } } But I get the same error. 
       
      I'm at a complete loss, can anyone help?
       
       
      config.plist
      ACPI.zip
×