Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave / Catalina on mobos Serie 100 / 200 / 300 / 400 SkyLake / KabyLake / CoffeeLake / CometLake DSDT

5,430 posts in this topic

Recommended Posts

Posted (edited)

 

@MaLd0n TY so mutch fora all,

about this

8 hours ago, MaLd0n said:

use a hackintool for create patch

any suggestions, guides ...? Unfortunately, I don't know where to start, practically pretty much everything works, except for HDMI. I opened hackingtool and the only "strange" thing I focused on is that for the Intel UHD 630 it shows me 3 ports (3 dP), but in reality they are only 2 (1 dP and 1 HDMI).

 

 

Screenshot 2020-04-23 at 14.18.22.png

Screenshot 2020-04-23 at 14.19.52.png

Edited by fobus

Share this post


Link to post
Share on other sites
Advertisement

Finally I have got Mojave working in my laptop. I have tried kexts and clover patches to fix issues and almost everything works.

 

The only things that I wasn’t able to fix:

 

-Backlight screen control doesn’t appear.

-When it is connected to HDMI and I close the lid and reopen it, the laptop screen appears almost black, with really low brightness

-Sometimes in the boot, I receive a message saying “Error allocating  …. pages at ….” and I have to reboot.

 

I have been reading many guides and posts to patch DSDT and SSDTs but I am a bit lost. I have got disassembly DSDT and SSDTs but I don’t know how to get it compiles and what patches to apply. 

 

My laptop features:

 

ASUS X554L

Intel i5 5200u 2500Mhz (Broadwell)

Motherboard: X555LDB

Graphics: Intel HD Graphics 5500 + Nvidia (disabled)

Ram: 4Gb in the motherboard + 8Gb Crucial 

Wifi: Ateros AR956x

Ethernet: Realtek PCIe GBE Family Controller

Bios X555LDB.306

Audio Realtek ALC233

 

I have attached my config.plist and my DSDT.dsl. Could you please help me in the patching process? 

config.plist

DSDT.aml

DSDT.dsl

Share this post


Link to post
Share on other sites
On 10/22/2018 at 4:21 AM, MaLd0n said:

Hi Maldon,

 

I wanted to fresh install Catalina on this machine:

 

-i7 8700

-Asus Prime Z370 A

-16Gb Gskill Ripjaws 2400

-Sapphire Pulse Radeon RX 580 gb 

 

I don't know in this situation how to create a Bootlog...

 

Im stuck at installer when verbose finish black screen appears... I've tried several things but I Cant.... Could you give us some help please?

Send me iMac-de-Jabi.zip

Share this post


Link to post
Share on other sites
13 hours ago, Ikerox said:

Hi Maldon,

use my folder from first post, reboot and extract new send_me

Share this post


Link to post
Share on other sites
On 4/23/2020 at 6:11 PM, ajarillo said:

Finally I have got Mojave working in my laptop. I have tried kexts and clover patches to fix issues and almost everything works.

 

The only things that I wasn’t able to fix:

 

-Backlight screen control doesn’t appear.

-When it is connected to HDMI and I close the lid and reopen it, the laptop screen appears almost black, with really low brightness

-Sometimes in the boot, I receive a message saying “Error allocating  …. pages at ….” and I have to reboot.

 

I have been reading many guides and posts to patch DSDT and SSDTs but I am a bit lost. I have got disassembly DSDT and SSDTs but I don’t know how to get it compiles and what patches to apply. 

 

My laptop features:

 

ASUS X554L

Intel i5 5200u 2500Mhz (Broadwell)

Motherboard: X555LDB

Graphics: Intel HD Graphics 5500 + Nvidia (disabled)

Ram: 4Gb in the motherboard + 8Gb Crucial 

Wifi: Ateros AR956x

Ethernet: Realtek PCIe GBE Family Controller

Bios X555LDB.306

Audio Realtek ALC233

 

I have attached my config.plist and my DSDT.dsl. Could you please help me in the patching process? 

config.plist

DSDT.aml

DSDT.dsl

 

I have fixed 2 of the issues that I had after including "change GFX0 to IGPU" in config.plist with clover configurator.

Now, I have backlight screen control working properly and I can close the lid of the laptop and reopen it being HDMI connected.

For the last issue, I have included OsxAptioFix2Drv-free2000.efi in CLOVER/drivers64UEFI folder and now I received less frequently the  “Error allocating  …. pages at ….” , but it still appears some times.

 

I am using a patched DSDT that I have downloaded from internet for a similar laptop than mine and now I see the battery level. But I have read that it is not recommended to use DSDT of other computers in yours.

 

Maldon, Could please you help me to patch my DSDT?

 

Also, if you have have any idea about how to solve the "Error allocating ... pages at ...", let me know and I will test it.

Share this post


Link to post
Share on other sites
Posted (edited)

Hello @MaLd0n

Can you help me patch DSDT and config EFI my Pc:

Main: GIGABYTE  Z370m D3H

VGA: Vega 64 REF

CPU : Intel Core i7 8700 3.2Ghz

RAM Gskill 16GB (2x8GB) DDR4 Bus 3000Mhz - F4-3000C16D-16GTZR

           Gskill 16GB (2x8GB) DDR4 Bus 3200Mhz  F4-3200C16D-16GTZR

HDD: Western Caviar Blue 1TB 7200Rpm, SATA3 6Gb/s, 64MB Cache

SSD : SSD M2 PCIe Samsung SM961 NVMe 2280 - 256GB

 

I Used Folder OpenCore link post #1.

Thank you very much.

Send me iMac-Pro.zip

Edited by vodanhbk

Share this post


Link to post
Share on other sites

Hi  @MaLd0n

I My pc build:

- Main: Gigabyte X79 UD3 ver 1.0

- CPU: i7 3930K

- Vga: AMD RX580 8GB

- HDD: WD green 2Tb

- SSD: HP S700 250GB install windows 

- SSD NVME sk hynix 256GB with   adaptor PCIE - install mac OS 

I Cant boot mac Os from SD NVME sk hynix 256GB with  adaptor PCIE , USB 3.0 not fix, cant you help me config EFI and DSDT.

Thanks you very much.

Send me Davids-Mac-Pro.zip

Share this post


Link to post
Share on other sites
15 hours ago, vodanhbk said:

Main: GIGABYTE  Z370m D3H

DSDT.aml.zip

11 hours ago, okia12345 said:

- Main: Gigabyte X79 UD3 ver 1.0

use my folder for x79

Share this post


Link to post
Share on other sites
Posted (edited)
17 hours ago, MaLd0n said:

Thank you guy, but i need it for Opencore. This DSDT doesn't work with OC or OCNDK.

 

Greetings

Edited by plofplof

Share this post


Link to post
Share on other sites

HLEP!!! config.plist sandy bridge thinkpad L420 i5-240M 1366x768 ALC269 RTL8111D chipest 6 / c200 please run OS mojave or high sierra the problem is that the line does not start flash drive

Share this post


Link to post
Share on other sites
12 hours ago, plofplof said:

Thank you guy, but i need it for Opencore. This DSDT doesn't work with OC or OCNDK.

u need extract one dump with oc running

 

12 hours ago, ford22 said:

HLEP!!! config.plist sandy bridge thinkpad L420 i5-240M 1366x768 ALC269 RTL8111D chipest 6 / c200 please run OS mojave or high sierra the problem is that the line does not start flash drive

check first post

Share this post


Link to post
Share on other sites

Hi MaLd0n,

Still having issues with a vanilla install, I would appreciate trying your patched DSDT.

please find here my send file.

Regards

Send me delxx.zip

Share this post


Link to post
Share on other sites
On 5/11/2020 at 6:40 AM, delxx said:

Hi MaLd0n,

Still having issues with a vanilla install, I would appreciate trying your patched DSDT.

please find here my send file.

Regards

Send me delxx.zip

DSDT.aml.zip

remove all ssdts

 

On 5/11/2020 at 12:16 PM, nakasaka said:

Hi MaLd0n

My Pc build 

Main : H81m - ds2 v3,0

Ram: 2 stick 8GB of ram

Card: GTX 950

I used EFI #1 post, can you help me patch DSDT , Pls 

Thanks you very much. 

 

Send me nakasakas-iMac.zip

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By tonyx86
      *** I have started another thread for installing Catalina on the Dell Latitude E6410.  If you were thinking of installing Mojave, but would prefer to skip right to Catalina, click here. ***
       
      *** I am no longer maintaining the installation files in this first post.  Refer to my Catalina thread for the latest guidelines / files for installing macOS on this Latitude E6410 with Nvidia graphics ***
       
      I was inspired by @duduclx post here for installing El Capitan on a Dell Latitude E6410, so I decided to install Mojave 10.14.5 and subsequently 10.14.6.  Everything works perfectly (including sleep).  I'm starting this thread hoping to help others install Mojave on their E6410s.  A brief installation guide is provided later in this first post.  The interested reader is encouraged to read the other posts in this thread to see how this solution evolved and to learn additional tips/details not provided in this first post (including dual-booting with macOS and Windows).
       
      My system is as follows:
      Dell Latitude E6410 (I7-620m, Nvidia 3100M, 8GB DDR3, 512GB SSD, 1440x900 display, BIOS: A17) MacOS: Mojave 10.14.6 (APFS) (Patched with DosDude Mojave Patcher 1.3.3) MacModel: MacBookPro 6,2 (LPCB._DSM.Name "pci8086,3b09") Kexts: Lilu 1.3.6, VoodooHDA 2.9.2, AirportBrcmFixup 2.0.0, IntelMausiEthernet 2.4.1d1, ACPIBatteryManager 1.90.1, BrcmPatchRam2.kext, BrcmFirmwareRepo.kext, VoodooPS2Controller (the "Refined ALPS Touchpad" version - release 6 developed by @Dr. Hurt and compiled by @bronxteck), not the original version), USBInjectAll (with custom SSDT-UIAC), VoodooSDHC.kext (configured as shown here). Wi-Fi: Broadcom BCM 94352HMB (with AirportBrcmFixup.kext) CLOVER (Legacy): R4961  
      Configuration items that may be different from what you have seen in other E6410 configurations
      Addition of _OFF and _ON methods to _PTS and _WAK methods respectively (to control discrete graphics in order to enable sleep/wake) LPCB._DSM patched with device-id "3b09" AND "name", "pci8086,3b09" for native Nehalem power management with MacBookPro 6,2 ECDV renamed to EC so that AppleBusPowerController loads AGP.VID._DSM patched with device-id "0a29" so that AppleGraphicsPowerManagement loads No CLOVER Generate P or Generate C States (with the correct LPCB._DSM and MacBookPro 6,2, these CLOVER options are unnecessary for this architecture and only limit max multiplier and reduce number of P states) DSDT patched to include HDAU device (device-id 0x0be3)  
      What is NOT working:
      Display brightness can be controlled with keyboard keys, but cannot be controlled with slider in Display settings. Graphics Power Management - AGPM loads (because 10de,0a29 device is injected), but there's no evidence that 3100m frequency and voltage is changing.
        What is NOT tested:
      Smartcard Reader eSata (I have this disabled in my BIOS) Firewire Port (it does appear in the Network settings, just haven't tried it) Microphone Jack PC Card Slot (I have this disabled in my BIOS)  
      What IS working:
      SLEEP IS WORKING! Everything else not mentioned above.   Speedstep/CPUPowerManagement is perfect, system temps are low, CPU multiplier operates as expected, battery life is long Shutdown is fast Display/graphics acceleration is perfect (thanks to DosDude's Mojave patcher) Brightness (adjusted with brightness keys on keyboard) works perfectly Battery Manager works (battery status is displayed in menu bar) simply by installing ACPIBatterManager.kext. Wi-Fi (after changing to Broadcom BCM94352HMB and installing AirportBrcmFixup.kext) Audio (volume adjustable, volume indicator appears in menu bar).  Switched to VoodooHDA from AppleALC after AppleALC caused slow boot due to "IOHDACodecFunction timeout." Ethernet port (with IntelMausiEthernet.kext) Broadcom BCM20702A0 Bluetooth (with BrcmPatchRam2.kext and BrcmFirmwareRepo.kext) Optical Drive External VGA (with corrected NVCAP.  Need NVCAP 04000000 00000100 0E000000 00000007 00000000 (credit: here) for working external VGA display. Headphone jack Display Port (tested using DP > HDMI adapter) Camera SD Card Reader  
      Known issues and their solutions (These issues have all been resolved, with the solutions incorporated into the attached config files.  The issues are listed here for historical purposes and no further work is needed unless stated otherwise).
      (Solution to this issue is to remove Device (PNLF) from the DSDT): Some users experience display issues.  Solution is to remove Device (PNLF) from the DSDT.  The attached DSDT currently still includes Device (PNLF), so you will need to edit the DSDT to remove PNLF. USB sleep/wake power IORegistry keys are no longer provided in IOUSBHostFamily.kext after High Sierra 10.13.6.  Solution is to added SSDT-USBX.aml to EFI/CLOVER/ACPI/patched.  The attached SSDT-USBX.aml includes USB sleep/wake properties for MacBookPro6,2 from High Sierra 10.13.6 IOUSBHostFamily.kext. Laptop does not sleep on lid close.  Solution is to add Notify (LID0) code to Method (BTNV) in the DSDT.  This is solved in the attached DSDT. Leaving this for historical purposes, but the CLOVER USBFix is no longer necessary after finding that I had incorrectly applied the DSDT _DSM patch for Device (EHC1).  The CLOVER USBFix is not needed after fixing the DSDT..  AAPL,clock-id and device_type do not appear in IORegistry for EHC1.  Solution is to use CLOVER on-the-fly patching/fixing/renaming for EHC1 and EHC2.  Thank you, @feartech, for this tip. ALPS trackpad performance is not good with the "standard" VoodooPS2Controller.kext that I initially used.  Switching to the "Refined ALPS TouchPad driver" is a big improvement.  I've implemented and tested this on my system.  The ALPS version of VoodooPS2Controller.kext mixes up a few keys.  Need to switch the Command and Option keys (System Preferences > Keyboard > Modifier Keys) and change keyboard type to ISO European. This configuration (captured in the attached config files) uses an injected device-id (10de,0a29) for NVidia 3100m to get AGPM to load.  While I haven't observed any performance differences, a better approach may be to inject AGPM properties for device 10de,0a6c (the actual device-id for the 3100m).  This AGPM method is discussed later in this thread.  I have briefly tested this "FakeSMC.kext method" for injecting AGPM attributes without any noticeable changes in laptop/graphics behavior. IOHWControl is not loaded under AGPM (Should be AGP > VID > NVDA,Display-A@0 > NVDATesla > AGPM > gpu-control > IOHWControl as viewed in IORegistryExplorer).  It is loaded on a real MacBookPro6,2 running Mojave and is loaded on this Dell Latitude E6410 running High Sierra.  If I "Inject NVidia" via CLOVER, IOHWControl loads properly. The Dell Latitude DSDT (BIOS A17) has a bug in Method (GNOT).  In the method, the expression  If (LOr (LGreater (OSYS, 0x07D0), LLess (OSYS, 0x07D6))) always evaluates to TRUE, so the patched DSDT has no dependency on the value of OSYS.  I suspect that LOr should be replaced with LAnd, so that this expression is TRUE for variants of Windows 2001 and False for any other OS.  While this may have no affect on MacOS, it makes one wonder how such an obvious bug made it through Dell QA and is still present in BIOS A17.  Also makes one wonder whether the sleep problem (which no one has solved) was fixed in Windows to address another DSDT bug. The assigned value of ACOS and OSYS in the DSDT are conditional on the operating system.  There is no condition for "Darwin."  The solution is to add a condition for "Darwin" (making it equivalent to one of the defined operating systems (e.g. Linux, Win7, etc).  The attached config hard-codes ACOS and OSYS values equivalent to those for Linux.  Another way to handle this (different from the method employed in the attached config files) might be to override _OSI with XOSI (defined in a custom SSDT). The portType of the Internal Bluetooth device is portType=0 which, according to Rehabman's comments in SSDT-UIAC-All.dsl, is an external USB 2 port.  This should be an internal USB port (portType=2).  I learned through trial and error that the HUB1 and HUB2 definitions in Rehabman's SSDT-UIAC-ALL.dsl apply to the ports on the EHCx USB hubs.  The solution is to include the HUB1 definition in SSDT-UIAC.dsl and change portType to 2 for HP15.  This change doesn't appear to affect/fix sleep, but it may prevent instant wake if we get sleep working. There are minor differences between a real MacBookPro6,2 IORegistry dump and this HackBookPro6,2 IORegistry dump that can be resolved with simple DSDT edits.  I am now running with these changes, but haven't found these changes to make any difference in operational behavior.
      Rename Device (AC) -> Device (ADP1) Remove UID from Device (HPET) Add compatible ID "PNP0C01" to Device (HPET) Change ADP1:_STA from 0x0F to 0xFFFFFFFF Enable Ambient Light Sensor and renamed to Device (ALS0) from Device (ALS) Add compatible ID "smc-als" to ALS0 Rename LID -> LID0 Change "name" definitions to Buffers in _DSM methods Rename Device (PBTN) to PWRB Rename Device (SBTN) to SLPB Sleep / Wake does not work with the basic DSDT edits.  I have discovered that Sleep / Wake can be made to work by adding discrete graphics _OFF and _ON methods to _PTS and _WAK methods respectively (borrowed the concept and code from a working E6430 DSDT: Credit here: https://osxlatitude.com/forums/topic/9248-working-sleep-on-intel-hd-and-nvidia-nvs-on-dell-latitude-e6430-optimus-enabled-or-disabled/page/6/. The Clover boot arg should be changed to "darkwake=0" for reasons explained by @holyfield in this thread.  Leaving this for historical purposes: LCD screen is blank when waking laptop by opening lid (screen is not blank when waking with power button).  Solution is to add darkwake=8 to CLOVER boot args.  Thank you @Hervé for this tip.  
      Brief Installation Guide:
      Configure BIOS (version A17) as follows (leave default unless listed here): Boot Sequence: USB, Internal HDD, CD/DVD, Modular Bay HDD; Boot List Option: Legacy; Integrated NIC: Enabled; Parallel Port: Disabled; Serial Port: Disabled; SATA Operation: AHCI; Misc Devices: Enable Modular Bay, Camera, External USB, Microphone, Media Card and 1394; Latitude ON Reader: Disabled; Keyboard Illumination: Auto ALS and Input; Ambient Light Sensor: Enabled; OROM Keyboard Access: Disable; TPM Security: Disable; Computrace: Deactivate; CPU XD Support: Enable; Performance: Enable all options; Power Management: Disable Wake on AC, Disable Wake on LAN/WAN, Express Charge: Standard, Charge Behavior: Enabled; Keypad: Fn Key Only; Mouse/Touchpad: Touchpad/PS-2 Mouse; USB Emulation: Enable Legacy; Fn Key Emulation: Disabled; Fastboot: Thorough; Virtualization: Enable Intel Virtualization, Disable VT for Direct I/O, Disable Trusted Execution; Wireless Switch: Bluetooth and WLAN; Wireless Device Enable: Bluetooth and WLAN;  Create your MacOS installer USB (Use DosDude's Mojave Patcher for Mojave) (start with High Sierra and not Mojave if you're new to hackintosh). Install CLOVER (Legacy) on installer USB using attached EFI as your guide for patched ACPI, kexts and config.plist Install MacOS to your SSD.  When you run DosDude's Mojave Patcher, DO NOT install LegacyUSBInjector.kext - you're going to use Rehabman's USBInjectAll.kext.  Also, do not install the DosDude SIP kext (you're using CLOVER to manage SIP). Install the following kexts in /Library/Extensions:  ACPIBatteryManager.kext, AirportBrcmFixup.kext, BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakeSMC.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, IntelMausiEthernet.kext, Lilu.kext, USBInjectAll.kext, VoodooPS2Controller.kext (the "Refined ALPS Touchpad driver," not the original), VoodooSDHC.kext (configured as shown here). Switch Command and Option keys to compensate for Refined ALPS driver issue (System Preferences > Keyboard > Modifier Keys).  Also change keyboard type to ISO European to fix the [ ` ~ ] key (to the left of the "1" (one) key. Install VoodooHDA Install HWMonitor application  
      Tips for Improved Performance (on this and other older systems)
      System Preferences > Spotlight > Search Results: Uncheck all options System Preferences > Spotlight > Privacy: Add all Volumes System Preferences > Accessibility > Display: Check "Reduce motion" System Preferences > Accessibility > Display: Check "Reduce transparency"  
      Other tips
      If your fan is always running and temps are good, try pressing Fn + z After applying Mojave updates, HWMonitor may not display discrete graphics attributes.  On systems with multiple displays, a second (or third display) may not be active after applying the Mojave update.  The solution to this is to run "sudo kextcache -i /" (in a terminal window) and reboot.  This will usually fix the issue.  If the issue is not fixed, run DosDude's Post Install Utility, apply the Legacy Graphics Patch, reboot and then run "sudo kextcache -i /" if necessary.  
      Screenshots
       
       
      Credits
      In addition to those mentioned in this first post and in subsequent posts in this thread, much of this solution for the Latitude E6410 was made possible by the numerous contributions of @RehabMan.  I hope he's doing well, wherever he is.  Hopefully he has long since forgotten what a PIA I was (and still am) as I was (and still am) learning hackOS.  
       
      E6410-Mojave-v4.zip
    • By jlrycm
      Finally I was able to move from Clover to OpenCore 0.5.9 on my hackintosh build. It boots really fast and even with the famous boot chime. I attached the OC config.plist for anyone who wants to give it a try. I followed the Github step-by-step guide:
      Haswell · GitBook
        dortania.github.io My build specs are:
      Gigabyte Z97-HD3 rev. 2.1, i5-4690K, 16 GB RAM, Gigabyte Aorus AMD RX 580 8gb GPU.
      I used OpenCanopy to give a Clover feeling to the OpenCore boot menu (I don’t like list-type boot menus). 
      config.plist
    • By ludufre
      Installing macOS Big Sur 11.0 DP1 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      06/28/2020 22:05h GMT-0
      - Replaced detach command when creating ISO.
      - Thanks @ham4ever 
      - Added instruction to run one line at time.
       
      06/27/2020 02:37h GMT-0
      - iMessage works too. Just not at first boot.
       
      06/26/2020 18:54h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Work.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Fix iMessage (other iServices works perfectly)
      - Nothing
       
       
      Disclaimer! 
       
      Bootloaders are currently unable to start the installation.
      The solution is to use a virtual machine and use a physical disk (additional, USB or SATA, NVME) as a target in the installation.
      Change the OpenCore compiled from the source code, and add some entries in NVRAM through config.plist.
       
      This is not the best solution. But it is the only way at the moment. There are some ready-made images available out there, but I prefer not to use them and create a clean installation.
       
       
      What you need to install
       
      - Running install of macOS
      - Already working OpenCore with this setup
      - Create bootable ISO file
      - Spare Disk/SSD
      - macOS Big Sur DP1 install app
      - Latest OpenCore + Kexts compiled from sources
      - Some KEXTs and SSDT patches
       
       
       
      UEFI configuration
       
      My BIOS is F10 (I use an 8th generation processor, so I don't need to upgrade)
       
      You can configure manually or load my BIOS profile.
       
      Manually:
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: BIOS - CSM Support to Disabled
      - Change value: BIOS - Secure Boot to Disabled
      - Change value: Peripherals - Initial Display to IGP
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Save & Exit Setup
       
      or, BIOS profile
      You can use one of my BIOS profiles attached bellow.
      It's two versions. One stock and another with overclock [5.0 GHz]
      - Put the profile in the root of the flash drive at EFI partition.
      - Restart with DEL pressed to enter BIOS setup.
      - Go to Save & Exit.
      - Select Load Profiles.
      - Select last option and then the flasdrive in the list.
      - And finally choose MACOS_STOCK or MACOS_5GHZ.
      - Save & Exit Setup



      How create bootable ISO file
       
      Download Big Sur DP1
       
      Run this command on Temrinal:
      sudo /System/Library/PrivateFrameworks/Seeding.framework/Resources/seedutil enroll DeveloperSeed Go to System Updater and download the Install macOS Beta app.
       
      Create ISO
       
      Then run on Terminal (One line at a time):
      hdiutil create -size 12G -fs hfs+ -volname install -type SPARSEBUNDLE ~/Desktop/install hdiutil attach ~/Desktop/install.sparsebundle sudo /Applications/Install\ macOS\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/install --nointeraction hdiutil detach `diskutil list |grep 'Install macOS Beta' |awk '{print $8}'` -force hdiutil makehybrid -o ~/Desktop/install ~/Desktop/install.sparsebundle rm -rf ~/Desktop/install.sparsebundle
       
      Now you have install.iso on desktop.
       
       
      How create create the virtual machine and install to disk/SSD
       
      Download and install the trial version of the VMware Fusion from their site. I'm used the version 11.5.5.
       
      - Create a custom virtual machine
       

       
      - Operating System: Apple OS X - macOS 10.15
       

       
      - Create a new virtual disk (The size doesn't matter, We'll delete later)
       

       
      - Click in "Customize Settings"
       

       
      - Save the VM on desktop with name: bigsur
       

       
       
      - Insert the spare disk/SSD on PC (reboot if necessary) and identify what /dev/diskX is.
      You can look on Disk Utility.app:

       
      - Create VMDK that point to it:
      sudo diskutil unmountDisk diskX /Applications/VMware\ Fusion.app/Contents/Library/vmware-rawdiskCreator create /dev/diskX fullDevice ~/Desktop/bigsur.vmwarevm/physical sata - Edit the virtual machine settings created previously
       

       
      - Click in Hard Disk (SATA) and delete it (Remove Hard Disk)
       

       
      - Then add the physical disk
       

       
      - There's a bug in Fusion. To select the physical.vmdk, right click then "Quick Look", then "Share virtual disk with the virtual machine that created it"
       

       
      - Click Apply.
       

       
      - Now mount de install.iso
       


       
      - Start the VM and install as usual until: Disk Utility, format GUID with APFS (VMware Virtual SATA Hard Drive Media), Install macOS, wait few reboots and stop at first boot wizard.
       
      This can take up to 45 minutes. It may seem like it is stopped, but it is not.
       

       
      - Press Command + Q and shutdown (usually WIN + Q)
       

       
      - Close VMware Fusion.
       
       
      Copy OpenCore to EFI
       
      - Mount the EFI with:
      sudo diskutil mount diskXs1  
      - Copy your current working OpenCore EFI to that mounted EFI.
       
      - Download mine attached or Update your OpenCore, Kexts and driver UEFI.
              - You can use the @MaLd0n script attached to compile all (OlarilaOC.command.zip)
              - If using mine add your MLB, ROM, SystemUUID and SystemSerialNumber. (see how to)
       
      - Add following items do config.plist:
       
      NVRAM -> Add -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> boot-args -> -lilubetaall (append)
      NVRAM -> Add -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-basesystem + Data + <00>
      NVRAM -> Add -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-kernel + Data + <00>
      NVRAM -> Delete -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-basesystem
      NVRAM -> Delete -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-kernel
       

       
      Done!
       
      Boot from the new disk/SSD and finish de first boot wizard.
       
       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @khamsakamal48, @MaLd0n, @joedm and @vit9696 and all others members involved directly or indirectly.
       
      Attachments
       
      MACOS_5GHZ
      MACOS_STOCK
      OlarilaOC.command.zip
      EFI.zip
       
       
    • By macnuub
      Asus R541U 
      I installed Niresh Mojave On it Every thing working expect Wifi when seen through Hacktool
      I found it has a Pci Realtek 8723be
      Its not working where as external mini usb wifi adapter is working
      Please Help me to fix wifi Realtek 8723be PCIe wifi
       
    • By denixx95
      Hello,
      Big Problem.., My Hack can not recognize my USB3 and no Bluetooth ....
      I'm on High Sierra 10.13.6  (max with my NVIDIA GeForce GTX 970 CG 4070 MB)
      My Setup
      - Rampage V + 5820K config  
      - 32G Ram
      - GeForce GTX 970
      - full of HD ssd
      I am attaching my config.plist! and print my ktext screen ( I have to clean my room...)
       
      Thank you for your help !!
      config.plist.zip

×