Jump to content
MaLd0n

[Guide] Sierra / High Sierra / Mojave / Catalina on mobos Serie 100 / 200 / 300 / 400 SkyLake / KabyLake / CoffeeLake / CometLake DSDT

5,430 posts in this topic

Recommended Posts

Hi @MaLd0n

 

Thanks again about your explanation on Olarila about USB Power :)

 

Sorry if I am Off topic.

 

First question:

I use usbinjectall and xhci_unsupported kexts with your great DSDT and SSDT, but I've some USB speed mantissa issues. I don't understand why.

 

Second question:

Do you have disable panic kext logging patch for 10.15

 

 

Log show in attachment

USB mantissa error - 30-09-2019.zip

Share this post


Link to post
Share on other sites
Advertisement
9 hours ago, Matgen84 said:

Hi @MaLd0n

 

Thanks again about your explanation on Olarila about USB Power :)

 

Sorry if I am Off topic.

 

First question:

I use usbinjectall and xhci_unsupported kexts with your great DSDT and SSDT, but I've some USB speed mantissa issues. I don't understand why.

 

Second question:

Do you have disable panic kext logging patch for 10.15

 

 

Log show in attachment

USB mantissa error - 30-09-2019.zip

check

https://pikeralpha.wordpress.com/2016/11/10/two-port-usb-3-1-gen-ii-pci-express-card/

Share this post


Link to post
Share on other sites
50 minutes ago, MaLd0n said:

 

My Gigabyte Z390 Aorus Master is a mix of USB ports (details below)

 

Chipset:
1 x USB Type-C™ port with USB 3.1 Gen 2 support, available through the internal USB header
1 x USB Type-C™ port on the back panel, with USB 3.1 Gen 2 support
3 x USB 3.1 Gen 2 Type-A ports (red) on the back panel
4 x USB 3.1 Gen 1 ports (2 ports on the back panel, 2 ports available through the internal USB header)
Chipset+USB 2.0 Hub:
8 x USB 2.0/1.1 ports (4 ports on the back panel, 4 ports available through the internal USB headers)

I check Piker Alpha article, I don't understand his explanations. My knowledge being limited especially for mantissa speed errors, can you take a look at your SSDT in attachment.

 

Thanks a lot :)

SSDT-6-A M I.aml.zip

Share this post


Link to post
Share on other sites
11 minutes ago, Matgen84 said:

 

My Gigabyte Z390 Aorus Master is a mix of USB ports (details below)

 


Chipset:
1 x USB Type-C™ port with USB 3.1 Gen 2 support, available through the internal USB header
1 x USB Type-C™ port on the back panel, with USB 3.1 Gen 2 support
3 x USB 3.1 Gen 2 Type-A ports (red) on the back panel
4 x USB 3.1 Gen 1 ports (2 ports on the back panel, 2 ports available through the internal USB header)
Chipset+USB 2.0 Hub:
8 x USB 2.0/1.1 ports (4 ports on the back panel, 4 ports available through the internal USB headers)

I check Piker Alpha article, I don't understand his explanations. My knowledge being limited especially for mantissa speed errors, can you take a look at your SSDT in attachment.

 

Thanks a lot :)

SSDT-6-A M I.aml.zip

is a personal, u need check all ports

Share this post


Link to post
Share on other sites
14 minutes ago, idfox09 said:

Hi MaLMaLd0n 

Last week i use your file DSDT, everything good but my bluetooth do not active , i use card bcm943224pciebt2. Can you help me fix it.

My config 

  • ASRock B365 Pro4 
  • i5-9400 
  • Non GPU 
I use the HDMI port
Thank you very much 
---

Send me idfox09-Mac-mini.zip

Screen Shot 2019-10-09 at 11.48.09 PM.png

DSDT.aml.zip

https://github.com/acidanthera/BrcmPatchRAM

Share this post


Link to post
Share on other sites

 

14 minutes ago, Matgen84 said:

 

My Gigabyte Z390 Aorus Master is a mix of USB ports (details below)

 


Chipset:
1 x USB Type-C port with USB 3.1 Gen 2 support, available through the internal USB header
1 x USB Type-C port on the back panel, with USB 3.1 Gen 2 support
3 x USB 3.1 Gen 2 Type-A ports (red) on the back panel
4 x USB 3.1 Gen 1 ports (2 ports on the back panel, 2 ports available through the internal USB header)
Chipset+USB 2.0 Hub:
8 x USB 2.0/1.1 ports (4 ports on the back panel, 4 ports available through the internal USB headers)

I check Piker Alpha article, I don't understand his explanations. My knowledge being limited especially for mantissa speed errors, can you take a look at your SSDT in attachment.

 

Thanks a lot :)

SSDT-6-A M I.aml.zip

 

3 minutes ago, MaLd0n said:

is a personal, u need check all ports

 

I Know. I've already take a look using Hackintool app. But I can test USB-C ports, because I've no devices to put in it.

 

The SSDT in attachment is already patched by you. I do not want to change your work by making mistakes.

Share this post


Link to post
Share on other sites
12 hours ago, Tran Quoc Dang said:

Hi @MaLd0n.

My Laptop was panic, can you help me config:

- Lenovo Legion Y530-15ICH

- CPU: Core I5 8300H

- RAM: 8GB

- VGA: 630 Graphic...

Thank you very much

Send me Trans-Mac-mini.zip

u have a many renames etc, dont need it, use a good, clean and correct config first

Share this post


Link to post
Share on other sites
On 10/5/2019 at 6:54 PM, MaLd0n said:

check if work

EFI.zip

IMG_1168.thumb.JPG.0440c3f2fe83a0f620c5d4725752cb4f.JPG

 

Hi thanks for the help.

 

It runs through nicely till it hits this line. Then it reboots.

did the picture with don't reboot on panic.

 

btw got it to boot with AAPL,ig-platform-id 9000B9E3  but without acceleration. will try more IDs..

Edited by blackbird_n1

Share this post


Link to post
Share on other sites

i upgraded from 10.13.6 to 10.14.6 , dell 790 gt710 2gb, i have no sound, (would love to have hdmi audio) i tried too much stuff but nothing works that i totally confused myself on what i have tried and didnt try , can a very nice person have a look at my files please, and tell where i went wrong or fix them or send me a working EFI preferably with hdmi sound please,  and thank you 

IMG_1894.jpg

DSDT.aml

config.plist

10.14.zip

Other.zip

Share this post


Link to post
Share on other sites
8 hours ago, patmck123 said:

i upgraded from 10.13.6 to 10.14.6 , dell 790 gt710 2gb, i have no sound, (would love to have hdmi audio) i tried too much stuff but nothing works that i totally confused myself on what i have tried and didnt try , can a very nice person have a look at my files please, and tell where i went wrong or fix them or send me a working EFI preferably with hdmi sound please,  and thank you 

 

DSDT.aml

config.plist

10.14.zip

Other.zip

use applealc and inject layout id for ur audio codec

10 hours ago, blackbird_n1 said:

Hi thanks for the help.

 

It runs through nicely till it hits this line. Then it reboots.

did the picture with don't reboot on panic.

 

btw got it to boot with AAPL,ig-platform-id 9000B9E3  but without acceleration. will try more IDs..

let me know

Share this post


Link to post
Share on other sites
On 10/23/2019 at 5:08 AM, blackbird_n1 said:

 

Hi, I got it to boot like that. But still no Video Acceleration.

Never had such a hard fight with any setup yet.

 

Any Idea ?

 

Attached another sendme

 

Thanks for the effort.

Send me Blacks-MacBook-Pro.zip

IS A 4K?

try this patch

<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
			<dict>
				<key>AAPL,GfxYTile</key>
				<data>
				AQAAAA==
				</data>
				<key>AAPL,ig-platform-id</key>
				<data>
				CQClPg==
				</data>
				<key>device-id</key>
				<data>
				pT4AAA==
				</data>
				<key>enable-hdmi20</key>
				<data>
				AQAAAA==
				</data>
				<key>framebuffer-con0-alldata</key>
				<data>
				AAAIAAIAAACYAAAA
				</data>
				<key>framebuffer-con0-enable</key>
				<integer>1</integer>
				<key>framebuffer-con1-alldata</key>
				<data>
				AQEJAAAIAADHAQAA
				</data>
				<key>framebuffer-con1-enable</key>
				<integer>1</integer>
				<key>framebuffer-con2-alldata</key>
				<data>
				AgYKAAAEAADHAQAA
				</data>
				<key>framebuffer-con2-enable</key>
				<integer>1</integer>
				<key>framebuffer-fbmem</key>
				<data>
				AACQAA==
				</data>
				<key>framebuffer-patch-enable</key>
				<data>
				AQAAAA==
				</data>
				<key>framebuffer-stolenmem</key>
				<data>
				AAAwAQ==
				</data>
				<key>framebuffer-unifiedmem</key>
				<data>
				AAAAgA==
				</data>
				<key>hda-gfx</key>
				<string>onboard-1</string>
				<key>model</key>
				<string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string>
			</dict>

 

Share this post


Link to post
Share on other sites

Hello MaLd0n, can you please help me with a patch?

I tried a lot of fixes but I cannot succed make wifi working.I use a compatible wifi card DW1560. This is a Lenovo L480, HD screen

Many thanks in advance!

 

Send me Mihais-MacBook-Pro.zip

Edited by mihu_yo

Share this post


Link to post
Share on other sites
2 hours ago, mihu_yo said:

Hello MaLd0n, can you please help me with a patch?

I tried a lot of fixes but I cannot succed make wifi working.I use a compatible wifi card DW1560. This is a Lenovo L480, HD screen

Many thanks in advance!

 

Send me Mihais-MacBook-Pro.zip

u have a last kext for wifi? just need it

https://github.com/acidanthera/AirportBrcmFixup/releases

 

for bt is here

https://github.com/acidanthera/BrcmPatchRAM

 

 

Share this post


Link to post
Share on other sites
On 9/21/2019 at 6:06 PM, MaLd0n said:

EFI.zip

use only this efi folder, enable intelhd in bios/uefi setup for enable intelquicksync

Hello @MaLd0n, After a month i had to rma my vega 56 due to some overheating problems, now i bought a xfx rx 5700 (custom) and i'm not able to boot with this configuration, neither in safe mode...

What can i do?

Share this post


Link to post
Share on other sites
5 minutes ago, Paolo7297 said:

Hello @MaLd0n, After a month i had to rma my vega 56 due to some overheating problems, now i bought a xfx rx 5700 (custom) and i'm not able to boot with this configuration, neither in safe mode...

What can i do?

xfx have several problems under macos

Share this post


Link to post
Share on other sites
6 hours ago, Paolo7297 said:

So there's nothing to do?

some people use bios from other manufacturer for solve problems with xfx

Share this post


Link to post
Share on other sites
On 10/29/2019 at 9:16 PM, MaLd0n said:

IS A 4K?

try this patch


<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
			<dict>
				<key>AAPL,GfxYTile</key>
				<data>
				AQAAAA==
				</data>
				<key>AAPL,ig-platform-id</key>
				<data>
				CQClPg==
				</data>
				<key>device-id</key>
				<data>
				pT4AAA==
				</data>
				<key>enable-hdmi20</key>
				<data>
				AQAAAA==
				</data>
				<key>framebuffer-con0-alldata</key>
				<data>
				AAAIAAIAAACYAAAA
				</data>
				<key>framebuffer-con0-enable</key>
				<integer>1</integer>
				<key>framebuffer-con1-alldata</key>
				<data>
				AQEJAAAIAADHAQAA
				</data>
				<key>framebuffer-con1-enable</key>
				<integer>1</integer>
				<key>framebuffer-con2-alldata</key>
				<data>
				AgYKAAAEAADHAQAA
				</data>
				<key>framebuffer-con2-enable</key>
				<integer>1</integer>
				<key>framebuffer-fbmem</key>
				<data>
				AACQAA==
				</data>
				<key>framebuffer-patch-enable</key>
				<data>
				AQAAAA==
				</data>
				<key>framebuffer-stolenmem</key>
				<data>
				AAAwAQ==
				</data>
				<key>framebuffer-unifiedmem</key>
				<data>
				AAAAgA==
				</data>
				<key>hda-gfx</key>
				<string>onboard-1</string>
				<key>model</key>
				<string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string>
			</dict>

 

 

Hi, it is a 1080p 240hz screen

 

I inserted the patch. But it reacts like some time before. It runs through nicely. Seems like it detects the video correctly. But then reboots.

Ive attached a pic with the command not to reboot upon panic.

 

 

19-11-09 00-24-43 6586.jpg

Share this post


Link to post
Share on other sites
5 hours ago, blackbird_n1 said:

 

Hi, it is a 1080p 240hz screen

 

I inserted the patch. But it reacts like some time before. It runs through nicely. Seems like it detects the video correctly. But then reboots.

Ive attached a pic with the command not to reboot upon panic.

 

 

 

block plugin battery at boot, SMCBatteryManager.kext and test

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

  • Similar Content

    • By ThomasMattOnline
      Hello Everyone,

      Trying to get Hardware Acceleration working on my Hackintosh (HEVC Support) however I am such a noob, OpenCore is very new to me and would love some support.
      I have included screenshots and the EFI that is currently working on my System, I have USB 2 & 3.0 all working, however, the only thing I can fault is my GPU not being hardware acceleration enabled.

      Final Cut Pro X - Recognises GPU
      VideoProc - Doesn't recognise anything.
       
      (I am running the latest version of OpenCore 0.5.9)

      Things I've tried: I tried following the post https://www.tonymacx86.com/threads/catalina-10-15-2-update-lost-hevc-h265-acceleration.288563/ - No Luck
      I have also tried: https://forums.macrumors.com/threads/activate-amd-hardware-acceleration.2180095/page-53?post=28255048#post-28255048 - No luck either!

      My friend online tells me I shouldn't need such Kext as he has the same build as me but when I load his EFI on my system it boots with no USB 2 or 3.0 (I'm keeping his EFI off here as I've uploaded mine.)

      Please note: I appreciate all (any) pieces of advice and please do bear in mind that I am a noob and may need whatever you say simplifying as I can get easily confused.


      config.plist

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9400K, 9600K, 9700K, 9900K, 9900KS (All KF Models work but use SMBios iMacPro1,1 instead)
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, RX 5500, 5500 XT, 5600, 5600 XT, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Reference RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM94360CS2 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      CLOVER & OPENCORE EFIs 
      Current EFIs Updated 01/06/2020
       
       
      Clover EFI Update v5118 - 01/06/2020 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
       
      Clover Z390 Master Navi Vega EFI 010620.zip - Vega, Navi (5700, 5700XT etc), Radeon VII DSDT EFI
      Clover Z390 Master Polaris EFI 010620.zip - RX500 Polaris Series (RX590, 580, 570 etc) DSDT EFI
       
      Please Note - I have now set KernelPM to No as standard so if you don’t have a unlocked MSR or not using my MSR Unlocked Bios Profile then go into the Clover Config.plist and set KernelPM to Yes or you won’t be able to boot up. An even better fix would be to unlock your MSR using my profile method.
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
       
       
      OpenCore EFI Update v0.5.9 - 01/06/2020
      Myself and @texem have now created a OpenCore EFI done the way the OpenCore Devs intended it to be made, There is no DSDT in use so you can use this EFI on any supported GPU and the SSDTs have been made so they will not be used in any other Operating System apart from MacOS.
       
      OpenCore 059 Z390 Master 19,1 010620.zip - OpenCore v0.5.9, SMBios iMac19,1
      OpenCore 059 Z390 Master 1,1 010620.zip - OpenCore v0.5.9, SMBios iMacPro1,1 (IGPU Disabled)
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
      Note 2 - Do not try to carry across your old OpenCore Config.plist to the new EFI as to many changes have occurred in 0.5.9. Use the new Config.plist instead.
       
       
      PlistEdit Pro.zip - PlistEdit Pro (use to edit OpenCore)
       
      Using PlistEdit Pro add your details by modifying the following 

       
      PLEASE NOTE - These EFIs are setup to be used with your msr Unlocked so make sure you use the F11c Unlocked Profile but if for any reason you can not unlock MSR then just modify following in the OpenCore config.plist :
      
       
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       

       

       

       

       

       

       

       
      OpenCore 058 Z390 Master 1,1 040520.zip
    • By batty86
      Buonasera a tutti, ho bisogno di aiuto per l'installazione di Mojave sul pc in firma. Ho provato ad installarlo, tutto procede bene, solo che al secondo riavvio dal ssd di destinazione del oS l'installazione procede fino alla maschera di configurazione del computer ma si riavvia non consentendomi di configurarlo, va loop di riavvio. Sono grato in anticipo per il vs aiuto.
    • By ludufre
      Installing macOS Catalina 10.15.5 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      05/27/2020 20:02h GMT-0
      - Update instructions 10.15.5.
       
      03/24/2020 20:23h GMT-0
      - Update instructions 10.15.4.
       
      01/30/2020 23:54h GMT-0
      - Update instructions 10.15.3.
       
      12/11/2019 03:58h GMT-0
      - Update instructions 10.15.2.
      - Updated EFI folder attached.
       
      11/30/2019 18:03h GMT-0
      - Changed Device -> Graphics platform to fix dual HDMI monitor.
      - Updated EFI folder and config.plist
       
      11/29/2019 21:28h GMT-0
      - Added full EFI folder as requested.
       
      11/27/2019 02:33h GMT-0
      - Added BIOS profiles for ease.
       
      11/25/2019 22:45h GMT-0
      - Fixed wrong ethernet link (IntelMausi.kext).
      - Thanks to @MiMoHo
       
      11/24/2019 04:56h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Work.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Empty
       
      What you need to install
       
      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Catalina install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction  This will take about 30 minutes.
       


      Install bootloader
       
      Download the CloverEFI from official repository (used 5099) and install only with these options on "Install macOS Catalina":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
      - UEFI Drivers - Additional drivers - NvmExpressDxe (If you are going to use NVMe)
       
      FileVault 2
       
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
       
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      OR download attached bellow.
       
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
       
      That's it! FileVault 2 will work without problems.
       

       
       
       
      Make things works
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below according to your processor version.
      - Put all SSDT-*.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.8.0.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Copy the Clover Configurator to flash drive because you will need later.
       
      Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC.kext, SMCProcessor.kext, SMCSuperIO.kext and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/). I used the version 1.0.9.
      - Download the Lilu.kext from here. I used the version 1.3.9.
      - Download the WhateverGreen.kext from here. I used the version 1.3.4.
      - Download the AppleALC.kext from here. I used the version 1.4.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the IntelMausi.kext from here. I used the version 1.0.2.
      - Download the SmallTree-Intel-211-AT-PCIe-GBE.kext attached bellow to enable second ethernet.
       
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
       
      Wifi and Bluetooth (BCM94360CS)
       
      Works out of box (plug 'n' play).
       
       
      Now you can start the installation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is F10 (I use an 8th generation processor, so I don't need to upgrade)
       
      You can configure manually or load my BIOS profile.
       
      Manually:
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: BIOS - CSM Support to Disabled
      - Change value: BIOS - Secure Boot to Disabled
      - Change value: Peripherals - Initial Display to IGP
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Save & Exit Setup
       
      or, BIOS profile
      You can use one of my BIOS profiles attached bellow.
      It's two versions. One stock (Geekbench 4: 5840/27384) and another with overclock [5.0 GHz] (Geekbench 4: 6360/30348)
      - Put the profile in the root of the flash drive at EFI partition.
      - Restart with DEL pressed to enter BIOS setup.
      - Go to Save & Exit.
      - Select Load Profiles.
      - Select last option and then the flasdrive in the list.
      - And finally choose MACOS_STOCK or MACOS_5GHZ.
      - Save & Exit Setup
       
      Then:
      - Now, hold the F12
      - In the list, select your flash drive.
      - Choose the flash drive (white icon).
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press ESC again and select the flash drive.
       
      Choose the internal disk (gray hdd icon) if not already selected.

      The second part of the installation will begin. This will take 16 minutes.

       
      Post installation
       
      Bootloader

      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
       
      Copy the EFI folder to desktop.
       
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
       
      Move the EFI folder from Desktop to EFI partition of the internal disk.
       
      Eject the flash drive.
       
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
      Last thing
       
      Run this command in Terminal to disable hibernation (doesn't work in macOS):
      sudo pmset -a hibernatemode 0  
       
      It's done!
       
       
      System Updates
       
      10.15.2
       
      Before install, update the following kexts:
      - Lilu.kext. I used version 1.4.0.
      - WhateverGreen.kext. I used version 1.3.5.
      - AppleALC.kext. I used version 1.4.4.
      (all download links above)
       
      Download the latest CLOVERX64.efi.zip build. I used version 5100.
      Mount EFI partition and unzip to:
      - /Volumes/EFI/EFI/CLOVER/CLOVERX64.efi
      - /Volumes/EFI/EFI/BOOT/BOOTX64.efi (rename the copy of CLOVERX64.efi to BOOTX64.efi
       
      Install update. Will reboot at least four time.
       
       
      10.15.3
       
      Updated with success without changing anything.
       
       
      10.15.4
       
      Before install, update the following kexts:
      - Lilu.kext. I used version 1.4.2.
      - WhateverGreen.kext. I used version 1.3.7.
      - AppleALC.kext. I used version 1.4.7.
      - VirtualSMC.kext. I used version 1.3.7.
      (all download links above)
       
      Download the latest CLOVER installer. I used version 5107.
      - Install respecting the configuration mentioned above in "Install bootloader" section.
       
      Install update. Will reboot at least four time.
       
       
      10.15.5
       
      - Same as usual, update all Kexts and Clover.
      - Install Update, reboot.
       
      If you like me, I had a problem with two monitors. I needed to roll back two Kexts of video from 10.15.4: FixGraphics10.15.5.zip
      After replace, fix permissions and cache.
       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
       
      Attachments
       
      config.plist v2.zip
      EFI v4.zip
      Filevault 2 additional drivers.zip
      SmallTree-Intel-211-AT-PCIe-GBE.kext.zip
      SSDTs.zip
      MACOS_5GHZ
      MACOS_STOCK
       
       
       
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×