Jump to content

[Guide] Catalina / BigSur / Monterey on mobos Serie 100 / 200 / 300 / 400 / 500 Sky Lake / Kaby Lake / Coffee Lake / Comet Lake / Rocket Lake DSDT


MaLd0n
5,447 posts in this topic

Recommended Posts

Dear MaLd0n

Due to a production error in the audio chip, the motherboard was replaced by Gigabyte. The DSDT files you sent worked on my new motherboard. :)  I want to thank you again. Now I am cleaning up again, if there is a problem I will want your help.
Link to comment
Share on other sites

Ok, I got it to boot! I have installed OSX!!

 

Next questions:

1) My monitor is 21:9 3440x1440, but OSX doesn't have an option for me to select 3440x1440, so my image is pixellated, and stretched (16:9 1080p)

2) Does my computer have to use Clover Bootloader every time it starts up? Is there a way around this, so it boots up normally?

3) I have OSX currently installed on a 2.5" HDD. I have a m.2 NVMe SSD installed in my computer (which OSX does not recognize). How do I get OSX to recognize the m.2 drive, and what's the easiest way to transfer the installation from the 2.5" HD over to the m.2 SSD, so I can use the m.2 SSD as my main OSX drive?

  • Like 2
Link to comment
Share on other sites

Good Job!

 

#1 Not sure, I know that its possible, mine's 3440 x 1440 @ 60 Hz

#2 OSX needs clover to boot, so either set the clover disk as 1st boot or F12 (whatever your hotkey is)

#3 See Rehabman's great, use search. 

  • Like 1
Link to comment
Share on other sites

Ok, I got it to boot! I have installed OSX!!

Good!

 

for nmve i prefer Pike patches, in installation, put kext ionvmefamily in Clover/Kexts/Others

but rehabman method work good, but dont use xdsm in all Devices, use only in ur nvme device to avoid KP, look at ioreg

Link to comment
Share on other sites

Good!

 

for nmve i prefer Pike patches, in installation, put kext ionvmefamily in Clover/Kexts/Others

but rehabman method work good, but dont use xdsm in all Devices, use only in ur nvme device to avoid KP, look at ioreg

 

Ok, I'll take a look at those methods, thanks!

 

Also, audio doesn't work for me. I have CA0132 drivers and Nvidia (unknown) drivers. I think I have a lot of conflicting audio kexts. I also have a TON of kexts that I don't think I need, in /S/L/E/...(like a bunch of AMD6000Controller kexts, and other stuff)

Link to comment
Share on other sites

I successfully installed Sierra on i7 7700k with Gigabyte z270x-Gaming 7. But i am having huge mouse and keyboard lag. Both are wired.

-Post ur full Clover folder with original tables, press F4 in Clover Boot Screen, files generate in Clover/Acpi/origin
-Post Ioreg, extract with Ioreg Explorer
-Run it, post files generate in ur desktop
Link to comment
Share on other sites

 

-Post ur full Clover folder with original tables, press F4 in Clover Boot Screen, files generate in Clover/Acpi/origin
-Post Ioreg, extract with Ioreg Explorer
-Run it, post files generate in ur desktop

 

Okay i fixed it. I installed the USB Kext and also loaded BIOS optimized defaults. Don't know which one fixed it but its fixed now. But cannot seem to enable Nvidia Pascal Web drivers. Its installed fine. But switched to the default Mac OS driver everytime.

  • Like 1
Link to comment
Share on other sites

Activate Nvidia in Boot section and System parameters in ur config.plist.

For 20 series chipset need emuvariable64 driver too.

 

Ur DSDT os fully edited?

Done all the Nvidia steps. No luck.

 

How do i edit the DSDT?

 

Also my external USB 3.0 drives are not being read. But thumb drives are being read on the same port. Might be some bus power issue?

 

The computer is also shutting down at times randomly.

 

 

Attaching my ACPI, IOReg and Send Me files.

My Files.zip

Link to comment
Share on other sites

Hey @MaLd0n I have a asrock z270 itx ac & i7 7700k  :) I read the requirements for you making a DSDT but just 2 questions :1) for my processor iocpunumber on the tscsync kext has to be 7 or 3? Core or thread count? :)
After install, using SSDT for my cpu will I still need fake cpu id? Thanks and great thread BTW

  • Like 1
Link to comment
Share on other sites

asrock z270 itx ac

First try with 10.12.4 without VoodooTscSync, if work, dont use

 

Yes, need fakecpuid

 

After install post ur files here, ill work in ur Clover folder

Link to comment
Share on other sites

Check

Replace full folder, use ur Nvidia, use only one GPU, remove AMD GPU

attachicon.gifCLOVER.zip

 

Done

 

Run it

attachicon.gifOlarila.command.zip

 

Done. Attaching the end result screenshot.

 

Install WebDrivers

https://images.nvidia.com/mac/pkg/378/WebDriver-378.05.05.05f02.pkg

Reboot

 

For now i am sticking to the AMD GPU which works out of the box. Will try the GTX 1050 later.

 

ur system need 10.12.4 update

 

My mac says its already updated to this version.

 

 

post-910294-0-35176800-1492961478_thumb.png

Link to comment
Share on other sites

  • MaLd0n changed the title to [Guide] Catalina / BigSur / Monterey on mobos Serie 100 / 200 / 300 / 400 / 500 Sky Lake / Kaby Lake / Coffee Lake / Comet Lake / Rocket Lake DSDT
×
×
  • Create New...