Jump to content

[Guide] Catalina / BigSur / Monterey on mobos Serie 100 / 200 / 300 / 400 / 500 Sky Lake / Kaby Lake / Coffee Lake / Comet Lake / Rocket Lake DSDT


MaLd0n
5,448 posts in this topic

Recommended Posts

U use a intel HD Graphics? if yes, u need a fakeid intelgfx

i dont use onboard video ;)

Check HERE

 

Sorry not responding before (got busy – no time to play with hackintosh)... so after all we got Pascal drivers and everything is fine... Got audio working selecting internal speakers and internal microphone in System Preferences.

Link to comment
Share on other sites

Hey MaLd0n, system is running well thanks 2 u.  :thumbsup_anim:

 

Now that Pascal's r supported I decided to replace my 5 year old Kepler GTX 670 and ordered w a GTX 1080. After I replace the 670, should anything else be necessary on the config/software side? I'm using the most recent Nvidia-Web-driver.

 

Thanx :)  

  • Like 1
Link to comment
Share on other sites

Well, just installed the GTX 1080 to replace the GTX 670. Prior to installing it everything needed by the 670 had been working great. Now I cant get past the initial apple logo screen and I get a kernel panic with "nvda_drv=1" & w/o. Any idea how I can start troubleshooting to see what's happening/ or not. The screen goes by so quickly, but I think I see something after the panic about sensors. ???

  • Like 1
Link to comment
Share on other sites

Might need some guidance on doing this. " remove sensors inside fakesmc, folder Plug Ins" :blush:

But here is what u asked for.BTW F10 would never save a screenshot 4 me in /EFI/CLOVER/Misc.


Sorry img not added.

  • Like 1
Link to comment
Share on other sites

MaLd0n, pelo que li em seu post, meus parabéns por ele, desculpe não ter visto antes, tá corrido meu trabalho, talvez seja mais complexo para instalar.

 

Por gentileza, qual sua opinião sobre esta placa: http://londritech.com.br/placa-mae-1151-gigabyte-ga-z170xp-sli-atx-ddr4-3466mhz-raid-sli-usb31-12726.html

 

Com o sistema que estou acha que deve subir e depois a dá para alterar o DSDT? 

 

Obrigado!!!

  • Like 1
Link to comment
Share on other sites

É mais complicado se vc usar Processador Kabylake que ainda não tem o suporte nativo, se vc for usar o seu Skylake, só precisa do EmuVariableUefi-64.

Qualquer placa mãe com chipset intel vai funcionar.

A parada é editar o DSDT e usar o mínimo de kexts ;)

  • Like 1
Link to comment
Share on other sites

Thanks for this awesome guide! I have been trying to find a guide closest to my build, and one which is likely to be the most stable and have the best performance. I think this might be the one for me :) I have a few initial questions before I get started:

 

- I have a similar mobo, but as it's a tiny bit different (GA-Z270X-Gaming 7 running latest BIOS - F5), do I need different SSDT and DSDT patches?

 

- My CPU is an i7700k, so should my fake cpuid be 0x0506E3?

 

- I am going to try this build out on a crappy old HDD I have laying around. If it works, and seems stable, I'll want to use my best drive (an m.2 SSD). Is there anything additional I would need to do in order to use the m.2. SSD as my main boot drive?

 

- Because this installation guide uses SSDT and DSDT patches, and doesn't use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], does that mean this is likely to result in the most stable build with the best performance (because things are edited from the machine language level)?

 

- Is this method going to affect Windows 10, which I have running on a different drive?

  • Like 1
Link to comment
Share on other sites

Hi, dellala! Welcome here!


 I have a similar mobo, but as it's a tiny bit different (GA-Z270X-Gaming 7 running latest BIOS - F5), do I need different SSDT and DSDT patches?

Same patches. Just post ur files. I edit for u.


- My CPU is an i7700k, so should my fake cpuid be 0x0506E3?

Yes. U need a fake cpu id and voodootscsync, the folder in first post have all u need.


- I am going to try this build out on a crappy old HDD I have laying around. If it works, and seems stable, I'll want to use my best drive (an m.2 SSD). Is there anything additional I would need to do in order to use the m.2. SSD as my main boot drive?

U need patches or HackNvme kext


- Because this installation guide uses SSDT and DSDT patches, and doesn't use #########, does that mean this is likely to result in the most stable build with the best performance (because things are edited from the machine language level)?

Yes. The best method for me is DSDT and SSDT pike. I apply all good patches, cosmetics, etc, etc. Like one real mac.


Is this method going to affect Windows 10, which I have running on a different drive?

No.

but i like disconnect all others HDs, install OSX and after connect other HDs again. ;)

  • Like 1
Link to comment
Share on other sites

Ok, awesome, thank you!

 

I've done the first step (created "OSX Flash Drive" with Flash Drive Maker). 

 

I'm trying to install Clover (v2.4k_r4049) onto the same USB drive, and I get the following error: "this package is incompatible with this version of os x" should I use an earlier version of Clover?

 

EDIT: what options do I need to select when installing clover? Just "Install for UEFI booting only"? Or any specific drivers as well?

 

EDIT: Is it ok that my USB flash drive is USB 3.0? I read that some users have kernel panics with similar motherboards because of USB 3.0...

Link to comment
Share on other sites

I'm not up to the post-installation part of your post yet, I'm still stuck on step 2. Below are the first two instructions in the post:

 

--Create a bootable copy of macOS Sierra

Check out the link

 

 
 
I have done this.

--Install Clover UEFI mode in USB stick

 

 
I cannot do this, because I get the error "this package is incompatible with this version of os x"
Link to comment
Share on other sites

Hey MaLd0n, Everything is pretty much back to normal here after upgrading video... except audio. I'm thinking it might be related to B4 when my 670 only had one DisplayPort and the new 1080 has three. Address issue? the only audio options avail. in sys pref's are all onboard inputs. I"m sending you a new ioreg if that's any help.....almost there

tstc’s iMac.zip

Link to comment
Share on other sites

Ahhhh, that might be it. I'm on El Capitain. Should I upgrade to Sierra or should I use an older version of Clover?

Very strange error. No idea.

try old version, if work update after install Sierra and update to 10.12.4

https://sourceforge.net/projects/cloverefiboot/files/Installer/Clover_v2.3k_r3911.zip/download

Hey MaLd0n, Everything is pretty much back to normal here after upgrading video... except audio. I'm thinking it might be related to B4 when my 670 only had one DisplayPort and the new 1080 has three. Address issue? the only audio options avail. in sys pref's are all onboard inputs. I"m sending you a new ioreg if that's any help.....almost there

U update system? If yes, need AppleHda alc1220 again

Hey MaLd0n

Send me ioreg with ioreg explorer

IORegistryExplorer 3.app.zip

Link to comment
Share on other sites

  • MaLd0n changed the title to [Guide] Catalina / BigSur / Monterey on mobos Serie 100 / 200 / 300 / 400 / 500 Sky Lake / Kaby Lake / Coffee Lake / Comet Lake / Rocket Lake DSDT
×
×
  • Create New...