Jump to content
Sa-ROG

[Guide] Asus G750 Sierra 10.12.3

14 posts in this topic

Recommended Posts

90ony1.jpg
Sa-ROG

[Guide] Asus G750JW Sierra 10.12.3
szeqsm.jpg

 

f2t2x2.jpg
INSTALL 10.12.3
Create an USB Drive Installer of macOS Sierra 10.12.3 with Clover Bootloader
In EFI/CLOVER/kexts/Others add FakeSMC.kext to recognize the System Management Controller
and ApplePS2SmartTouchPad.kext to recognize keyboard and touch-pad during installation
Start installation in SafeMode (-x)
When you finish, install the last version of Clover to start-up from HDD
 
2u7llxt.jpg
NVIDIA GTX 765M
Use any Clover configurator to change the system definition in config.plist
In SMBIOS section choose iMac14,2
In Boot section add the Custom Flag nvda_drv=1 to enable graphics Nvidia with Web Driver
Graphic card will work natively!

 

2whjo09.jpg
AUDIO ALC282
Use any kext installer to install to S/L/E folder these kexts:
AppleHDA.kext (to recognize ALC282 audio)
HDAEnabler13.kext (to assign Layout ID=13)
(Otherwise, you can use the new AppleHDA Patcher.app
to directly patch AppleHDA.kext in S/L/E)

 

2ljhz7n.jpg
ETHERNET QUALCOMM ATHEROS QCA8171
Install ALXEthernet.kext to S/L/E folder using any kext installer

 

nlojeq.jpg
CARD READER
Install AppleStorageDrivers.kext to S/L/E folder using any kext installer
Though it seems not be recognized, don't worry! It will work correctly!

23skzo.jpg
WI-FI BROADCOM BCM94352
From Os X Mavericks to macOS Sierra I needed to change the WiFi card
In my case, I’ve used a Broadcom BCM94352 half-mini card
For correct working, I needed to install to EFI folder these kexts:
FakePCIID_Broadcom_WiFi.kext
FakePCIID.kext

Using any Clover configurator, add in config.plist these strings:
<dict>
<key>Comment</key>
<string>Brcm4360 Sierra fvco init</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>81F952AA00007529=</data>
<key>Name</key>
<string>AirPortBrcm4360</string>
<key>Replace</key>
<data>81F952AA00006690=</data>
</dict>
Change in S/L/E folder the IO80211Family.kext with the same kext you can found in Os X Yosemite Installer

zn49g.jpg
BLUETOOTH BROADCOM BCM20702A0
Install to EFI folder these kexts:
BrcmFirmwareData.kext
BrcmFirmwareRepo.kext
BrcmNonPatchRAM.kext
BrcmNonPatchRAM2.kext
BrcmPatchRAM.kext
BrcmPatchRAM2.kext

2q9xa3l.jpg
MONITORING HWSENSORS
Before to use HWMonitor.app
you need to install to EFI folder these kexts:
FakeSMC_ACPISensors.kext
FakeSMC_CPUSensors.kext
FakeSMC_GPUSensors.kext
FakeSMC_LPCSensors.kext
If you'd like your monitoring appears like this:
33fdq83.jpg
you need to go to HWMonitor.app/Contents/Resources/ and change these files:
multipliers.png and pcicard.png

30djmsm.jpg
CUSTOMIZE
To change logo on About This Mac
2j51lrp.jpg
Simply you need to modify this file:
/Applications/Utilities/System Information.app/Contents/Resources/SystemLogo.tiff
For example:
2u8jr5j.jpg

2a9cuc7.jpg
TOOLS
Meanwhile I'm working on keyboard's kexts to fix Brightness, Backlight and Fn Key...
...you can use this app to adjust Brightness:
2v8na88.jpg


65bm2s.jpg
KEYBOARD
***COMING SOON***

*********************************************************************************************
FOR ANY QUESTIONS, CONTACT ME.
I WILL BE HAPPY TO HELP YOU!
IF YOU WANT TO CONTRIBUTE TO MY WORK
YOU CAN MAKE AN OFFER HERE:
PayPal.Me/SaROG
MANY THANKS

90ony1.jpg
Sa-ROG

Archive.zip

Share this post


Link to post
Share on other sites
Advertisement

I recently purchased a Asus g750jw and this guide is the best I found to realize my first hackintosh!

 

I think Sa-ROG has done a GREAT JOB!

If there were more specific guides like these, everything would be simpler
It's easy to criticize other people's work, but it's hard to build something
thank you Sa-ROG
I'm with you :) :thumbsup_anim:

Share this post


Link to post
Share on other sites

No, it's a 4th generation processor Haswell:
Intel I7-4700HQ 6M Cache, up to 3.40 GHz
https://ark.intel.com/products/75116/Intel-Core-i7-4700HQ-Processor-6M-Cache-up-to-3_40-GHz
But in this case, Intel HD Graphics 4600 is physically bypassed.

 

P.S.: I love your photos ;)

<- Asus G750JW / Core I7 4700HQ / nVidia GTX 765M 2 GB DDR5 / 24 GB RAM DDR3 / Samsung SSD Evo 840 1TB / Samsung SSD Evo 840 500GB ->

Video made by this laptop

Share this post


Link to post
Share on other sites

I have the Asus G750JX with the GTX 770M but users from the Asus Republic of Gamers forum are using many of my files especially the DSDT.  My backlight is working thanks to Dinesh for the Best DSDT on the planet.  Everything just works.  I have to install 10.12.4 but I have everything working on 10.12.3.  The audio is a bit of a problem since Sierra but SLice's Voodoo takes care of the 2 channel 3 speaker system but the Master volume is still an issue.  There is a workaround.  When I install 10.12.4 I can share my DSDT or all of the patches needed for our DSDT's.  Dinesh has a backlight kext for those systems where the DSDT patch alone will not work.  Rehabman has one as well.

Share this post


Link to post
Share on other sites

So I have a jm with an 860m in it.  I've managed to get everything working now except for the nvidia gpu.  When I try to install the web driver and add the statement in to use it.  I'll go into a reboot cycle until I pass the flag for nvidia to VESA.  

The reading I've done seems to say that this is because the 860m is an optimus(sp) card.  But the reading I've done would have suggested that yours would have been too.  Any chance someone could elaborate on this?  

 

Share this post


Link to post
Share on other sites

Hello,

Would this procedure work on the ASUS G-75vw? If not, could you possibly point me in the right direction.

Thank You!

Share this post


Link to post
Share on other sites

Hi, thanks to this thread and many hours searching I have Sierra on my G750GX. Mine is a bit different from most as it has a 120hz 3D screen internally connected to a display port. I have a whole load of windows and linux on one mbr disk and this Sierra on a second gpt clover disk.

However, mostly working now, just tidying up a few things.

Do you have the battery level working? I have installed RehabMans ACPIBatteryManager.kext and have an icon in the status bar. It shows when charging but battery percentage is always 0%.

How about mouse scrolling? hardly works at all for my logitech.

Thanks

EDIT: not sure if anyone is actually reading this but...

added a fix in dsdt and battery level working :)

Mouse scrolling works ok with a simple Logitech mouse but not well at all with my Logitech gaming mouse G403 ????????

Share this post


Link to post
Share on other sites

Hi, I have installed high sierra on my machine, everything works except the brightness issue, also I have problems with sleep and shutdown as well

Share this post


Link to post
Share on other sites
On 4/8/2017 at 7:11 PM, oSxFr33k said:

I have the Asus G750JX with the GTX 770M but users from the Asus Republic of Gamers forum are using many of my files especially the DSDT.  My backlight is working thanks to Dinesh for the Best DSDT on the planet.  Everything just works.  I have to install 10.12.4 but I have everything working on 10.12.3.  The audio is a bit of a problem since Sierra but SLice's Voodoo takes care of the 2 channel 3 speaker system but the Master volume is still an issue.  There is a workaround.  When I install 10.12.4 I can share my DSDT or all of the patches needed for our DSDT's.  Dinesh has a backlight kext for those systems where the DSDT patch alone will not work.  Rehabman has one as well.

Hey I have the same pc. can you help me out I've managed to install high sierra but it's excruciatingly slow so I can't perform the post-install stops. could this be something with the drivers. I installed it using inject Nvidia, use web drivers, used the nvdia_drv=1 command. I takes like 10 minutes to open a folder and is constantly stuck.

Share this post


Link to post
Share on other sites

Hi All! I found a way to change the screen brightness control on Asus G750 Sierra 10.12.3 using the keyboard. To do this, go to settings - keyboard, in the shortcut keys to select the screen and select reduce brightness and increase brightness. Insert a check mark and reassign the keys as desired.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Macpro3.1
      Hi,
       
      Im glad to be a part of this forum. Just signed up 20 mins ago.

      I have an old macpro 2008 fully loaded using yosemite 10.10.5.
       
      I would not like to touch that OSX version but been curious with mojave on hackintosh PC.
       
      i also have a low/mid range gaming windows PC.
       
      My specs for my W7/10 dual boot (same SSD) windows PS are as follows:


      Motherboard: Asus P8B75-V
      Intel i7 3770k
      8GB DDR3 1600mhz RAM
      Antec HCG 620W PSU
      Asus GTX 560 DC
      Corsair Force GT 120GB SSD
       
      Built everything in mid 2012.
       
      Will these hardware lets me install Mojave? If not, whats the max OSX i can install? 
      Then worst case, will i be able to install atleast yosemite 10.10?
      I dont mind if i get Nullcpupowermanagement and not be able to use my bios C1 packages and sleep or any intel speedstep as i dont use them anyways in my windows OS.
      i just need it to work smoothly with MB audio built-in, wifi, ethernet, Usb port 2.0 and 3.0.
      im not a gamer but likes to use Logic pro X.
       
       
      was thinking of using the W10 partition for the hackintosh OSX but if possible, i could use a 64GB USB 3.0 thumbdrive.
       
      Thanks in advance.
       
       
       
       
       
       
       
       
       
       
    • By fusion71au
      Clover r4747 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4747 for VMware.zip". Mount Clover-v2.4k-4747-X64 by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By superdooper71
      Hi all,
      I hope someone can help me as I am struggling with this bloody installation.
      I am running on several problems that I can't face : (
       
      First of all my config:
      Mobo: ASROCK H81M-DGS R2
      CPU: Intel Xeon E3-1220 v3 @3.10ghz
      RAM: 16gb DDR3 1600Mhz
      SSD: Crucial BX100 120Gb SSD
      Monitor: Hp 27w Hdmi
       
      POST Installation CLOVER
       
      Current Issues:
      • System will not boot (clover boot loader do not shows up) from SSD
         - System boot only with USB stick
      • Screen Resolution is only 1024x768
      • Monitor recognised as 17" instead of 24"
      • Monitor identified as secondary
      • Grafic Card Geforce GT710 shows 0 Mb
      • System info do not match Config.plistin Clover
       
      I attach screenshot of System Info, Kext in Clover, Resolution etc etc.
       
      Please can someonhelp me?
       
      Please can you tell me what is the Clover Parameter to activate when installing Clover  (Clover_v2.4k_r4722) into Boot Disk?
       
      I hope someone can help me out of this little troble: )
       
      Cheers
      Franco
       
      system info.tiff
      kext.tiff
      resolution.tiff
      system.tiff
      config.plist
    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty) New!
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By Alexandru
      Hello InsanelyMacForum,
       
      I managed to boot into Mac OS Sierra with my Intel Core 2 Duo, Nvidia 9400 GT and 4 GB of Ram machine, got internet and sound working, but the issue appears when I boot with Nvidia Web Driver. I get these acid colours, but Graphics Acceleration is working fine. I tried to inject EDID from my display, but no results as well. Would be really grateful if someone could provide some help. Thank you!

×