Jump to content
mr buffy

BCM943602CS combo card, Bluetooth not working

20 posts in this topic

Recommended Posts

Hi All,

I purchased a BCM943602CS Wi-Fi Bluetooth card off amazon.co.uk. I have Wi-Fi working but Bluetooth is not.

If I scan for devices, none are seen. I connected a Magic Mouse 2 via USB to setup. The OS says setup was successful, but after the USB cable is disconnected, I can't connect to the mouse from the Bluetooth menu. How can I confirm it is using Bluetooth on the PCI card? These were the same issues as using Bluetooth on the ASUS Maximus VIII Formula motherboard, which is why I purchased the card.

The machine is dual boot, both Wi-Fi and Bluetooth work fine in Windows 8.1 Pro with the magic mouse 2 successfully setup.

Does anyone have any trouble shooting tips?

Cheers, Paul

Share this post

Link to post
Share on other sites

Share this post

Link to post
Share on other sites


Thanks for the reply. The data is here:



Hopefully this is all you requested!

Share this post

Link to post
Share on other sites

check folder

u need only it


dont use kexts in s/l/e, etc, use Clover folder in UEFI mode

Check, if dont work back here


I tried using the attached Clover folder, but the machine reboots due to a kernal panic. A video of the boot in verbose mode is uploaded in the box.com folder noted above.


I am running 10.11.6, I notice all the kexts are in 10.12 folder, I tried renaming this to 10.11, makes no difference.


Can you clarify what you mean 'use Clover folder in UEFI mode'. I machine is UEFI based.


Cheers, Paul

Share this post

Link to post
Share on other sites

It booted after replacing the DSDT however, it still has the original problem: The mouse pairs via USB, but does not work. Can't see any other BT devices.


Cheers, Paul

Share this post

Link to post
Share on other sites

just put kexts


try it

I tried this as well as using the Kext Utility to add them to the Extensions folder. Both times the same result.


Thanks for all your suggestions thus far, any other ideas?

Share this post

Link to post
Share on other sites


Use DSDT above  DSDT.02 and add two kexts in Clover/Kexts.10.xx

attachicon.gifArquivo Comprimido.zip

Remove all kexts about bluetooth inside ur clover folder

Post Ioreg, extract with Ioreg Explorer



I finally got bluetooth working.


Turns out none of the extensions were needed... I turned off the motherboard bluetooth controller in the UEFI and viola it works!!!

Share this post

Link to post
Share on other sites
On 4/8/2017 at 6:07 AM, mr buffy said:


I finally got bluetooth working.


Turns out none of the extensions were needed... I turned off the motherboard bluetooth controller in the UEFI and viola it works!!!

I have same Wifi BT card, and a Gigabyte AORUS Z370 Gaming WIFI motherboard rev.1. I have your exact problem but I can not find the option.

Share this post

Link to post
Share on other sites

I am having same issue on my setup. @MaLd0n will your process above work for other Broadcom cards? Using a slightly different card BROADCOM BCM94352Z. 

Is there somewhere that I can read up on why it is better to put .kext files in the /others folder instead of /library/extensions like some guides say? I know that Morgonaut has said on her beginners guide that it is better to keep everything Apple Only in the /library/extensions folder but seems like many do not necessarily agree. 

Share this post

Link to post
Share on other sites
Posted (edited)

Strange thing with H370m-D3H: installed BCM943602CS, and everything works ok except phones. I can use BT mice, keyboards, magic trackpad but not my phones, simply can't see it during search. Btw, no problem when booted same PC with Windows, phones works great.  

Edited by serge sky

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By End3rPower50
      Hi, i want install MacOS catalina in my laptop.
      i created a USB bootable with Catalina and Clover but it crashed at startup.
      Thanks in advance. 
      P.S I upload my EFI’s folder and crash screenshot
      Sorry for my bad english.
      This is my laptop: 
      CPU: intel i7 6500U 
      Graphics: Intel HD Graphics 520
      Ethernet: Realtek FE Family 
      Wireless: Dell 1820A (BCM94350ZAE)
      USB 3.0

    • By AbhilashSathe
      As shown in the image below, bluetooth works fine. However, it can't detect my wireless bluetooth earphones. These same earphones are easily detectable through Windows 10 on my machine. What could be the problem? I'm currently on 10.15.3 - Catalina. Using BrcmBluetoothInjector.kext BrcmFirmwareData.kext BrcmPatchRAM3.kext

    • By Desknote

      I will be using ASUS ROG STRIX B360-I GAMING (mini-ITX) for my new build, and I'm trying to figure out the best solution for WiFi & Bluetooth. I understand that it should be possible to replace the WiFi/BT card that comes with the motherboard, but I'm confused about with what kind of card exactly. What connector will I need to be using? There are cards with miniPCI, M.2, some solutions require adapters, ...

      Is there a card I can simply swap in?

      Thank you
    • By End3rPower50
      Hi, I want to install MacOS Catalina on my laptop.
      I was installed MacOS Mojave previously but i had a lot of problem, for example my wifi's card (Dell DW1820A) had a problem: My pc sometimes doesn't boot up or pc after some minutes crashed or slowed. 
      Now i want to try again to install macOS.
      this is my spec: 
      HP 15-AY034NL 
      CPU: i7 6500U  with HD520
      SSD: 500GB SSD Samsung
      Wifi & Bluetooth: Dell DW1820A (Bluetooth: BCM2045A0) (Wifi: BCM94350ZAE)
      USB 3.0 
      Ethernet: Realtek 8100
      Attached in this thread, my old clover configuration created by me (CLOVER OLD) and clover with Wifi driver (CLOVER) created by Hervè (I had asked help at insanelymac's community)
      Thanks in advance 
      CLOVER OLD.zip
    • By Drovosek
      I have system unit Dell Vostro 3267 (i5-6400, Skylake). Information in signature.
      In this system block module installed Atheros AR9565 802.11 b/g/n Wireless Network Adapter, which, as I understand it, combines Wi-Fi - Atheros AR9565 and Bluetooth Qualcomm QCA9565.
      I managed to get working Wifi with kext from chunnann.
      Bluetooth works only if you first boot into Windows and then reboot into macOS from it. At the same time, you need to install drivers for bluetooth in Windows from the official Dell website, because the original drivers that Windows downloaded and installed itself - did not allow the bluetooth module to work even in Windows.
      In bluetooth settings, the power button was inactive and there was an eternal search for devices (if macOS was loaded immediately after the PC started). Enable button disable I cured just by adding the folder /kexts/Other kext BrcmBluetoothInjector by writing inside it in the Info.the plist file corresponds to the VendorID and ProductID of my bluetooth (which are displayed in the system report). BrcmBluetoothInjector_Mod.kext.zip
      I am disappointed that Windows is able to automatically download the firmware to the bluetooth module during the download, and Hackintosh macOS has not yet done such a kext.
      In the search for solutions to the problem I came across here are the options for the text:
      IOath3kfrmw (OS-X-Atheros-3k-Firmware)

      BTFirmwareUploader (as I understand it, this is an improved IOath3kfrmwr)
      And here's a way - to use a virtual machine to the OS from it to download the firmware to the bluetooth module
      Unfortunately, not one of these options did not help me to ensure that bluetooth worked when "cold" start the PC in macOS.
      I started to read more about kexts. In texte BrcmPatchRAM says that it is possible to add support for their bluetooth module in this kext. I downloaded the drivers for my bluetooth from the official site and extracted from .exe installer driver files themselves (This is easily done using 7-zip in Windows or using Keka in macOS). There were more files .dfu than others. As I found out .dfu files are compiled firmware files that the driver loads into the bluetooth module. In the instructions to BrcmPatchRAM States only .hex firmware files for Broadcom.
      I started looking for information on the Internet and found out that .hex files are the original "text" of the firmware as well .dfu is compiled .hex files.
      I immediately started looking for converters/decompilers/disassemblers from .in dfu .hex, but found only what's out .hex does .dfu file:
      As well as console utilities "dfu-tool" and "dfu-util" in Linux. I found out that dfu-util can be installed in macOS using Homebrew or use this option (it differs in functionality) https://github.com/the-darkvoid/dfu-util-osx
      I also learned that .dfu files are used in macOS /System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/IOBluetoothUSBDFU.kext/Contents/Resources
      I think we should try to replace all of them on that file that Windows loads the bluetooth module (I think if you try to do so, you need to make several copies of this file and rename it to the original ones .dfu files to be deleted).
      As is the idea is just mine .dfu file rename to file .zhx and add it to the kext OS-X-BrcmPatchRAM (in BrcmFirmwareRepo.kext). But there is a problem - first, I don't know which one .dfu files are downloaded to my bluetooth, maybe even a few, because there are 3 files > 40 KB IN size and a lot of files ~ 2 KB in size.
      In "dfu-tool" and "dfu-util" I saw commands that extract firmware from the device. Maybe it will be possible to boot into Linux and if bluetooth starts working there, then try to extract the firmware from bluetooth with these utilities, and then add this firmware to kexts somehow.
      In the file BTFirmwareUploader.kex/Contents/MacOS/BTFirmwareUploader inside already have a list of firmwares, but they are in .hex format. Maybe there's a way to replace them with the contents .dfu file?
      I will continue to describe the ideas and results of the experiments. If you have any ideas or you can help to solve this problem, do not hesitate to write.
      Links to download drivers: