Jump to content
gaieges

Issues with Lan (IntelMausiEthernet kext) with z270g motherboard onboard lan

3 posts in this topic

Recommended Posts

Hi there,

 

I've been struggling for a while now with getting my Asus z270g motherboard's onboard lan to work with Sierra.  I've been able to get most of the other components working thanks to the generous efforts of this forum, but this last problem has been causing me quite the level of stress!  

 

The z270g apparently has a i219-v chip, however it appears to be a bit different than the device's supported by IntelMausiEthernet (Which I've heard works very well with that chipset).  It's using deviceID 8086:15d6  After looking through the source of the driver it appears that the particular device id isnt being searched for:

 

00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (5) I219-V [8086:15d6]
	Subsystem: ASUSTeK Computer Inc. Ethernet Connection (5) I219-V [1043:8672]
	Flags: bus master, fast devsel, latency 0, IRQ 123
	Memory at df100000 (32-bit, non-prefetchable) [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: e1000e
	Kernel modules: e1000e

Here's what I've tried so far:

 

  • With IntelMausiEthernet kext:
    • Installed driver in /S/L/E and /L/E in addition to the Clover bootloader kext directory.  By itself, none of these caused kextstat to load the driver automatically (Aside from the clover directory)
    • Spoofing the Lan ID to something that the driver did support (ie one of the ones that was also using the i219v chipset), caused the driver to load (via kextstat), but no devices in system information or the network pref panel
    • Followed a number of steps in the troubleshooting steps that Mieze listed with the same result (driver loaded but no devices)
    • Didn't see any useful logging info in the debug info steps but happy to get that info if it would help
  • With AppleIntelE1000e kext (from insanely mac)
    • Very similar results to above
  • With AppleIGB kext
    • No luck across the board (although I haven't tried spoofing the id with this drive)

 

Happy to provide more information that would be relevant to the situation but not sure exactly what would help.

 

Thanks!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By e.ricu
      Salve, sono da poco riuscito ad installare l'OS di High Sierra sul mio laptop, ma adesso non va la scheda di rete, il bluetooth pare funzionare, invece; inoltre non riesco a rendere l'HDD bootabile, ho installato clover, copiato clover della chiavetta ma niente, la scheda madre non lo riconosce come un OS e non esiste alcuna opzione del tipo "OS type", qualcuno può aiutarmi? grazie in anticipo 
    • By moman2000
      Hi,
       
      Here it is (attached) for anyone who needs it for patching or restoring!
       
      Taken from macOS 10.14 Beta 1 18A293u
       
      Regards,
      Mohamed
      AppleHDA_282.5.kext.zip
    • By JDizz
      #UPDATE AS OF APRIL 27, 2018 Thursday, 3:53 PM EST

      SIMPLE INSTRUCTIONS
      After you figure out how to get High Sierra 10.13 or 10.13.4 installed to a USB with Clover Bootloader, and you're loaded onto MacOS High Sierra:

      Download Clover Configurator and MOUNT your partition and OPEN it to reveal your EFI folder. Delete it.
      Simply download the attached ZIP and unzip it by double clicking it. Then copy and paste the EFI folder you unzipped to the location of your mounted partition.

      Done. Enjoy. Special thanks to Jake Lo !


      WORKING [Dell M6800 - High Sierra 10.13.4]
      Sleep/Wake WHILE THE POWER CORD IS PLUGGED IN (Not from closing the screen down, but from clicking the Apple logo and sleep or by timer).
      Wi-Fi (AirPort Extreme) via Broadcom BCM43xx.
      2 USB ports on the LEFT side as USB 2.0/3.0 and the 1 USB 2.0/eSATA on the back.
      KeyBoard.
      TouchPad (With MultiTouch - Fully functional)
      iMessage, iCloud, FaceTime, AppStore work perfectly.
      NVIDIA Graphics work perfectly thanks to the Lilu and NvidiaGraphicsFixUp kext. THIS FIXES THE BLACK OR BLANK SCREEN PROBLEM.
      DVD-Drive/Burning if you even care to use CD, DVD disk.
      Bluetooth (Works even with Apple HomePod =] )
      Ethernet/RJ-45
      2 USBs on right side as USB 2.0/3.0
      Native Sound (On board Speakers and can adjust sound with buttons)
      SD Card Readers
      Adjusting Brightness (Download an app from the AppStore called Brightness Slider -OR- use Night Shift [will not adjust brightness, but will be bearable]).


      NOT WORKING [Dell M6800 - High Sierra 10.13.4]
      Headphone Jack (Excessive Static)
    • By ivanagui2
      VMQemuVGA display adapter driver for OSx86 running as a VirtualBox guest. The binary should work on all OSs from Snow Leopard up to Yosemite 10.10. It allows to set different screen resolutions in VirtualBox from System Preferences.   The changes I've made to the fork have been minimal.
      GitHub project page Binary and source releases Special thanks:
      PureDarwin
      probonopd
      rafirafi
      Zenith432
      VMware, Inc


    • By Mieze
      This project is dedicated to the memory of Mausi, the cat I loved more than anybody else.
       

       
      A few days before Christmas I started my latest project, a new driver for recent Intel onboard LAN controllers. My intention was not to replace hnak's AppleIntelE1000e.kext completely but to deliver best performance and stability on recent hardware. That's why I dropped support for a number of older NICs. Currently the driver supports:
       
      5 Series
      82578LM 82578LC 82578DM 82578DC 6 and 7 Series
      82579LM 82579V 8 and 9 Series
      I217LM I217V I218LM I218V I218LM2 I218V2 I218LM3 100 Series (since V2.1.0d0)
      I219LM I219V 200 Series (since V2.3.0d0)
      I219LM I219V 300 Series (since V2.4.0d0)
      I219LM I219V Key Features of the Driver
      Support for multisegment packets relieving the network stack of unnecessary copy operations when assembling packets for transmission. No-copy receive and transmit. Only small packets are copied on reception because creating a copy is more efficient than allocating a new buffer. TCP, UDP and IPv4 checksum offload (receive and transmit). Support for TCP/IPv6 and UDP/IPv6 checksum offload. Makes use of the chip's TCP Segmentation Offload (TSO) feature with IPv4 and IPv6 in order to reduce CPU load while sending large amounts of data (disabled). Fully optimized for Sierra (64bit architecture) but should work with older 64bit versions of macOS too, provided you build from source with the appropriate SDK for the target OS. Support for Energy Efficient Ethernet (EEE). VLAN support is implemented but untested as I have no need for it. The driver is published under GPLv2. Current Status
      The driver has been tested successfully with I217V, I218V and 82579V under 10.9.5 and above. The attached archive includes source code as well as a prebuilt binary (debug version) for Mavericks and Yosemite. Known Issues
      There seem to be problems while using VMware with version 1.x.x of the driver. In case you are affected use version 2.0.0 or newer. FAQ
      Could you add support of for...? Well, you are probably asking me to add support for one of the older NICs like the 82571/2/3/4L or 82583 and the answer will be no as I dropped support for these chips intentionally. They are broken and I lost more than 2 weeks trying to make it work on the 82574L without success. I was asked to add support for I210, I211 and I350 but as these chips have a completely different architecture, which isn't supported by the underlying Linux driver, this is impossible, sorry. Does it work with Snow Leopard or 32 bit kernels? No and I have no plans to make a version for 32 bit kernels or anything older than Lion. WoL from S5 doesn't work with this driver but under Windows it's working. Is this a driver bug? No it isn't, the driver is working as it should because OS X doesn't support WoL from S5. Installation
      Goto /S/L/E and delete AppleIntelE1000e.kext. Recreate the kernel cache. Open System Preferences and delete the corresponding network interface, e. g. en0. Reboot. Install the new driver and recreate the kernel cache. I recommend to use Kext Wizard or a similar utility for the installation. Reboot Open System Preferences again, select Network and check if the new network interface has been created automatically or create it manually now. Configure the interface. Troubleshooting
      Make sure you have followed the installation instructions especially when you have issues with certain domains while the others are working fine. Use the debug version to collect log data when trying to track down problems. The kernel log messages can be retrieved with "grep kernel /var/log/system.log" in Terminal. Starting from Sierra use "log show --predicate "processID == 0" --debug" in order to retrieve kernel logs. Include the log data when asking for support or giving feedback. I'm an engineer, not a clairvoyant. Don't copy and paste large amounts of log data to your post. Create an archive with the log data and attach it to your post. In case you don't want to make your log data publicly accessible, contact me via PM and I will provide you a mail address to send it directly to me.  Check your BIOS settings. You might want to disable Network Boot and the UEFI Network Stack as these can interfere with the driver. Double check that you have removed any AppleIntelE1000e.kext from your system because it could prevent the driver from working properly. Delete the following files: /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist /Library/Preferences/SystemConfiguration/preferences.plist Verify your bootloader configuration, in particular the kernel flags. Avoid using npci=0x2000 or npci=0x3000.  In Terminal run netstat -s in order to display network statistics. Carefully examine the data for any unusual activity like a high number of packets with bad IP header checksums, etc. In case auto-configuration of the link layer connection doesn't work it might be necessary to select the medium manually in System Preferences under Network for the interface. Use Wireshark to create a packet dump in order to collect diagnostic information. Keep in mind that there are many manufacturers of network equipment. Although Ethernet is an IEEE standard, different implementations may show different behavior causing incompatibilities. In case you are having trouble try a different switch or a different cable. Changelog
      Version 2.4.0 (2018-04-14) Added support for 300 series versions of I219LM and I219V. Updated underlying Linux source code. Version 2.3.0 (2017-06-20) Added support for 200 series versions of I219LM and I219V. Version 2.2.0 (2016-09-23) Disabled TSO to work around a hardware bug. Version 2.1.0 (2016-05-24) Added support for I219LM and I219V Version 2.0.0 (2015-04-22) First official release which is identical to 2.0.0d2 (only the version number has been changed). Version 2.0.0d2 (2015-04-04) Changed the tx descriptor write back policy for 82579, I217 and I218 to prevent random tx deadlocks. Version 2.0.0d1 (2015-03-14) Uses Apple's private driver interface introduced with 10.8. Supports packet scheduling with QFQ Solves the VMware issue. Version 1.0.0d6 (2015-03-04) Reworked TSO6 support to avoid problems with VMware. Wake-on-LAN now working. Version 1.0.0d5 (2015-02-27) Reworked TSO4 support to eliminate the bug of 1.0.0d4. Added some debug code in order to collect information about the VMware related issue. Version 1.0.0d4 (2015-02-25) Set total length field of the IP-header to zero for TSO4 operations. Report EEE activation state in kernel log message when the link has been established. Version 1.0.0d3 (2015-02-11) Reworked media selection and EEE support (EEE is now activated when both link partners support it. It can be disabled selecting the medium manually). Duplex setting for 10/100 MBit connections is now reported correctly. The number of tx descriptors has been reduced from 2048 to 1024. The code has been cleaned up and obsolete files have been removed. Version 1.0.0d2 (2015-01-31) First development release. Getting the Driver
      The source code can be found on GitHub: https://github.com/Mieze/IntelMausiEthernet There is also a prebuilt binary for 10.11 and above in the download section: http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/ Build from Source for 10.8
      Register as a developer on Apple's developer website. A free membership is sufficient. Download a copy of Xcode 5.1.1 and install it on your machine. In the project select 10.8 as the "Base SDK" and the "Deployment Target". Call "Archive" from the menu "Product" and save the built driver. Credits
      Thanks to RehabMan and Yung Raj for running tests and pointing me in the right direction while I was trying to fix TSO. Special thanks to Yung Raj for motivating me when I was about to give up.
×