Jump to content
Sinetek

[RYZEN] macOS 10.12.x (Sierra) Kernel Research&Development Thread

780 posts in this topic

Recommended Posts

Advertisement

Hi guys, i have a runing Sierra 10.12.5 with Ryzen 5 1500X and Radeon RX 560. Here i share details about software, hardware and settings i use

 

Hardware:

Board       : ASRock AB350 Pro4

CPU         : AMD Ryzen 5 1500X 4C/8T @3.5GHz

GPU         : Sapphire Radeon RX 560 4GB OC

Memory      : Corsair LPX Vengeance 2x4GB DDR4 2666MHz

Display     : Dell 1909Wb 1440x900@60Hz

HDD         : WDC Blue 1TB + Seagate Barracuda 1TB

Standard USB mouse and keyboard

 

Software:

OS Image    : SierraAMD v4 (10.12.5)

Bootloader  : Clover_v2.4k_r4152

 

Configurations:

BIOS :

  • SMT             : Enable
  • Super I/O       : Disable
  • XMP             : Enable
  • Virtualization  : Enable

Clover : config.plist

 

Kexts:

  • Lilu.kext           -> EFI/CLOVER/kexts/Other
  • WhateverGreen.kext  -> EFI/CLOVER/kexts/Other

 

Modified kext:

  • /S/L/E/AMD9510Controller.kext//Contents/Info.plist

from:

<key>IOPCIMatch</key>
<string>0x67EF1002</string>

to:

<key>IOPCIMatch</key>
<string>0x67FF1002</string>

Benchmark:

- Cinebench R15

attachicon.gifScreen Shot 2017-08-14 at 11.26.19 AM.png

 

- Geekbench 4

CPU .   : https://browser.geekbench.com/v4/cpu/3697268

Compute : https://browser.geekbench.com/v4/compute/1015156

Hey Question I have the Same MB AsRock AB350 Pro4 When I run the installer I losse all USB fuctions Can you help me?

Share this post


Link to post
Share on other sites

hello to all of you and thanks for the great work.

 

ive successfully installed osx sierra on a msi pc mate b350 using a ryzen 1600, but sadly the most important program (cubase) cannot be run.

 

 

better said its elicenser software refuses to run and gives errors. ive tried all the kernels here and none of them work :(

on windows its a .net app if i remember right, so maybe this helps?

 

https://www.steinberg.net/index.php?id=12892

soft can be free downloaded so maybe you can give it a try.

any chance to get this thing running?

 

regards

Share this post


Link to post
Share on other sites

can someone check this, please

**please test this only on a test partition

removed

Share this post


Link to post
Share on other sites

No luck for me, can't get past ************************************ reboot.

Thanks for the first try, Gigamaxx

Share this post


Link to post
Share on other sites

Hey Question I have the Same MB AsRock AB350 Pro4 When I run the installer I losse all USB fuctions Can you help me?

 

i never had problem with usb installer. i'am using default uefi setting with xmp profile enabled

Share this post


Link to post
Share on other sites

i never had problem with usb installer. i'am using default uefi setting with xmp profile enabled

My problem was With seirraamd_V5 I took v4 like you and my usb ports are fine now

Share this post


Link to post
Share on other sites

Hey Is Siri working for everyone?

I get error "Sorry, I'm having trouble with the connection. Please try again in a moment."

I've looked for fixes and did the Imessage and Facetime fix already I can sign into everything.. any ideas?

Share this post


Link to post
Share on other sites

Gigamaxx,

 

I'm getting back to some testing today. This Bronya 10,2 kernel has a lot more than just the kernel file, and doesn't include the pre-linked kernel. Should be be replacing all of the files in the package? And do I need to mess with the prelinked kernel?

Share this post


Link to post
Share on other sites

Hi dj_sash ! 

If there is no difference so it must work but I have not seen the difference between these processors! You first try ! 
And I have if you have the time look and may be will !

Share this post


Link to post
Share on other sites

 

Hi dj_sash ! 

If there is no difference so it must work but I have not seen the difference between these processors! You first try ! 
And I have if you have the time look and may be will !

 

The difference in number of cores won't make any issue?

 

Bronya… I am asking you if it will work on Threadripper ?¿

Share this post


Link to post
Share on other sites

Yes .

Please test kernel... 

That's a WOW motherboard for THREADRIPPER :)

with ThunderBolt 3 Support. :)

Gigabyte's X399 Designare-EX

https://www.anandtech.com/show/11847/gigabyte-announces-x399-designare-ex

 

Finally I think, it gonna be time to really invest in upgrading now. :)

 

All + a VEGA :)

 

Look at the name, I guess they release that version of motherboard specially for DESIGNERS :)

Share this post


Link to post
Share on other sites

 

Hi dj_sash ! 

If there is no difference so it must work but I have not seen the difference between these processors! You first try ! 
And I have if you have the time look and may be will !

 

 

I think the main difference is the PCIE lanes Threadripper has 64 lanes.

Share this post


Link to post
Share on other sites

Thanks kernel coders!..

 

rJR1GV.png

 

| AMD Ryzen 3 - 1200 | MSI A320M PRO-VH PLUS | CORSAIR 8GB Vengeance RED DDR4 2400MHz XMP 2.0 CL16 | Zotac Nvidia GT710 GDDR5 Fanless | OCZ 240GB TL100 Series 240GB SSD Sata 3.0 | Seagate 2.5" 500GB HDD Barracuda Sata 3.0 128MB Cache 5400Rpm | Windows 10 Pro x64 | macOS Sierra 10.12.6 |

Share this post


Link to post
Share on other sites

Yes

Ok !

Do i have to use the system.kext and the .framework files too ?

If yes , then how should i install the .framework files ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×