Jump to content
Sinetek

[RYZEN] macOS 10.12.x (Sierra) Kernel Research&Development Thread

780 posts in this topic

Recommended Posts

My Ryzen 1700X hackintosh used the same MB as yours.

 

GTX-980 is also similar to your 1080 but less powerful.

Up to 10.12.6 these worked quite well except OpenGL performance tested by Cinebench R15 only 40~50% score values of AMD 7950.

You will need Clover bootloader to enable Nvidia Web Driver at 10.12.x.

For Bronya's 2667 bootloader will get black screen unless booted by nv_disable=1 and loss of hardware acceleration function (CI/QE).

 

Need this machine for video editing..

waw so it is posible ..perfect...is there any tutorial how to do that :D

Where can i get 10.12.6 OSX?

clover bootloader from tonymacs?

Share this post


Link to post
Share on other sites
Advertisement

Hi !

Here kernel 10.9.5 for ryzen ? ))

Ok .

Try new kernel and boot(chameleon) for Ryzen !

This kernel and bootloader maked 1 July ! 

attachicon.gifboot_kernel_10.9.5_ryzen.zip

Thanks for this new kernel which fixed previous issues booted by Clover:

Now timer is normal and performance tested by Cinebench R15 is normal too !

Thanks a million !

At both 10.12.x and 10.9.5 my Ryzen 1700X hackintosh are working stably with superior performance and could be used daily for productive job !

Looking forward to your patched kernel and boot for High Sierra (10.13) in both FX-6300 &/or Ryzen 1700X hackintosh as soon as possible !

Share this post


Link to post
Share on other sites

Thanks for this new kernel which fixed previous issues booted by Clover:

Now timer is normal and performance tested by Cinebench R15 is normal too !

Thanks a million !

At both 10.12.x and 10.9.5 my Ryzen 1700X hackintosh are working stably with superior performance and could be used daily for productive job !

Looking forward to your patched kernel and boot for High Sierra (10.13) in both FX-6300 &/or Ryzen 1700X hackintosh as soon as possible !

If you don't mind me  asking,What video card are you running? If it's nvidia: whats your FPS on cinebench?

Share this post


Link to post
Share on other sites

If you don't mind me  asking,What video card are you running? If it's nvidia: whats your FPS on cinebench?

Please check Post #85 and #90 at

http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-06052017/page-5

 For Ryzen hackintosh only AMD 7950, 6870, or 5770 are recommended at present.

Currently my Ryzen 1700X hackintosh is using AMD 7950 which performs very well from 10.9.5 to 10.12.6.

Nvidia GTX 980 or GTX-680 performed very poor in my Ryzen 1700X hackintosh as the previous posts shown.

 

[EDIT]

Nvidia GTX-1060 also performed very poor in my Ryzen 1700X hackintosh, but it worked great in Intel Z97 or Z87 hackintoshs at 10.12.6.

Edited by jsl

Share this post


Link to post
Share on other sites

Please check Post #85 and #90 at

http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-06052017/page-5

For Ryzen hackintosh only AMD 7950, 6870, or 5770 are recommended at present.

Currently my Ryzen 1700X hackintosh is using AMD 7950 which performs very well from 10.9.5 to 10.12.6.

Nvidia GTX 980 or GTX-680 performed very poor in my Ryzen 1700X hackintosh as the previous posts shown.

Thank you very much for the information. You are very helpful.

Share this post


Link to post
Share on other sites

Hi !

Here kernel 10.9.5 for ryzen ? ))

Ok .

Try new kernel and boot(chameleon) for Ryzen !

This kernel and bootloader maked 1 July ! 

attachicon.gifboot_kernel_10.9.5_ryzen.zip

 

wooh !!

 

good job Bronya :thumbsup_anim:

 

just replace kernel, use old prebootloaderRyzenBronya chameleon 2667. ;)

 

the sound voodooHDA works good, Mavericks is winner !! {censored} nV GTX 1050 // Sierra !!!  for sale !! :hysterical:

 

best HD 7950 !!

post-2087795-0-06811700-1498924347_thumb.png

Share this post


Link to post
Share on other sites

Hi Guys,

 

Trying to install osx sierra on vmware with my ryzen 1600. Can't get past this section on install process.

Any ideas?

post-2164550-0-88013800-1498944334_thumb.png

Share this post


Link to post
Share on other sites

Hi Guys,

 

Trying to install osx sierra on vmware with my ryzen 1600. Can't get past this section on install process.

Any ideas?

"STILL WAITING FOR ROOT DEVICE" error usually defer to the boot disk being disconnected or unreachable.

 

If you are installing from an USB, try adding USB kexts to the (I guess) /system/library/extensions folder on your installation disk and repair permissions.

 

I would make an .ISO of the installation disk and mount it to the virtual machine.

Share this post


Link to post
Share on other sites

:)

 

use HDD installer (sata)  ;)

 

 

Ah cool. Do you know where I can get an iso for ryzen to install? I only have a usb that was imaged where a Mac system can read it as it uses a .dmg file....

Share this post


Link to post
Share on other sites

wooh !!

 

good job Bronya :thumbsup_anim:

 

just replace kernel, use old prebootloaderRyzenBronya chameleon 2667. ;)

 

the sound voodooHDA works good, Mavericks is winner !! {censored} nV GTX 1050 // Sierra !!!  for sale !! :hysterical:

 

best HD 7950 !!

Hi @papiercul

can you write guide using chameleon?

Share this post


Link to post
Share on other sites
Hi .. i have the problem of booting my ryzen system, Chameleon 2667 restart my pc with blank screen

I used working osx 10.9.5 clone hdd.. 

Share this post


Link to post
Share on other sites

Unfortunately the Ryzen Kernel isn't working with Lilu + Whatevergreen, It would be great if someone finds a solution.

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Unfortunately the Ryzen Kernel isn't working with Lilu + Whatevergreen, It would be great if someone finds a solution.

 

 

Inviato dal mio iPhone utilizzando Tapatalk

 

A Ryzen user on my forum has it working. He's using the auto kernel from Bronya and the latest Clover with the kexts in EFI/Clover/Kexts/10.12 and inject kexts set to true. No graphics options enabled in the config either.

Share this post


Link to post
Share on other sites

A Ryzen user on my forum has it working. He's using the auto kernel from Bronya and the latest Clover with the kexts in EFI/Clover/Kexts/10.12 and inject kexts set to true. No graphics options enabled in the config either.

 

Yep, same here, but no acceleration in 12.5 :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×