Jump to content
Sinetek

[RYZEN] macOS 10.12.x (Sierra) Kernel Research&Development Thread

780 posts in this topic

Recommended Posts

Advertisement

It is necessary to look

 

virtual machine 8T= 8 Threads and not 16 threads 

 

Posting specs in your signature line would help as well.

Share this post


Link to post
Share on other sites

hi everybody, i just bought a ryzen 1700x and the asus prime x370 pro,i'd read the entire forum bout the sierra installation and i saw how much the the community is active and helping each other...its really a pleasure to see all the sharings of time solving the issues..great job guys really great job..


the facts is that i would like to install sierra... can some popularized the procedures or provide any tutorial??? as the the way too the solution was too complex.


Share this post


Link to post
Share on other sites

hi everybody, i just bought a ryzen 1700x and the asus prime x370 pro,i'd read the entire forum bout the sierra installation and i saw how much the the community is active and helping each other...its really a pleasure to see all the sharings of time solving the issues..great job guys really great job..

the facts is that i would like to install sierra... can some popularized the procedures or provide any tutorial??? as the the way too the solution was too complex.

Search the "Help Topic Ryzen thread", and there is also a "Ryzen patcher" thread. Good luck and keep us posted. Most of the essentials should be there in the help thread, and the patcher has worked for a few as well.

Share this post


Link to post
Share on other sites

Me too!    I'm afraid to restart but what the heck, it's a backup to a backup disk.

 

Restart worked!    Nice, the Sierra 12.4 to 12.5 update went smoothly so far, lost RX 480 metal and Realtek8111 Ethernet but that's to be expected.

post-1753549-0-27452000-1494899542_thumb.png

post-1753549-0-40659700-1494899562_thumb.png

Share this post


Link to post
Share on other sites

Me too!    I'm afraid to restart but what the heck, it's a backup to a backup disk.

 

Restart worked!    Nice, the Sierra 12.4 to 12.5 update went smoothly so far, lost RX 480 metal and Realtek8111 Ethernet but that's to be expected.

Can you or some one else whose Ryzen hackintosh bootable by Clover EFI ?

I found CPU power management and Nvidia Web Driver issues could be fixed by Clover bootloader.

But up to now my AMD hackintoshs can be booted by Enoch r.2877 or Bronya modified r.2667 bootloader only,

except FX-6300 hackintosh which can be booted by Clover r.4061 without the above-mentioned two issues.

Everytime when I try to boot by Clover always got frozen immediately as the attached photo.

Is there anyone can solve this bootloader problem related to Clover EFI ?

This problem have been posted by Shaneee long time ago, but there is no significant progress of solution yet.

It occured at 10.11.x and 10.12. only, no such an error at 10.10.5

post-70188-0-38407700-1494903414_thumb.jpeg

Share this post


Link to post
Share on other sites

I'm having strange issues in open GL app Uningine Valley with RX 480 everything is rolling along nicely 40-43 fps Extreme HD settings and then about 3/4 of the way through it defaults to the Nvidia GT210 or now the R7 265.    it should be getting a score in the 1800s but the default or reset to the lesser card kills the score.

post-1753549-0-96414300-1494903429_thumb.png

post-1753549-0-35604900-1494903460_thumb.png

Share this post


Link to post
Share on other sites

need advice

 

i Used this files

------------------------------------------------------------------------------------------------------

Use boot_beta.zip and 10.12.4 Patch kernel (auto and fakeMSR kernel)

and kernel_10.2.4_fakeMsr.zip   9.59MB   65 downloads

zip.gif  kernel_10.2.4_auto.zip   9.59MB   106 downloads

------------------------------------------------------------------------------------

 

 

i did

1.replace system.kext    , /system/library/extensions (chmod -R 755 and Chown -R root:wheel )

 

2. Replace kernel  to /system/library/kernels/kernel

2. frameworks three files Replace /system/library/Frameworks and (chmod -R 755 and Chown -R root:wheel )

CPU halted and auto shut down.

 

dyld: Library not loaded: /system/library/Frameworks/IOKit.Framework/Version/A~@*$@)*$)@

(Screen shot is this link https://goo.gl/photos/7J4QpoNNACawMLnG6 )

 

3. So i try different way.

replace 10.12.4 origirinal Frameworks 3 Files and merge patch frameworks 3 files.

than i can see another messages

 

(Screen shot is think link https://goo.gl/photos/NQ9DqTYAuRqPtGiRA )

and youtube Video link https://youtu.be/3GLlqnuXpsU

 

 

--------------------------------------

I Need advice . what mistake ?

Share this post


Link to post
Share on other sites

need advice

 

i Used this files

------------------------------------------------------------------------------------------------------

Use boot_beta.zip and 10.12.4 Patch kernel (auto and fakeMSR kernel)

and kernel_10.2.4_fakeMsr.zip   9.59MB   65 downloads

zip.gif  kernel_10.2.4_auto.zip   9.59MB   106 downloads

------------------------------------------------------------------------------------

 

 

i did

1.replace system.kext    , /system/library/extensions (chmod -R 755 and Chown -R root:wheel )

 

2. Replace kernel  to /system/library/kernels/kernel

2. frameworks three files Replace /system/library/Frameworks and (chmod -R 755 and Chown -R root:wheel )

CPU halted and auto shut down.

 

dyld: Library not loaded: /system/library/Frameworks/IOKit.Framework/Version/A~@*$@)*$)@

(Screen shot is this link https://goo.gl/photos/7J4QpoNNACawMLnG6 )

 

3. So i try different way.

replace 10.12.4 origirinal Frameworks 3 Files and merge patch frameworks 3 files.

than i can see another messages

 

(Screen shot is think link https://goo.gl/photos/NQ9DqTYAuRqPtGiRA )

and youtube Video link https://youtu.be/3GLlqnuXpsU

 

 

--------------------------------------

I Need advice . what mistake ?

 

Try with just the kernel. Skip the kext and Frameworks for now.

Share this post


Link to post
Share on other sites

Guys.. I have one more question.

 

Strange Cinebench Open GL Score

 

Ryzen 1800X & Gtx 980 Ti. OpenGL Score is 43 fps

 

Cpu score 1677cb (Yes 1800x 3.8Ghz this score. no problem)

 

But

 

GTX 980Ti Cinebench openGL Score too low..

(Normal GTX980 & 980 Ti) Score 95 ~ 120 fps

 

But ryzen 10.12.4 Cinebench R15 Score 43 or 44 Fps..

 

is this kernel Problem? or Nvidia Web driver Problem?

 

can you tell your ryzen & Nvidia 10.12.4 system OpenGL Score? 

 

 

Cinebench OpenGL Score screenshot link-

 

https://goo.gl/photos/WE33P4zum8KNe2uj8

Share this post


Link to post
Share on other sites

 

is this kernel Problem? or Nvidia Web driver Problem?

 

 

 

What kind of question is this ???

If this question, ok i close project . 

My cinebench is 50 fps OpenGL Score . My video card is ATI Radeon HD 6870 Series 1024 МБ

post-31928-0-90792000-1495014034_thumb.png

Share this post


Link to post
Share on other sites

Guys.. I have one more question.

 

Strange Cinebench Open GL Score

 

Ryzen 1800X & Gtx 980 Ti. OpenGL Score is 43 fps

 

Cpu score 1677cb (Yes 1800x 3.8Ghz this score. no problem)

 

But

 

GTX 980Ti Cinebench openGL Score too low..

(Normal GTX980 & 980 Ti) Score 95 ~ 120 fps

 

But ryzen 10.12.4 Cinebench R15 Score 43 or 44 Fps..

 

is this kernel Problem? or Nvidia Web driver Problem?

 

can you tell your ryzen & Nvidia 10.12.4 system OpenGL Score? 

 

 

Cinebench OpenGL Score screenshot link-

 

https://goo.gl/photos/WE33P4zum8KNe2uj8

not a kernel problem,,it seems like is it ur 1st hackintosh..gpu made for windows performs 20/30 percent slower on macOS

Share this post


Link to post
Share on other sites

not a kernel problem,,it seems like is it ur 1st hackintosh..gpu made for windows performs 20/30 percent slower on macOS

 

auctally this is not my first hakintosh. ( many Hackintosh Tested for Intel PC, you think more.)

but AMD System is first.. so I don't know why slow Nvidia OpenGL performance slower half score than Intel Hackintosh

Share this post


Link to post
Share on other sites

Guys.. I have one more question.

 

Strange Cinebench Open GL Score

 

Ryzen 1800X & Gtx 980 Ti. OpenGL Score is 43 fps

 

Cpu score 1677cb (Yes 1800x 3.8Ghz this score. no problem)

 

But

 

GTX 980Ti Cinebench openGL Score too low..

(Normal GTX980 & 980 Ti) Score 95 ~ 120 fps

 

But ryzen 10.12.4 Cinebench R15 Score 43 or 44 Fps..

 

is this kernel Problem? or Nvidia Web driver Problem?

 

can you tell your ryzen & Nvidia 10.12.4 system OpenGL Score?

 

 

Cinebench OpenGL Score screenshot link-

 

https://goo.gl/photos/WE33P4zum8KNe2uj8

Not a kernel problem, it's a configuration problem. On other sites many people are having trouble with the Nvidia web drivers even on real Macs. It usually boils down to configuration issues, I was able to get Nvidia cards working fine e.g.. Nvidia GT210, Gt710, 8400GS, all worked well, but they were not relying on web drivers. The kernel did not cause any problems with Nvidia cards so it must be the drivers and or configuration. Chameleon doesn't have the clover fixes for injecting web drivers or at least not yet a clear and easy solution.

 

Are there some bugs and problems with Ryzen and Sierra, yes? It's been a very short time and to have working Ryzen hackintoshes so soon is a miracle and we all owe Bronya a big thank you for making it possible. These little bugs here and there are what need to be worked out like USB, sound, Bluetooth, Ethernet etc.., These issues may require reworking some of the kexts or replacing them with modified kexts. This is the work that now needs to be done, we can't rely on the kernel to do it all. At some point we need to look at the software and or bootloader configuration or lack of.

 

When the Kaby Lake Intel chips came out it took some time to get fixes working for many of these same issues (3-6 months), and that was with clover support and many testers finding solutions. Ryzen launched less than 2 months ago and this isn't a tick-tock change like Intel. Kaby lake used Skylake fixes we can't really rely on older AMD fixes the cpus are way too different. We are in good shape so far with these CPUs and the boot and kernel files are working well ahead of time for what most predicted for a timeline.

 

We should be counting our blessings because we are lucky enough to have Bronya boot and kernel files to work with.

Share this post


Link to post
Share on other sites

What kind of question is this ???

If this question, ok i close project . 

My cinebench is 50 fps OpenGL Score . My video card is ATI Radeon HD 6870 Series 1024 МБ

attachicon.gif17_may.png

 

yes but.....

 

..................................

 

macOS 10.12.6 beta 1 works ;)

post-2087795-0-48797200-1495065879_thumb.png

post-2087795-0-40182100-1495065898_thumb.png

post-2087795-0-59483900-1495066862_thumb.png

post-2087795-0-92777100-1495067720_thumb.png

Share this post


Link to post
Share on other sites

What kind of question is this ???

If this question, ok i close project . 

My cinebench is 50 fps OpenGL Score . My video card is ATI Radeon HD 6870 Series 1024 МБ

attachicon.gif17_may.png

 

hi bronya 

 

my english is not good..

so i don't understand 100% english.

so sometimes i dont understand.. what happend?  

 

but i guess...and feel....

 i seem to offend someone 

am i right? 

 

first

i want say to you.  " i'm sorry "

 

maybe.. my language problem make Communication problem. 

 

i really think Bronya Kernel is Awsome  :)

 

 

is this kernel Problem? or Nvidia Web driver Problem?   = I Mean . i thunk 'Why My GPU SLow.  i mistake something? hmm..how to fix this. i need more information. i have to ask someone'  = it's mean "I need help."

 

so i write question...it's was just question. 

it's  my language communication problem.. 

 

thanks a lot . bronya

 

Not a kernel problem, it's a configuration problem. On other sites many people are having trouble with the Nvidia web drivers even on real Macs. It usually boils down to configuration issues, I was able to get Nvidia cards working fine e.g.. Nvidia GT210, Gt710, 8400GS, all worked well, but they were not relying on web drivers. The kernel did not cause any problems with Nvidia cards so it must be the drivers and or configuration. Chameleon doesn't have the clover fixes for injecting web drivers or at least not yet a clear and easy solution.

 

Are there some bugs and problems with Ryzen and Sierra, yes? It's been a very short time and to have working Ryzen hackintoshes so soon is a miracle and we all owe Bronya a big thank you for making it possible. These little bugs here and there are what need to be worked out like USB, sound, Bluetooth, Ethernet etc.., These issues may require reworking some of the kexts or replacing them with modified kexts. This is the work that now needs to be done, we can't rely on the kernel to do it all. At some point we need to look at the software and or bootloader configuration or lack of.

 

When the Kaby Lake Intel chips came out it took some time to get fixes working for many of these same issues (3-6 months), and that was with clover support and many testers finding solutions. Ryzen launched less than 2 months ago and this isn't a tick-tock change like Intel. Kaby lake used Skylake fixes we can't really rely on older AMD fixes the cpus are way too different. We are in good shape so far with these CPUs and the boot and kernel files are working well ahead of time for what most predicted for a timeline.

 

We should be counting our blessings because we are lucky enough to have Bronya boot and kernel files to work with.

 

thanks your long reply.

i know your message. and agree

Share this post


Link to post
Share on other sites

Not a kernel problem, it's a configuration problem. On other sites many people are having trouble with the Nvidia web drivers even on real Macs. It usually boils down to configuration issues, I was able to get Nvidia cards working fine e.g.. Nvidia GT210, Gt710, 8400GS, all worked well, but they were not relying on web drivers. The kernel did not cause any problems with Nvidia cards so it must be the drivers and or configuration. Chameleon doesn't have the clover fixes for injecting web drivers or at least not yet a clear and easy solution.

 

Are there some bugs and problems with Ryzen and Sierra, yes? It's been a very short time and to have working Ryzen hackintoshes so soon is a miracle and we all owe Bronya a big thank you for making it possible. These little bugs here and there are what need to be worked out like USB, sound, Bluetooth, Ethernet etc.., These issues may require reworking some of the kexts or replacing them with modified kexts. This is the work that now needs to be done, we can't rely on the kernel to do it all. At some point we need to look at the software and or bootloader configuration or lack of.

 

When the Kaby Lake Intel chips came out it took some time to get fixes working for many of these same issues (3-6 months), and that was with clover support and many testers finding solutions. Ryzen launched less than 2 months ago and this isn't a tick-tock change like Intel. Kaby lake used Skylake fixes we can't really rely on older AMD fixes the cpus are way too different. We are in good shape so far with these CPUs and the boot and kernel files are working well ahead of time for what most predicted for a timeline.

 

We should be counting our blessings because we are lucky enough to have Bronya boot and kernel files to work with.

I totally agree with you regarding Ryzen kernel & boot.

Without Bronya's contribution we can NOT get Ryzen hackintosh working so soon and so few issues up to now.

The only issue bothered me is Power Management related to Shutdown/Restart/Sleep/Wakeup problem at 10.9.5 ~ 10.12.5 which should be fixed by bootloader instead of kernel I think.

I can get much higher OpenGL score by Cinebench R15 for GTX-980 & GTX-680 in Intel hackintosh at 10.12.5 (16F73), but always got lower score in my AMD hackintoshs.

post-70188-0-00470900-1495074594_thumb.png

post-70188-0-90820700-1495102659_thumb.png

Share this post


Link to post
Share on other sites

I totally agree with you regarding Ryzen kernel & boot.

Without Bronya's contribution we can NOT get Ryzen hackintosh working so soon and so few issues up to now.

The only issue bothered me is Power Management related to Shutdown/Restart/Sleep/Wakeup problem at 10.9.5 ~ 10.12.5 which should be fixed by bootloader instead of kernel I think.

I can get much higher OpenGL score by Cinebench R15 for GTX-980 & GTX-680 in Intel hackintosh at 10.12.5 (16F73), but always got lower score in my AMD hackintoshs.

 

Very interesting.

Your 680 and 980 same fps score 112~113

 

980= 680? No...

 

 

In my case have 1800x  gtx660 and gtx980 ti two card have

 

 

Same score 10.12.4 

 

Gtx980 ti= 45 fps / gtx660 = 45 fps

 

Gtx980ti <=====FAR FAR away lineup8==> gtx660

 

But same score.. me and you..

Actually fps 45 is too low. 

 

If you clear this.problem give hint. And advic

 

Thx

Share this post


Link to post
Share on other sites

Very interesting.

Your 680 and 980 same fps score 112~113

 

980= 680? No...

 

 

In my case have 1800x  gtx660 and gtx980 ti two card have

 

 

Same score 10.12.4 

 

Gtx980 ti= 45 fps / gtx660 = 45 fps

 

Gtx980ti <=====FAR FAR away lineup8==> gtx660

 

But same score.. me and you..

Actually fps 45 is too low. 

 

If you clear this.problem give hint. And advic

 

Thx

My hypothesis is these GPU scores of GTX-9xx/6xx depend upon the optimization of performance from Nvidia Web Driver.

For example my GTX-980 got very low score at 10.10.5 in Ryzen 1700X hackintosh too.

Unable to test it at 10.11.6 or 10.12.5 because Nvidia Web Driver not properly loaded at all.

Maybe Cinebench R15 is not so reliable at Mac OS X of AMD hackintoshs either.

post-70188-0-56087400-1495107132_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×