Jump to content
TemperateCone0

Been trying installing different versions of OS X/MacOS on my main PC with no success

6 posts in this topic

Recommended Posts

So I have been trying to install OS X 10.10/10.11 and MacOS 10.12 on my main PC with no success.

 

 

So I once got Sierra working couple of days ago without Graphical Acceleration but afterwards it didn't even boot at all. I read that I would be able to get the graphical acceleration on Yosemite so I thought I should give it a try. There's 2 pics what kind of error message I get when trying to boot to the installer. I think it's about my GPU but do you have any kind of suggestions that how could I at least boot into the installer and install the OS?

 

 

Any kind of help would be appreciated.

 

Specs: 

CPU FX-8350

Mobo: ASUS Crosshair V Formula-Z

RAM: 16GB of Kingston HyperX DDR3 RAM

GPU: XFX R7 260X ( I know it's not a very optimal card for this, but I've found out it's possible to get it working )

Tried using Clover but I got reboots so I started using Enoch.

post-1637430-0-48471500-1488631415_thumb.jpg

Share this post


Link to post
Share on other sites
Advertisement

I've found that people with AMD FX CPUs and R7 260x were able to boot with Yosemite in safe mode (-x) and apparently replacing the vanilla IOPCIFamily.kext and AppleACPIPlatform.kext took away the need to boot in safe mode: http://www.insanelymac.com/forum/files/file/354-amd-replace-kext-for-yosemite/

 

So give either of those suggestions a try and see if it helps. 

 

Thread related to this: http://www.insanelymac.com/forum/topic/303275-radeon-r7-260x-no-qecigraphicsaccel-on-chameleon-cant-boot-with-clover/

Share this post


Link to post
Share on other sites

Hi

 

Help needed

 

I installed Sierra 10.12.3 on my new PC : Intel i7 6700, Gigabyte H170M-D3H motherboard, 8GB DDR4 Adata, Asus AMD R7370 4GB Video Card and Kingston 120GB SSDnow. OSX was downloaded from Appstore. The installation went fine. 

My problem is that the display doesn't see to work properly. I checked the system info and it shows AMD R9 270 3MB VRAM. The other problem is no audio device. Can any one help me out?

Thanks in advance

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Fede1132
      Hi guys i have a problem install macOs Mojave on my PC, I have this configuration:

      CPU: Ryzen 7 2700X;
      GPU1: GTX 970 Strix(For game rendering and 144Hz Monitor);
      GPU2: GTX 750ti Strix(For 2nd monitor rendering to get 100% performances from 1st 144Hz Monitor);
      MotherBoard: MSI x470 GAMING PLUS
      Hard Disk 1 (Windows 10): Samsung EVO M.2;
      Hard Disk 2 (For Storage): RAID (1) between two hard disks;
      Hard Disk 3 (For Mojave): Kingston SSD 120GB;

      I have created my USB with this:
       
      Create Bootable USB Code: sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB -- /Applications/Install\ macOS\ Mojave.app -- nointeract && say Done. Clover Settings: Boot: Verbose; dart=0; nv_disable=0; kext-dev-mode=1; GraphicsEnabler=No; XMPDetection = No. Cpu: C6. Devices: (Not Enabled = [ ] - Enabled = [-] - Full Enabled [✓]) Inject (Full Enabled); Add ClockID (Full Enabled); FixOwnership (Full Enabled); Gui: (Not Enabled = [ ] - Enabled = [-] - Full Enabled [✓]) Enabled (Full Enabled); Screen Resolution: 1920x1080; Kernel and Kext Patches: (Not Enabled = [ ] - Enabled = [-] - Full Enabled [✓]) Apple RTC (Full Enabled); KernelPm (Full Enabled); SMBIOS: iMac(18,3); System Parameters: Inject Kexts = Yes; Inject System ID; Used Kexts: FakeSMC FakePCIID NVIDIA WEB LILU BIOS: VT-d = Disabled; XHCI Hand-Off = Enabled; Legacy USB Support: Enabled; Hard Disk: AHCI Mode; Selection Mode: Legacy + EUFI; Clover Install Log:
      Full Error Log:
       
    • By tokia
      Hello,
       
      My desktop Hackintosh is running macOS Mojave 10.14.2 with two dedicated GPUs installed: NVIDIA GTX 1080 Ti, AMD Radeon HD 7970.
       
      The AMD GPU is used primarily under macOS and the NVIDIA one under Windows.
       
      macOS boots without issues as long as there are no displays connected to the NVIDIA GPU. If a display is connected then the display connected to the AMD GPU will become blank. The system can be accessed using Screen Sharing/VNC.
       
      There are no problems if I swap PCI-e slots for the GPUs so that the AMD GPU is in the first slot (primary GPU), but I prefer not to do this.
       
      I have tried to remove the whole PCI (bridge) device in the DSDT file and all the lines that refer to it. The PCI entries in ioreg and System Information are gone but System Information still shows an NVIDIA GPU under Graphics/Display.
       
      Many of the suggestions I have found in guides and forum posts do not seem to apply here. My problem with some of the guides and answers is that they give the solution without explaining how anything works, or they tell you what to do without explaining the reasons behind it.
       
      What else can I do? Thank you for any assistance you can provide!
       
      I have attached some files that may help you help me.
       
      DSDT_BIOS_3101.zip contains the original ACPI (*.aml) files without any patches.
      Send me Steffens-iMac.zip is a file produced by RunMe.app, and do contain simple patches to rename some devices.
      DSDT.dsl.patch is a diff of the original DSDT.dsl file and the one with the PCI devices removed (commented out).
       
      Motherboard: ASUS Rampage V Extreme (X99), BIOS version 3101 (macOS does not boot with anything newer).
      Clover version: 4813.
       
      DSDT.dsl.patch:
      --- /Users/sl/Desktop/DSDT_BIOS_3101/DSDT.dsl 2018-12-17 05:24:30.000000000 +0100 +++ /Volumes/EFI/EFI/CLOVER/ACPI/patched/DSDT.dsl 2018-12-17 16:52:08.000000000 +0100 @@ -5,7 +5,7 @@ * * Disassembling to symbolic ASL+ operators * - * Disassembly of DSDT.aml, Mon Dec 17 05:24:30 2018 + * Disassembly of DSDT.aml, Mon Dec 17 04:01:52 2018 * * Original Table Header: * Signature "DSDT" @@ -2128,7 +2128,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -2274,7 +2274,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -2420,7 +2420,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -2570,7 +2570,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -2803,12 +2803,14 @@ If ((CSTA (Arg0, Arg1) == 0x00)) { FLAG = 0x00 - PRID (APID = 0xFF) = 0xFF + APID = 0xFF + PRID = 0xFF } Else { Local0 = APID - PRID (FLAG = 0x01) = Local0 + FLAG = 0x01 + PRID = Local0 } Return (APIC) @@ -15259,7 +15261,7 @@ ^BR2B.OSHP () ^BR2C.OSHP () ^BR2D.OSHP () - ^BR3A.OSHP () + //^BR3A.OSHP () ^BR3B.OSHP () ^BR3C.OSHP () ^BR3D.OSHP () @@ -26861,7 +26863,7 @@ } } - Device (BR3A) + /*Device (BR3A) { Name (_ADR, 0x00030000) // _ADR: Address OperationRegion (MCTL, SystemMemory, 0xE0013188, 0x04) @@ -27496,7 +27498,7 @@ { Name (_ADR, 0xFFFF) // _ADR: Address } - } + }*/ Device (BR3B) { @@ -30267,7 +30269,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -30567,21 +30569,21 @@ WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4158, // Range Minimum - 0x0000, // Range Maximum + 0x4158, // Range Maximum 0x0000, // Translation Offset 0x0001, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x5758, // Range Minimum - 0x0000, // Range Maximum + 0x5758, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x5858, // Range Minimum - 0x0000, // Range Maximum + 0x5858, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) @@ -37604,7 +37606,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -37904,21 +37906,21 @@ WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4558, // Range Minimum - 0x0000, // Range Maximum + 0x4558, // Range Maximum 0x0000, // Translation Offset 0x0001, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4259, // Range Minimum - 0x0000, // Range Maximum + 0x4259, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4359, // Range Minimum - 0x0000, // Range Maximum + 0x4359, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) @@ -44941,7 +44943,7 @@ ^^PCI0.BR2B.OSHP () ^^PCI0.BR2C.OSHP () ^^PCI0.BR2D.OSHP () - ^^PCI0.BR3A.OSHP () + //^^PCI0.BR3A.OSHP () ^^PCI0.BR3B.OSHP () ^^PCI0.BR3C.OSHP () ^^PCI0.BR3D.OSHP () @@ -45241,21 +45243,21 @@ WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4958, // Range Minimum - 0x0000, // Range Maximum + 0x4958, // Range Maximum 0x0000, // Translation Offset 0x0001, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4559, // Range Minimum - 0x0000, // Range Maximum + 0x4559, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) WordIO (ResourceProducer, MinFixed, MaxFixed, PosDecode, EntireRange, 0x0000, // Granularity 0x4659, // Range Minimum - 0x0000, // Range Maximum + 0x4659, // Range Maximum 0x0000, // Translation Offset 0x0000, // Length ,, , TypeStatic, DenseTranslation) @@ -53823,7 +53825,7 @@ Notify (\_SB.PCI0.BR2D.H007, Local0) } - If ((\_SB.PCI0.BR3A.PMEP == 0x01)) + /*If ((\_SB.PCI0.BR3A.PMEP == 0x01)) { Local0 = \_SB.PCI0.BR3A.PMEH (0x05) } @@ -53848,7 +53850,7 @@ Notify (\_SB.PCI0.BR3A.H005, Local0) Notify (\_SB.PCI0.BR3A.H006, Local0) Notify (\_SB.PCI0.BR3A.H007, Local0) - } + }*/ If ((\_SB.PCI0.BR3B.PMEP == 0x01)) { @@ -54608,11 +54610,11 @@ \_SB.PCI0.BR2D.PMEP = 0x01 } - If ((Local1 == 0x07)) + /*If ((Local1 == 0x07)) { \_SB.PCI0.BR3A.PMES = 0x01 \_SB.PCI0.BR3A.PMEP = 0x01 - } + }*/ If ((Local1 == 0x08)) { @@ -54879,10 +54881,10 @@ Notify (\_SB.PCI0.BR2D, 0x02) } - If ((\_SB.PCI0.BR3A.DEVS () != 0x00)) + /*If ((\_SB.PCI0.BR3A.DEVS () != 0x00)) { Notify (\_SB.PCI0.BR3A, 0x02) - } + }*/ If ((\_SB.PCI0.BR3B.DEVS () != 0x00)) { @@ -55927,10 +55929,10 @@ { Notify (\_SB.PCI0.BR2D, 0x00) } - Case (0x28) + /*Case (0x28) { Notify (\_SB.PCI0.BR3A, 0x00) - } + }*/ Case (0x29) { Notify (\_SB.PCI0.BR3B, 0x00) @@ -56736,11 +56738,11 @@ } } - Scope (_SB.PCI0.BR3A) + /*Scope (_SB.PCI0.BR3A) { Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { - If ((Arg0 == ToUUID ("e5c937d0-3553-4d7a-9117-ea4d19c3434d") /* Device Labeling Interface */)) + If ((Arg0 == ToUUID ("e5c937d0-3553-4d7a-9117-ea4d19c3434d") / * Device Labeling Interface * /)) { If (((Arg1 == 0x02) && (Arg2 == 0x00))) { @@ -56765,7 +56767,7 @@ 0x00 }) } - } + }*/ Scope (_SB.PCI1.QR1A) {  
      DSDT_BIOS_3101.zip
      Send me Steffens-iMac.zip
      DSDT.dsl.patch
    • By twikoffin
      Hello. My hardware is:
      AMD Athlon X2 7750 dual-core
      Gigabyte NVIDIA 8400GS 512MB ( [VGA] ,HDMI,DVI)
      Motherboard Gigabyte based on NFORCE without AHCI support (only IDE)
      I have successfully installed Mac OS Yosemite, Mavericks and El Capitan with AppleNFORCEATA.kext
      But I can't use it with Mac OS 10.8, don't know why, it just gives error and my internal HDD's are not appearing in Disk Utility.

       
         
    • By kamyar1979
      I have bought a 2nd hand AMD Radeon 7750 to fix my Mojave installation problems. Although the Vendor/Device Id is in AMD7000Controller.Kext, I get a black screen and with some changes a yellow screen. I can not find any useful information to fix that. All information are for High Sierra and older macOS versions. Is there any fix to resolve that? What if I buy an RX 650 for example?
    • By macinsane
      This is bothering me for a long time now: Why does Apple deliberately disables the the RX4xx, RX5xx capabilities to hardware encode HEVC and is using Intel Quicksync instead? Is it to make the iMacPro look better than it is? I stumbled over a thread at tony-mac where people are going a totally different road for Radeon graphics. Instead of hassling around with getting Quicksync to work, they proposed to activate the AMD hardware renderer for Polaris GPU's. I tried it out and it works...somewhat
       
      I used a dummy kext from that tomato thread and edited it, so that it enables the AMDU7V4 IOGVACodec like on Vega cards, switched to iMacPro1,1 SMBIOS from iMac18,3, disabled the IGPU and the results were astonishing:
      My 3:34min 4k50p film was rendered by FCP with HEVC in 2:34 minutes. Nearly half the time than with Quicksync! With the iMac18 SMBIOS and the "help" of Intel Quicksync it took FCP 4:41 minutes to get it done!
       
      The problem is: As soon as the "wrong" IOGVACodec is enabled H.264 encoding leads to Mojave crashing at once (be it FCP, QuickTime or Videoproc). Watching H264 material is fine, though. 
       
      If anyone has any idea how to handle this, I would be very grateful. I would even accept Mojave using software encoding for H264 if I could keep this amazing speeds on HEVC!
       
      BTW: Without IGPU on iMacPro1,1 SMBIOS no problem with DRM or iTunes, no need for Whatevergreen or Shiki. That is a bonus
      Ellesmere.kext.zip
×