Jump to content
InsanelyMac Forum
Sign in to follow this  
BepTokc

Need help with graphics setup for Mountain Lion (iATKOS)

Recommended Posts

Hey Guys
I desperately need help, and before you advice me to search web, I should say in my defense that last 3 days the only things I did were multiple re-installation of OS X with different sets of kext selections and tweaking with commands before system boot(found on web) - nothing worked for me so far.
Now about my problem - I have a following setup:
---
Tecra A10 Notebook
4GB DDR2 of RAM
P8700 C2D Processor 2,53Ghz
Nvidia Quadro NVS 150M
OS X 10.8.2 Mountain Lion v. 12С54; Darvin/x86 boot v5.0.132 - Chameleon v2. 2svn r2140 (Installed from iATKOS image)
---
Problem is that I can't figure out why my graphic card doesn't want to work properly.

Installation is successful, however when system boots, it either panics with a message to restart the pc or black screen is shown, however sound is playing, which indicates that system is not in panic.

In case if I enter nv_disable=1 key before the system starts, system successfully launches, with sound support of keyboard and mouse drivers.

And it would seem that what else I should be worried about - why am I complaining?
Well, it's lags in browser and other graphic applications - that's my concern. I am unable to scroll normally in any browser(be it Safari, Firefox or Google Chrome), and if I click 'Notifications' button on the system bar, right menu with lags and red lines is shown up for 1,5 seconds, after which it disappears.

I did some research, and found out that it's VESA mode I am using, when I enter key nv_disable=1 and it causes all of lagging.

I can't use system normally with such problem, and I desperately need some OS X version that will work without such problems or an advice how to fix this problem for ML 10.8.2 - my job depends on this.

If anyone can help me with some advice - please do.

I also should say that the reason I chose the iATKOS image is for it's Chameleon boot - I am not fond of Clover, and it's too complicated with it's tweaking.

If you need any screenshots from console during the system boot, I will gladly provide them.



 

Share this post


Link to post
Share on other sites
Advertisement

Do you boot with Chameleon option GraphicsEnabler=Yes ? That'll be necessary.
 
I expect you'll have to inject nVidia characteristics in a _DSM method to the DSDT video device located at address 0x00010000. Post your DSDT. If you don't use one, extract it with macIASL. Also post a saved IORegistryExplorer output.
 
You'll need to inject something that will look similar to this Quadro NVS 135M example:

                   Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                   {
                       Store (Package (0x1A)
                       {
                           "AAPL,slot-name", 
                           Buffer (0x09)
                           {
                               "Built-in"
                           }, 
                           "@0,built-in", 
                           Buffer (One)
                           {
                                0x01                                           
                           }, 
                           "@0,compatible", 
                           Buffer (0x0B)
                           {
                               "NVDA,NVMac"
                           }, 
                           "@0,device_type", 
                           Buffer (0x08)
                           {
                               "display"
                           }, 
                           "@0,name", 
                           Buffer (0x0F)
                           {
                               "NVDA,Display-A"
                           }, 
                           "@1,compatible", 
                           Buffer (0x0B)
                           {
                               "NVDA,NVMac"
                           }, 
                           "@1,device_type", 
                           Buffer (0x08)
                           {
                               "display"
                           }, 
                           "@0,display-cfg", 
                           Buffer (0x04)
                           {
                                0x03, 0x01, 0x00, 0x00                         
                           }, 
                           "@1,display-cfg", 
                           Buffer (0x04)
                           {
                                0xFF, 0xFF, 0x00, 0x01                         
                           }, 
                           "@1,name", 
                           Buffer (0x0F)
                           {
                               "NVDA,Display-B"
                           }, 
                           "NVCAP", 
                           Buffer (0x18)
                           {
                               /* 0000 */  0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x01, 0x00,
                               /* 0008 */  0x06, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
                               /* 0010 */  0x00, 0x00, 0x00, 0x00                         
                           }, 
                           "device_type", 
                           Buffer (0x0C)
                           {
                               "NVDA,Parent"
                           }, 
                           "model", 
                           Buffer (0x17)
                           {
                               "NVIDIA Quadro NVS 135M"
                           }
                       }, Local0)
                       DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                       Return (Local0)
                   }

In fact, you could probably try injecting that code to see what it gives...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By wojko
      Hello! I have a problem installation UniBootX bootloader. When I tried start bootloader with pendrive I see only black screen. Any ideas? My config:
      1.Toshiba Satellite U920T
      2.Intel Core i5 3317u with SSE2, SSE3
      3. HM76
      4. Intel® HD Graphics 4000
      5. Resolutons : 1366 x 768
      6. Realtek High Definition Audio
      7.Intel Centrino Wireless N 2230
      8. No DVD
      9. Dysk SSD 120GB AHCI one partition
      10. Mouse USB 3.0
    • By coscos
      I recently set up my hackintosh. Everything else works fine, the only issue is my monitor cannot come back from sleep.
      Symptom: 
      If I click the "sleep" menu manually, the system goes to sleep fine. After the system sleeps for a while (more than a few mins, I guess it's called "deep sleep"), when I try to wake it up, the monitor wakes up but stays black screen. The machine is on. If I leave the system to time out and sleep by itself, only the monitor goes off; when I try to wake it up, same symptom as above.
      What I have tried (but none worked):
      additional boot flag: ngfxpatch=pikera additional boot flag: darkwake = 0 Customize EDID
      Specs:
      Motherboard: Gigabyte Z77x-UD5H BIOS: F16j CPU: Ivy Bridge i5-3570K CPU @ 3.40GHz (quad core) Graphics: Nvidia GTX 1050 Monitor: Dell P2715Q @ 4k / 60Hz, Display Port Wifi / Bluetooth: BCM94360CS with PCIE Onboard GPU: disabled OS: High Sierra 10.13.3
      Please see attached for following files:
      EFI zip file: https://www.dropbox.com/s/8nun37msu9b1bva/EFI.zip?dl=0 I generated my own SSDT.aml using ssdtPRGen.sh; Other SSDT patches are copied from this repository: https://github.com/VoiletDragon/Z77X-UD5H-Clover-Hotpatch-Patches ioreg dump: https://www.dropbox.com/s/5a10k82guczaaws/macchiato.ioreg.zip?dl=0 result from following command: https://www.dropbox.com/s/0b22qcw79ovnjdg/kext-touch.txt.zip?dl=0 kextstat|grep -y acpiplat kextstat|grep -y appleintelcpu kextstat|grep -y applelpc kextstat|grep -y applehda sudo touch /System/Library/Extensions && sudo kextcache -u /
      I am looking forward to your suggestions. Thanks.
    • By tomh117
      When I turn on my PC it will show Clover on the 1080p monitor and the other two DP monitors will go into standby, if I boot OSX like this then all monitors will black screen instead of showing the login screen. The DP monitors will go into an endless loop of trying to get a signal and saying "Display Port" like they do when looking for a singal and the 1080p DVI one will just display a black screen. The system is not hung, I can still ssh into it.
       
      The only way for me to successfully boot and have all 3 monitors work is either to:
      fully turn off both DP monitors, boot only with DVI until log in screen, then turn on both DP monitors
      manually turn on both DP monitors while booting but before it comes to the login screen, so they are not in standby
      But if I just let it start normally it without doing either it black screens.
      The same thing also happens when I'm already logged in and have it running successfully and turn off all monitors and come back later. Usually (8 out of 10 times) when I turn them all on it works again, but the other 2 times all of them start to black screen the same way. It seems the most consistent way to avoid that is to turn both DP monitors on at the same time.
       
      What I've tried so far:
      SMBIOS 14.2, 15.1, and MacPro 6.1 (the current one), none of that helped.
      Lilu.kext + NvidiaGraphicsFixup
      Patching AppleGraphicsDevicePolicy.kext/Contents/Info.plist and setting everything to none
      Switching the 1080p monitor to HDMI but that was the same, can't switch the DP monitors really since they are 4k and need DP.
      Nothing had any effect.
       
      My setup:
      i7 4790k, GA-Z97X-UD3H, 32gb
      980Ti (reference card) driver 378.10.10.10.25.104 (should be the latest one)
      2x Samsung 4k monitor (Display Port)
      1x 1080p via DVI
    • By TommyV6
      Hi, on my gear (i7-3770 16GB GA-Z77X-UD3H GTX 760 2GB) Web Driver works only 1-3 reboots after instalation. After this I`m geting black screen in middle of loading. I can login remotly to my machine when screen is black. After rebuilding cache manualy or with kext Utility screen work again!   I have MacOS Sierra 10.12.6 with all updates nVidia Web Driver 378.05.05.25f04 installad Lilu.kext and NvidiaGraphicsFixup.kext On macos default driver I`m getting same results.   Latest Clovers is my boot loader.   How I can fix this up permanently ?  
    • By muharremkackin
      Hello Guys! First sorry for bad English.
       
      I am a newbie in the hackintosh world. I want use macOSX very bad. But I don't know how can I start.
      If you help me I would be grateful. There is my laptop information.
       
      Toshiba R850-116 2nd Generation Intel 2410M 2.30GHz CPU AMD Radeon HD 7400M (DeviceID = 6760 - VendorID = 1002) Qualcomm Atheros AR9002WB-1NG Wireless Network Adapter (WLAN) Intel 82579V Gigabit Network Connection (LAN) If you want another information, I will write quickly.
       
      A long time ago I tried to install macOSX Sierra, I installed and booted correctly. However, I could not install Graphic Card.
      It did not work and when I looked in Device Manager, I saw 4MB cache. Just that.
       
      How can I boot a correctly work macOSX?
       
      Please help me. I need macOSX for my job. But I do not have money.
       
      Thank all of you for hard working and for replies.
       
      And sorry for the headline. I wrote wrong heading. My problem is Graphic Card.
×