Jump to content
Sinetek

Sinetek's Driver for Realtek "RTSX" SDHC Card Readers

258 posts in this topic

Recommended Posts

No bro...

 

My Card Reader is detected as a USB, but I can't make it work.  :(

So sad, my card reader is also detected as a USB. I think no USB2-CRW will work on latest version of macOS. The only solution, I think, is to port Linux driver.

Share this post


Link to post
Share on other sites
Advertisement

Are you saying that your card reader works after your computer wakes from sleep?

yes it does, even with the card plugged i can put it to sleep no probs. The only thingy is that to eject the volumes it hangs

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

As a side note i have disabled XWAK XSEL ESEL from my DSDT and have an OSI patch for Windows 8 . It works brilliant.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Hi I’m trying to test this out on a dell xps13 9360 with an  0x522A10EC card reader but iI think I’m missing somehitng. I have tested the first and second version of the kext.
So far :
on the second versionI checked on the kext (show package contents) Contents/Info.plist and my card is listed
on the fisrt version I added my card to info.plist
 I try to install in E/C/K/O, L/E and S/L/E

I Have the SIP disabled
I repaired the disk permissions , rebuilt kernel caches, etc
I even tryied dimitri's suggesiton of installing DSDT-XOSI.aml

I can’t see the device in DPCI manager, and the kext ain’t loading.

I really want to try this in order to use my sd reader, but as I said I htink I’m missing somehitng. Any insight will be much appreciatted.
 
Thanks
 

Share this post


Link to post
Share on other sites

As a side note i have disabled XWAK XSEL ESEL from my DSDT and have an OSI patch for Windows 8 . It works brilliant.

 

 

Sent from my iPhone using Tapatalk

 

So I deleted XSEL and ESEL from my DSDT.  (I don't have XWAK method.)  I still couldn't get my card reader to work after my laptop wakes from sleep.  Which laptop is your card reader working on after sleep?

Share this post


Link to post
Share on other sites

So I deleted XSEL and ESEL from my DSDT. (I don't have XWAK method.) I still couldn't get my card reader to work after my laptop wakes from sleep. Which laptop is your card reader working on after sleep?

It's an Asus X550LDV, my id is in the post above. I am really happy Sinnetek put his effort into this! It works great!

 

 

Sent from my iPhone using Tapatalk

It's an Asus X550LDV, my id is in the post above. I am really happy Sinnetek put his effort into this! It works great!

 

 

Sent from my iPhone using Tapatalk

By the way please don't delete those methods, just make them return (0) then they are disabled. They might be in other dependencies

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I can’t see the device in DPCI manager, and the kext ain’t loading.

 

 

Have you checked that the card reader is not disabled in system BIOS?

And here's the sources:  https://github.com/sinetek/Sinetek-rtsx

[mention]Sinetek[/mention] the repo lists the latest commit date as February 11 but your last kext post is March 1 -- does the repo have your most recent work?

Share this post


Link to post
Share on other sites

 

Have you checked that the card reader is not disabled in system BIOS?

[mention]Sinetek[/mention] the repo lists the latest commit date as February 11 but your last kext post is March 1 -- does the repo have your most recent work?

 

Yes I did, the card its fully functional if I boot with windows...

Share this post


Link to post
Share on other sites

Great initiative Sinetek.

I have an Acer 4830T. It has Realtek RTS5209 (0x520910EC).

 

I have installed your kext in /L/E and rebuild cache. It's loaded but does not work:

post-658617-0-47538800-1498946037_thumb.png

 

No SD cards are recognised.

There's no trace of 'rtsx' in the logs or dmesg output. Found the logs traces:

kernel: rtsx_softc::probe(PXSX)
kernel: rtsx_softc::start(PXSX) <5>
kernel: PXSX: rtsx_softc (0x142ae05d700ca90d) is already a child
kernel: rtsx_softc::probe(pci10ec,5209)
kernel: rtsx_softc::start(pci10ec,5209) <7>
kernel: pci10ec,5209: rtsx_softc (0x142ae05d705fcd0d) is already a child
kernel: pci10ec,5209: rtsx_softc (0x142ae05d705fcd0d) is already a child
kernel: (Sinetek-rtsx) : 4-bit
kernel: (Sinetek-rtsx) rtsx: cannot write phy register
kernel: (Sinetek-rtsx) 
kernel: (Sinetek-rtsx) rtsx: card inserted
kernel: (Sinetek-rtsx) rtsx: attach card
kernel: (Sinetek-rtsx) rtsx: voltage change ocr=0x403c0000
kernel: (Sinetek-rtsx) rtsx: executing cmd 52
kernel: (Sinetek-rtsx) rtsx: soft reset
kernel: (Sinetek-rtsx) rtsx: cmd 52 arg=0x80000c08 data=0x0 dlen=0 flags=0x1c01 proc="" (error 60)
kernel: (Sinetek-rtsx) rtsx: executing cmd 5
kernel: (Sinetek-rtsx) rtsx: soft reset
kernel: (Sinetek-rtsx) rtsx: cmd 5 arg=0 data=0x0 dlen=0 flags=0x1031 proc="" (error 60)
kernel: (Sinetek-rtsx) rtsx: executing cmd 0
kernel: (Sinetek-rtsx) rtsx: cmd 0 arg=0 data=0x0 dlen=0 flags=0x21 proc="" (error 0)
kernel: (Sinetek-rtsx) rtsx: executing cmd 55
kernel: (Sinetek-rtsx) rtsx: soft reset
kernel: (Sinetek-rtsx) rtsx: cmd 55 arg=0 data=0x0 dlen=0 flags=0x1c01 proc="" (error 60)
kernel: (Sinetek-rtsx) rtsx: executing cmd 1
kernel: (Sinetek-rtsx) rtsx: soft reset
kernel: (Sinetek-rtsx) rtsx: cmd 1 arg=0x40000000 data=0x0 dlen=0 flags=0x1031 proc="" (error 60)
kernel: (Sinetek-rtsx) rtsx: can't read memory OCR
kernel: (Sinetek-rtsx) rtsx: voltage change ocr=0x0
kernel: (Sinetek-rtsx) rtsx: host reset
kernel: (Sinetek-rtsx) rtsx: soft reset
kernel: (Sinetek-rtsx) rtsx: can't enable card
kernel: (Sinetek-rtsx) rtsx: detach card
kernel: (Sinetek-rtsx) rtsx: voltage change ocr=0x0
kernel: (Sinetek-rtsx) rtsx: host reset
kernel: (Sinetek-rtsx) rtsx: soft reset

What's strange, is that in the IOREG tree, I see TWO occurrence of rtsx_softc:

post-658617-0-30995600-1498946214_thumb.png

post-658617-0-96269100-1498946177_thumb.png

 

Any suggestions ?

What can I do to debug this kext further ?

Share this post


Link to post
Share on other sites

Hi folks, I know it's been a while.
After doing some more study I realized what went wrong while writing my driver.

Now I found a way to make power management (Machine sleep) a reality.

 

Stay tuned! And thanks so much for the folks who pushed me to not give up on this!

Share this post


Link to post
Share on other sites

Latest version of your kext working in latest beta of macOS 10.13 ! Even sleep is working, although ejecting doesn't. Keep up the good work mate, you are awesome and deserve all the credit!

Share this post


Link to post
Share on other sites

My laptop build is a HP Envy DV7-7212nr with Realtek RTS5229 PCI Express Card Reader.

 

I attempted to load the second version of your RTSX.kext.  SIP is disabled, Kext loaded to S/L/E, permissions reset and cache rebuilt.

  • Kext fails to load

Added _OSX patch in clover per Dmitry's suggestion

  • Kext fails to load

Added SSDT-XOSI.aml per Dmitry's suggestion

  • Kext fails to load.

Tried to load kext manually from terminal

  • Kext still fails to load.

System logs attached.                                 Thank you for your work on this project!!

Sys log - RTSX fail.rtf

RTSX manual load failure.rtf

RTSX errors.rtf

Share this post


Link to post
Share on other sites

My laptop build is a HP Envy DV7-7212nr with Realtek RTS5229 PCI Express Card Reader.

 

I attempted to load the second version of your RTSX.kext.  SIP is disabled, Kext loaded to S/L/E, permissions reset and cache rebuilt.

  • Kext fails to load

Added _OSX patch in clover per Dmitry's suggestion

  • Kext fails to load

Added SSDT-XOSI.aml per Dmitry's suggestion

  • Kext fails to load.

Tried to load kext manually from terminal

  • Kext still fails to load.

System logs attached.                                 Thank you for your work on this project!!

Yeah the next release will likely fix that..

 

Everything is done EXCEPT for the sleep support which I still can't get working. The chip seems to be utterly confused coming back from sleep even though i'm restoring register state and all..

 

-- Sinetek

Share this post


Link to post
Share on other sites

Thanks for your work and help Sinetek. Your present driver works fine in a ProBook 440 G3, except for eject after wake from sleep, which is, I understand, expected. But can you please make the kext work in El Capitan also? As for me, it works only in Sierra, and Sierra is by far worse than El Capitan on my ProBook.

 

Thank you.

Share this post


Link to post
Share on other sites

Yeah the next release will likely fix that..

 

Everything is done EXCEPT for the sleep support which I still can't get working. The chip seems to be utterly confused coming back from sleep even though i'm restoring register state and all..

 

-- Sinetek

 

Not an important one (just aesthetic) : Does it show our Card Reader info now into About this Mac > System Report > Card Reader ?

 

Also after you finnish this PCI Card Reader Port,do you plan on Porting a USB Version of Card Reader,it would be very nice to have that too,i wouldn't hesitate to support your valuable time for that with some donation,im sure the entire hackintosh community would be pleased for that too and it is for a quite a while now since theres lack of Interest on people trying to port a kext from Linux.

 

Good Luck,can we expect a new kext soon,atleast just with the recent improvements excluding the non working sleep left ?

Share this post


Link to post
Share on other sites

Thanks Sinetek for the feedback.  Looking forward to the next release.

Share this post


Link to post
Share on other sites

Thank you for your efforts on making this Sinetek. I tried it last week when I was real busy and sometimes it would work and sometimes it wouldn't. But I just learned this morning that on my HP Envy 15 hackintosh it works every time but ONLY if I have the sd card in at boot up. Otherwise it might load the driver and it might not. I tried to manually load it with kextload and kextutil, and it says it was already loaded but again sometimes it loads it and other times not. Might be just be my machine or setup? RTS5227

dmSGEfB.jpg

Share this post


Link to post
Share on other sites

i'm using a full T420 (thanks to tluck)

just install your kext with Kext Utility/app

after reboot

i'be got that in info

 

 Integrated Smart Card Reader :

 

Identifiant du produit : 0x1003

Identifiant du fournisseur : 0x17ef (Lenovo)

Version : 1.00

Vitesse : Jusqu’à 12 Mb/s

Fabricant : Lenovo

Identifiant de l’emplacement : 0x1d150000 / 2

Courant disponible (mA) : 500

Courant requis (mA) : 100

Exploitation supplémentaire actuelle (mA) : 0

Intégré : Oui

 

but non sd card mount

 

Device Id : 0xe823

Vendor Id : 0x1180

 

what can i do to report and help you to solde that?

 

thanks a lot for taking this forgottent subject :)

Share this post


Link to post
Share on other sites

i'm using a full T420 (thanks to tluck)

just install your kext with Kext Utility/app

after reboot

i'be got that in info

 

 Integrated Smart Card Reader :

 

Identifiant du produit : 0x1003

Identifiant du fournisseur : 0x17ef (Lenovo)

Version : 1.00

Vitesse : Jusqu’à 12 Mb/s

Fabricant : Lenovo

Identifiant de l’emplacement : 0x1d150000 / 2

Courant disponible (mA) : 500

Courant requis (mA) : 100

Exploitation supplémentaire actuelle (mA) : 0

Intégré : Oui

 

but non sd card mount

 

Device Id : 0xe822

Vendor Id : 0x1180

 

what can i do to report and help you to solde that?

 

thanks a lot for taking this forgottent subject :)

Ca c'est un lecteur USB, je peux rien faire avec ca.

Share this post


Link to post
Share on other sites

Here didn't work... :(

 

attachicon.gifScreen Shot 2017-02-12 at 11.14.56.png

 

<key>IOPCIMatch</key>

 

<string>0x01290BDA</string>

EDIT: Used in Clover/kexts folder.

Hi @Allan   :)

 

How are you my friend :)

I was wondering if you were able to get the SD Card reader to work 

I have an interest in this device ID for the SD Card 0x01290BDA and I'd like to know if that's even possible to activate it?

 

@Sinetek

Great job and thanks a lot for your hard work :) I would like to know your opinion on the matter as well, is it even possible to have this device activated by your kext? 

Share this post


Link to post
Share on other sites

Hi @Allan   :)

 

How are you my friend :)

I was wondering if you were able to get the SD Card reader to work 

I have an interest in this device ID for the SD Card 0x01290BDA and I'd like to know if that's even possible to activate it?

Hello buddy!

 

Bro, unfortunately I don't have this card working yet....

 

Would be awesome if we get this driver ok in Hacks.

Share this post


Link to post
Share on other sites

Hello buddy!

 

Bro, unfortunately I don't have this card working yet....

 

Would be awesome if we get this driver ok in Hacks.

Thanks for the reply bro:)

 

Yeah that would be really great if we can get it to work. May be Sinetek's driver will support this model in later releases. :)

 

Cheers!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×