Jump to content
ricola

[pre-release] macOS Sierra 10.12.4

235 posts in this topic

Recommended Posts

Installed Public Beta 2 on the laptop. Network MIDI is finally fixed.

 

Brightness slider is still broken when using IntelBackLight. It works if I remove the kext but the screen is dim even with the slider set at full.

Share this post


Link to post
Share on other sites
Advertisement

I've noticed that Night Shift doesn't seem to like my display profile.  I created my own calibrated display using the advanced options (used to be the normal options for color profiles) and, when I reboot or adjust my Night Shift options, it ditches my color profile and I have to go into Display Preferences and reselect it (even when it is already selected.). I suspect these are the kinds of bugs that Apple is looking to resolve before 10.12.4 final is released.

Share this post


Link to post
Share on other sites

@Slice right and this new Kernel Version seems to break XCPM Patches for unknown CPU´s at least in case of IvyBridge. Applying the well known patches leads to a boot loop...

Share this post


Link to post
Share on other sites

@Slice right and this new Kernel Version seems to break XCPM Patches for unknown CPU´s at least in case of IvyBridge. Applying the well known patches leads to a boot loop...

Seemed that I didn't get any changes of the patches. I also patch the kernel for my IVB model to enable XCPM. Could you please tell some details, for example, your "not worked" patch?

Share this post


Link to post
Share on other sites

@Slice, @PMheart sorry my fault forget about it...

I use Ozmosis and since it lacks support of on the fly patching I´ll have to bin patch the kernel on my own and messed things up I guess. XCPM is up and working as before :thumbsup_anim:  

sysctl -n machdep.xcpm.mode
1
sysctl -n machdep.xcpm.vectors_loaded_count
1

Sorry for the inconvenience I may have caused.

Share this post


Link to post
Share on other sites

@Slice, @PMheart sorry my fault forget about it...

I use Ozmosis and since it lacks support of on the fly patching I´ll have to bin patch the kernel on my own and messed things up I guess. XCPM is up and working as before :thumbsup_anim:  

sysctl -n machdep.xcpm.mode
1
sysctl -n machdep.xcpm.vectors_loaded_count
1

Sorry for the inconvenience I may have caused.

That's ok.  :P

Congratulations.

Share this post


Link to post
Share on other sites

@Slice, @PMheart sorry my fault forget about it...

I use Ozmosis and since it lacks support of on the fly patching I´ll have to bin patch the kernel on my own and messed things up I guess. XCPM is up and working as before :thumbsup_anim:  

sysctl -n machdep.xcpm.mode
1
sysctl -n machdep.xcpm.vectors_loaded_count
1

Sorry for the inconvenience I may have caused.

Could you explain how did you patched the kernel on Ozmosis?

Thanks.

 

I put the command and Terminal says: 

 

sysctl -n machdep.xcpm.mode

1

 
but
 
sysctl -n machdep.xcpm.vectors_loaded_count

0

Share this post


Link to post
Share on other sites

Could you explain how did you patched the kernel on Ozmosis?

Thanks.

 

I put the command and Terminal says: 

 

sysctl -n machdep.xcpm.mode

1

 
but
 
sysctl -n machdep.xcpm.vectors_loaded_count

0

You may need to inject FrequencyVectors via Pike's freqVectorsEdit.sh or change your SMBios which is containing FrequencyVectors.

Share this post


Link to post
Share on other sites

Did anyone find out, if 10.12.4 brings any differences for the Polaris GPUs? 

 

Well, now I did... Doesn't work :/ 

Share this post


Link to post
Share on other sites

Question, is there a way to get a full installer of the latest beta?

 

I just got a Kaby lake laptop. I thought I'd throw it at it and see if it sticks. If not I can still spoof the CPU.

Share this post


Link to post
Share on other sites

Question, is there a way to get a full installer of the latest beta?

 

I just got a Kaby lake laptop. I thought I'd throw it at it and see if it sticks. If not I can still spoof the CPU.

No... Apple never seeds a complete installer of beta version except for the new system build which is released on WWDC.

Share this post


Link to post
Share on other sites

Updated to Sierra 12.4 beta 2 (16E154a) and Clover r4003.

Everything works fine and stable as always, except for NvidiaWebDrive. With the plist edited from 16D to 16E, it recognizes the graphic card and has some resolutions, but without full acceleration...

PMheart, as you suggested I installed your MP61_freqV_w_iMac171.kext on SLE and erased it on Clover. And now it seems to me that it's your kext that's running the FreqVectors. I installed it before the OS update and yes, it survived ;)

Thanks friend :)

post-1313347-0-93364100-1487025253_thumb.png

post-1313347-0-90877500-1487025273_thumb.png

post-1313347-0-09989400-1487025291_thumb.png

post-1313347-0-70446800-1487025304_thumb.png

post-1313347-0-83843700-1487025317_thumb.png

Share this post


Link to post
Share on other sites

Yes. iMac17,1 is containing FrequencyVectors.

Will using the frequency vectors script be beneficial for my skylake system using Imac 17,1 ?

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Will using the frequency vectors script be beneficial for my skylake system using Imac 17,1 ?

 

Sent from my SM-G930F using Tapatalk

No. Pike's freqVectorsEdit.sh is just for adding/replacing FrequencyVectors. IMHO iMac17,1's FrequencyVectors is the best one for your Skylake Desktop build. You may need to enable HWP for further optimizations but TBH it's a little complicated... Sorry I can't talk about this clearly since I'm currently on my mobile phone.

Share this post


Link to post
Share on other sites

Sorry, no.

My result is because of additional kext attachicon.gifX17PlatformPlugin.kext.zip

AFAIK works only in SLE.

Actually iMac17,1 has contained FrequencyVectors already and thus you don't need to inject it via a dummy kext.

But as iMac17,1 does not support some features like hwp, epp for Skylake, I find that you are using another set of FrequencyVectors from other SMBios. Maybe a MacBookPro13,1, sorry for more details, I can't tell. (I inferred it's MBP131 just because I found your LFM is 0xD/13 and your EPP is 0x92/146, that's what MBP131 used.)

post-1579222-0-80510600-1487129111_thumb.png

 

Anyway. For desktops I think the 'perf-bias' should be 0x01/1 instead of 0x05/5, 0x05 is laptops used (for a better battery life time). And I think EPP should be 0x80/128 (by default). That can be better.

Also. Yep. These kinds of dummy kext/injector should only work in SLE/LE.

 

I adjusted your FrequencyVectors, have a try?  :) You can check what I did via Hex Editor.

[EDIT]

Confusing contents removed.

Share this post


Link to post
Share on other sites

Actually iMac17,1 has contained FrequencyVectors already and thus you don't need to inject it via a dummy kext.

But as iMac17,1 does not support some features like hwp, epp for Skylake, I find that you are using another set of FrequencyVectors from other SMBios. Maybe a MacBookPro13,1, sorry for more details, I can't tell. (I inferred it's MBP131 just because I found your LFM is 0xD/13 and your EPP is 0x92/146, that's what MBP131 used.)

attachicon.gifSnip20170215_1.png

 

Anyway. For desktops I think the 'perf-bias' should be 0x01/1 instead of 0x05/5, 0x05 is laptops used (for a better battery life time). And I think EPP should be 0x80/128 (by default). That can be better.

Also. Yep. These kinds of dummy kext/injector should only work in SLE/LE.

 

I adjusted your FrequencyVectors, have a try?  :) You can check what I did via Hex Editor.

attachicon.gifnew_X17PlatformPlugin.kext.zip

Thanks, but with your kext CPU is always at high speed.

Снимок экрана 2017-02-15 в 7.10.04.png

Share this post


Link to post
Share on other sites

Thanks, but with your kext CPU is always at high speed.

attachicon.gifСнимок экрана 2017-02-15 в 7.10.04.png

Oops weird. Try to increase the EPP value to 0xC0/192 and set 'perf-bias' to 5? Like this.

 

X17PlatformPlugin.kext.zip

 

[uPDATE]

I don't think that you should use the FrequencyVectors from a laptop SMBios. You can try this patched plist which is modified based on the vanilla Mac-DB15BD556843C820.plist (iMac17,1), with HWP enabled, EPP value 0x80/128. Please also try this?

 

HWP_Mac-DB15BD556843C820.plist.zip

Share this post


Link to post
Share on other sites

Oops weird. Try to increase the EPP value to 0xC0/192 and set 'perf-bias' to 5? Like this.

 

attachicon.gifX17PlatformPlugin.kext.zip

 

[uPDATE]

I don't think that you should use the FrequencyVectors from a laptop SMBios. You can try this patched plist which is modified based on the vanilla Mac-DB15BD556843C820.plist (iMac17,1), with HWP enabled, EPP value 0x80/128. Please also try this?

 

attachicon.gifHWP_Mac-DB15BD556843C820.plist.zip

OK, I will try but little later.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
      -Donations with PicPay 
      @danielnmaldonado
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -Tutorial
      https://tinyurl.com/re2c9sz
       
      -Post Installation
      Paste EFI folder into EFI Partition in your SSD, reboot and extract one full dump with this app and post here!
      https://tinyurl.com/ybwr9kq3
      RunMe.app
      https://tinyurl.com/y9562hz7
       
      --DSDT PATCHES--
      DSDT.Gigabyte Z490-UD.zip
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--























       









       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, headkaze, onemanosx, erroruser, Jenny David, Sampath007, Facebook Hackintosh community, Facebook Olarila community, SchmockLord, daliansky and many, many, many others!
       
      We're all here to have fun and learn from each other!
    • By fantomas
      macOS Catalina 10.15.6 beta (19G36e)
    • By mavifree
      Sir 
       
      I am new in Hackintosh and i try to make my hp laptop a hackintosh but am not able to boot in Installation menu i don't know why please help as am new in hackintosh world so i really need your help if some can. I really be very thankful to you. Please Help me.
       
      installation stuck at (Please go to https://panic.apple.com to report this panic)
       
      MY Laptop Specs :
       
      --------------------------------------------------------------------
      Laptop : HP cs2082tx
      Mobo : HP84C1
      Southbridge : Coffee Lake-U/Y PCH
      CPU : Intel Core i5 8265U @ 1.60GHz Kaby Lake- U/Y
      Ram : 8 Gb
      HDD : 256GB SSD & 1TB HDD
      Graphics : Intel UHD Graphic 620 with nvidia MX250
      ----------------------------------------------------------------------
       
      And here is the screenshot attachment and my EFI folder:
       


      Clover.rar
    • By y010204025
      Perhaps it was the first NEC (Lenovo) Lavie Z HZ550 to install hackintosh. I hope more people who like Lavie Z series can experience Hackintosh at HZ550. She is really great.
       
      I found HZ550 & HZ750 on the Chinese website, which is amazing. It weighs only 790g, 13.3 inches, and the standard 2k screen, which is too attractive to me. I am a Hackintosh enthusiast. I think HZ550 or HZ750 with MacOS is the best Unfortunately, the Lavie Z series is not listed in China, only exists in the Japanese and American markets, and in the Japanese market is the NEC brand, while the American market uses the Lenovo logo.
       
      Fortunately, I got an HZ550 from Taobao. Yes, not HZ750. In comparison, HZ750 has more touch screens and 360 ° flip. These are hard to attract me. More importantly, HZ750 is about 200g heavier than HZ550 That's why I chose HZ550. Well, because he is only 2,000 RMB.
       
      The specific introduction can refer to NEC Japan official website:http://nec-lavie.jp/products/hz13b/
       
      The HZ550 hardware list I obtained:
                                    
                       -/+:.          ningnan@ningnandeMacBook-Air
                      :++++.          OS: 64bit Mac OS X 10.15.5 19F96
                     /+++/.           Kernel: x86_64 Darwin 19.5.0
             .:-::- .+/:-``.::-       Uptime: 19m
          .:/++++++/::::/++++++/:`    Packages: 1
        .:///////////////////////:`   Shell: zsh 5.7.1
        ////////////////////////`     Resolution: 3840x2160
       -+++++++++++++++++++++++`      DE: Aqua
       /++++++++++++++++++++++/       WM: Quartz Compositor
       /sssssssssssssssssssssss.      WM Theme: Blue (Dark)
       :ssssssssssssssssssssssss-     Disk: 11G / 108G (12%)
        osssssssssssssssssssssssso/`  CPU: Intel Core i7-5500U @ 2.40GHz
        `syyyyyyyyyyyyyyyyyyyyyyyy+`  GPU: Intel Iris Graphics 6100
         `ossssssssssssssssssssss/    RAM: 4376MiB / 8192MiB
           :ooooooooooooooooooo+.    
            `:+oo+/:-..-:/+o+/-     
       
       
      Advantages: small size, light weight, 2K screen, 8G memory, 512g SSD, keyboard feels good, and wireless network card can be replaced, which is unimaginable in today's thin and light books.
      Disadvantages: The sound is small, almost the same as the mosquitoes.
       
      Ok, bragging is over!
      In order to use the wireless network, I changed the wireless network card from inter 7265 to BCM94352ZAE. Some people called it DW1560. It is uncomfortable that in China, this card and his elder brother DW1830 were hyped to a high price of 480RMB. of. Fortunately, I bought it early, and this card is also very stable under win10, and there is no high delay and outage. The hard disk should be PM951 of Samsung, not PM981, which is lucky.   Before installing Hackintosh: You need to prepare a 16G U disk, SanDisk is not a rough choice for making MacOS installation disk, I used the latest MacOS Catalina 10.15.5, got config.plist from Rehabman, and put together an EFI, the latest version of clover and kext drivers. Thanks to Rehabman and the developers of the Black Apple community. I do n’t like that OC team very much.
      Make an installation disk: If you have a computer running MacOS, you can use the command line to make it, if you do n’t have a computer running MacOS, you can try VMware, I know that the insanelymac forum allows discussion, or use ether to write the image to U disk, use the EFI I provided to boot into the installation process.   BIOS setting: Press F12 at boot to enter the BIOS settings, Tab switches to "Security-Secure boot", set to "DISable", this is what we need, and switch to "Boot -Boot devices", set the U disk as the first boot item You can directly enter the clover guide interface, please follow it for google it.
      It is worth noting that the remaining space of your EFI partition needs to be greater than 200M, otherwise, the disk format will be wrong. In addition, the format partition format is APFS, do not choose to encrypt, your data is not valuable, at least you must have this awareness of Hackintosh, the file safe is also the same, do not enable, do not use to find your mac, otherwise, change the machine, OK .   Fortunately, no additional ssdt patch is required. All the patch functions are implemented through clover. The flat Apple is turned on. This is to solve the problem of the flower screen. You can find a solution yourself.
      Experience your black apple, this will bring a better experience than MacBook Pro. EFI_HZ550.zip
×