Jump to content
ricola

[pre-release] macOS Sierra 10.12.4

235 posts in this topic

Recommended Posts

Advertisement

Unfortunately this did not work in my situation. Maybe my DSDT patching is different to yours.

 

Yes this works fine for me also but does not provide adjustment via my f keys but it is a good workaround for now. Hopefully Apple will correct this with the next beta,

Me too. I lost brightness real change in 10.12.4 dp1. I can increase/decrease only brightness popup when i change it.

 

Hope fix next build.

 

나의 LG-F410S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

Updated 10.12.4 build 16E144f for my real MacBook9,1 & MacBookPro13,2 and the brightness saving just work like a charm...

But I think this could be related to NVRAM for hackintosh builds. I saw AppleEFINVRAM has been changed a lot but I can't assure if it causes so.

Share this post


Link to post
Share on other sites
Radeon HD 5570 shows flicker.

I restored the kext graphics of 12.3 but the situation is the same: hd works but bad for exactly the same way.

No idea where the problem may reside for a card whose id is still present in AMDLegacySupport.kext?

 

Sorry for the English and thank you.

Share this post


Link to post
Share on other sites

Update from 12.3 Final to 12.4 Beta (16E144f)
I lost the onboard sound on the ALC1150, but I'm still not sure if it was because the OS or the Clover update for v3.2k_r3994.

I tried with the Clover r3974 and did not finish the boot. With Clover r3994, the system boots normally, but without ALC1150 onboard sound and without speedsteps. (I'm trying to understand and study about it) :) 
The Nvidia Web Driver, editing NVDAStartup.kext form 16D to 16E, recognizes my graphic card and allows some resolutions (not all), but without full acceleration what is understandable.
Bluetooth, WiFi and all USB's remained ok.
XPCM/Speedsteps have stopped working and I think it requires new or additional patches... but as I said above, I am studying the case! :yes:

 

EDIT 1:
I just tested and confirmed that it is a Clover bug. As I mentioned before, with 12.2 and 12.3 and with the previous Clover I had no stress. I started having it from the moment I updated to 12.4 and upgraded to the Clover r3994, since the previous version of Clover did not finish the boot in 12.4
And the result was this:
With all xcpm patchs enabled in Plist - Cpu blocks at maximum frequency.
With all xcpm patchs disabled in Plist - Everything everything went back to normal, XCPM working, Speedsteps working, Freq.Vectors loaded, everything loaded.
With all xcpm patchs deleted in Plist - Cpu blocks at maximum frequency.
Sounds like a Big Clover Bug! They reversed the disabled/enabled flags  ;) 

 

EDIT 2:
Everything solved with the installation of the new Clover r3998 icon_thumbup.gif

post-1313347-0-38404100-1485735119_thumb.png

post-1313347-0-82025300-1485735567_thumb.png

post-1313347-0-87077700-1485735578_thumb.png

post-1313347-0-18084300-1485735594_thumb.png

post-1313347-0-37023500-1485735600_thumb.png

post-1313347-0-91701000-1485735605_thumb.png

Share this post


Link to post
Share on other sites

You need to fix your audio either with appleHDA patcher or which ever method you used. I am also awaiting new nvidia drivers as I lost acceleration with 16E as well.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Update from 12.3 Final to 12.4 Beta (16E144f)

I lost the onboard sound on the ALC1150, but I'm still not sure if it was because the OS or the Clover update for v3.2k_r3994.

I tried with the Clover r3974 and did not finish the boot. With Clover r3994, the system boots normally, but without ALC1150 onboard sound and without speedsteps. (I'm trying to understand and study about it) :)

The Nvidia Web Driver, editing NVDAStartup.kext form 16D to 16E, recognizes my graphic card and allows some resolutions (not all), but without full acceleration what is understandable.

Bluetooth, WiFi and all USB's remained ok.

XPCM/Speedsteps have stopped working and I think it requires new or additional patches... but as I said above, I am studying the case! :yes:

http://www.insanelymac.com/forum/index.php?/topic/306156-Clover-Bug/Issue-Report-and-Patch&do=findComment&comment=2357571

 

Try this

 

And give me report.

 

Need to find issue clearly now

 

Thank you

 

나의 LG-F410S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

You need to fix your audio either with appleHDA patcher or which ever method you used. I am also awaiting new nvidia drivers as I lost acceleration with 16E as well.

 

Sent from my SM-G930F using Tapatalk

Clover has audio issue(patches not work in KextToPatch) in r3994.

 

I already report before. Still not resolved completely.

 

If you have audio issue, try http://www.insanelymac.com/forum/index.php?/topic/306156-Clover-Bug/Issue-Report-and-Patch&do=findComment&comment=2357571

 

Thank you

 

나의 LG-F410S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

My audio working fine with alc1150 and clover 3994

 

Sent from my SM-G930F using Tapatalk

What is your audio kext?

AppleALC? Or VoodooHDA?

there are no problem above 2 kexts,

 

Only happen binary patch in KextToPatch with DummyHDA.kext

 

 

나의 LG-F410S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

Update from 12.3 Final to 12.4 Beta (16E144f)

I lost the onboard sound on the ALC1150, but I'm still not sure if it was because the OS or the Clover update for v3.2k_r3994.

I tried with the Clover r3974 and did not finish the boot. With Clover r3994, the system boots normally, but without ALC1150 onboard sound and without speedsteps. (I'm trying to understand and study about it) :)

The Nvidia Web Driver, editing NVDAStartup.kext form 16D to 16E, recognizes my graphic card and allows some resolutions (not all), but without full acceleration what is understandable.

Bluetooth, WiFi and all USB's remained ok.

XPCM/Speedsteps have stopped working and I think it requires new or additional patches... but as I said above, I am studying the case! :yes:

here is fix clover files.

 

tell me if you get sound and speedstep and work any features

 

thank you

Ah ok I use fully patched AppleHDA from AppleHDA patcher.

 

Sent from my SM-G930F using Tapatalk

strange. my case is not work. also some users report this.

 

Add. You use "Full" AppleHDA file. Already done binary patched. Therefore, you dont have sound issue

 

thank you.

r3994 fix.zip

Share this post


Link to post
Share on other sites

For me the generic brightness.kext uploaded by mnfesq works from clover/kext folder.

 

Earlier was using the ACPIBacklight.kext by rehab man. That does not work anymore.

.

My hardware is pretty old so may be thats the reason. May be something has changed with nightshift incorporation that affects how brightness works in hackintoshes.

Share this post


Link to post
Share on other sites

For me the generic brightness.kext uploaded by mnfesq works from clover/kext folder.

 

Earlier was using the ACPIBacklight.kext by rehab man. That does not work anymore.

.

My hardware is pretty old so may be thats the reason. May be something has changed with nightshift incorporation that affects how brightness works in hackintoshes.

 

you're right. i tested it. rehabman's intelbacklight.kext is not work in 10.12.4 dp1

generic brightness.kext is working for me. my hardware is skylake laptop

 

we have to report it to @rehabman

 

thank you for information

Share this post


Link to post
Share on other sites

 

 

you're right. i tested it. rehabman's intelbacklight.kext is not work in 10.12.4 dp1

generic brightness.kext is working for me. my hardware is skylake laptop

 

we have to report it to @rehabman

 

thank you for information

Similar to my situation, with IntelBacklight.kext brightness does not function but without kext it does just unsure if it has the right amount of "steps" and it's not as fluid when changing brightness. Have never used any other kext for backlight.

you're right. i tested it. rehabman's intelbacklight.kext is not work in 10.12.4 dp1

generic brightness.kext is working for me. my hardware is skylake laptop

 

we have to report it to @rehabman

 

thank you for information

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Similar to my situation, with IntelBacklight.kext brightness does not function but without kext it does just unsure if it has the right amount of "steps" and it's not as fluid when changing brightness. Have never used any other kext for backlight.

 

 

Sent from my SM-G930F using Tapatalk

Having the same issue... Should I remove IntelBacklight kext then?

Share this post


Link to post
Share on other sites

Having the same issue... Should I remove IntelBacklight kext then?

You can remove it and try the generic brightness.kext posted or try without a kext.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Having the same issue... Should I remove IntelBacklight kext then?

I would use "Brightness" by bergdesign until I figure a fix for IntelBacklight.kext (or Apple fixes what they broke).

Share this post


Link to post
Share on other sites

here is fix clover files.

 

tell me if you get sound and speedstep and work any features

 

thank you

 

strange. my case is not work. also some users report this.

 

Add. You use "Full" AppleHDA file. Already done binary patched. Therefore, you dont have sound issue

 

thank you.

Thank you Sherlocks,

With this fix for Clover r3994, my ALC1150 and AppleHDA returned to normal. Now with great sound again!  :yes:

But about XCPM:

With all xcpm patchs enabled in Plist - Cpu blocks at maximum frequency.

With all xcpm patchs disabled in Plist - Everything everything went back to normal, XCPM working, Speedsteps working, Freq.Vectors loaded, everything loaded.

With all xcpm patchs deleted in Plist - Cpu blocks at maximum frequency.

Sounds like a Big Clover Bug! They reversed the disabled/enabled flags  ;) 

post-1313347-0-62794100-1485883745_thumb.png

Share this post


Link to post
Share on other sites

Thank you Sherlocks,

With this fix for Clover r3994, my ALC1150 and AppleHDA returned to normal. Now with great sound again! :yes:

But about XCPM:

With all xcpm patchs enabled in Plist - Cpu blocks at maximum frequency.

With all xcpm patchs disabled in Plist - Everything everything went back to normal, XCPM working, Speedsteps working, Freq.Vectors loaded, everything loaded.

With all xcpm patchs deleted in Plist - Cpu blocks at maximum frequency.

Sounds like a Big Clover Bug! They reversed the disabled/enabled flags ;)

You are first reporter now!!!! Thank you so much.

 

KernelToPatch Enable or disable not working right? Or work like r3974? I dont have good english.

Okay reversed enable/disable in KernelPatch. I will check

 

If have problem about enable/disable in KernelToPatch, i will give you file to fix this issue.

 

나의 LG-F410S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

You are first reporter now!!!! Thank you so much.

 

KernelToPatch Enable or disable not working right? Or work like r3974? I dont have good english.

Okay reversed enable/disable in KernelPatch. I will check

 

If have problem about enable/disable in KernelToPatch, i will give you file to fix this issue.

 

나의 LG-F410S 의 Tapatalk에서 보냄

@Sherlocks I testd your version and all work, but I use AppleALC.

Here you go bootlog

Share this post


Link to post
Share on other sites

Thank you Sherlocks,

With this fix for Clover r3994, my ALC1150 and AppleHDA returned to normal. Now with great sound again!  :yes:

But about XCPM:

With all xcpm patchs enabled in Plist - Cpu blocks at maximum frequency.

With all xcpm patchs disabled in Plist - Everything everything went back to normal, XCPM working, Speedsteps working, Freq.Vectors loaded, everything loaded.

With all xcpm patchs deleted in Plist - Cpu blocks at maximum frequency.

Sounds like a Big Clover Bug! They reversed the disabled/enabled flags  ;) 

 

 

@Sherlocks I testd your version and all work, but I use AppleALC.

Here you go bootlog

 

@Fergarth

@crusher. thank you for report. your log is good. also you don't have problem audio, because AppleALC has already binary patch.

 

here is r3995 fix file. please test again

 

i tested r3995 fix. but need more report

post-980913-0-10983100-1485886337_thumb.png

r3995 fix.zip

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
      -Donations with PicPay 
      @danielnmaldonado
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -Tutorial
      https://tinyurl.com/re2c9sz
       
      -Post Installation
      Paste EFI folder into EFI Partition in your SSD, reboot and extract one full dump with this app and post here!
      https://tinyurl.com/ybwr9kq3
      RunMe.app
      https://tinyurl.com/y9562hz7
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--
       









































       
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, headkaze, onemanosx, erroruser, Jenny David, Sampath007, Facebook Hackintosh community, Facebook Olarila community, SchmockLord, daliansky and many, many, many others!
       
      We're all here to have fun and learn from each other!
    • By fantomas
      macOS Catalina 10.15.6 beta (19G36e)
    • By mavifree
      Sir 
       
      I am new in Hackintosh and i try to make my hp laptop a hackintosh but am not able to boot in Installation menu i don't know why please help as am new in hackintosh world so i really need your help if some can. I really be very thankful to you. Please Help me.
       
      installation stuck at (Please go to https://panic.apple.com to report this panic)
       
      MY Laptop Specs :
       
      --------------------------------------------------------------------
      Laptop : HP cs2082tx
      Mobo : HP84C1
      Southbridge : Coffee Lake-U/Y PCH
      CPU : Intel Core i5 8265U @ 1.60GHz Kaby Lake- U/Y
      Ram : 8 Gb
      HDD : 256GB SSD & 1TB HDD
      Graphics : Intel UHD Graphic 620 with nvidia MX250
      ----------------------------------------------------------------------
       
      And here is the screenshot attachment and my EFI folder:
       


      Clover.rar
    • By y010204025
      Perhaps it was the first NEC (Lenovo) Lavie Z HZ550 to install hackintosh. I hope more people who like Lavie Z series can experience Hackintosh at HZ550. She is really great.
       
      I found HZ550 & HZ750 on the Chinese website, which is amazing. It weighs only 790g, 13.3 inches, and the standard 2k screen, which is too attractive to me. I am a Hackintosh enthusiast. I think HZ550 or HZ750 with MacOS is the best Unfortunately, the Lavie Z series is not listed in China, only exists in the Japanese and American markets, and in the Japanese market is the NEC brand, while the American market uses the Lenovo logo.
       
      Fortunately, I got an HZ550 from Taobao. Yes, not HZ750. In comparison, HZ750 has more touch screens and 360 ° flip. These are hard to attract me. More importantly, HZ750 is about 200g heavier than HZ550 That's why I chose HZ550. Well, because he is only 2,000 RMB.
       
      The specific introduction can refer to NEC Japan official website:http://nec-lavie.jp/products/hz13b/
       
      The HZ550 hardware list I obtained:
                                    
                       -/+:.          ningnan@ningnandeMacBook-Air
                      :++++.          OS: 64bit Mac OS X 10.15.5 19F96
                     /+++/.           Kernel: x86_64 Darwin 19.5.0
             .:-::- .+/:-``.::-       Uptime: 19m
          .:/++++++/::::/++++++/:`    Packages: 1
        .:///////////////////////:`   Shell: zsh 5.7.1
        ////////////////////////`     Resolution: 3840x2160
       -+++++++++++++++++++++++`      DE: Aqua
       /++++++++++++++++++++++/       WM: Quartz Compositor
       /sssssssssssssssssssssss.      WM Theme: Blue (Dark)
       :ssssssssssssssssssssssss-     Disk: 11G / 108G (12%)
        osssssssssssssssssssssssso/`  CPU: Intel Core i7-5500U @ 2.40GHz
        `syyyyyyyyyyyyyyyyyyyyyyyy+`  GPU: Intel Iris Graphics 6100
         `ossssssssssssssssssssss/    RAM: 4376MiB / 8192MiB
           :ooooooooooooooooooo+.    
            `:+oo+/:-..-:/+o+/-     
       
       
      Advantages: small size, light weight, 2K screen, 8G memory, 512g SSD, keyboard feels good, and wireless network card can be replaced, which is unimaginable in today's thin and light books.
      Disadvantages: The sound is small, almost the same as the mosquitoes.
       
      Ok, bragging is over!
      In order to use the wireless network, I changed the wireless network card from inter 7265 to BCM94352ZAE. Some people called it DW1560. It is uncomfortable that in China, this card and his elder brother DW1830 were hyped to a high price of 480RMB. of. Fortunately, I bought it early, and this card is also very stable under win10, and there is no high delay and outage. The hard disk should be PM951 of Samsung, not PM981, which is lucky.   Before installing Hackintosh: You need to prepare a 16G U disk, SanDisk is not a rough choice for making MacOS installation disk, I used the latest MacOS Catalina 10.15.5, got config.plist from Rehabman, and put together an EFI, the latest version of clover and kext drivers. Thanks to Rehabman and the developers of the Black Apple community. I do n’t like that OC team very much.
      Make an installation disk: If you have a computer running MacOS, you can use the command line to make it, if you do n’t have a computer running MacOS, you can try VMware, I know that the insanelymac forum allows discussion, or use ether to write the image to U disk, use the EFI I provided to boot into the installation process.   BIOS setting: Press F12 at boot to enter the BIOS settings, Tab switches to "Security-Secure boot", set to "DISable", this is what we need, and switch to "Boot -Boot devices", set the U disk as the first boot item You can directly enter the clover guide interface, please follow it for google it.
      It is worth noting that the remaining space of your EFI partition needs to be greater than 200M, otherwise, the disk format will be wrong. In addition, the format partition format is APFS, do not choose to encrypt, your data is not valuable, at least you must have this awareness of Hackintosh, the file safe is also the same, do not enable, do not use to find your mac, otherwise, change the machine, OK .   Fortunately, no additional ssdt patch is required. All the patch functions are implemented through clover. The flat Apple is turned on. This is to solve the problem of the flower screen. You can find a solution yourself.
      Experience your black apple, this will bring a better experience than MacBook Pro. EFI_HZ550.zip
×