Jump to content
wmchris

[GUIDE] Dell XPS 15 (9550) Mojave 10.14.x Quick Installation

1,407 posts in this topic

Recommended Posts

5 hours ago, dcarozza6 said:

Thanks for your response. So I tried doing that and mounted the EFI shown in my screenshot, however, I still continue to get the same error, even after copying over the contents of the Clover folder. I've also attached a screenshot of what the ESP drive looks like.

 

I managed to get iMessage and iCloud working, I would just like to be able to boot from the internal drive.

 

If it matters, I also have a second partition that I'd eventually install Windows on. I have attached what that looks like in Disk Utility.

 

 

 

 

hmmm... interesting. So after you choose ESP option, can you select your OS partition with the "Change Install location" button?

pic

 

You followed the tutorial correctly right? Especially this part:

"If you want to multiboot with Windows 10, then you'll have to create a second partition, too (also HFS! Dont use FAT or it will not boot! You have to reformat it when installing Windows)."

Edited by Mr.C
there wa a dumb question in it

Share this post


Link to post
Share on other sites
Advertisement

ESP is your EFI Partition, it just has the wrong name. ESP = Efi System Partition.

 

This has been created by Windows instead of the OSX Installer. It contains the Windows Bootfiles. So it seems like you didn't follow the tutorial.

 

I dunno if it still valid with APFS, but with HFS this setup would be unbootable.

Edited by wmchris

Share this post


Link to post
Share on other sites
30 minutes ago, Mr.C said:

 

hmmm... interesting. So after you choose ESP option, can you select your OS partition with the "Change Install location" button?

pic

 

You followed the tutorial correctly right? Especially this part:

"If you want to multiboot with Windows 10, then you'll have to create a second partition, too (also HFS! Dont use FAT or it will not boot! You have to reformat it when installing Windows)."

When I got to that part, I partitioned the Windows part as "MacOS Extended (Journaled)", which I thought was the equivalent as HFS (which wasn't an option). I've attached my Clover installer screen, you can see where I am choosing to install on "OSX", not "Windows".

Screen Shot 2018-10-25 at 2.57.03 PM.png

Share this post


Link to post
Share on other sites

You didnt partition the SD, you just reformatted the existing partition.

Redo the installation, and re-partition the whole drive.

Edited by wmchris

Share this post


Link to post
Share on other sites
Just now, wmchris said:

You didnt partition the SD, you just reformatted the existing partition.

Redo the installation.

Ok, thank you! So when I redo it, where did I go wrong? When I opened Disk Utility before the installer, I reformatted the drive to "MacOS Extended (Journaled)" I believe, and then made 2 partitions and named it OSX and Windows, both MacOS Ext. Journaled.

Share this post


Link to post
Share on other sites
5 hours ago, wmchris said:

http://bfy.tw/KXtJ

There it is explained...

Thanks for your help, I got it working! It's really awesome to see you helping all these people throughout the years you've worked on this!

Share this post


Link to post
Share on other sites

wmchris, just wanted to drop by and say thanks a bunch. After reviewing your files and making some adjustments to work for my 9560, it is near perfect.

One issue I had was with voodoops2. On a cold boot, the keyboard didn't work until another restart. Trackpad and even brightness keys worked but no key input so couldn't log in till a restart. After restart then keys worked fine. I solved it by installing voodoops2 into LE. No no more problems. Would have rather not have to install it but other than that things have been great.

Share this post


Link to post
Share on other sites

Apologies if this has been answered before but I couldn't find anything after searching: does anyone experience severe battery drain with the 9550? The battery probably lasts only about an hour on my machine. Moreover, the battery percentage only ever reaches 62%.

Share this post


Link to post
Share on other sites
43 minutes ago, alex.daoud said:

Apologies if this has been answered before but I couldn't find anything after searching: does anyone experience severe battery drain with the 9550? The battery probably lasts only about an hour on my machine. Moreover, the battery percentage only ever reaches 62%.

Not that bad but when I had my SD card slot enabled in BIOS it drained faster. I already had my touch screen disabled so can't comment based on that. I am using basically the same configuration as this guide. I have had weird issues of when unplugging the power cable and plugging it back in it taking a while to start recognising it is charging. The .1 update is out now BTW so I am holding off until tomorrow to test it as I need my computer working tomorrow. 

Share this post


Link to post
Share on other sites
16 minutes ago, reece394 said:

Not that bad but when I had my SD card slot enabled in BIOS it drained faster. I already had my touch screen disabled so can't comment based on that. I am using basically the same configuration as this guide. I have had weird issues of when unplugging the power cable and plugging it back in it taking a while to start recognising it is charging. The .1 update is out now BTW so I am holding off until tomorrow to test it as I need my computer working tomorrow. 

Thanks for the tip re: SD card, I've disabled it to see if it makes much of a difference. I wonder if a proper driver for it would fix it...

Share this post


Link to post
Share on other sites
4 minutes ago, alex.daoud said:

Thanks for the tip re: SD card, I've disabled it to see if it makes much of a difference. I wonder if a proper driver for it would fix it...

SD card makes a huge difference, but not the amount you've reported.

My 9550 is running 2-3h ... with a heavily broken battery (<60% of the normal Ah)

It seems more like your GPU is enabled, SD Cardreader (btw there is a driver, but its very buggy) active + inel speedstep disabled + a worn out battery. Otherwise 1h would be practically impossible.

Edited by wmchris

Share this post


Link to post
Share on other sites
1 hour ago, wmchris said:

SD card makes a huge difference, but not the amount you've reported.

My 9550 is running 2-3h ... with a heavily broken battery (<60% of the normal Ah)

 It seems more like your GPU is enabled, SD Cardreader (btw there is a driver, but its very buggy) active + inel speedstep disabled + a worn out battery. Otherwise 1h would be practically impossible.

Unfortunately GPU and SD card reader are disabled and speedstep is enabled. Battery drain is still pretty bad and I only charge up to 62%. It's looking more like a worn out battery rather than any bug with macOS at this point. It's probably from abusing it from the last two years of VoodooI2C dev :p

Share this post


Link to post
Share on other sites

There is a security update for 12.6, 13.6, 14 rolling out today. Some changes that can harm the update process:

Quote

EFI

Available for: macOS High Sierra 10.13.6

Impact: Systems with microprocessors utilizing speculative execution and speculative execution of memory reads before the addresses of all prior memory writes are known may allow unauthorized disclosure of information to an attacker with local user access via a side-channel analysis

Description: An information disclosure issue was addressed with a microcode update. This ensures that older data read from recently-written-to addresses cannot be read via a speculative side-channel.

CVE-2018-3639: Jann Horn (@tehjh) of Google Project Zero (GPZ), Ken Johnson of the Microsoft Security Response Center (MSRC)

EFI

Available for: macOS High Sierra 10.13.6, macOS Mojave 10.14

Impact: A local user may be able to modify protected parts of the file system

Description: A configuration issue was addressed with additional restrictions.

CVE-2018-4342: Timothy Perfitt of Twocanoes Software

IOHIDFamily

Available for: macOS Sierra 10.12.6, macOS High Sierra 10.13.6

Impact: A malicious application may be able to execute arbitrary code with kernel privileges

Description: A memory corruption issue was addressed with improved input validation

CVE-2018-4408: Ian Beer of Google Project Zero

 

 

source: https://support.apple.com/en-us/HT209193 
 

if you're brave enough, try it :D

Share this post


Link to post
Share on other sites
13 hours ago, alex.daoud said:

Unfortunately GPU and SD card reader are disabled and speedstep is enabled. Battery drain is still pretty bad and I only charge up to 62%. It's looking more like a worn out battery rather than any bug with macOS at this point. It's probably from abusing it from the last two years of VoodooI2C dev :p

you can boot into the Dell Hardware Checkup and test your battery. It sometimes happens, that OSX will report a wrong power charge value (eg. displaying 90% and not charging, unplugging will immediately let it jump to 100%), but this is only occasionally on a worn battery. Maybe there is another culprit...

2 hours ago, Mr.C said:

There is a security update for 12.6, 13.6, 14 rolling out today. Some changes that can harm the update process:

 

source: https://support.apple.com/en-us/HT209193 
 

if you're brave enough, try it :D

normally EFI related updates will only prevent the update to happen (failure -> abort), but will not result in an unbootable system. I'll give it a hit when i'm back from work tonight.

Edited by wmchris

Share this post


Link to post
Share on other sites
3 hours ago, wmchris said:

first test with 10.14.1 without any problem. seems safe.

I concur with that. Had to reinstall AppleBacklightInjector to Library/Extensions and fight though a few unable to allocate errors with the memory fix. I updated clover, Lilu and WhatEverGreen to their latest versions before updating to be on the safe side

55 minutes ago, Mr.C said:

 

Hope the new 1.9.0 System BIOS won't break it

No fixes I am concerned with on that BIOS. You should only update BIOS if there are major security fixes or you are having issues. I don't use those features so I will stay on 1.8.0. Also Dell have a tendency to break things with BIOS updates :P

 

Share this post


Link to post
Share on other sites

Just something I discovered there now. I found out if you want the bigger Apple logo on you 4K screen there is a plist config option in clover. I used clover configurator and went into the boot graphics section and enabled EFILoginHiDPI by putting 1 and setting UIScale to 2. Makes it look nicer. Just a cosmetic thing but maybe you could put it in your guide as a post install fix.

Share this post


Link to post
Share on other sites
12 hours ago, Mr.C said:

 

Hope the new 1.9.0 System BIOS won't break it

works fine.

9 hours ago, reece394 said:

Just something I discovered there now. I found out if you want the bigger Apple logo on you 4K screen there is a plist config option in clover. I used clover configurator and went into the boot graphics section and enabled EFILoginHiDPI by putting 1 and setting UIScale to 2. Makes it look nicer. Just a cosmetic thing but maybe you could put it in your guide as a post install fix.

as you said - just a cosmetic thing and will look strange on non 4k displays. I already added the GUIScale var before, so changing it is only a minor adaptation.

Edited by wmchris

Share this post


Link to post
Share on other sites

Hi ya'll,

9550 i7 16g 4k 512 w/ existing W10 and Linux os's already installed using grub boot loader

Having some trouble getting the installation going.  I have the PC300 NVMe Hynix 512 and was getting page allocation errors so I followed the slide tutorial and reviewed many times how to calculate just to be sure and first available space calculated to slide=146.  Using this I would get another kernel cache error:

ERROR!!! Load prelinked kernel with status 0x800...9
Error loading kernel cache (0x9)

So I tried all variants of OsxAptioFixDrv V1, V2, V3, LowMemFix and free2000 each with and without using the slide value and/or slide=0 but couldn't get past this until I went w/ V1 - OsxAptioFixDrv-64.efi + AllocFix.efi + no slide value.

I get past the kernel cache even though there is what looks like an error:

Start ProcessOptions

AWF: Only 141/256 slide values are usable! Booting may fail!
Valid slides are 0-140
End ProcessOptions

Then continues on with boot routines until:

Start FinalizeBootStruct
Start RandomSeed
End RandomSeed
+++++++++++++++++++++++++++++++++++++++++++++

This is where it hangs. Any help greatly appreciated.


p.s. forgot to mention I also have the IONVMeFamily Preferred Block Size and Hynix SSD patches in my config.plist (my sector size is not converted to 4k, not sure if this matters):
 

<dict>
  <key>Comment</key>
  <string>IONVMeFamily Preferred Block Size 0x10 -> 0x02, credit RehabMan based on 10.12 patch, (c) Pike R. Alpha </string>
  <key>Disabled</key>
  <true/>
  <key>Name</key>
  <string>com.apple.iokit.IONVMeFamily</string>
  <key>Find</key>
  <data>9sEQD4VBAQAA</data>
  <key>Replace</key>
  <data>9sECD4VBAQAA</data>
</dict>
<dict>
  <key>Comment</key>
  <string>IONVMeFamily Pike R. Alpha Hynix SSD patch</string>
  <key>Disabled</key>
  <false/>
  <key>Find</key>
  <data>9sEQD4UcAQAA</data>
  <key>Name</key>
  <string>IONVMeFamily</string>
  <key>Replace</key>
  <data>9sECD4UcAQAA</data>
</dict>

 

Edited by pingram
extra info

Share this post


Link to post
Share on other sites
11 hours ago, pingram said:

Hi ya'll,

9550 i7 16g 4k 512 w/ existing W10 and Linux os's already installed using grub boot loader

Having some trouble getting the installation going.  I have the PC300 NVMe Hynix 512 and was getting page allocation errors so I followed the slide tutorial and reviewed many times how to calculate just to be sure and first available space calculated to slide=146.  Using this I would get another kernel cache error:


ERROR!!! Load prelinked kernel with status 0x800...9
Error loading kernel cache (0x9)

So I tried all variants of OsxAptioFixDrv V1, V2, V3, LowMemFix and free2000 each with and without using the slide value and/or slide=0 but couldn't get past this until I went w/ V1 - OsxAptioFixDrv-64.efi + AllocFix.efi + no slide value.

I get past the kernel cache even though there is what looks like an error:


Start ProcessOptions

AWF: Only 141/256 slide values are usable! Booting may fail!
Valid slides are 0-140
End ProcessOptions

Then continues on with boot routines until:


Start FinalizeBootStruct
Start RandomSeed
End RandomSeed
+++++++++++++++++++++++++++++++++++++++++++++

This is where it hangs. Any help greatly appreciated.


p.s. forgot to mention I also have the IONVMeFamily Preferred Block Size and Hynix SSD patches in my config.plist (my sector size is not converted to 4k, not sure if this matters):
 


<dict>
  <key>Comment</key>
  <string>IONVMeFamily Preferred Block Size 0x10 -> 0x02, credit RehabMan based on 10.12 patch, (c) Pike R. Alpha </string>
  <key>Disabled</key>
  <true/>
  <key>Name</key>
  <string>com.apple.iokit.IONVMeFamily</string>
  <key>Find</key>
  <data>9sEQD4VBAQAA</data>
  <key>Replace</key>
  <data>9sECD4VBAQAA</data>
</dict>
<dict>
  <key>Comment</key>
  <string>IONVMeFamily Pike R. Alpha Hynix SSD patch</string>
  <key>Disabled</key>
  <false/>
  <key>Find</key>
  <data>9sEQD4UcAQAA</data>
  <key>Name</key>
  <string>IONVMeFamily</string>
  <key>Replace</key>
  <data>9sECD4UcAQAA</data>
</dict>

 

Which version are you trying to install?

 

I have the Hynix NVMe too, and the boot errors have nothing to do with the SSD. 

I had Sierra working fine without the 4K patch, but couldn't get High Sierra to recognize the SSD (or install to it..cant recall its been a while). I think you'll have to convert to 4K sector size if you want to install 10.13 or later.

 

I know this doesn't address the issue youre facing, buy thought id share this just so you can prepare for losing the existing windows and Linux partitions (i was in a similar situation) :(

Share this post


Link to post
Share on other sites
11 hours ago, nabeelmoeen said:

Which version are you trying to install?

 

I have the Hynix NVMe too, and the boot errors have nothing to do with the SSD. 

I had Sierra working fine without the 4K patch, but couldn't get High Sierra to recognize the SSD (or install to it..cant recall its been a while). I think you'll have to convert to 4K sector size if you want to install 10.13 or later.

 

I know this doesn't address the issue youre facing, buy thought id share this just so you can prepare for losing the existing windows and Linux partitions (i was in a similar situation) :(

Hi @nabeelmoeen

 

I'm trying to install 10.14.  The Arch Linux distro is my daily driver and I only have W10 left over from OEM just in case it's ever needed.

My workstation daily driver however is 10.12 which will get some attention soon.  I tried grabbing a 10.12 install from the App store but I have nothing in my purchase history.  I have the original .raw file I used so I might give 10.12 a shot if I can't get this working.

 

Quote

I think you'll have to convert to 4K sector size if you want to install 10.13 or later.

Can anyone confirm this?  It sounds like others have Hynix NVMe's too, anyone w/ 512 sector and working?

Share this post


Link to post
Share on other sites
1 hour ago, pingram said:

Hi @nabeelmoeen

 

I'm trying to install 10.14.  The Arch Linux distro is my daily driver and I only have W10 left over from OEM just in case it's ever needed.

My workstation daily driver however is 10.12 which will get some attention soon.  I tried grabbing a 10.12 install from the App store but I have nothing in my purchase history.  I have the original .raw file I used so I might give 10.12 a shot if I can't get this working.

 

Can anyone confirm this?  It sounds like others have Hynix NVMe's too, anyone w/ 512 sector and working? 

hynix is incompatible with 4k, but is installable with the supplied patches. Still your error has nothing to do with the SSD, your memory is fragmented. If you cant get it to work with the supplied files and tutorials, chances are slim to impossible to get it in a running state. Try calculating the slide value, if this doesnt work either then OSX is not suitable for your device.

Edited by wmchris

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By spec3
      hi,
       
      Is someone using ultrawide monitor 75hz whit hackintosh?
       
      I would like to buy LG 34UC99 (resolution 3440x1440 and freq: 75hz)
       
      will it work for you?
       
       
    • By BugsB
      SleepOnLowBattery (“SOLB”)
      by BugsB, based on a script by Toggi3 * + more code snippets from the www
       
      For those of us whose HackBook/ MacBook does not go to into power saving mode automatically on very low battery but just powers down coldly: “SOLB”, a small and low load footprint AppleScript based utility that checks the battery level every 2 minutes. You can choose between two versions, either with or without sound. Both display a notification in the top right of your screen.
       
      Between ≤10 and >8% battery charge:

       
      Between ≤8 and >5% battery charge:

       
      On ≤ 5% battery charge you will see a 10 seconds countdown dialog box in 1 second intervals:

       

       
      which you can cancel, or have your your *ac*Book be sent to sleep when down to 0.
       
      The version with sound uses the pleasant macOS US female voice Allison. If the lady is not installed, you can download "her" via System Preferences, Accessibility, Speech (pane tab should get opened by the install script), click onto the two arrows to the right of System Voice, Customize, English (Unites States) -- Female, activate Allison, OK (macOS downloads voices to /System/Library/Speech/Voices - Allison consumes 120 MB).
       
      If you want to see/ see and listen first, disconnect your Mac from its power supply and double click the “run Demo” file in either folder, with or without sound.
       
      The launcher is installed per user, so one user can use the script with and another user the script without sound.
       
      Run your desired install.command, with or without sound. The script should be active right away without restart.
       
      Regarding the sound version, you can also:
      - download any other English voice of your liking and edit the name inside the script at the very top
      - download any language voice and translate the text inside the script
      Edit with Apple Script Editor, save, install, reboot.
       
      Tested working in macOS High Sierra 10.13.6. Please feedback if this utility also works in Mojave.
       
      If you have ideas, experience bugs, etc., please contribute as precise, succinct, productive and friendly as possible. In case of a bug, always include your version of macOS for me or others to try and help. Thank you.
       
      ENJOY
       
      VERSION HISTORY:
      2018-11-10:
      1.0 (initial version)
       
      IDEAS TO IMPLEMENT IN FUTURE RELEASES:
      Have the sound version install script check if Allison is installed, and if not, offer to download and install it. Purely cosmetic: find a way to have the display notification in the top right of the screen not display the Script Editor icon but the one of the utility without turning the utility into an app but by maintaining a script to keep the load footprint low. This is currently neither possible with an Apple Script nor with an Apple Script Bundle file, only with the script compiled into an app. One possibility might be a Perl approach, if someone volunteers. ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      * Thanks to Toggi3 for the base script:
      https://hints.macworld.com/article.php?story=20110219013713667
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      THE CODE (of the version with sound):
      install.command:
       
      LaunchAgent SleepOnLowBatterySound.plist:
       
      Script SleepOnLowBatterySound.scpt:
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      SleepOnLowBattery (SOLB) by BugsB v.1.0 (2018-11-10).zip
    • By RogerDodger93
      Salve a tutti ragazzi,
      Mi sono appena iscritto e innanzi tutto vorrei esprimere la mia gratitudine per l'aiuto offerto. Il mio problema come da titolo riguarda il mio Pavilion Power 15 più precisamente il modello cb015nl. Ho notato che c'era un altro topic su un modello simile ma immagino che anche se i modelli sono simili non è detto che siano compatibili quindi ne ho creato uno per il mio modello. Per arrivare al dunque, sono riuscito ad installare con successo Mojave 10.14 ma ho riscontrato diversi problemi una volta avviato l'OS. Quello che non riesco a far funzionare è l'indicatore della batteria, il power managment (Stop non funziona e la luminosità), la porta ethernet e credo che la scheda wifi sia incompatibile, le gesture del trackpad, e l'audio che con una scheda audio esterna funziona a meraviglia e l'ultimo grosso problema è che non riesco a far partire clover senza la usb di installazione, ho installato clover bootoader sull'hd dove ho mojave ma niente senza la usb mi parte il bootloader di hp/windows. Premetto che sono partito con una copia di mojave scaricata dall'appstore. Vi allego il report di HackInfo sperando che possa essere d'aiuto per il troubleshooting
      HackInfo_Report.zip
    • By spec3
      ciao, 
       
      ho un problema con un monitor Dell p2715q 4k, funziona bene a prima vista, ma quando lavoro su programmi piu' pesanti, ho qualche problemino , del tipo che su certe azioni risulta rallentato a livello grafico. Invece se ridimensionato il monitor alla risoluzione nativa (3840x2160), sembra che questo problema sparisca. In pratica ho problemi solo nelle dimensioni intermedie. sapete se si puo' fare qualcosa? Il problema credo sia dovuto al monitor e non alla scheda video, perche' su un monitor full hd non ho problemi di rallentamento. 
       
      Per ora sto usando solo Lilu e wahtervergreen , senza questi il monitor nemmeno si accende.
       
      Se avete idee sono bene accette, 
       
      Grazie!
       
    • By ITzTravelInTime
      Hi guys, this thread is to show you a new and open source app, created by me, that I called TINU:
       
      The name means: TINU Is Not #####, the U refers to a popular software that is used to create macOS hackintosh installers (that for good reasons is banned on this forum), but the aim of the name is to explain that this app is a totally different thing from that software and works in a totally different way.
       
      This app basically is a graphical interface for the createinstallmedia executable that is inside the macOS and Mac OS X installer apps, it is capable to create a bootable installer completely vanilla like what you do using the command line method, and also this method is recommended by apple itself. In addition to this, this app provvides to you simplicity and flexybility, and lets you to avoid most of the steps needed with every other app.
       
      TINU allows you to create easily a bootable macOS installer without messing around with command line stuff and without using disk utility, all you need to do is use the app and then install clover on the usb drive once TINU has finished or leave it as is if you want to use it on a real Mac.
       
      Features:
      - Simple-to-use UI that allows you to easily start the bootable macOS installer creation process.
      - It can work with every macOS installer app that has the createinstallmedia executable inside its resources folder (including also beta and newly released installers).
      - You can use any erasable volume that is at least 7 GB of size (if the volume's drive is not in GUID format, TINU will re-format it accordingly).
      - Can work with the Mac OS recovery system, so you can create a bootable macOS installer from the macOS installer itself or from the macOS recovery partition, and you can use TINU to install macOS, too.
      - 100% clean: The bootable macOS installers created with this tool are vanilla, just as if you created them using the command line "createinstallmedia" method in Terminal.
      - Open Source: You can verify what this program does on your computer and you can create your own version by downloading and playing with the source code.
      - Does not require any special preparations. Just open the program, make sure you have a USB drive plugged in and have a macOS installer app on your disk.
      - No need to use Disk Utility. TINU can format your drive or partition for you.
      - Integrated EFI partition mounter tool.
      - Uses recent, modern, APIs and SDKs and the Swift 3 language.
      - Transparent graphics style available (type alt-S or choose from the menu bar: View -> Use transparent style).
      - Works using the latest versions of macOS and will also support newer Mac installers out of the box without requiring an update.
      - Offers advanced features to customize your bootable macOS installer.
       
      Features that are planned for future versions:
      - Install and configure [Clover](https://sourceforge.net/projects/cloverefiboot/).
      - Install kexts into Clover's kexts folder.
      - Clover drivers customization
      - Use custom DSDT in Clover
      - Integrated pre-made Clover config templates database from a remote and open repository.
      - Support for other languages, at least Italian.
       
      # Requirements:
      - A computer that runs Mac OS X Yosemite or a more recent version (Mac OS X El Capitan is required to use TINU in a macOS recovery or installer).
      - A drive or a free partition (on a drive which already supports GUID) of least 7 GB that you want to turn into a macOS/Mac OS X installer.
      - A copy of a macOS/Mac OS X installer app (Maveriks or newer versions are supported) in the /Applications folder or in the root of any storage drive on your machine (excepted the drive or volume you want to turn into your macOS install media).
       
      Download:
      https://github.com/ITzTravelInTime/TINU/releases

      Frequently asked questions:
      https://github.com/ITzTravelInTime/TINU/wiki/FAQs
       
      Useful links:
      Thread (english) on insanelymac.com:
      - http://www.insanelymac.com/forum/topic/326959-tinu-the-macos-installer-creator-app-mac-app/
      Thread (italian) on insanelymac.com:
      - https://www.insanelymac.com/forum/topic/333261-tinu-app-per-creare-chiavette-di-installazione-di-macos-thread-in-italiano/
      Thread (english-german) on hackintosh-forum.de:
      - https://www.hackintosh-forum.de/index.php/Thread/33630-TINU/
      Post on Reddit:
      - https://www.reddit.com/r/hackintosh/comments/a1h61d/tinu_vanilla_bootable_macos_installer_creation/
      Facebook hackintosh help and beta testing (Italian only):
      - https://www.facebook.com/groups/Italia.hackintosh/?fref=ts
      Contact me (project creator):
      - Insanelymac.com profile: http://www.insanelymac.com/forum/user/1390153-itztravelintime/
      - email: piecaruso97@gmail.com
       
      Note that:
      - This software is under GNU GPL v3 license so any new branch/mod/third party release must be open source and under the same license
      - I (project creator) assume no responsibility for any use of this app and this source code, and also for any kind of hardware and software damage to any computer and any device or peripheral that may come from this app or source code during it's use and outside it's usage
      - I (project creator) do not guarantee support to you, this is only an open source project, not a product released by a company!
      - This project is born only for educational and demonstrative purposes, it's not intended to be used for commercial purposes and it will never be, don't use source code from this project to create apps or software for that aim.
      - This is a no-profit project, born only to let people to create macOS install medias in a more simple way and also to learn how to create this kind of apps.
       
      Credits:
      - Apple for macos and installer apps and scripts
      - People that helped me a lot:
      Francesco Perchiazzi, Nicola Tomarelli, Roberto Sciortino, Raffaele Sonnessa, Ermanno Nicoletti, Tommaso Dimatore, Michele Vitiello Bonaventura, Massimiliano Faralli, Davide Dessì, Giorgio Dall'Aglio, Peter Paul Chato.   
      - Special thanks to Italian Hackintosh group!! for help (https://www.facebook.com/groups/Italia.hackintosh/?fref=ts)
      - Thomas Tempelmann for help with the UI
      - Pietro Caruso (ITzTravelInTime) for creating, maintaing and developing this project
       
       
         
×