Jump to content
wmchris

[GUIDE] Dell XPS 15 (9550) Mojave 10.14 / 10.15 Quick Installation

1,578 posts in this topic

Recommended Posts

@wmchris I don't have the VoodooI2C Kexts installed, because of the High CPU Usage, but the Fans also get very loud, when there is a little bit load on the CPU. It seems that OS X doesn't lower the Fan Speed, when the CPU has no more load in it. Maybe because it can't read properly the Fan RPMs-

Share this post


Link to post
Share on other sites
Advertisement
On 10/26/2019 at 12:28 AM, agrafuese said:

I see you have the intermittent keyboard problem as well. That is currently the biggest annoyance for me. I tried putting voodoops2controller into /L/E instead of the EFI folder because that is supposedly the best way to load in kexts, but that didn't work for me (and I did properly follow kext installation procedures). Side note: voodoops2controller seems to affect the touchpad mostly, so I'm not sure if I am looking at the wrong kext or if there is another answer to this problem. The randomness is just so odd and frustrating. Anyone else know more about this?

 

Hmm, I get this problem intermittently for both keyboard and touchpad (so far only one stops working, for me it's usually the touchpad) and restart fixes it. I suspect for keyboard at least it may be a hardware problem because I have dual boot with windows and I've had the keyboard stop working on windows as well.

Also I haven't had the wifi issue since making the change you suggested.

Share this post


Link to post
Share on other sites
On 11/9/2019 at 8:20 PM, jwijesundra said:

 

Hmm, I get this problem intermittently for both keyboard and touchpad (so far only one stops working, for me it's usually the touchpad) and restart fixes it. I suspect for keyboard at least it may be a hardware problem because I have dual boot with windows and I've had the keyboard stop working on windows as well.

Also I haven't had the wifi issue since making the change you suggested.

Glad to hear about the wifi continuing to work well for you! :) 

 

Regarding the keyboard/touchpad: I just updated my Clover folder with the newest changes from the repo, and I'm hoping I will see an improvement in the keyboard/touch pad since the Voodoo kexts are the ones that were updated. So far, the touchpad seems to feel better when I use it (the cursor used to jump a few pixels when I would click, and now it doesn't seem to do that as badly). And the keyboard hasn't failed on boot up yet (although I haven't rebooted a lot since updating the kexts, so it could still be an issue).

 

I should note, I decided to update from the repo in the first place because the latest Apple security update for Mojave completely wiped out my touchpad. It came back to life when I implemented the repo updates. So, I'm not sure if that is just a coincidence or intentional, but in either case, if anyone notices touchpad issues after installing the Apple security update, be sure to try the new repo files. And if you do, WARNING: since the config.plist has also been updated, you will definitely want to make sure to add in your custom serial number/ID/etc for making iCloud services functional. To make this easy, I used a file comparison app to find/replace my custom entries and move them over to the newest config.plist.

Share this post


Link to post
Share on other sites

...and of course the good came with the bad...

 

Just got my first kernel panic a moment ago while booting up, and I think it was from voodoops2controller (see below for output from Crash Reporter). 

 

This is the first time it has happened in about 5-10 reboots since installing the newest kexts from repo and the latest Apple security update. I've rebooted twice so far since the panic, and that has been fine. So, this could be a random occurrence. I will report back if it worsens.

 

*** Panic Report ***
panic(cpu 0 caller 0xffffff800aedc9bd): Kernel trap at 0xffffff7f8e73aca8, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x0000000000000000, CR3: 0x0000000023ba1000, CR4: 0x00000000003626e0
RAX: 0xfa424d5d87c8003d, RBX: 0xffffff8040e84000, RCX: 0x0000000000000008, RDX: 0xffffff7f8e742470
RSP: 0xffffff81ff7b3d60, RBP: 0xffffff81ff7b3d70, RSI: 0x0000000000000000, RDI: 0x0000000000000000
R8:  0xffffff81be441200, R9:  0xffffff81be4411fc, R10: 0xffffff81be441000, R11: 0x0000000000000000
R12: 0xffffff8042292d50, R13: 0xffffff8042292d58, R14: 0xffffff80420db800, R15: 0xffffff8042292d00
RFL: 0x0000000000010286, RIP: 0xffffff7f8e73aca8, CS:  0x0000000000000008, SS:  0x0000000000000000
Fault CR2: 0x0000000000000000, Error code: 0x0000000000000000, Fault CPU: 0x0, PL: 0, VF: 1

Backtrace (CPU 0), Frame : Return Address
0xffffff81ff7b3830 : 0xffffff800adaf57d 
0xffffff81ff7b3880 : 0xffffff800aeeb065 
0xffffff81ff7b38c0 : 0xffffff800aedc79a 
0xffffff81ff7b3930 : 0xffffff800ad5c9d0 
0xffffff81ff7b3950 : 0xffffff800adaef97 
0xffffff81ff7b3a70 : 0xffffff800adaede3 
0xffffff81ff7b3ae0 : 0xffffff800aedc9bd 
0xffffff81ff7b3c50 : 0xffffff800ad5c9d0 
0xffffff81ff7b3c70 : 0xffffff7f8e73aca8 
0xffffff81ff7b3d70 : 0xffffff800b42baaa 
0xffffff81ff7b3dc0 : 0xffffff800b4374bb 
0xffffff81ff7b3df0 : 0xffffff7f8e73a531 
0xffffff81ff7b3e20 : 0xffffff7f8e741d5d 
0xffffff81ff7b3e40 : 0xffffff800b42f6cb 
0xffffff81ff7b3e80 : 0xffffff800b42f385 
0xffffff81ff7b3f00 : 0xffffff800b42e947 
0xffffff81ff7b3f50 : 0xffffff800b430436 
0xffffff81ff7b3fa0 : 0xffffff800ad5c0ce 
      Kernel Extensions in backtrace:
         as.acidanthera.voodoo.driver.PS2Trackpad(2.0.4)[CFDA888E-E3F7-3220-BE69-F6C46E719297]@0xffffff7f8e739000->0xffffff7f8e748fff
            dependency: as.acidanthera.voodoo.driver.PS2Controller(2.0.4)[E2927F57-AEFE-372E-ACAD-19C77D1D69E9]@0xffffff7f8e6d0000
            dependency: com.apple.iokit.IOHIDFamily(2.0.0)[CCEA17E9-B816-3148-AFF1-E43E46E1C37B]@0xffffff7f8bc0e000

BSD process name corresponding to current thread: kernel_task
Boot args: dart=0 nv_disable=1 agdpmod=vit9696 -v brcmfx-country=#a darkwake=no -lilubetaall kext-dev-mode=1 

Mac OS version:
18G1012

Kernel version:
Darwin Kernel Version 18.7.0: Sat Oct 12 00:02:19 PDT 2019; root:xnu-4903.278.12~1/RELEASE_X86_64
Kernel UUID: DFB5D0E2-3B41-3647-A48B-D704AFCC06B4
Kernel slide:     0x000000000aa00000
Kernel text base: 0xffffff800ac00000
__HIB  text base: 0xffffff800ab00000
System model name: MacBookPro13,3 (Mac-A5C67F76ED83108C)

System uptime in nanoseconds: 6834762454
last loaded kext at 3353261784: com.apple.driver.AppleActuatorDriver	2450.1 (addr 0xffffff7f8df64000, size 61440)
loaded kexts:
com.alexandred.VoodooI2CHID	1
com.no-one.BrcmPatchRAM2	2.2.10
com.no-one.BrcmFirmwareStore	2.2.10
com.metakine.handsoff.driver	4.2.1
as.acidanthera.voodoo.driver.PS2Mouse	2.0.4
as.acidanthera.voodoo.driver.PS2Trackpad	2.0.4
as.acidanthera.voodoo.driver.PS2Keyboard	2.0.4
org.rehabman.driver.FakePCIID	1.3.15
ru.joedm.SMCSuperIO	1.0.2
com.alexandred.VoodooI2C	2.2
org.coolstar.VoodooGPIO	1.1
as.acidanthera.voodoo.driver.PS2Controller	2.0.4
as.vit9696.SMCProcessor	1.0.2
xyz.racermaster.NoTouchID	1.0.1
as.lvs1974.AirportBrcmFixup	1.1.9
as.vit9696.AppleALC	1.3.6
org.tw.CodecCommander	2.7.1
as.vit9696.WhateverGreen	1.2.7
ru.usrsse2.SMCBatteryManager	1
org.vanilla.driver.CPUFriend	1.1.6
ru.usrsse2.SMCLightSensor	1
as.vit9696.VirtualSMC	1.0.2
as.vit9696.Lilu	1.3.5
com.alexandred.VoodooI2CServices	1
com.apple.driver.AppleTopCaseHIDEventDriver	138.4
com.apple.driver.AppleFileSystemDriver	3.0.1
com.apple.driver.AppleVirtIO	2.1.3
com.apple.filesystems.hfs.kext	407.200.4
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
com.apple.BootCache	40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0
com.apple.AppleSystemPolicy	1.0
com.apple.driver.AppleSmartBatteryManager	161.0.0
com.apple.filesystems.apfs	945.275.8
com.apple.driver.AirPort.BrcmNIC	1400.1.1
com.apple.driver.AppleAHCIPort	329.260.5
com.apple.driver.AppleACPIEC	6.1
com.apple.driver.AppleRTC	2.0
com.apple.driver.AppleACPIButtons	6.1
com.apple.driver.AppleHPET	1.8
com.apple.driver.AppleBacklight	170.12.12
com.apple.driver.AppleSMBIOS	2.1
com.apple.driver.AppleAPIC	1.7
com.apple.nke.applicationfirewall	202
com.apple.security.TMSafetyNet	8
com.apple.driver.AppleActuatorDriver	2450.1
com.apple.driver.AppleHSBluetoothDriver	138.4
com.apple.driver.IOBluetoothHIDDriver	6.0.14d3
com.apple.iokit.IOBluetoothFamily	6.0.14d3
com.apple.driver.AppleMultitouchDriver	2450.1
com.apple.driver.AppleInputDeviceSupport	2440.2
com.apple.driver.AppleUSBAudio	315.6
com.apple.driver.usb.IOUSBHostHIDDevice	1.2
com.apple.driver.usb.cdc	5.0.0
com.apple.driver.usb.networking	5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice	1.2
com.apple.iokit.IOSerialFamily	11
com.apple.filesystems.hfs.encodings.kext	1
com.apple.driver.AppleUSBMergeNub	900.4.2
com.apple.driver.AppleUSBHostMergeProperties	1.2
com.apple.driver.usb.AppleUSBHostPacketFilter	1.0
com.apple.iokit.IOUSBFamily	900.4.2
com.apple.driver.AppleXsanScheme	3
com.apple.iokit.IOAHCIBlockStorage	301.270.1
com.apple.driver.AppleEFINVRAM	2.1
com.apple.iokit.IO80211Family	1200.12.2
com.apple.driver.mDNSOffloadUserClient	1.0.1b8
com.apple.driver.corecapture	1.0.4
com.apple.driver.AppleEFIRuntime	2.1
com.apple.driver.AppleIntelLpssI2C	3.0.60
com.apple.driver.AppleIntelLpssGspi	3.0.60
com.apple.iokit.IOAHCIFamily	288
com.apple.driver.usb.AppleUSBXHCIPCI	1.2
com.apple.driver.usb.AppleUSBXHCI	1.2
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.driver.AppleBacklightExpert	1.1.0
com.apple.iokit.IONDRVSupport	530.51
com.apple.iokit.IOGraphicsFamily	530.67
com.apple.security.quarantine	3
com.apple.security.sandbox	300.0
com.apple.kext.AppleMatch	1.0.0d1
com.apple.iokit.IOAudioFamily	206.5
com.apple.vecLib.kext	1.2.0
com.apple.iokit.IOSMBusFamily	1.1
com.apple.driver.DiskImages	493.0.0
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.driver.AppleEffaceableStorage	1.0
com.apple.driver.AppleKeyStore	2
com.apple.driver.AppleUSBTDM	456.260.3
com.apple.driver.AppleMobileFileIntegrity	1.0.5
com.apple.iokit.IOUSBMassStorageDriver	145.200.2
com.apple.iokit.IOSCSIBlockCommandsDevice	408.250.3
com.apple.iokit.IOSCSIArchitectureModelFamily	408.250.3
com.apple.iokit.IOStorageFamily	2.1
com.apple.kext.CoreTrust	1
com.apple.driver.AppleCredentialManager	1.0
com.apple.driver.KernelRelayHost	1
com.apple.iokit.IOUSBHostFamily	1.2
com.apple.driver.usb.AppleUSBCommon	1.0
com.apple.driver.AppleBusPowerController	1.0
com.apple.driver.AppleSEPManager	1.0.1
com.apple.driver.IOSlaveProcessor	1
com.apple.iokit.IOReportFamily	47
com.apple.iokit.IOTimeSyncFamily	740.2
com.apple.iokit.IONetworkingFamily	3.4
com.apple.driver.AppleACPIPlatform	6.1
com.apple.driver.AppleSMC	3.1.9
com.apple.iokit.IOPCIFamily	2.9
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.pthread	1
com.apple.kec.Libm	1
com.apple.kec.corecrypto	1.0

EOF

 

Share this post


Link to post
Share on other sites
On 10/31/2019 at 8:16 PM, golimpio said:

FIY: Updated to 10.15.1 without any issues so far. Also updated to the latest BIOS (1.11.2), but it doesn't make any difference for this specific MacOS update, I've done it just to keep the system updated and also for testing it.

Hi, I have no issues installing 10.14.6 on my 9550.  I followed the guide for installing 1015.1 using the files provided here but never get to the 10.15.1 installer.  It just freezes on the console screen. I even tried creating another partition and trying to install to from my 10.14.6 install.  Same result.  'What did you do to get 10.15.1 installed?  Thanks.

Share this post


Link to post
Share on other sites
22 hours ago, dmeister said:

Hi, I have no issues installing 10.14.6 on my 9550.  I followed the guide for installing 1015.1 using the files provided here but never get to the 10.15.1 installer.  It just freezes on the console screen. I even tried creating another partition and trying to install to from my 10.14.6 install.  Same result.  'What did you do to get 10.15.1 installed?  Thanks.

I had 10.15 installed before and just did the normal macOS upgrade to 10.15.1. Same for 10.15, I had 10.14.? installed, and did an upgrade to 10.15 via the macOS Software Update.

Share this post


Link to post
Share on other sites

I upgraded to MacOS 10.15.1 without any issues, and just wanted to say thanks to everybody who keeps this post and the github archive updated. I've had this Hackintosh working perfectly for the last 1.5 years with upgrades being ridiculously easy to perform because of your efforts, and I am very thankful :)

Share this post


Link to post
Share on other sites
On 11/15/2019 at 4:02 AM, wmchris said:

kernel panics with voodoops2 are rare, but they happen.

Hopefully the new version will not result in more KPs than before. @agrafuese please keep us updated

 

@wmchris Came back to report 2 more KPs from voodoops2controller - one last night and one this morning, same exact error report as previously posted. It happens on boot up, and I can't figure out any reason for it. I should also reiterate that before I installed this version of the repo, my keyboard (and very rarely trackpad) would not work sometimes upon boot up, forcing me to reboot and try again. So, it's almost as if I traded that problem for the KPs. Could it be that I have slightly different hardware? My 9550 is the 4k touchscreen version, if that matters? Let me know if I can assist with anymore info.

 

@wmchris ...and two more today.

Edited by agrafuese

Share this post


Link to post
Share on other sites

*EDITED:* original message deleted (the issue reported didn't exist).

Edited by golimpio

Share this post


Link to post
Share on other sites
On 11/18/2019 at 7:53 PM, agrafuese said:

@wmchris Came back to report 2 more KPs from voodoops2controller - one last night and one this morning, same exact error report as previously posted. It happens on boot up, and I can't figure out any reason for it. I should also reiterate that before I installed this version of the repo, my keyboard (and very rarely trackpad) would not work sometimes upon boot up, forcing me to reboot and try again. So, it's almost as if I traded that problem for the KPs. Could it be that I have slightly different hardware? My 9550 is the 4k touchscreen version, if that matters? Let me know if I can assist with anymore info.

 

@wmchris ...and two more today.

Damn. Sadly I can’t reproduce this. Take a look at the voodoops2 drivers and maybe install older versions or from different forks. Maybe you can find a Version with less bugs. Please keep us updated.

 

The other reported issues (had to reboot because keyboard was not responding) were an issue which was so rare, it didn’t require a fix, just a quick reboot ;)

Share this post


Link to post
Share on other sites
On 11/19/2019 at 9:03 AM, golimpio said:

There was one issue on 10.15.1 that I haven't noticed before:

  • Connecting to bluetooth devices was not working, even though the devices were showing up on the list.

I've just upgrade: BrcmFirmwareData.kext and BrcmBluetoothInjector.kext to the latest version (2.5.0) and it's working now (BrcmPatchRAM3.kext was already updated).

There was nothing wrong with the files in the repository, they were all updated to the correct version already. It was my mistake, I did something wrong while copying these files. I apologise for not having double checked it before posting here.

Edited by golimpio

Share this post


Link to post
Share on other sites
On 11/22/2019 at 1:27 PM, wmchris said:

Damn. Sadly I can’t reproduce this. Take a look at the voodoops2 drivers and maybe install older versions or from different forks. Maybe you can find a Version with less bugs. Please keep us updated.

 

The other reported issues (had to reboot because keyboard was not responding) were an issue which was so rare, it didn’t require a fix, just a quick reboot ;)

 

Thanks for trying. On a possibly unrelated note, I'm finally going to try to fix the "couldn't allocate" error that I've also been having (needs the slide fix, I think), and I'm hoping that it somehow magically fixes the problems I'm having with the voodoo2controller kext. In my case, the previous problem of the keyboard not working was just as recurring as this KP is now, so reverting back to that older kext would only get me so far. I'll report back if the slide fix gets me anywhere. Slide fix did not work. :(

Edited by agrafuese

Share this post


Link to post
Share on other sites

New System BIOS released 18 Nov 2019:
Fixes:
- Fixed the issue where the mouse lags when the Dell TB16 dock is unplugged or plugged in.
- Fixed the issue where the screen does not display content when the lid is opened and closed repeatedly.
- Firmware updates to address security advisory INTEL-SA-00213 (CVE-2019-0086, CVE-2019-0091, CVE-2019-0092, CVE-2019-0093, CVE-2019-0094 and CVE-2019-0096)
- Firmware updates to address security advisories INTEL-SA-00233(CVE-2018-12126, CVE-2018-12127, CVE-2018-12130 and CVE-2019-11091)
- Removed the preboot Intel RST Manager Optimized Defaults option.
- Fixed the issue where the BitLocker prompts for recovery. It occurs when Auto Power On option in BIOS setup is set to wake up the system at a specific time.

Enhancements:
- Modified battery algorithm to prolong lifespan and minimize risk of swelling.

 

-----

Didn't try yet

Share this post


Link to post
Share on other sites
11 hours ago, Mr.C said:

New System BIOS released 18 Nov 2019:
Fixes:
- Fixed the issue where the mouse lags when the Dell TB16 dock is unplugged or plugged in.
- Fixed the issue where the screen does not display content when the lid is opened and closed repeatedly.
- Firmware updates to address security advisory INTEL-SA-00213 (CVE-2019-0086, CVE-2019-0091, CVE-2019-0092, CVE-2019-0093, CVE-2019-0094 and CVE-2019-0096)
- Firmware updates to address security advisories INTEL-SA-00233(CVE-2018-12126, CVE-2018-12127, CVE-2018-12130 and CVE-2019-11091)
- Removed the preboot Intel RST Manager Optimized Defaults option.
- Fixed the issue where the BitLocker prompts for recovery. It occurs when Auto Power On option in BIOS setup is set to wake up the system at a specific time.

Enhancements:
- Modified battery algorithm to prolong lifespan and minimize risk of swelling.

 

-----

Didn't try yet

I've updated to this BIOS about a week ago and it's stable in my laptop. I don't have a dock though, so I can't comment on the mouse lags issue.

Share this post


Link to post
Share on other sites

So I just did a fresh install of MacOs 10.15.1 and had previously had 10.14 working on my system for the last year. After following the 10.15 tutorial I have my MacOs bootable on clover but not my windows. I am able to see my windows efi in clover. When I select and try to boot into windows, I get a blue screen error saying device is not available (error 0xc0000001). I am able to use older clovers and boot fine into my windows, but then I am unable to boot my Catalina MacOs. I am also able to manually boot windows via my bios. So I'm pretty sure it is something on clover's end... would anyone know what I need to change/do?

Share this post


Link to post
Share on other sites

Hi,
I followed the guide before to install on my xps 15 osx 10.13.3.
Now i'm trying to do a fresh install of catalina but when i try to boot from usb my drive loads the new clover but it doesn't list the osx installer, only the boot from my ssd and the recovery.

Can anyone guide me to fix this issue?
Thanks

Share this post


Link to post
Share on other sites

hai 

I have catalina installed on my 9550(4K、I7、32GB RAM)

I found the touchscreen Only one finger operation can be realized,other finger operation not work

but the Touch pad work well

the kext(VoodooI2C、VoodooI2CHID) in Clover

please give me  some suggestions ?

Share this post


Link to post
Share on other sites
On 12/3/2019 at 2:13 PM, sangra4l said:

Hi,
I followed the guide before to install on my xps 15 osx 10.13.3.
Now i'm trying to do a fresh install of catalina but when i try to boot from usb my drive loads the new clover but it doesn't list the osx installer, only the boot from my ssd and the recovery.

Can anyone guide me to fix this issue?
Thanks

Hi,

I've done some tests to try and overcome this problem.
The version of macos that i downloaded from the appstore is the 10.15.1.
I've tried installing different versions of clover (the one included in this repository 4972, and the latest version 5099).
What i've found is that for me there is no way to make the clover in my thumbdrive list the install partition in the thumbdrive itself.
I've tried installing the clover versions and not overwrite the files in the EFI partition with the ones provided in this repository, and i've tried overwriting them with no success.
The strange thing is that i've tried to perform the whole process using the latest Mojave install file (10.14.6) and with both versions of clover they show the install partition only if i don't overwrite any file from the EFI partition.

Share this post


Link to post
Share on other sites
On 12/3/2019 at 7:09 AM, tev66 said:

So I just did a fresh install of MacOs 10.15.1 and had previously had 10.14 working on my system for the last year. After following the 10.15 tutorial I have my MacOs bootable on clover but not my windows.

 

wrong forum. This is a general problem using clover. Read the topics there or/and use google.

https://www.insanelymac.com/forum/327-clover/

 

On 12/3/2019 at 2:13 PM, sangra4l said:

Hi,
I followed the guide before to install on my xps 15 osx 10.13.3.
Now i'm trying to do a fresh install of catalina but when i try to boot from usb my drive loads the new clover but it doesn't list the osx installer, only the boot from my ssd and the recovery.

you created the usb installer the wrong way. No support for this issue, as this can be interpreted as piracy. Use google. Hint: many times the app store doesnt download a full installation image. If you use this as the base image, then it's not bootable. Use a different approach.

 

12 hours ago, chilmeat said:

hai 

I have catalina installed on my 9550(4K、I7、32GB RAM)

I found the touchscreen Only one finger operation can be realized,other finger operation not work

but the Touch pad work well

the kext(VoodooI2C、VoodooI2CHID) in Clover

please give me  some suggestions ? 

> https://github.com/alexandred/VoodooI2C

Edited by wmchris

Share this post


Link to post
Share on other sites
3 hours ago, wmchris said:

you created the usb installer the wrong way. No support for this issue, as this can be interpreted as piracy. Use google. Hint: many times the app store doesnt download a full installation image. If you use this as the base image, then it's not bootable. Use a different approach.

 

Hi,

thanks for the reply.

I've created the usb installer the way that is written in the repository that is linked in the first page of this thread.

As I said in the previous post, using the Mojave installer I can create a working boot drive, but if I overwrite the files in the EFI partition of the drive with the ones in the repository (./10.15/CLOVER) the boot drive is not listed anymore in clover, I see only my ssd and the recovery.

 

I've read multiple guides and multiple fixes but nothing seems to work.

I'm already grateful for your work because I have a working hackintosh and I'm sorry but I can't understand the piracy argument.

 

Share this post


Link to post
Share on other sites
22 hours ago, sangra4l said:

 

Hi,

thanks for the reply.

I've created the usb installer the way that is written in the repository that is linked in the first page of this thread.

As I said in the previous post, using the Mojave installer I can create a working boot drive, but if I overwrite the files in the EFI partition of the drive with the ones in the repository (./10.15/CLOVER) the boot drive is not listed anymore in clover, I see only my ssd and the recovery.

 

I've read multiple guides and multiple fixes but nothing seems to work.

I'm already grateful for your work because I have a working hackintosh and I'm sorry but I can't understand the piracy argument.

 

 

10.15 sometimes needs a different approach to download the OS Base Image. The images from the app store look like normal images, but are not bootable on its own. You can identify this by looking at the size of the image. Just take a look in this thread, this happened a few people here before.

 

Helping you there could be interpreted as illegal download of copyrighted content.

Edited by wmchris

Share this post


Link to post
Share on other sites
24 minutes ago, wmchris said:

 

10.15 sometimes needs a different approach to download the OS Base Image. The images from the app store look like normal images, but are not bootable on its own. You can identify this by looking at the size of the image. Just take a look in this thread, this happened a few people here before.

 

Helping you there could be interpreted as illegal download of copyrighted content.

 

Ok thanks,

 

but what about the fact that when i change the files in clover the bootable installer of Mojave disappears?

Seems to me that i can't understand what to do with those.

 

Share this post


Link to post
Share on other sites
21 hours ago, sangra4l said:

 

Ok thanks,

 

but what about the fact that when i change the files in clover the bootable installer of Mojave disappears?

Seems to me that i can't understand what to do with those.

 

 

I've done some more testing.

I have created a bootable Catalina usb drive that is listed in clover correctly until I switch the config.plist in the stock clover with the one found in the GitHub repository.

I don't know what can be causing the problem but I'm sure is in that file.

 

Share this post


Link to post
Share on other sites
On 12/7/2019 at 4:04 PM, sangra4l said:

 

I've done some more testing.

I have created a bootable Catalina usb drive that is listed in clover correctly until I switch the config.plist in the stock clover with the one found in the GitHub repository.

I don't know what can be causing the problem but I'm sure is in that file.

 

then please take a deeper look into it. merge it line by line till it's not booting anymore.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ricardos7
      Preciso de ajuda para terminar um meu hackintosh, alguém poderia me ajudar?
       
      Boa tarde a todos, gostaria de ajuda com o meu hackintosh, estou fazendo um hack em um notebook Dell 5557, as configurações estão abaixo.
       
      ESPECIFICAÇÕES TÉCNICAS
      Processador
      Modelo: Intel Core i7 - 6ª Geração Intel Core i7-6500U
      Velocidade: 2.5 GHz até 3.1 GHz com Max Turbo Cache: 4Mb
      Memória RAM Quantidade: 16GB DDR3L 1600MHz (2X8).
      Armazenamento Capacidade: 240 GB SSD
      Tela Tamanho:15.6” Resolução: FULL HD 1920x1080p Touch
      Webcam integrada de alta definição (720p) com microfone digital
      Gráfico Integrado Intel HD 520
      NVIDIA® GeForce 930M com 4GB DDR3 Dedicada
      Áudio Realteck 

      Dell Wireless 1705 WiFi
      1x  HDMI 1.4ª
      2x USB 3.0
      1x USB 2.0
      1x Ethernet 10/100 RJ-45
      1x Entrada de Cartão 5 em 1 (SD, SD 3.0, SDHC, MS e MS PRO)
      Leitor de Cartão
      Tipo: SD, SDHC, SD3.0, MS, MS Pro
      Alimentação Bivolt 3 células 43Wh
       
      Os problemas que encontrei ate agora foram.
      O que não funciona?
      WIFI
      AUDIO
      BRILHO DA TELA
      BLUETOOTH
      GERENCIAMENTO DE ENERGIA NAO SEI COMO SABER SE FUNCIONA
      GRAFICOS DEDICADOS NVIDEA 930M
       
       
      O QUE FUNCIONA?
      GRAFICOS INTEL
      TECLADO
      TRACKPAD
      TECLAS FN
      PLACA DE REDE
       
      AS DSDT E AS SSDT?
      Nao sei como fazer para esse modelo mais ja extrai as originais mais nao sei quais arquivos usar e quais pachs ativar,
      alguém poderia me ajudar a terminar esse hack por favor. Desde ja obrigado.




    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F10, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.1Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Nitro+ SE Vega56 ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.1
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      CLOVER EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F10 to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f10.zip - Z390 MASTER Bios Revision F10
       
      Use this folder with igpu Enabled in bios for working Sidecar (Updated 1st Nov)
      AudioGods Z390 Master Vega Navi EFI.zip - Vega 56/64 Navi & Radeon VII DSDT
      AudioGods Z390 Master RX EFI.zip - RX Series DSDT
       
       
      ADDITIONAL DSDT's  (A big thanks to @MaLd0n for compiling these DSDT's)

       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://olarila.com/forum/viewtopic.php?f=19&t=1131 
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F10)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 512MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS
       

       

       

       

       

       

       

       

       

       

       
       
    • By JamesMaloney
      Salve a tutti,
      ho provato diverse volte ad installare macOS sul mio laptop ma sempre senza successo, non riesco mai ad arrivare nemmeno all'installer!
      Ho tentato ormai diverse configurazioni/driver ma non capisco mai da cosa siano derivanti gli errori o i blocchi che mi trovo davanti e sto quindi cercando aiuto per capire come procedere 
      Nello specifico il config che sto provando ad utilizzare non mi trova per niente la partizione con l'installer, mentre un altro vecchio (presente sempre nella cartella di clover allegata con estensione .orig) si inchioda subito dopo la scelta della partizione di avvio.
      Qualcuno mi sa dare una mano su come superare ciò?
      Grazie in anticipo,
       
      Giacomo
       
       
      P.S. Le mie specifiche sono:
       
      - Modello ASUS N552VW-FI202T
      - Schermo 3840x2160
      - CPU Intel Core i7-6700HQ
      - RAM 16GB ddr4 2400mHz
      - Intel HD Graphics 530 + nVidia 960m 4GB (anche funzionasse solo la Intel sarebbe perfetto)
      - SSD 256GB
      - HDD 1TB
      CLOVER.zip
    • By BuXb
      SleepOnLowBattery (“SOLB”)
      by BugsB, based on a script by Toggi3 * + more code snippets from the www
       
      For those of us whose HackBook (or even real MacBook) doesn't automatically and properly go into power saving mode on very low battery but just powers down coldly, crashing macOS: “SOLB”, a small and RAM/ CPU wise very low footprint AppleScript based utility that checks the battery level every 2 minutes, running via daemon in the background.
       
      You can choose between two versions, either with or without sound. Both display a notification in the top right of your screen.
       
      Between ≤10 and >8% battery charge:

       
      Between ≤8 and >5% battery charge:

       
      On ≤ 5% battery charge you will see a 10 seconds countdown dialog box in 1 second intervals:

       

       
      which you can cancel, or have your your *ac*Book be sent to sleep when down to 0.
       
      The version with sound uses the pleasant macOS US female voice Allison. If the lady is not installed, you can download "her" via System Preferences, Accessibility, Speech (pane tab should get opened by the install script), click onto the two arrows to the right of System Voice, Customize, English (Unites States) -- Female, activate Allison, OK (macOS downloads voices to /System/Library/Speech/Voices - Allison consumes 120 MB).
       
      If you want to see/ see and listen first, disconnect your Mac from its power supply and double click the “run Demo” file in either folder, with or without sound.
       
      The launcher is installed per user, so one user can use the script with and another user the script without sound.
       
      Run your desired install.command, with or without sound. The script should be active right away without restart.
       
      Regarding the sound version, you can also:
      - download any other English voice of your liking and edit the name inside the script at the very top
      - download any language voice and translate the text inside the script
      Edit with Apple Script Editor, save, install, reboot.
       
      Tested working in macOS High Sierra 10.13.6, Mojave 10.14.6 and Catalina 10.15.1.
      Please feedback if this utility also works for you.
       
      If you have ideas, experience bugs, etc., please contribute as precise, succinct, productive and friendly as possible. In case of a bug, always include your version of macOS for me or others to try and help. Thank you.
       
      ENJOY
       
      VERSION HISTORY:
      2019-11-15 v. 1.1
          •    BUG FIX: changed all occurrences of ExternalChargeCapable to ExternalConnected in all Apple Script .scpt files (SleepOnLowBattery.scpt, SleepOnLowBatterySound.scpt, demo.scpt) to restore functionality
          •    IMPROVEMENT: made queries of MaxCapacity and CurrentCapacity more compatible to work with hopefully any system
          •    NEW: added Catalina compatibility to install scripts; verified Mojave compatibility
          •    NEW: Sound script uses voice Allison if installed, otherwise automatically defaults back to another English standard voice (Daniel, Alex or Fred)
       
      2018-11-10 v.1.0
          •    initial version
       
      IDEAS TO IMPLEMENT IN FUTURE RELEASES:
      Have the sound version install script check if Allison is installed, and if not, offer to download and install it. Purely cosmetic: find a way to have the display notification in the top right of the screen not display the Script Editor icon but the one of the utility without turning the utility into an app but by maintaining a script to keep the load footprint low. This is currently neither possible with an Apple Script nor with an Apple Script Bundle file, only with the script compiled into an app. One possibility might be a Perl approach, if someone volunteers. ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      * Thanks to Toggi3 for the base script:
      https://hints.macworld.com/article.php?story=20110219013713667
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      THE CODE (of the version with sound):
      install.command:
       
      LaunchAgent SleepOnLowBatterySound.plist:
       
      Script SleepOnLowBatterySound.scpt:
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
       
      SleepOnLowBattery (SOLB) by BugsB v.1.1 (2019-11-15).zip
×